You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
36 lines
1.0 KiB
36 lines
1.0 KiB
=== modified file 'tools/Makefile.am'
|
|
--- tools/Makefile.am 2010-11-11 15:25:43 +0000
|
|
+++ tools/Makefile.am 2010-11-24 23:00:06 +0000
|
|
@@ -1,11 +1,13 @@
|
|
if USE_GTK3
|
|
INDICATOR_LIB = -lindicator3
|
|
+libexec_PROGRAMS = indicator-loader3
|
|
+VER=3
|
|
else
|
|
+VER=
|
|
INDICATOR_LIB = -lindicator
|
|
+libexec_PROGRAMS = indicator-loader
|
|
endif
|
|
|
|
-libexec_PROGRAMS = \
|
|
- indicator-loader
|
|
|
|
#############################
|
|
# Indicator Loader
|
|
@@ -24,6 +26,14 @@
|
|
-L$(top_builddir)/libindicator/.libs \
|
|
$(INDICATOR_LIB)
|
|
|
|
+# We duplicate these here because Automake won't let us use $(VER) on the left hand side.
|
|
+# Since we carefully use $(VER) in the right hand side above, we can assign the same values.
|
|
+# Only one version of the library is every compiled at the same time, so it is safe to reuse
|
|
+# the right hand sides like this.
|
|
+indicator_loader3_SOURCES = $(indicator_loader_SOURCES)
|
|
+indicator_loader3_CFLAGS = $(indicator_loader_CFLAGS)
|
|
+indicator_loader3_LDADD = $(indicator_loader_LDADD)
|
|
+
|
|
xsessiondir = $(sysconfdir)/X11/Xsession.d
|
|
|
|
xsession_DATA = 80indicator-debugging
|
|
|