Update to 2.12.3

epel9
Sandro Mani 6 years ago
parent dd7998f237
commit 26bef486a4

1
.gitignore vendored

@ -13,3 +13,4 @@
/libimagequant-2.11.10.tar.gz
/libimagequant-2.12.1.tar.gz
/libimagequant-2.12.2.tar.gz
/libimagequant-2.12.3.tar.gz

@ -1,6 +1,6 @@
Name: libimagequant
Version: 2.12.2
Release: 2%{?dist}
Version: 2.12.3
Release: 1%{?dist}
Summary: Palette quantization library
License: GPLv3+ and MIT
@ -9,8 +9,6 @@ Source0: %{url}/archive/%{version}/%{name}-%{version}.tar.gz
# Fix shared library permissions
Patch0: libimagequant_solibperm.patch
# Fix some "error: '<var>' not specified in enclosing 'parallel'" errors
Patch1: libimagequant_omp.patch
BuildRequires: gcc
@ -59,6 +57,9 @@ rm -f %{buildroot}%{_libdir}/%{name}.a
%changelog
* Mon May 27 2019 Sandro Mani <manisandro@gmail.com> - 2.12.3-1
- Update to 2.12.3
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.12.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild

@ -1,36 +0,0 @@
diff -rupN libimagequant-2.12.2/kmeans.c libimagequant-2.12.2-new/kmeans.c
--- libimagequant-2.12.2/kmeans.c 2018-10-28 22:39:27.000000000 +0100
+++ libimagequant-2.12.2-new/kmeans.c 2019-02-04 11:20:03.367754202 +0100
@@ -74,7 +74,7 @@ LIQ_PRIVATE double kmeans_do_iteration(h
double total_diff=0;
#pragma omp parallel for if (hist_size > 2000) \
- schedule(static) default(none) shared(average_color,callback) reduction(+:total_diff)
+ schedule(static) default(none) shared(average_color,callback,hist_size,achv,n,map) reduction(+:total_diff)
for(int j=0; j < hist_size; j++) {
float diff;
unsigned int match = nearest_search(n, &achv[j].acolor, achv[j].tmp.likely_colormap_index, &diff);
diff -rupN libimagequant-2.12.2/libimagequant.c libimagequant-2.12.2-new/libimagequant.c
--- libimagequant-2.12.2/libimagequant.c 2018-10-28 22:39:27.000000000 +0100
+++ libimagequant-2.12.2-new/libimagequant.c 2019-02-04 11:34:43.067012436 +0100
@@ -1277,7 +1277,7 @@ LIQ_NONNULL static float remap_to_palett
kmeans_init(map, max_threads, average_color);
#pragma omp parallel for if (rows*cols > 3000) \
- schedule(static) default(none) shared(acolormap) shared(average_color) reduction(+:remapping_error)
+ schedule(static) default(none) shared(acolormap,input_image,transparent_index,n,output_pixels,map,cols,rows) shared(average_color) reduction(+:remapping_error)
for(int row = 0; row < rows; ++row) {
const f_pixel *const row_pixels = liq_image_get_row_f(input_image, row);
const f_pixel *const bg_pixels = input_image->background && acolormap[transparent_index].acolor.a < 1.f/256.f ? liq_image_get_row_f(input_image->background, row) : NULL;
diff -rupN libimagequant-2.12.2/mediancut.c libimagequant-2.12.2-new/mediancut.c
--- libimagequant-2.12.2/mediancut.c 2018-10-28 22:39:27.000000000 +0100
+++ libimagequant-2.12.2-new/mediancut.c 2019-02-04 11:25:19.039487962 +0100
@@ -196,7 +196,7 @@ static double prepare_sort(struct box *b
const unsigned int ind1 = b->ind;
const unsigned int colors = b->colors;
#pragma omp parallel for if (colors > 25000) \
- schedule(static) default(none) shared(achv, channels)
+ schedule(static) default(none) shared(achv, channels, ind1, colors)
for(unsigned int i=0; i < colors; i++) {
const float *chans = (const float *)&achv[ind1 + i].acolor;
// Only the first channel really matters. When trying median cut many times

@ -1,6 +1,6 @@
diff -rupN libimagequant-2.12.1/Makefile libimagequant-2.12.1-new/Makefile
--- libimagequant-2.12.1/Makefile 2018-06-03 21:46:28.000000000 +0200
+++ libimagequant-2.12.1-new/Makefile 2018-06-08 15:44:20.705219935 +0200
diff -rupN libimagequant-2.12.3/Makefile libimagequant-2.12.3-new/Makefile
--- libimagequant-2.12.3/Makefile 2019-05-23 10:42:15.000000000 +0200
+++ libimagequant-2.12.3-new/Makefile 2019-05-27 12:03:00.329740733 +0200
@@ -114,7 +114,7 @@ install: all $(PKGCONFIG)
install -d $(DESTDIR)$(PKGCONFIGDIR)
install -d $(DESTDIR)$(INCLUDEDIR)

@ -1 +1 @@
SHA512 (libimagequant-2.12.2.tar.gz) = 7e7bfcffd163d8b73a46d523dc441e4a4726f5dde804f306f13900f74afae6f6e7cf780bf157b5823a71c790bcdd0e9c9c34cf43f84a21289e470fc78835d8d8
SHA512 (libimagequant-2.12.3.tar.gz) = 4818b00b6f154407f3e402d56f4891c2d7594c8056fada0402d7fa0024ae50127340dd8295da5f5dca13fe1829670a3fa8793aa528f3e74a2294c9a7e37b7257

Loading…
Cancel
Save