diff --git a/SOURCES/0002-tests-gdisk-test-expand-gpt.pl-Implement-SKIP-rule-f.patch b/SOURCES/0002-tests-gdisk-test-expand-gpt.pl-Implement-SKIP-rule-f.patch
new file mode 100644
index 0000000..36ef1b0
--- /dev/null
+++ b/SOURCES/0002-tests-gdisk-test-expand-gpt.pl-Implement-SKIP-rule-f.patch
@@ -0,0 +1,31 @@
+From c25ff1a8022cf345d3ce29682207ed3732a4244a Mon Sep 17 00:00:00 2001
+From: "Richard W.M. Jones" <rjones@redhat.com>
+Date: Mon, 14 Oct 2024 10:43:08 +0100
+Subject: [PATCH] tests/gdisk/test-expand-gpt.pl: Implement SKIP rule for this
+ test
+
+Reported-by: David Runge
+Related: https://github.com/libguestfs/libguestfs/issues/155
+---
+ tests/gdisk/test-expand-gpt.pl | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/tests/gdisk/test-expand-gpt.pl b/tests/gdisk/test-expand-gpt.pl
+index 23a52b23c..5c77247c0 100755
+--- a/tests/gdisk/test-expand-gpt.pl
++++ b/tests/gdisk/test-expand-gpt.pl
+@@ -20,6 +20,11 @@ use warnings;
+ 
+ use Sys::Guestfs;
+ 
++if ($ENV{SKIP_TEST_EXPAND_GPT_PL}) {
++    print "$0: test skipped because SKIP_TEST_EXPAND_GPT_PL is set\n";
++    exit 77;
++}
++
+ sub tests {
+ 	my $g = Sys::Guestfs->new ();
+ 
+-- 
+2.43.0
+
diff --git a/SOURCES/0003-lib-inspect-osinfo.c-Add-Windows-Server-2025-osinfo.patch b/SOURCES/0003-lib-inspect-osinfo.c-Add-Windows-Server-2025-osinfo.patch
new file mode 100644
index 0000000..2c6d26a
--- /dev/null
+++ b/SOURCES/0003-lib-inspect-osinfo.c-Add-Windows-Server-2025-osinfo.patch
@@ -0,0 +1,44 @@
+From 0f489f8eec0c02e9ed1d606a2032edccf81ef025 Mon Sep 17 00:00:00 2001
+From: "Richard W.M. Jones" <rjones@redhat.com>
+Date: Thu, 17 Oct 2024 08:59:49 +0100
+Subject: [PATCH] lib/inspect-osinfo.c: Add Windows Server 2025 osinfo
+
+The guest was found to have these inspection fields:
+
+    type: windows
+    distro: windows
+    product_name: Windows Server 2025 Standard
+    product_variant: Server
+    version: 10.0
+    arch: x86_64
+    hostname: WIN-84V4KKQ30SM
+    build ID: 26080
+    windows_systemroot: /Windows
+    windows_software_hive: /Windows/System32/config/SOFTWARE
+    windows_system_hive: /Windows/System32/config/SYSTEM
+    windows_current_control_set: ControlSet001
+
+Reported-by: Ming Xie
+Fixes: https://issues.redhat.com/browse/RHEL-62935
+---
+ lib/inspect-osinfo.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/lib/inspect-osinfo.c b/lib/inspect-osinfo.c
+index c77344f63..f792d771a 100644
+--- a/lib/inspect-osinfo.c
++++ b/lib/inspect-osinfo.c
+@@ -142,7 +142,9 @@ guestfs_impl_inspect_get_osinfo (guestfs_h *g, const char *root)
+       switch (minor) {
+       case 0:
+         if (strstr (product_variant, "Server")) {
+-          if (strstr (product_name, "2022"))
++          if (strstr (product_name, "2025"))
++            return safe_strdup (g, "win2k25");
++          else if (strstr (product_name, "2022"))
+             return safe_strdup (g, "win2k22");
+           else if (strstr (product_name, "2019"))
+             return safe_strdup (g, "win2k19");
+-- 
+2.43.0
+
diff --git a/SOURCES/0002-RHEL-Disable-unsupported-remote-drive-protocols-RHBZ.patch b/SOURCES/0004-RHEL-Disable-unsupported-remote-drive-protocols-RHBZ.patch
similarity index 99%
rename from SOURCES/0002-RHEL-Disable-unsupported-remote-drive-protocols-RHBZ.patch
rename to SOURCES/0004-RHEL-Disable-unsupported-remote-drive-protocols-RHBZ.patch
index aa5c327..7900899 100644
--- a/SOURCES/0002-RHEL-Disable-unsupported-remote-drive-protocols-RHBZ.patch
+++ b/SOURCES/0004-RHEL-Disable-unsupported-remote-drive-protocols-RHBZ.patch
@@ -1,4 +1,4 @@
-From 2f798c87910e0fe65247a0695855ba7c6338bb71 Mon Sep 17 00:00:00 2001
+From 5efb2b2ab438f7621897e0da8602cf6d81a03ce2 Mon Sep 17 00:00:00 2001
 From: "Richard W.M. Jones" <rjones@redhat.com>
 Date: Mon, 29 Jul 2013 14:47:56 +0100
 Subject: [PATCH] RHEL: Disable unsupported remote drive protocols
diff --git a/SOURCES/0003-RHEL-Reject-use-of-libguestfs-winsupport-features-ex.patch b/SOURCES/0005-RHEL-Reject-use-of-libguestfs-winsupport-features-ex.patch
similarity index 97%
rename from SOURCES/0003-RHEL-Reject-use-of-libguestfs-winsupport-features-ex.patch
rename to SOURCES/0005-RHEL-Reject-use-of-libguestfs-winsupport-features-ex.patch
index bd152e1..edf09f4 100644
--- a/SOURCES/0003-RHEL-Reject-use-of-libguestfs-winsupport-features-ex.patch
+++ b/SOURCES/0005-RHEL-Reject-use-of-libguestfs-winsupport-features-ex.patch
@@ -1,4 +1,4 @@
-From e9a4e3efb7c86bf732c35f2582bec671b3604c83 Mon Sep 17 00:00:00 2001
+From e23ae7abc6b92235a7ccb72db9eaa23728511f18 Mon Sep 17 00:00:00 2001
 From: "Richard W.M. Jones" <rjones@redhat.com>
 Date: Tue, 7 Jul 2015 09:28:03 -0400
 Subject: [PATCH] RHEL: Reject use of libguestfs-winsupport features except for
diff --git a/SPECS/libguestfs.spec b/SPECS/libguestfs.spec
index 0c7deea..6598268 100644
--- a/SPECS/libguestfs.spec
+++ b/SPECS/libguestfs.spec
@@ -42,7 +42,7 @@ Summary:       Access and modify virtual machine disk images
 Name:          libguestfs
 Epoch:         1
 Version:       1.54.0
-Release:       1%{?dist}
+Release:       2%{?dist}
 License:       LGPL-2.1-or-later
 
 # Build only for architectures that have a kernel
@@ -81,8 +81,10 @@ Source8:       copy-patches.sh
 
 # Patches.
 Patch0001:     0001-website-Add-links-for-1.54-and-1.55-download-locatio.patch
-Patch0002:     0002-RHEL-Disable-unsupported-remote-drive-protocols-RHBZ.patch
-Patch0003:     0003-RHEL-Reject-use-of-libguestfs-winsupport-features-ex.patch
+Patch0002:     0002-tests-gdisk-test-expand-gpt.pl-Implement-SKIP-rule-f.patch
+Patch0003:     0003-lib-inspect-osinfo.c-Add-Windows-Server-2025-osinfo.patch
+Patch0004:     0004-RHEL-Disable-unsupported-remote-drive-protocols-RHBZ.patch
+Patch0005:     0005-RHEL-Reject-use-of-libguestfs-winsupport-features-ex.patch
 
 BuildRequires: autoconf, automake, libtool, gettext-devel
 
@@ -1108,9 +1110,11 @@ rm ocaml/html/.gitignore
 
 
 %changelog
-* Wed Oct 09 2024 Richard W.M. Jones <rjones@redhat.com> - 1:1.54.0-1
+* Thu Oct 17 2024 Richard W.M. Jones <rjones@redhat.com> - 1:1.54.0-2
 - Rebase to libguestfs 1.54.0
   resolves: RHEL-56810
+- Fix osinfo for Windows Server 2025
+  resolves: RHEL-62989
 
 * Wed Aug 28 2024 Richard W.M. Jones <rjones@redhat.com> - 1:1.52.2-4
 - Synchronize patches with RHEL 9.5