commit
f854f76308
@ -0,0 +1 @@
|
||||
SOURCES/libgpg-error-1.42.tar.bz2
|
@ -0,0 +1 @@
|
||||
5e620d71fc24d287a7ac2460b1d819074bb8b9bb SOURCES/libgpg-error-1.42.tar.bz2
|
@ -0,0 +1,122 @@
|
||||
diff -up libgpg-error-1.29/configure.ac.multilib libgpg-error-1.29/configure.ac
|
||||
--- libgpg-error-1.29/configure.ac.multilib 2018-04-11 14:41:10.479019981 +0200
|
||||
+++ libgpg-error-1.29/configure.ac 2018-04-11 14:43:31.288394113 +0200
|
||||
@@ -215,13 +215,13 @@ GNUPG_FUNC_MKDIR_TAKES_ONE_ARG
|
||||
|
||||
|
||||
# Find a 64 bit integer type to be used instead of off_t. We prefer
|
||||
-# the standard integer types over int64_t and finally try long long.
|
||||
-if test "$ac_cv_sizeof_int" = "8"; then
|
||||
+# int64_t and finally try long long.
|
||||
+if test "$ac_cv_header_stdint_h" = yes; then
|
||||
+ replacement_for_off_t="int64_t"
|
||||
+elif test "$ac_cv_sizeof_int" = "8"; then
|
||||
replacement_for_off_t="int"
|
||||
elif test "$ac_cv_sizeof_long" = "8"; then
|
||||
replacement_for_off_t="long"
|
||||
-elif test "$ac_cv_header_stdint_h" = yes; then
|
||||
- replacement_for_off_t="int64_t"
|
||||
elif test "$ac_cv_sizeof_long_long" = "8"; then
|
||||
replacement_for_off_t="long long"
|
||||
else
|
||||
diff -up libgpg-error-1.29/configure.multilib libgpg-error-1.29/configure
|
||||
--- libgpg-error-1.29/configure.multilib 2018-04-11 09:34:30.000000000 +0200
|
||||
+++ libgpg-error-1.29/configure 2018-04-11 14:41:10.481020028 +0200
|
||||
@@ -11301,7 +11301,7 @@ shlibpath_var=
|
||||
shlibpath_overrides_runpath=unknown
|
||||
version_type=none
|
||||
dynamic_linker="$host_os ld.so"
|
||||
-sys_lib_dlsearch_path_spec="/lib /usr/lib"
|
||||
+sys_lib_dlsearch_path_spec="/lib /usr/lib /usr/lib64 /usr/lib64"
|
||||
need_lib_prefix=unknown
|
||||
hardcode_into_libs=no
|
||||
|
||||
@@ -11775,7 +11775,7 @@ fi
|
||||
# Append ld.so.conf contents to the search path
|
||||
if test -f /etc/ld.so.conf; then
|
||||
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;s/"//g;/^$/d' | tr '\n' ' '`
|
||||
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
|
||||
+ sys_lib_dlsearch_path_spec="/lib /usr/lib /usr/lib64 /usr/lib64 $lt_ld_extra"
|
||||
fi
|
||||
|
||||
# We used to test for /lib/ld.so.1 and disable shared libraries on
|
||||
@@ -15879,12 +15879,12 @@ fi
|
||||
|
||||
# Find a 64 bit integer type to be used instead of off_t. We prefer
|
||||
# the standard integer types over int64_t and finally try long long.
|
||||
-if test "$ac_cv_sizeof_int" = "8"; then
|
||||
+if test "$ac_cv_header_stdint_h" = yes; then
|
||||
+ replacement_for_off_t="int64_t"
|
||||
+elif test "$ac_cv_sizeof_int" = "8"; then
|
||||
replacement_for_off_t="int"
|
||||
elif test "$ac_cv_sizeof_long" = "8"; then
|
||||
replacement_for_off_t="long"
|
||||
-elif test "$ac_cv_header_stdint_h" = yes; then
|
||||
- replacement_for_off_t="int64_t"
|
||||
elif test "$ac_cv_sizeof_long_long" = "8"; then
|
||||
replacement_for_off_t="long long"
|
||||
else
|
||||
diff -up libgpg-error-1.29/src/gen-posix-lock-obj.c.multilib libgpg-error-1.29/src/gen-posix-lock-obj.c
|
||||
--- libgpg-error-1.29/src/gen-posix-lock-obj.c.multilib 2016-11-16 13:22:03.000000000 +0100
|
||||
+++ libgpg-error-1.29/src/gen-posix-lock-obj.c 2018-04-11 14:41:10.481020028 +0200
|
||||
@@ -72,6 +72,7 @@ main (void)
|
||||
#ifdef USE_POSIX_THREADS
|
||||
unsigned char *p;
|
||||
int i;
|
||||
+ int initidx = 0;
|
||||
#endif
|
||||
struct {
|
||||
long vers;
|
||||
@@ -111,11 +112,12 @@ main (void)
|
||||
|
||||
/* To force a probably suitable alignment of the structure we use a
|
||||
union and include a long and a pointer to a long. */
|
||||
- printf ("typedef struct\n"
|
||||
+ printf ("#include <pthread.h>\n"
|
||||
+ "typedef struct\n"
|
||||
"{\n"
|
||||
" long _vers;\n"
|
||||
" union {\n"
|
||||
- " volatile char _priv[%d];\n"
|
||||
+ " volatile char _priv[sizeof(pthread_mutex_t)];\n"
|
||||
"%s"
|
||||
" long _x_align;\n"
|
||||
" long *_xp_align;\n"
|
||||
@@ -123,7 +125,6 @@ main (void)
|
||||
"} gpgrt_lock_t;\n"
|
||||
"\n"
|
||||
"#define GPGRT_LOCK_INITIALIZER {%d,{{",
|
||||
- SIZEOF_PTHREAD_MUTEX_T,
|
||||
# if USE_16BYTE_ALIGNMENT
|
||||
" int _x16_align __attribute__ ((aligned (16)));\n",
|
||||
# elif USE_DOUBLE_FOR_ALIGNMENT
|
||||
@@ -137,10 +138,16 @@ main (void)
|
||||
p = (unsigned char *)&mtx;
|
||||
for (i=0; i < sizeof mtx; i++)
|
||||
{
|
||||
+ if (p[i] != 0)
|
||||
+ initidx = i;
|
||||
+ }
|
||||
+
|
||||
+ for (i=0; i <= initidx; i++)
|
||||
+ {
|
||||
if (i && !(i % 8))
|
||||
printf (" \\\n%*s", 36, "");
|
||||
printf ("%u", p[i]);
|
||||
- if (i < sizeof mtx - 1)
|
||||
+ if (i < initidx)
|
||||
putchar (',');
|
||||
}
|
||||
fputs ("}}}\n", stdout);
|
||||
diff -up libgpg-error-1.29/src/gpg-error.h.in.multilib libgpg-error-1.29/src/gpg-error.h.in
|
||||
--- libgpg-error-1.29/src/gpg-error.h.in.multilib 2018-04-11 14:41:10.481020028 +0200
|
||||
+++ libgpg-error-1.29/src/gpg-error.h.in 2018-04-11 14:45:28.184203566 +0200
|
||||
@@ -17,7 +17,7 @@
|
||||
* License along with this program; if not, see <https://www.gnu.org/licenses/>.
|
||||
* SPDX-License-Identifier: LGPL-2.1+
|
||||
*
|
||||
- * @configure_input@
|
||||
+ * Do not edit. Generated from gpg-error.h.in.
|
||||
*/
|
||||
|
||||
/* The GnuPG project consists of many components. Error codes are
|
@ -0,0 +1,177 @@
|
||||
From 89a353f418f5e879ab5564ec0767a6cbdb19d51c Mon Sep 17 00:00:00 2001
|
||||
From: NIIBE Yutaka <gniibe@fsij.org>
|
||||
Date: Wed, 7 Apr 2021 16:59:35 +0900
|
||||
Subject: [PATCH Libgpg-error 1/4] build: Fix gpgrt-config for handling
|
||||
'Requires' field.
|
||||
|
||||
* src/gpgrt-config.in (get_attr_l): Fix thinko for word split.
|
||||
|
||||
--
|
||||
|
||||
GnuPG-bug-id: 5381
|
||||
Reported-by: Jakub Jelen <jjelen@redhat.com>
|
||||
Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
|
||||
---
|
||||
src/gpgrt-config.in | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/gpgrt-config.in b/src/gpgrt-config.in
|
||||
index 0fe14e8..6352384 100644
|
||||
--- a/src/gpgrt-config.in
|
||||
+++ b/src/gpgrt-config.in
|
||||
@@ -1,4 +1,5 @@
|
||||
#!@INSTALLSHELLPATH@
|
||||
+# -*- mode: shell-script; sh-shell: "/bin/sh" -*-
|
||||
# Copyright (C) 2018, 2021 g10 Code GmbH
|
||||
#
|
||||
# This file is free software; as a special exception the author gives
|
||||
@@ -41,7 +42,7 @@ get_attr () {
|
||||
|
||||
# variant of get_attr for list (separated by ',')
|
||||
get_attr_l () {
|
||||
- (IFS=', '; for x in "$(get_attr $1)"; do echo $x; done)
|
||||
+ (IFS=', '; echo "$(get_attr $1)")
|
||||
}
|
||||
|
||||
# Remove ${varname} part in the beginning of a string.
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
||||
From 956c40f106ead6d0191bc183805021e70c15e760 Mon Sep 17 00:00:00 2001
|
||||
From: NIIBE Yutaka <gniibe@fsij.org>
|
||||
Date: Thu, 8 Apr 2021 10:58:56 +0900
|
||||
Subject: [PATCH Libgpg-error 2/4] core: Fix gpgrt_wait_processes, by skipping
|
||||
invalid PID.
|
||||
|
||||
* src/spawn-posix.c (_gpgrt_wait_processes): Skip invalid PID.
|
||||
|
||||
--
|
||||
|
||||
The API itself is not good to handle multiple processes. Given the
|
||||
API, skipping invalid PID is better for usefulness.
|
||||
|
||||
GnuPG-bug-id: 5381
|
||||
Reported-by: Jakub Jelen <jjelen@redhat.com>
|
||||
Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
|
||||
---
|
||||
src/spawn-posix.c | 7 ++++++-
|
||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/spawn-posix.c b/src/spawn-posix.c
|
||||
index ac4c4ce..d33bade 100644
|
||||
--- a/src/spawn-posix.c
|
||||
+++ b/src/spawn-posix.c
|
||||
@@ -703,8 +703,13 @@ _gpgrt_wait_processes (const char **pgmnames, pid_t *pids, size_t count,
|
||||
{
|
||||
int status = -1;
|
||||
|
||||
+ /* Skip invalid PID. */
|
||||
if (pids[i] == (pid_t)(-1))
|
||||
- return GPG_ERR_INV_VALUE;
|
||||
+ {
|
||||
+ r_exitcodes[i] = -1;
|
||||
+ left -= 1;
|
||||
+ continue;
|
||||
+ }
|
||||
|
||||
/* See if there was a previously stored result for this pid. */
|
||||
if (get_result (pids[i], &status))
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
||||
From ad062b0a5b7d598081405ecfb71b51540281a1b7 Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Jelen <jjelen@redhat.com>
|
||||
Date: Mon, 12 Apr 2021 13:06:17 +0900
|
||||
Subject: [PATCH Libgpg-error 3/4] build,tests: Fix leaks of memory or file
|
||||
pointer.
|
||||
|
||||
* src/mkheader.c (parse_config_h): Close FP.
|
||||
* tests/t-b64.c (test_b64enc_string): Free STATE.
|
||||
(test_b64dec_string): Free BUFFER.
|
||||
* tests/t-syserror.c (main): Close FP.
|
||||
|
||||
--
|
||||
|
||||
GnuPG-bug-id: 5381
|
||||
Signed-off-by: Jakub Jelen <jjelen@redhat.com>
|
||||
---
|
||||
src/mkheader.c | 1 +
|
||||
tests/t-b64.c | 2 ++
|
||||
tests/t-syserror.c | 1 +
|
||||
3 files changed, 4 insertions(+)
|
||||
|
||||
diff --git a/src/mkheader.c b/src/mkheader.c
|
||||
index 77826da..1d2ea20 100644
|
||||
--- a/src/mkheader.c
|
||||
+++ b/src/mkheader.c
|
||||
@@ -244,6 +244,7 @@ parse_config_h (const char *fname)
|
||||
{
|
||||
fprintf (stderr, "%s:%d: error reading file: %s\n",
|
||||
fname, lnr, strerror (errno));
|
||||
+ fclose (fp);
|
||||
return 1;
|
||||
}
|
||||
|
||||
diff --git a/tests/t-b64.c b/tests/t-b64.c
|
||||
index 0171909..db08fc0 100644
|
||||
--- a/tests/t-b64.c
|
||||
+++ b/tests/t-b64.c
|
||||
@@ -108,6 +108,7 @@ test_b64enc_string (const char *string, const char *expected, const char *title)
|
||||
err = gpgrt_b64enc_write (state, string, strlen (string));
|
||||
if (err)
|
||||
{
|
||||
+ free (state);
|
||||
fail ("gpgrt_b64enc_write failed: %s\n", gpg_strerror (err));
|
||||
return err;
|
||||
}
|
||||
@@ -191,6 +192,7 @@ test_b64dec_string (const char *string, const char *expected, const char *title)
|
||||
gpgrt_log_debug_string (expected, "expect(len=%zu): ",
|
||||
strlen (expected));
|
||||
}
|
||||
+ free (buffer);
|
||||
return GPG_ERR_FALSE;
|
||||
}
|
||||
|
||||
diff --git a/tests/t-syserror.c b/tests/t-syserror.c
|
||||
index a4cb983..93264dd 100644
|
||||
--- a/tests/t-syserror.c
|
||||
+++ b/tests/t-syserror.c
|
||||
@@ -49,6 +49,7 @@ main (int argc, char *argv[])
|
||||
}
|
||||
if (fp)
|
||||
{
|
||||
+ fclose (fp);
|
||||
fprintf (stderr, "unable to run test\n");
|
||||
return 1;
|
||||
}
|
||||
--
|
||||
2.30.2
|
||||
|
||||
|
||||
From 5e60ba508a2b23aa73a9b26616e1dd3f1fc1cb7d Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Jelen <jjelen@redhat.com>
|
||||
Date: Wed, 7 Apr 2021 11:56:40 +0200
|
||||
Subject: [PATCH Libgpg-error 4/4] logging: Supress cppcheck warning
|
||||
|
||||
Signed-off-by: Jakub Jelen <jjelen@redhat.com>
|
||||
---
|
||||
src/logging.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/logging.c b/src/logging.c
|
||||
index e4b7e40..69bf8c5 100644
|
||||
--- a/src/logging.c
|
||||
+++ b/src/logging.c
|
||||
@@ -1274,6 +1274,7 @@ _gpgrt_log_printhex (const void *buffer, size_t length,
|
||||
* complains about uninitialized use. */
|
||||
static va_list dummy_argptr;
|
||||
|
||||
+ // cppcheck-suppress va_list_usedBeforeStarted
|
||||
_gpgrt_logv_printhex (buffer, length, NULL, dummy_argptr);
|
||||
}
|
||||
}
|
||||
--
|
||||
2.30.2
|
||||
|
@ -0,0 +1,30 @@
|
||||
From 75e06a7861cb4a8479a382946217e846e9b58154 Mon Sep 17 00:00:00 2001
|
||||
From: Jakub Jelen <jjelen@redhat.com>
|
||||
Date: Mon, 6 Dec 2021 20:52:57 +0100
|
||||
Subject: [PATCH Libgpg-error] configure: Add missing check for logging
|
||||
|
||||
* configure.ac: Add missing check for inet_pton to avoid using inet_addr
|
||||
in modern systems.
|
||||
--
|
||||
|
||||
Signed-off-by: Jakub Jelen <jjelen@redhat.com>
|
||||
---
|
||||
configure.ac | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index da013d8..3686a9c 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -215,7 +215,7 @@ AC_SUBST(INSTALLSHELLPATH)
|
||||
|
||||
AC_FUNC_FORK
|
||||
AC_CHECK_FUNCS([flockfile vasprintf mmap rand strlwr stpcpy setenv stat \
|
||||
- getrlimit getpwnam getpwuid getpwnam_r getpwuid_r ])
|
||||
+ getrlimit getpwnam getpwuid getpwnam_r getpwuid_r inet_pton ])
|
||||
|
||||
|
||||
#
|
||||
--
|
||||
2.31.1
|
||||
|
Binary file not shown.
@ -0,0 +1,343 @@
|
||||
Name: libgpg-error
|
||||
Version: 1.42
|
||||
Release: 5%{?dist}
|
||||
Summary: Library for error values used by GnuPG components
|
||||
URL: https://www.gnupg.org/related_software/libgpg-error/
|
||||
License: LGPLv2+
|
||||
|
||||
Source0: https://www.gnupg.org/ftp/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2
|
||||
Source1: https://www.gnupg.org/ftp/gcrypt/libgpg-error/%{name}-%{version}.tar.bz2.sig
|
||||
Patch1: libgpg-error-1.29-multilib.patch
|
||||
# https://dev.gnupg.org/T5381
|
||||
Patch2: libgpg-error-1.42-coverity.patch
|
||||
# https://dev.gnupg.org/T5720
|
||||
Patch3: libgpg-error-1.42-inet_pton.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gawk, gettext, autoconf, automake, gettext-devel, libtool
|
||||
BuildRequires: texinfo
|
||||
BuildRequires: gettext-autopoint
|
||||
BuildRequires: make
|
||||
|
||||
%description
|
||||
This is a library that defines common error values for all GnuPG
|
||||
components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
|
||||
pinentry, SmartCard Daemon and possibly more in the future.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for the %{name} package
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
This is a library that defines common error values for all GnuPG
|
||||
components. Among these are GPG, GPGSM, GPGME, GPG-Agent, libgcrypt,
|
||||
pinentry, SmartCard Daemon and possibly more in the future. This package
|
||||
contains files necessary to develop applications using libgpg-error.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch1 -p1 -b .multilib
|
||||
%patch2 -p1 -b .coverity
|
||||
%patch3 -p1 -b .inet_pton
|
||||
|
||||
autoreconf -f
|
||||
|
||||
# The config script already suppresses the -L if it's /usr/lib, so cheat and
|
||||
# set it to a value which we know will be suppressed.
|
||||
sed -i -e 's|^libdir=@libdir@$|libdir=@exec_prefix@/lib|g;s|@GPG_ERROR_CONFIG_HOST@|none|g' src/gpg-error-config.in
|
||||
sed -i -e '/--variable=host/d' src/gpg-error-config-test.sh.in
|
||||
|
||||
# Modify configure to drop rpath for /usr/lib64
|
||||
sed -i -e 's|sys_lib_dlsearch_path_spec="/lib /usr/lib|sys_lib_dlsearch_path_spec="/lib /usr/lib %{_libdir}|g' configure
|
||||
|
||||
%build
|
||||
%configure --disable-static --disable-rpath --disable-languages
|
||||
%make_build
|
||||
|
||||
%install
|
||||
%make_install
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||
rm -f $RPM_BUILD_ROOT%{_infodir}/dir
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
%ldconfig_scriptlets
|
||||
|
||||
%files -f %{name}.lang
|
||||
%license COPYING COPYING.LIB
|
||||
%doc AUTHORS README NEWS
|
||||
%{_bindir}/gpg-error
|
||||
%{_libdir}/libgpg-error.so.0*
|
||||
%{_datadir}/libgpg-error
|
||||
|
||||
%files devel
|
||||
%{_bindir}/gpg-error-config
|
||||
%{_bindir}/gpgrt-config
|
||||
%{_bindir}/yat2m
|
||||
%{_libdir}/libgpg-error.so
|
||||
%{_libdir}/pkgconfig/gpg-error.pc
|
||||
%{_includedir}/gpg-error.h
|
||||
%{_includedir}/gpgrt.h
|
||||
%{_datadir}/aclocal/gpg-error.m4
|
||||
%{_datadir}/aclocal/gpgrt.m4
|
||||
%{_infodir}/gpgrt.info*
|
||||
%{_mandir}/man1/gpgrt-config.*
|
||||
|
||||
%changelog
|
||||
* Mon Dec 06 2021 Jakub Jelen <jjelen@redhat.com> - 1.42-5
|
||||
- Avoid using bad function inet_addr
|
||||
|
||||
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 1.42-4
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 1.42-3
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Mon Apr 12 2021 Jakub Jelen <jjelen@redhat.com> - 1.42-2
|
||||
- Address coverity reported issues
|
||||
|
||||
* Mon Mar 22 2021 Jakub Jelen <jjelen@redhat.com> - 1.42-1
|
||||
- New upstream release (#1941582)
|
||||
|
||||
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.41-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Mon Jan 04 2021 Jakub Jelen <jjelen@redhat.com> - 1.41-1
|
||||
- New upstream release (#1909749)
|
||||
|
||||
* Tue Dec 01 2020 Jakub Jelen <jjelen@redhat.com> - 1.39-1
|
||||
- New upstream release (#1800640)
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.37-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Feb 28 2020 Tomáš Mráz <tmraz@redhat.com> 1.37-1
|
||||
- new upstream release 1.37
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.36-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Aug 14 2019 Tomáš Mráz <tmraz@redhat.com> 1.36-2
|
||||
- fix FTBFS in rawhide due to new gawk
|
||||
|
||||
* Sat Aug 3 2019 Peter Robinson <pbrobinson@fedoraproject.org> 1.36-1
|
||||
- new upstream release 1.36
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.33-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.33-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Jan 08 2019 Tomáš Mráz <tmraz@redhat.com> 1.33-1
|
||||
- new upstream release 1.33
|
||||
- dropped obsolete install-info scriptlets
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.31-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Jun 11 2018 Tomáš Mráz <tmraz@redhat.com> 1.31-1
|
||||
- new upstream release 1.31
|
||||
|
||||
* Wed Apr 11 2018 Tomáš Mráz <tmraz@redhat.com> 1.29-1
|
||||
- new upstream release 1.29
|
||||
|
||||
* Wed Feb 28 2018 Richard W.M. Jones <rjones@redhat.com> - 1.27-6
|
||||
- Backport patch which adds riscv64 support.
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.27-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.27-4
|
||||
- Switch to %%ldconfig_scriptlets
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.27-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.27-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Mar 15 2017 Tomáš Mráz <tmraz@redhat.com> 1.27-1
|
||||
- new upstream release 1.27
|
||||
|
||||
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.25-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Nov 15 2016 Tomáš Mráz <tmraz@redhat.com> 1.25-1
|
||||
- new upstream release 1.25
|
||||
|
||||
* Thu Jul 14 2016 Tomáš Mráz <tmraz@redhat.com> 1.24-1
|
||||
- new upstream release
|
||||
|
||||
* Fri Mar 18 2016 Rex Dieter <rdieter@fedoraproject.org> - 1.21-3
|
||||
- drop explicit /sbin/ldconfig scriptlet deps (#1319144)
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.21-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Dec 22 2015 Tomáš Mráz <tmraz@redhat.com> 1.21-1
|
||||
- new upstream release
|
||||
|
||||
* Tue Sep 1 2015 Tomáš Mráz <tmraz@redhat.com> 1.20-1
|
||||
- new upstream release
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.19-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Mon Apr 13 2015 Tomáš Mráz <tmraz@redhat.com> 1.19-1
|
||||
- new upstream release
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1.17-3
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
||||
* Fri Jan 30 2015 Tomáš Mráz <tmraz@redhat.com> 1.17-2
|
||||
- do not conflict on header file between architectures (#1180857)
|
||||
|
||||
* Thu Jan 29 2015 Tomáš Mráz <tmraz@redhat.com> 1.17-1
|
||||
- new upstream release
|
||||
|
||||
* Fri Sep 19 2014 Tomáš Mráz <tmraz@redhat.com> 1.16-1
|
||||
- new upstream release
|
||||
- move from /lib to /usr/lib
|
||||
|
||||
* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.13-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Fri Jul 18 2014 Tom Callaway <spot@fedoraproject.org> 1.13-2
|
||||
- fix license handling
|
||||
|
||||
* Wed Jun 25 2014 Tomáš Mráz <tmraz@redhat.com> 1.13-1
|
||||
- new upstream release
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri Aug 23 2013 Tomáš Mráz <tmraz@redhat.com> 1.12-1
|
||||
- new upstream release
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.11-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri Apr 5 2013 Tomáš Mráz <tmraz@redhat.com> 1.11-1
|
||||
- new upstream release
|
||||
|
||||
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.10-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Jul 15 2011 Tomáš Mráz <tmraz@redhat.com> 1.10-1
|
||||
- new upstream release
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2010 Rex Dieter <rdieter@fedoraproject.org> 1.9-1
|
||||
- libgpg-error-1.9
|
||||
|
||||
* Thu Feb 25 2010 Nalin Dahyabhai <nalin@redhat.com> - 1.7-3
|
||||
- turn off common lisp bindings the right way
|
||||
- drop finger output
|
||||
- recode the changelog into UTF-8 if it isn't UTF-8 (rpmlint)
|
||||
|
||||
* Mon Jan 11 2010 Nalin Dahyabhai <nalin@redhat.com> - 1.7-2
|
||||
- fix use of macro in changelog (rpmlint)
|
||||
- build with --disable-rpath (rpmlint)
|
||||
- build with %%{?_smp_mflags}
|
||||
|
||||
* Thu Oct 15 2009 Nalin Dahyabhai <nalin@redhat.com> - 1.7-1
|
||||
- long-overdue update to 1.7
|
||||
- add a disttag
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.6-2
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Fri Dec 7 2007 Nalin Dahyabhai <nalin@redhat.com>
|
||||
- remove the generic install docs (#226021)
|
||||
|
||||
* Fri Dec 7 2007 Nalin Dahyabhai <nalin@redhat.com> - 1.6-1
|
||||
- update to 1.6
|
||||
- add suggested summary, buildrequires, and modify install call as suggested
|
||||
by package review (#226021)
|
||||
|
||||
* Mon Oct 15 2007 Nalin Dahyabhai <nalin@redhat.com> - 1.5-6
|
||||
- use ldconfig to make the soname symlink so that it gets packaged (#331241)
|
||||
|
||||
* Wed Aug 22 2007 Nalin Dahyabhai <nalin@redhat.com> - 1.5-5
|
||||
- add missing gawk buildrequirement
|
||||
|
||||
* Thu Aug 16 2007 Nalin Dahyabhai <nalin@redhat.com> - 1.5-4
|
||||
- clarify license
|
||||
|
||||
* Mon Jul 30 2007 Nalin Dahyabhai <nalin@redhat.com> - 1.5-3
|
||||
- disable static libraries (part of #249815)
|
||||
|
||||
* Fri Jul 27 2007 Nalin Dahyabhai <nalin@redhat.com> - 1.5-2
|
||||
- move libgpg-error shared library to /%%{_lib} (#249816)
|
||||
|
||||
* Thu Jul 19 2007 Nalin Dahyabhai <nalin@redhat.com> - 1.5-1
|
||||
- update to 1.5
|
||||
|
||||
* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.4-2
|
||||
- rebuilt for unwind info generation, broken in gcc-4.1.1-21
|
||||
|
||||
* Mon Sep 18 2006 Bill Nottngham <notting@redhat.com> - 1.4-1
|
||||
- update to 1.4
|
||||
- don't ship lisp bindings
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.3-3.1
|
||||
- rebuild
|
||||
|
||||
* Mon Jun 5 2006 Nalin Dahyabhai <nalin@redhat.com> 1.3-3
|
||||
- give gpg-error-config libdir=@exec_prefix@/lib instead of @libdir@, so that
|
||||
it agrees on 32- and 64-bit arches (it suppresses the -L argument if @libdir@
|
||||
is /usr/lib, so this should be cleaner than adding a non-standard .pc file
|
||||
which upstream developers might inadvertently think they can depend to be on
|
||||
every system which provides this library)
|
||||
|
||||
* Mon May 15 2006 Karsten Hopp <karsten@redhat.de> 1.3-2
|
||||
- switch to pkgconfig so that gpg-error-config can be the same on
|
||||
32bit and 64bit archs
|
||||
|
||||
* Tue May 2 2006 Nalin Dahyabhai <nalin@redhat.com> - 1.3-1
|
||||
- update to version 1.3
|
||||
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.1-1.2.1
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.1-1.2
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Nov 30 2005 Karsten Hopp <karsten@redhat.de> 1.1-1
|
||||
- update
|
||||
|
||||
* Wed Mar 2 2005 Bill Nottingham <notting@redhat.com> - 1.0-2
|
||||
- we can rebuild it. we have the technology.
|
||||
|
||||
* Tue Aug 31 2004 Bill Nottingham <notting@redhat.com> - 1.0-1
|
||||
- update to 1.0
|
||||
|
||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Apr 16 2004 Bill Nottingham <notting@redhat.com> - 0.7-1
|
||||
- adapt upstream specfile
|
Loading…
Reference in new issue