From 73ea51e00b22da999d70e5f832f13f2ddd2d6f6c Mon Sep 17 00:00:00 2001
From: cvsdist <cvsdist@fedoraproject.org>
Date: Thu, 9 Sep 2004 07:28:27 +0000
Subject: [PATCH] auto-import changelog data from libglade2-2.0.1-5.1.src.rpm
 Fri Aug 29 2003 Owen Taylor <otaylor@redhat.com> 2.0.1-5.0 - Fix a couple of
 warnings for unknown properties GtkToolbar (Hardy     Merrill, Wed Jun 04
 2003 Elliot Lee <sopwith@redhat.com> - rebuilt

---
 libglade-2.0.1-nowarning.patch | 39 ++++++++++++++++++++++++++++++++++
 libglade2.spec                 | 14 +++++++++++-
 2 files changed, 52 insertions(+), 1 deletion(-)
 create mode 100644 libglade-2.0.1-nowarning.patch

diff --git a/libglade-2.0.1-nowarning.patch b/libglade-2.0.1-nowarning.patch
new file mode 100644
index 0000000..fd07121
--- /dev/null
+++ b/libglade-2.0.1-nowarning.patch
@@ -0,0 +1,39 @@
+--- libglade-2.0.1/glade/glade-gtk.c.nowarning	2003-08-29 14:50:10.000000000 -0400
++++ libglade-2.0.1/glade/glade-gtk.c	2003-08-29 14:58:41.000000000 -0400
+@@ -639,9 +639,8 @@
+ 		if (!strcmp (childinfo->properties[j].name, "label")) {
+ 		    label = childinfo->properties[j].value;
+ 		    break;
+-		} else {
+-		    g_warning ("Unknown CList child property: %s", childinfo->properties[j].name);
+ 		}
++		/* Ignore all other properties */
+ 	    }
+ 
+ 	    if (label) {
+@@ -683,6 +682,7 @@
+ 	    char *icon = NULL;
+ 	    gboolean use_stock = FALSE, active = FALSE, new_group = FALSE;
+ 	    gboolean use_underline = FALSE;
++	    gboolean sensitive = TRUE;
+ 	    GtkWidget *iconw = NULL;
+ 	    int j;
+ 
+@@ -708,6 +708,8 @@
+ 		    group_name = value;
+ 		} else if (!strcmp (name, "new_group")) {
+ 		    new_group = BOOL (value);
++		} else if (!strcmp (name, "sensitive")) {
++		    sensitive = BOOL (value);
+ 		} else if (!strcmp (name, "visible")) {
+ 		    /* ignore for now */
+ 		} else if (!strcmp (name, "tooltip")) {
+@@ -785,6 +787,8 @@
+ 		gtk_label_set_use_underline (GTK_LABEL (toolbar_child->label),
+ 					     TRUE);
+ 	    }
++	    
++	    gtk_widget_set_sensitive (child, sensitive);
+ 
+ 	    glade_xml_set_common_params (xml, child, childinfo->child);
+ 	} else {
diff --git a/libglade2.spec b/libglade2.spec
index 74f3179..50083a6 100644
--- a/libglade2.spec
+++ b/libglade2.spec
@@ -7,7 +7,7 @@
 Summary: The libglade library for loading user interfaces.
 Name: libglade2
 Version: 2.0.1
-Release: 3
+Release: 5.1
 Copyright: LGPL
 Group: System Environment/Libraries
 Source: libglade-%{version}.tar.bz2
@@ -20,6 +20,9 @@ BuildRequires: gtk2-devel >= %{gtk2_version}
 BuildRequires: fontconfig
 BuildRequires: pango-devel >= %{pango_version}
 
+# http://bugzilla.gnome.org/show_bug.cgi?id=121025
+Patch1: libglade-2.0.1-nowarning.patch
+
 %description
 Libglade is a small library that allows a program to load its user
 interface from am XML description at runtime. Libglade uses the XML
@@ -47,6 +50,8 @@ that you can use to develop libglade applications.
 %prep
 %setup -q -n libglade-%{version}
 
+%patch1 -p1 -b .nowarning
+
 %build
 
 rm ltmain.sh && cp %{SOURCE2} ltmain.sh
@@ -82,6 +87,13 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/gtk-doc
 
 %changelog
+* Fri Aug 29 2003 Owen Taylor <otaylor@redhat.com> 2.0.1-5.0
+- Fix a couple of warnings for unknown properties GtkToolbar (Hardy Merrill, 
+  #85384) and GtkCList.
+
+* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
+- rebuilt
+
 * Fri Feb 14 2003 Tim Powers <timp@redhat.com> 2.0.1-3
 - remove BuildRequires on Xft