diff --git a/0001-Disable-failing-test.patch b/0001-Disable-failing-test.patch
new file mode 100644
index 0000000..0f7b9f8
--- /dev/null
+++ b/0001-Disable-failing-test.patch
@@ -0,0 +1,29 @@
+From e833b8c00da12619ab58032715b8b1ccc404d5ea Mon Sep 17 00:00:00 2001
+From: Mathieu Bridon <bochecha@fedoraproject.org>
+Date: Sat, 22 Mar 2014 12:29:40 +0800
+Subject: [PATCH] Disable failing test
+
+https://github.com/libgit2/libgit2/issues/2199
+---
+ tests/blame/simple.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/tests/blame/simple.c b/tests/blame/simple.c
+index 79bd56b..eb0d8b9 100644
+--- a/tests/blame/simple.c
++++ b/tests/blame/simple.c
+@@ -135,6 +135,11 @@ void test_blame_simple__trivial_libgit2(void)
+ 	git_blame_options opts = GIT_BLAME_OPTIONS_INIT;
+ 	git_object *obj;
+ 
++        /* This test doesn't seem to work from a release tarball
++         * https://github.com/libgit2/libgit2/issues/2199
++         */
++        return;
++
+ 	cl_git_pass(git_repository_open(&g_repo, cl_fixture("../..")));
+ 
+ 	/* This test can't work on a shallow clone */
+-- 
+1.8.5.3
+
diff --git a/libgit2.spec b/libgit2.spec
index e543830..0d2060d 100644
--- a/libgit2.spec
+++ b/libgit2.spec
@@ -9,6 +9,9 @@ License: GPLv2 with exceptions
 URL: http://libgit2.github.com/
 Source0: https://github.com/%{name}/%{name}/archive/%{commit}/%{name}-%{version}.tar.gz
 
+# https://github.com/libgit2/libgit2/issues/2199
+Patch0: 0001-Disable-failing-test.patch
+
 # Add htonl() and friends declarations on non-x86 arches
 Patch1: libgit2-0.19.0-non-x86.patch
 
@@ -42,6 +45,7 @@ developing applications that use %{name}.
 find examples -name ".gitignore" -delete
 
 # Apply patches
+%patch0 -p1 -b .test
 %patch1 -p1 -b .non-x86
 
 # Fix pkgconfig generation
@@ -85,6 +89,7 @@ make install DESTDIR=%{buildroot}
 
 %changelog
 - Build with the bundled xdiff.
+- Disable a failing test. (libgit2#2199)
 
 * Sun Nov 24 2013 Ignacio Casal Quinteiro <icq@gnome.org> - 0.20.0-1
 - 0.20.0