Use Fedora standard linker flags

- Resolves #1548657

Signed-off-by: Rafael Santos <rdossant@redhat.com>
epel9
Rafael Santos 7 years ago
parent 4d67d81438
commit ea8e1ed339

@ -0,0 +1,11 @@
--- libgdither-0.6/Makefile 2018-04-10 18:23:46.000822954 +0200
+++ libgdither-0.6/Makefile 2018-04-10 18:25:25.783013273 +0200
@@ -10,7 +10,7 @@
$(CC) $(CFLAGS) -c gdither.c
libgdither.so: gdither.o
- $(CC) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
+ $(CC) $(LDFLAGS) -shared gdither.o -Wl,-soname,libgdither.so.1 -o libgdither.so.1.0
libgdither.pc: libgdither.pc.in Makefile
sed -e 's|@VERSION@|$(VERSION)|' -e 's|@PREFIX@|$(PREFIX)|' \

@ -1,6 +1,6 @@
Name: libgdither
Version: 0.6
Release: 15%{?dist}
Release: 16%{?dist}
Summary: Library for applying dithering to PCM audio sources
Group: System Environment/Libraries
@ -9,6 +9,7 @@ URL: http://plugin.org.uk/libgdither/README
Source0: http://plugin.org.uk/libgdither/libgdither-%{version}.tar.gz
Patch0: libgdither-0.6-default.patch
Patch1: libgdither-0.6-gavl.patch
Patch2: libgdither-0.6-ldflags.patch
BuildRequires: fftw-devel >= 3.0.0
@ -35,10 +36,12 @@ developing applications that use %{name}.
%setup -q
%patch0 -p1 -b .default
%patch1 -p1 -b .gavl_fix
%patch2 -p1 -b .ldflags
%build
export INIT_CFLAGS="${RPM_OPT_FLAGS}"
export LDFLAGS="%{build_ldflags}"
make %{?_smp_mflags}
@ -73,6 +76,9 @@ make test CFLAGS="${RPM_OPT_FLAGS} -Werror --std=c99 -I%{_builddir}/%{?buildsubd
%{_libdir}/pkgconfig/libgdither.pc
%changelog
* Tue Apr 10 2018 Rafael Santos <rdossant@redhat.com> - 0.6-16
- Use Fedora standard linker flags (bug #1548657)
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild

Loading…
Cancel
Save