You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
39 lines
1.2 KiB
39 lines
1.2 KiB
From 71ccd90029745e33eb62384e90069a77f5a69730 Mon Sep 17 00:00:00 2001
|
|
From: David Tardon <dtardon@redhat.com>
|
|
Date: Fri, 30 Sep 2016 10:40:03 +0200
|
|
Subject: [PATCH] make the mdds test forward-compatible
|
|
|
|
Change-Id: I8111097cbd51b5c875a9510ad26a2a0a7b8c90e8
|
|
---
|
|
configure.ac | 7 +++----
|
|
1 file changed, 3 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index bb946eb..39dd7fb 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -47,7 +47,7 @@ AC_PROG_SED
|
|
|
|
AM_MISSING_PROG([GPERF], [gperf])
|
|
|
|
-AS_IF([test "$with_mdds" = "1.0" -o "$with_mdds" = "1.2" ], [AX_CXX_COMPILE_STDCXX_11([noext])])
|
|
+AS_IF([test "$with_mdds" != "0.x"], [AX_CXX_COMPILE_STDCXX_11([noext])])
|
|
|
|
# ===============
|
|
# Find librevenge
|
|
@@ -138,9 +138,8 @@ AC_SUBST([GLM_CFLAGS])
|
|
# =========
|
|
# Find mdds
|
|
# =========
|
|
-AS_CASE(["$with_mdds"],
|
|
- ["1.2"], [PKG_CHECK_MODULES([MDDS], [mdds-1.2])],
|
|
- ["1.0"], [PKG_CHECK_MODULES([MDDS], [mdds-1.0])],
|
|
+AS_IF([test "$with_mdds" != "0.x"],
|
|
+ [PKG_CHECK_MODULES([MDDS], [mdds-][$with_mdds])],
|
|
[
|
|
PKG_CHECK_MODULES([MDDS], [mdds])
|
|
AC_MSG_CHECKING([checking if mdds::flat_segment_tree can store values of any type])
|
|
--
|
|
2.9.3
|
|
|