parent
2c255f4d1f
commit
7d51d87df2
@ -1,82 +0,0 @@
|
||||
From f6d14b3b510de5c50e45c98fe812a73ba00f3def Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Fridrich=20=C5=A0trba?= <fridrich.strba@bluewin.ch>
|
||||
Date: Thu, 9 Jun 2016 10:50:41 +0200
|
||||
Subject: [PATCH] Allow building with mdds-1.2
|
||||
|
||||
Change-Id: If8791b4c1c3fbefdd06af345276e0a724dff5482
|
||||
---
|
||||
configure.ac | 44 +++++++++++++++++++++++---------------------
|
||||
1 file changed, 23 insertions(+), 21 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index ca4bb07..bb946eb 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -24,7 +24,7 @@ AC_LANG([C++])
|
||||
# Configure options
|
||||
# =================
|
||||
AC_ARG_WITH([mdds],
|
||||
- AS_HELP_STRING([--with-mdds=1.0|0.x], [Specify which version of mdds to use (1.0 is the default)]),
|
||||
+ AS_HELP_STRING([--with-mdds=1.2|1.0|0.x], [Specify which version of mdds to use (1.0 is the default)]),
|
||||
[], [with_mdds="1.0"])
|
||||
|
||||
# ===========================
|
||||
@@ -47,7 +47,7 @@ AC_PROG_SED
|
||||
|
||||
AM_MISSING_PROG([GPERF], [gperf])
|
||||
|
||||
-AS_IF([test "$with_mdds" = "1.0"], [AX_CXX_COMPILE_STDCXX_11([noext])])
|
||||
+AS_IF([test "$with_mdds" = "1.0" -o "$with_mdds" = "1.2" ], [AX_CXX_COMPILE_STDCXX_11([noext])])
|
||||
|
||||
# ===============
|
||||
# Find librevenge
|
||||
@@ -138,25 +138,27 @@ AC_SUBST([GLM_CFLAGS])
|
||||
# =========
|
||||
# Find mdds
|
||||
# =========
|
||||
-AS_IF([test "$with_mdds" = "1.0"], [
|
||||
- PKG_CHECK_MODULES([MDDS], [mdds-1.0])
|
||||
-], [
|
||||
- PKG_CHECK_MODULES([MDDS], [mdds])
|
||||
- AC_MSG_CHECKING([checking if mdds::flat_segment_tree can store values of any type])
|
||||
- old_CPPFLAGS="$CPPFLAGS"
|
||||
- CPPFLAGS="$MDDS_CFLAGS $CPPFLAGS"
|
||||
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
||||
- #include <mdds/flat_segment_tree.hpp>
|
||||
- struct Value {};
|
||||
- mdds::flat_segment_tree<int, Value> tree(0, 4, Value());
|
||||
- ])], [
|
||||
- AC_MSG_RESULT([yes])
|
||||
- ], [
|
||||
- AC_MSG_RESULT([no])
|
||||
- AC_MSG_ERROR([please install mdds >= 0.12.1])
|
||||
- ])
|
||||
- CPPFLAGS="$old_CPPFLAGS"
|
||||
-])
|
||||
+AS_CASE(["$with_mdds"],
|
||||
+ ["1.2"], [PKG_CHECK_MODULES([MDDS], [mdds-1.2])],
|
||||
+ ["1.0"], [PKG_CHECK_MODULES([MDDS], [mdds-1.0])],
|
||||
+ [
|
||||
+ PKG_CHECK_MODULES([MDDS], [mdds])
|
||||
+ AC_MSG_CHECKING([checking if mdds::flat_segment_tree can store values of any type])
|
||||
+ old_CPPFLAGS="$CPPFLAGS"
|
||||
+ CPPFLAGS="$MDDS_CFLAGS $CPPFLAGS"
|
||||
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
|
||||
+ #include <mdds/flat_segment_tree.hpp>
|
||||
+ struct Value {};
|
||||
+ mdds::flat_segment_tree<int, Value> tree(0, 4, Value());
|
||||
+ ])], [
|
||||
+ AC_MSG_RESULT([yes])
|
||||
+ ], [
|
||||
+ AC_MSG_RESULT([no])
|
||||
+ AC_MSG_ERROR([please install mdds >= 0.12.1])
|
||||
+ ])
|
||||
+ CPPFLAGS="$old_CPPFLAGS"
|
||||
+ ]
|
||||
+)
|
||||
|
||||
# =================================
|
||||
# Libtool/Version Makefile settings
|
||||
--
|
||||
2.9.3
|
||||
|
@ -1,36 +0,0 @@
|
||||
From f0a19c02185babc48926b50a47ccdcc0ac443ecc Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Wed, 22 Feb 2017 21:52:23 +0100
|
||||
Subject: [PATCH] disable test on aarch64
|
||||
|
||||
Change-Id: I57069c5206dd82d6667ae15bad65d2a9717dabad
|
||||
---
|
||||
src/test/IWORKPathTest.cpp | 12 ------------
|
||||
1 file changed, 12 deletions(-)
|
||||
|
||||
diff --git a/src/test/IWORKPathTest.cpp b/src/test/IWORKPathTest.cpp
|
||||
index 1290dc8..abcdbc7 100644
|
||||
--- a/src/test/IWORKPathTest.cpp
|
||||
+++ b/src/test/IWORKPathTest.cpp
|
||||
@@ -60,18 +60,6 @@ void IWORKPathTest::testConstruction()
|
||||
CPPUNIT_ASSERT_NO_THROW((IWORKPath(src)));
|
||||
CPPUNIT_ASSERT_EQUAL(string("M 0 0 C 0.5 0.5 0 0 1 1"), IWORKPath(src).str());
|
||||
}
|
||||
-
|
||||
- {
|
||||
- const string src = "M 0 0 L 1 0 L 1 1 L 0 1 Z M 0 0";
|
||||
- CPPUNIT_ASSERT_NO_THROW((IWORKPath(src)));
|
||||
- CPPUNIT_ASSERT_EQUAL(string("M 0 0 L 1 0 L 1 1 L 0 1 Z"), IWORKPath(src).str());
|
||||
- }
|
||||
-
|
||||
- {
|
||||
- const string src = "M 0.0 0.0 L 0 1 C 1 1 0.5 0.5 0 0 Z M 0 0";
|
||||
- CPPUNIT_ASSERT_NO_THROW((IWORKPath(src)));
|
||||
- CPPUNIT_ASSERT_EQUAL(string("M 0 0 L 0 1 C 1 1 0.5 0.5 0 0 Z"), IWORKPath(src).str());
|
||||
- }
|
||||
}
|
||||
|
||||
void IWORKPathTest::testConversion()
|
||||
--
|
||||
2.9.3
|
||||
|
@ -1,36 +0,0 @@
|
||||
From 1a20d8ece2ea3e8aa1d319cd88e8a6aa637982f2 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Fri, 30 Sep 2016 09:57:15 +0200
|
||||
Subject: [PATCH] drop test that violates Unicode tr#35
|
||||
|
||||
(and therefore fails with latest liblangtag)
|
||||
|
||||
Change-Id: I0e06c6c4e8bcf999cf5559d6287e77ae97e555d8
|
||||
---
|
||||
src/test/IWORKLanguageManagerTest.cpp | 10 ----------
|
||||
1 file changed, 10 deletions(-)
|
||||
|
||||
diff --git a/src/test/IWORKLanguageManagerTest.cpp b/src/test/IWORKLanguageManagerTest.cpp
|
||||
index 8fca0a6..e663bd2 100644
|
||||
--- a/src/test/IWORKLanguageManagerTest.cpp
|
||||
+++ b/src/test/IWORKLanguageManagerTest.cpp
|
||||
@@ -104,16 +104,6 @@ void IWORKLanguageManagerTest::testTagToProps()
|
||||
}
|
||||
|
||||
{
|
||||
- const string tag(mgr.addTag("ccc"));
|
||||
- CPPUNIT_ASSERT(!tag.empty());
|
||||
- RVNGPropertyList props;
|
||||
- mgr.writeProperties(tag, props);
|
||||
- assertProperty("unknown lang", props, "fo:language", "ccc");
|
||||
- CPPUNIT_ASSERT(!props["fo:country"]);
|
||||
- CPPUNIT_ASSERT(!props["fo:script"]);
|
||||
- }
|
||||
-
|
||||
- {
|
||||
// invalid tag
|
||||
const string tag(mgr.addTag("13c"));
|
||||
CPPUNIT_ASSERT(tag.empty());
|
||||
--
|
||||
2.9.3
|
||||
|
@ -1,26 +0,0 @@
|
||||
From b63a2f52d95243aef4660b2d4573f0e149eeb9a6 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Wed, 22 Feb 2017 15:03:19 -0500
|
||||
Subject: [PATCH] fix test on i686
|
||||
|
||||
Change-Id: Ib9dafdfd76175cc6bbcd94596f7a7bd8b924ed34
|
||||
---
|
||||
src/test/IWORKTransformationTest.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/test/IWORKTransformationTest.cpp b/src/test/IWORKTransformationTest.cpp
|
||||
index 77f0b27..5e96e60 100644
|
||||
--- a/src/test/IWORKTransformationTest.cpp
|
||||
+++ b/src/test/IWORKTransformationTest.cpp
|
||||
@@ -232,7 +232,7 @@ void IWORKTransformationTest::testInverseOperations()
|
||||
|
||||
CPPUNIT_ASSERT(scale(2, 1) * scale(0.5, 1) == eye);
|
||||
CPPUNIT_ASSERT(scale(1, 2) * scale(1, 0.5) == eye);
|
||||
- CPPUNIT_ASSERT(scale(3, 2) * scale(1.0 / 3, 0.5) == eye);
|
||||
+ CPPUNIT_ASSERT(approxEqual(scale(3, 2) * scale(1.0 / 3, 0.5), eye));
|
||||
|
||||
// CPPUNIT_ASSERT(shear() == eye);
|
||||
|
||||
--
|
||||
2.11.1
|
||||
|
@ -1,38 +0,0 @@
|
||||
From 71ccd90029745e33eb62384e90069a77f5a69730 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Fri, 30 Sep 2016 10:40:03 +0200
|
||||
Subject: [PATCH] make the mdds test forward-compatible
|
||||
|
||||
Change-Id: I8111097cbd51b5c875a9510ad26a2a0a7b8c90e8
|
||||
---
|
||||
configure.ac | 7 +++----
|
||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index bb946eb..39dd7fb 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -47,7 +47,7 @@ AC_PROG_SED
|
||||
|
||||
AM_MISSING_PROG([GPERF], [gperf])
|
||||
|
||||
-AS_IF([test "$with_mdds" = "1.0" -o "$with_mdds" = "1.2" ], [AX_CXX_COMPILE_STDCXX_11([noext])])
|
||||
+AS_IF([test "$with_mdds" != "0.x"], [AX_CXX_COMPILE_STDCXX_11([noext])])
|
||||
|
||||
# ===============
|
||||
# Find librevenge
|
||||
@@ -138,9 +138,8 @@ AC_SUBST([GLM_CFLAGS])
|
||||
# =========
|
||||
# Find mdds
|
||||
# =========
|
||||
-AS_CASE(["$with_mdds"],
|
||||
- ["1.2"], [PKG_CHECK_MODULES([MDDS], [mdds-1.2])],
|
||||
- ["1.0"], [PKG_CHECK_MODULES([MDDS], [mdds-1.0])],
|
||||
+AS_IF([test "$with_mdds" != "0.x"],
|
||||
+ [PKG_CHECK_MODULES([MDDS], [mdds-][$with_mdds])],
|
||||
[
|
||||
PKG_CHECK_MODULES([MDDS], [mdds])
|
||||
AC_MSG_CHECKING([checking if mdds::flat_segment_tree can store values of any type])
|
||||
--
|
||||
2.9.3
|
||||
|
Loading…
Reference in new issue