parent
c71c45c8e0
commit
c5b8b52fc4
@ -1,3 +1,3 @@
|
||||
libesmtp-1.0.3r1.tar.bz2
|
||||
libesmtp-ssl.patch
|
||||
COPYING.LGPL
|
||||
libesmtp-1.0.4-ssl.patch
|
||||
libesmtp-build.patch
|
||||
libesmtp-1.0.4.tar.bz2
|
||||
|
@ -1,103 +1,28 @@
|
||||
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/configure.in libesmtp-1.0.3r1/configure.in
|
||||
--- libesmtp-1.0.3r1-orig/configure.in 2004-04-21 10:21:32.000000000 +0200
|
||||
+++ libesmtp-1.0.3r1/configure.in 2005-05-26 23:34:19.000000000 +0200
|
||||
@@ -56,7 +56,7 @@
|
||||
dnl Miscellaneous stuff
|
||||
dnl #########################################################################
|
||||
|
||||
-EXTRA_CFLAGS=""
|
||||
+AM_CFLAGS=""
|
||||
case $host_vendor-$host_os in
|
||||
sun*)
|
||||
AC_DEFINE(__EXTENSIONS__,1,[Sun's netdb.h needs this for getaddrinfo])
|
||||
@@ -79,13 +79,13 @@
|
||||
enable_more_warnings=yes)
|
||||
|
||||
if test "$GCC" = "yes" -a "$enable_more_warnings" != "no"; then
|
||||
- EXTRA_CFLAGS="$EXTRA_CFLAGS \
|
||||
+ AM_CFLAGS="$AM_CFLAGS \
|
||||
-Wall -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes \
|
||||
-Wstrict-prototypes -Wnested-externs -Wpointer-arith \
|
||||
-Wbad-function-cast -Wcast-align"
|
||||
fi
|
||||
if test "$GCC" = "yes" -a "$enable_more_warnings" = "picky"; then
|
||||
- EXTRA_CFLAGS="$EXTRA_CFLAGS -fno-builtin -W -Werror -Wwrite-strings \
|
||||
+ $AM_CFLAGS="$AM_CFLAGS -fno-builtin -W -Werror -Wwrite-strings \
|
||||
-Wcast-qual"
|
||||
fi
|
||||
|
||||
@@ -538,7 +538,7 @@
|
||||
dnl #########################################################################
|
||||
|
||||
AC_REPLACE_FUNCS(strdup strcasecmp strncasecmp memrchr)
|
||||
-AC_CHECK_FUNCS(strtol uname gethostname)
|
||||
+AC_CHECK_FUNCS(strtol uname gethostname snprintf vsnprintf)
|
||||
AC_SEARCH_LIBS(socket, socket)
|
||||
|
||||
dnl Conditional check for functions needed in threaded code
|
||||
@@ -582,9 +582,7 @@
|
||||
AC_SUBST(DIST_PLUGINS)
|
||||
AC_SUBST(LIBTOOL_DEPS)
|
||||
AC_SUBST(LIBS)
|
||||
-AC_SUBST(CFLAGS)
|
||||
-AC_SUBST(EXTRA_CFLAGS)
|
||||
-AC_SUBST(CC)
|
||||
+AC_SUBST(AM_CFLAGS)
|
||||
AC_SUBST(RANLIB)
|
||||
AC_SUBST(subdirs)
|
||||
|
||||
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/crammd5/Makefile.am libesmtp-1.0.3r1/crammd5/Makefile.am
|
||||
--- libesmtp-1.0.3r1-orig/crammd5/Makefile.am 2001-10-17 11:15:27.000000000 +0200
|
||||
+++ libesmtp-1.0.3r1/crammd5/Makefile.am 2005-05-26 23:28:15.000000000 +0200
|
||||
@@ -3,7 +3,6 @@
|
||||
libdir = @plugindir@
|
||||
|
||||
INCLUDES = -I@srcdir@
|
||||
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||
|
||||
lib_LTLIBRARIES = sasl-cram-md5.la
|
||||
|
||||
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/login/Makefile.am libesmtp-1.0.3r1/login/Makefile.am
|
||||
--- libesmtp-1.0.3r1-orig/login/Makefile.am 2001-10-17 09:18:00.000000000 +0200
|
||||
+++ libesmtp-1.0.3r1/login/Makefile.am 2005-05-26 23:28:12.000000000 +0200
|
||||
@@ -5,7 +5,6 @@
|
||||
INCLUDES = -I@srcdir@
|
||||
|
||||
lib_LTLIBRARIES = sasl-login.la
|
||||
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||
|
||||
sasl_login_la_SOURCES = client-login.c
|
||||
sasl_login_la_LDFLAGS = -module -avoid-version
|
||||
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/Makefile.am libesmtp-1.0.3r1/Makefile.am
|
||||
--- libesmtp-1.0.3r1-orig/Makefile.am 2003-01-22 09:45:23.000000000 +0100
|
||||
+++ libesmtp-1.0.3r1/Makefile.am 2005-05-26 23:28:20.000000000 +0200
|
||||
@@ -4,7 +4,6 @@
|
||||
INCLUDES = -I$(srcdir) $(VERSION_FLAGS)
|
||||
SUBDIRS = @subdirs@ @SASL_PLUGINS@
|
||||
DIST_SUBDIRS = @subdirs@ @DIST_PLUGINS@
|
||||
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||
|
||||
lib_LTLIBRARIES = libesmtp.la
|
||||
|
||||
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/ntlm/Makefile.am libesmtp-1.0.3r1/ntlm/Makefile.am
|
||||
--- libesmtp-1.0.3r1-orig/ntlm/Makefile.am 2002-05-31 15:35:47.000000000 +0200
|
||||
+++ libesmtp-1.0.3r1/ntlm/Makefile.am 2005-05-26 23:28:08.000000000 +0200
|
||||
@@ -3,7 +3,6 @@
|
||||
libdir = @plugindir@
|
||||
|
||||
INCLUDES = -I@srcdir@
|
||||
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||
|
||||
lib_LTLIBRARIES = sasl-ntlm.la
|
||||
|
||||
diff -ru -x '*.lo' -x '*.o' libesmtp-1.0.3r1-orig/plain/Makefile.am libesmtp-1.0.3r1/plain/Makefile.am
|
||||
--- libesmtp-1.0.3r1-orig/plain/Makefile.am 2001-10-17 09:18:08.000000000 +0200
|
||||
+++ libesmtp-1.0.3r1/plain/Makefile.am 2005-05-26 23:28:04.000000000 +0200
|
||||
@@ -3,7 +3,6 @@
|
||||
libdir = @plugindir@
|
||||
|
||||
INCLUDES = -I@srcdir@
|
||||
-CFLAGS = @CFLAGS@ @EXTRA_CFLAGS@
|
||||
|
||||
lib_LTLIBRARIES = sasl-plain.la
|
||||
--- libesmtp-1.0.4/missing.h.build 2004-04-19 13:15:45.000000000 +0200
|
||||
+++ libesmtp-1.0.4/missing.h 2006-03-24 23:50:38.000000000 +0100
|
||||
@@ -43,15 +43,4 @@
|
||||
void *memrchr (const void *a, int c, size_t len);
|
||||
#endif
|
||||
|
||||
-#ifndef HAVE_SNPRINTF
|
||||
-#include <sys/types.h>
|
||||
-int snprintf(char *s, size_t n, const char *format, ...);
|
||||
-#endif
|
||||
-
|
||||
-#ifndef HAVE_VSNPRINTF
|
||||
-#include <stdarg.h>
|
||||
-#include <sys/types.h>
|
||||
-int vsnprintf(char *s, size_t n, const char *format, va_list ap);
|
||||
-#endif
|
||||
-
|
||||
#endif
|
||||
--- libesmtp-1.0.4/headers.c~ 2005-12-15 21:52:01.000000000 +0100
|
||||
+++ libesmtp-1.0.4/headers.c 2006-03-24 23:53:58.000000000 +0100
|
||||
@@ -33,6 +33,7 @@
|
||||
#include <unistd.h>
|
||||
#include <time.h>
|
||||
#include <errno.h>
|
||||
+#include <sys/time.h>
|
||||
|
||||
#include <missing.h>
|
||||
|
||||
|
@ -1,3 +1,3 @@
|
||||
c07aa79293aa36298626fe5e68d6bfba libesmtp-1.0.3r1.tar.bz2
|
||||
f018f16cbebc56490d2c3c18a23d3113 libesmtp-ssl.patch
|
||||
a6f89e2100d9b6cdffcea4f398e37343 COPYING.LGPL
|
||||
8ddc9f7691fa3561e4a73dafb6658369 libesmtp-1.0.4-ssl.patch
|
||||
d0397bf2129d3a213cbc3d5cc74b9b63 libesmtp-build.patch
|
||||
8b4e8a794adc46268f0c6a0b3fb79486 libesmtp-1.0.4.tar.bz2
|
||||
|
Loading…
Reference in new issue