parent
2cb33d384f
commit
6e7391cac0
@ -0,0 +1,36 @@
|
||||
diff -up libdmtx-0.7.5/test/multi_test/Makefile.am.std libdmtx-0.7.5/test/multi_test/Makefile.am
|
||||
--- libdmtx-0.7.5/test/multi_test/Makefile.am.std 2018-04-06 13:14:23.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/multi_test/Makefile.am 2018-04-06 13:14:27.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-AM_CPPFLAGS = -Wshadow -Wall -pedantic -ansi
|
||||
+AM_CPPFLAGS = -Wshadow -Wall -pedantic -std=c99
|
||||
|
||||
check_PROGRAMS = multi_test
|
||||
|
||||
diff -up libdmtx-0.7.5/test/rotate_test/Makefile.am.std libdmtx-0.7.5/test/rotate_test/Makefile.am
|
||||
--- libdmtx-0.7.5/test/rotate_test/Makefile.am.std 2018-04-06 13:14:13.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/rotate_test/Makefile.am 2018-04-06 13:14:18.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-AM_CPPFLAGS = -Wshadow -Wall -pedantic -ansi
|
||||
+AM_CPPFLAGS = -Wshadow -Wall -pedantic -std=c99
|
||||
|
||||
check_PROGRAMS = rotate_test
|
||||
|
||||
diff -up libdmtx-0.7.5/test/simple_test/Makefile.am.std libdmtx-0.7.5/test/simple_test/Makefile.am
|
||||
--- libdmtx-0.7.5/test/simple_test/Makefile.am.std 2018-04-06 13:13:59.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/simple_test/Makefile.am 2018-04-06 13:14:04.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-AM_CPPFLAGS = -Wshadow -Wall -pedantic -ansi
|
||||
+AM_CPPFLAGS = -Wshadow -Wall -pedantic -std=c99
|
||||
|
||||
check_PROGRAMS = simple_test
|
||||
|
||||
diff -up libdmtx-0.7.5/test/unit_test/Makefile.am.std libdmtx-0.7.5/test/unit_test/Makefile.am
|
||||
--- libdmtx-0.7.5/test/unit_test/Makefile.am.std 2018-04-06 13:13:41.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/unit_test/Makefile.am 2018-04-06 13:13:53.000000000 +0200
|
||||
@@ -1,4 +1,4 @@
|
||||
-AM_CPPFLAGS = -Wshadow -Wall -pedantic -ansi
|
||||
+AM_CPPFLAGS = -Wshadow -Wall -pedantic -std=c99
|
||||
|
||||
check_PROGRAMS = unit_test
|
||||
|
@ -0,0 +1,11 @@
|
||||
diff -up libdmtx-0.7.5/test/simple_test/simple_test.c.math libdmtx-0.7.5/test/simple_test/simple_test.c
|
||||
--- libdmtx-0.7.5/test/simple_test/simple_test.c.math 2018-04-06 13:19:44.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/simple_test/simple_test.c 2018-04-06 13:19:52.000000000 +0200
|
||||
@@ -18,6 +18,7 @@
|
||||
#include <stdio.h>
|
||||
#include <string.h>
|
||||
#include <assert.h>
|
||||
+#include <math.h>
|
||||
#include <dmtx.h>
|
||||
|
||||
int
|
@ -0,0 +1,29 @@
|
||||
diff -up libdmtx-0.7.5/test/simple_test/simple_test.c.size_t libdmtx-0.7.5/test/simple_test/simple_test.c
|
||||
--- libdmtx-0.7.5/test/simple_test/simple_test.c.size_t 2018-04-06 13:16:35.000000000 +0200
|
||||
+++ libdmtx-0.7.5/test/simple_test/simple_test.c 2018-04-06 13:17:14.000000000 +0200
|
||||
@@ -58,9 +58,9 @@ main(int argc, char *argv[])
|
||||
|
||||
dmtxEncodeDestroy(&enc);
|
||||
|
||||
- fprintf(stdout, "width: \"%d\"\n", width);
|
||||
- fprintf(stdout, "height: \"%d\"\n", height);
|
||||
- fprintf(stdout, "bpp: \"%d\"\n", bytesPerPixel);
|
||||
+ fprintf(stdout, "width: \"%zd\"\n", width);
|
||||
+ fprintf(stdout, "height: \"%zd\"\n", height);
|
||||
+ fprintf(stdout, "bpp: \"%zd\"\n", bytesPerPixel);
|
||||
|
||||
for (int i=0; i<width*height; i++){
|
||||
fprintf(stdout, "%d", (pxl[i*3])==0);
|
||||
@@ -81,9 +81,9 @@ main(int argc, char *argv[])
|
||||
if(reg != NULL) {
|
||||
msg = dmtxDecodeMatrixRegion(dec, reg, DmtxUndefined);
|
||||
|
||||
- fprintf(stdout, "msg->arraySize : \"%d\"\n", msg->arraySize );
|
||||
- fprintf(stdout, "msg->codeSize : \"%d\"\n", msg->codeSize );
|
||||
- fprintf(stdout, "msg->outputSize: \"%d\"\n", msg->outputSize);
|
||||
+ fprintf(stdout, "msg->arraySize : \"%zd\"\n", msg->arraySize );
|
||||
+ fprintf(stdout, "msg->codeSize : \"%zd\"\n", msg->codeSize );
|
||||
+ fprintf(stdout, "msg->outputSize: \"%zd\"\n", msg->outputSize);
|
||||
int oned = sqrt(msg->arraySize);
|
||||
for (int i=0; i<msg->arraySize; i++){
|
||||
fprintf(stdout, " %c.", msg->array[i]);
|
Loading…
Reference in new issue