You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
31 lines
868 B
31 lines
868 B
From 08f3403fb6bea17775dacc51c055b3b46f425326 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
|
Date: Fri, 15 Apr 2016 11:06:42 +0200
|
|
Subject: [PATCH] fallback to pkg-config if cppunit-config is not available
|
|
|
|
Recent version of cppunit packages do not distribute the cppunit-config script
|
|
and expect the usage of pkgconfig file.
|
|
---
|
|
configure.ac | 8 +++++++-
|
|
1 file changed, 7 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 2a7f158..9467a87 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -305,7 +305,13 @@ AC_SUBST([UUID_LIBS])
|
|
|
|
AM_PATH_CPPUNIT(1.12.0,
|
|
[AM_CONDITIONAL([CPPUNIT], [true])],
|
|
- [AM_CONDITIONAL([CPPUNIT], [false])])
|
|
+ [
|
|
+ PKG_CHECK_MODULES(CPPUNIT, [cppunit >= 1.12.0],
|
|
+ [AM_CONDITIONAL([CPPUNIT], [true])],
|
|
+ [AM_CONDITIONAL([CPPUNIT], [false])]
|
|
+ )
|
|
+ ]
|
|
+)
|
|
|
|
DODS_DEBUG_OPTION
|
|
|