- Add missing big endian baselines (#1366787)
parent
63c77afdee
commit
fa2afd60df
@ -1,418 +1,173 @@
|
||||
From 080ce6905700259413076fb159f0ebb42235e2e5 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Thu, 14 Apr 2016 19:31:45 +0200
|
||||
Subject: [PATCH 1/2] add big endian baseline files for new tests
|
||||
commit fb5ea7a3554d0cbd0e287b27b9c0b5c06b5c0388
|
||||
Author: Dan Horák <dan@danny.cz>
|
||||
Date: Fri Aug 26 14:59:09 2016 +0200
|
||||
|
||||
---
|
||||
.../big-endian/test_array_12.xml.intern_base | 23 ++++++++++++++++
|
||||
.../big-endian/test_array_12.xml.trans_base | 29 ++++++++++++++++++++
|
||||
.../big-endian/test_array_13.xml.intern_base | 25 +++++++++++++++++
|
||||
.../big-endian/test_array_13.xml.trans_base | 31 ++++++++++++++++++++++
|
||||
.../big-endian/test_array_14.xml.intern_base | 25 +++++++++++++++++
|
||||
.../big-endian/test_array_14.xml.trans_base | 31 ++++++++++++++++++++++
|
||||
.../big-endian/test_array_9.xml.intern_base | 17 ++++++++++++
|
||||
.../big-endian/test_array_9.xml.trans_base | 20 ++++++++++++++
|
||||
.../big-endian/test_simple_6.2.xml.intern_base | 13 +++++++++
|
||||
.../big-endian/test_simple_6.2.xml.trans_base | 17 ++++++++++++
|
||||
.../big-endian/test_simple_6.3.xml.intern_base | 21 +++++++++++++++
|
||||
.../big-endian/test_simple_6.3.xml.trans_base | 24 +++++++++++++++++
|
||||
12 files changed, 276 insertions(+)
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_array_12.xml.intern_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_array_12.xml.trans_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_array_13.xml.intern_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_array_13.xml.trans_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_array_14.xml.intern_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_array_14.xml.trans_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_array_9.xml.intern_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_array_9.xml.trans_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_simple_6.2.xml.intern_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_simple_6.2.xml.trans_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_simple_6.3.xml.intern_base
|
||||
create mode 100644 tests/dmr-testsuite/big-endian/test_simple_6.3.xml.trans_base
|
||||
add missing big endian baselines
|
||||
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_12.xml.intern_base b/tests/dmr-testsuite/big-endian/test_array_12.xml.intern_base
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.1.trans_base b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.1.trans_base
|
||||
new file mode 100644
|
||||
index 0000000..c83cac0
|
||||
index 0000000..fddf8f8
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_12.xml.intern_base
|
||||
@@ -0,0 +1,23 @@
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.1.trans_base
|
||||
@@ -0,0 +1,33 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ </Int32>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <Dimension name="row" size="5"/>
|
||||
+ <Float32 name="row">
|
||||
+ <Dim name="/row"/>
|
||||
+ </Float32>
|
||||
+ <String name="x">
|
||||
+ <Dim name="/row"/>
|
||||
+ <Map name="/row"/>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ {123456789, 123456789, 123456789, 123456789, 123456789}, {} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_12.xml.trans_base b/tests/dmr-testsuite/big-endian/test_array_12.xml.trans_base
|
||||
new file mode 100644
|
||||
index 0000000..306fe92
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_12.xml.trans_base
|
||||
@@ -0,0 +1,29 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <Dimension name="row" size="5"/>
|
||||
+ <Float32 name="row">
|
||||
+ <Dim name="/row"/>
|
||||
+ <Attribute name="DAP4_Checksum_CRC32" type="String">
|
||||
+ <Value>ebd5bedf</Value>
|
||||
+ <Value>d5c902a7</Value>
|
||||
+ </Attribute>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ </Float32>
|
||||
+ <String name="x">
|
||||
+ <Dim name="/row"/>
|
||||
+ <Attribute name="DAP4_Checksum_CRC32" type="String">
|
||||
+ <Value>00000000</Value>
|
||||
+ <Value>d2207316</Value>
|
||||
+ </Attribute>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ {123456789, 123456789, 123456789, 123456789, 123456789}, {} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_13.xml.intern_base b/tests/dmr-testsuite/big-endian/test_array_13.xml.intern_base
|
||||
new file mode 100644
|
||||
index 0000000..4dde012
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_13.xml.intern_base
|
||||
@@ -0,0 +1,25 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="4"/>
|
||||
+ <Dim size="0"/>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="4"/>
|
||||
+ <Dim size="0"/>
|
||||
+ </Int32>
|
||||
+ <Map name="/row"/>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ {123456789, 123456789, 123456789, 123456789, 123456789}, {{},{},{},{}} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_13.xml.trans_base b/tests/dmr-testsuite/big-endian/test_array_13.xml.trans_base
|
||||
+{ {99.999, 99.999, 99.999, 99.999, 99.999}, {"Silly test string: 1", "Silly test string: 1", "Silly test string: 1", "Silly test string: 1", "Silly test string: 1"} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.2.trans_base b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.2.trans_base
|
||||
new file mode 100644
|
||||
index 0000000..21e4274
|
||||
index 0000000..90e228f
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_13.xml.trans_base
|
||||
@@ -0,0 +1,31 @@
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.2.trans_base
|
||||
@@ -0,0 +1,27 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="4"/>
|
||||
+ <Dim size="0"/>
|
||||
+ </Int32>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <Dimension name="row" size="5"/>
|
||||
+ <Float32 name="row">
|
||||
+ <Dim name="/row"/>
|
||||
+ </Float32>
|
||||
+ <String name="x">
|
||||
+ <Dim name="/row"/>
|
||||
+ <Map name="/row"/>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <Dimension name="row" size="2"/>
|
||||
+ <String name="x">
|
||||
+ <Dim name="/row"/>
|
||||
+ <Attribute name="DAP4_Checksum_CRC32" type="String">
|
||||
+ <Value>ebd5bedf</Value>
|
||||
+ <Value>55708e52</Value>
|
||||
+ </Attribute>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="4"/>
|
||||
+ <Dim size="0"/>
|
||||
+ <Attribute name="DAP4_Checksum_CRC32" type="String">
|
||||
+ <Value>00000000</Value>
|
||||
+ </Attribute>
|
||||
+ </Int32>
|
||||
+ <Map name="/row"/>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ {123456789, 123456789, 123456789, 123456789, 123456789}, {{},{},{},{}} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_14.xml.intern_base b/tests/dmr-testsuite/big-endian/test_array_14.xml.intern_base
|
||||
+{ {"Silly test string: 1", "Silly test string: 1"} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.3.trans_base b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.3.trans_base
|
||||
new file mode 100644
|
||||
index 0000000..99eeb81
|
||||
index 0000000..80ade42
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_14.xml.intern_base
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.3.trans_base
|
||||
@@ -0,0 +1,25 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ <Dim size="4"/>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ <Dim size="4"/>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ {123456789, 123456789, 123456789, 123456789, 123456789}, {} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_14.xml.trans_base b/tests/dmr-testsuite/big-endian/test_array_14.xml.trans_base
|
||||
new file mode 100644
|
||||
index 0000000..84f92ae
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_14.xml.trans_base
|
||||
@@ -0,0 +1,31 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ <Dim size="4"/>
|
||||
+ </Int32>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <Dimension name="row" size="5"/>
|
||||
+ <Float32 name="row">
|
||||
+ <Dim name="/row"/>
|
||||
+ </Float32>
|
||||
+ <String name="x">
|
||||
+ <Dim name="/row"/>
|
||||
+ <Map name="/row"/>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="i">
|
||||
+ <Dim size="5"/>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <String name="x">
|
||||
+ <Dim size="2"/>
|
||||
+ <Attribute name="DAP4_Checksum_CRC32" type="String">
|
||||
+ <Value>ebd5bedf</Value>
|
||||
+ <Value>55708e52</Value>
|
||||
+ </Attribute>
|
||||
+ </Int32>
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ <Dim size="4"/>
|
||||
+ <Attribute name="DAP4_Checksum_CRC32" type="String">
|
||||
+ <Value>00000000</Value>
|
||||
+ </Attribute>
|
||||
+ </Int32>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ {123456789, 123456789, 123456789, 123456789, 123456789}, {} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_9.xml.intern_base b/tests/dmr-testsuite/big-endian/test_array_9.xml.intern_base
|
||||
+{ {"Silly test string: 1", "Silly test string: 1"} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.4.trans_base b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.4.trans_base
|
||||
new file mode 100644
|
||||
index 0000000..2f53699
|
||||
index 0000000..80ade42
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_9.xml.intern_base
|
||||
@@ -0,0 +1,17 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ {} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_9.xml.trans_base b/tests/dmr-testsuite/big-endian/test_array_9.xml.trans_base
|
||||
new file mode 100644
|
||||
index 0000000..e24d475
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_9.xml.trans_base
|
||||
@@ -0,0 +1,20 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_9.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_9">
|
||||
+ <Int32 name="x">
|
||||
+ <Dim size="0"/>
|
||||
+ <Attribute name="DAP4_Checksum_CRC32" type="String">
|
||||
+ <Value>00000000</Value>
|
||||
+ </Attribute>
|
||||
+ </Int32>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ {} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_simple_6.2.xml.intern_base b/tests/dmr-testsuite/big-endian/test_simple_6.2.xml.intern_base
|
||||
new file mode 100644
|
||||
index 0000000..014c72e
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_simple_6.2.xml.intern_base
|
||||
@@ -0,0 +1,13 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_simple_6.2.xml" dapVersion="4.0" dmrVersion="1.0" name="test_simple_6.2">
|
||||
+ <Structure name="s"/>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_simple_6.2.xml" dapVersion="4.0" dmrVersion="1.0" name="test_simple_6.2">
|
||||
+ <Structure name="s"/>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ { } }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_simple_6.2.xml.trans_base b/tests/dmr-testsuite/big-endian/test_simple_6.2.xml.trans_base
|
||||
new file mode 100644
|
||||
index 0000000..b393e3f
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_simple_6.2.xml.trans_base
|
||||
@@ -0,0 +1,17 @@
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.4.trans_base
|
||||
@@ -0,0 +1,25 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_simple_6.2.xml" dapVersion="4.0" dmrVersion="1.0" name="test_simple_6.2">
|
||||
+ <Structure name="s"/>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <Dimension name="row" size="5"/>
|
||||
+ <Float32 name="row">
|
||||
+ <Dim name="/row"/>
|
||||
+ </Float32>
|
||||
+ <String name="x">
|
||||
+ <Dim name="/row"/>
|
||||
+ <Map name="/row"/>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_simple_6.2.xml" dapVersion="4.0" dmrVersion="1.0" name="test_simple_6.2">
|
||||
+ <Structure name="s">
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <String name="x">
|
||||
+ <Dim size="2"/>
|
||||
+ <Attribute name="DAP4_Checksum_CRC32" type="String">
|
||||
+ <Value>00000000</Value>
|
||||
+ <Value>55708e52</Value>
|
||||
+ </Attribute>
|
||||
+ </Structure>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ { } }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_simple_6.3.xml.intern_base b/tests/dmr-testsuite/big-endian/test_simple_6.3.xml.intern_base
|
||||
new file mode 100644
|
||||
index 0000000..c0ea6cc
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_simple_6.3.xml.intern_base
|
||||
@@ -0,0 +1,21 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_simple_6.3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_simple_6.3">
|
||||
+ <Structure name="s">
|
||||
+ <Int32 name="i1"/>
|
||||
+ <String name="s"/>
|
||||
+ <Structure name="inner"/>
|
||||
+ </Structure>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_simple_6.3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_simple_6.3">
|
||||
+ <Structure name="s">
|
||||
+ <Int32 name="i1"/>
|
||||
+ <String name="s"/>
|
||||
+ <Structure name="inner"/>
|
||||
+ </Structure>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ { 123456789, "Silly test string: 1", { } } }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_simple_6.3.xml.trans_base b/tests/dmr-testsuite/big-endian/test_simple_6.3.xml.trans_base
|
||||
+{ {"Silly test string: 1", "Silly test string: 1"} }
|
||||
diff --git a/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.5.trans_base b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.5.trans_base
|
||||
new file mode 100644
|
||||
index 0000000..d260d64
|
||||
index 0000000..8943261
|
||||
--- /dev/null
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_simple_6.3.xml.trans_base
|
||||
@@ -0,0 +1,24 @@
|
||||
+++ b/tests/dmr-testsuite/big-endian/test_array_3.1.dmr.5.trans_base
|
||||
@@ -0,0 +1,27 @@
|
||||
+Parse successful
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_simple_6.3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_simple_6.3">
|
||||
+ <Structure name="s">
|
||||
+ <Int32 name="i1"/>
|
||||
+ <String name="s"/>
|
||||
+ <Structure name="inner"/>
|
||||
+ </Structure>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <Dimension name="row" size="5"/>
|
||||
+ <Float32 name="row">
|
||||
+ <Dim name="/row"/>
|
||||
+ </Float32>
|
||||
+ <String name="x">
|
||||
+ <Dim name="/row"/>
|
||||
+ <Map name="/row"/>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+<?xml version="1.0" encoding="ISO-8859-1"?>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_simple_6.3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_simple_6.3">
|
||||
+ <Structure name="s">
|
||||
+ <Int32 name="i1"/>
|
||||
+ <String name="s"/>
|
||||
+ <Structure name="inner"/>
|
||||
+<Dataset xmlns="http://xml.opendap.org/ns/DAP/4.0#" xml:base="file:dap4/test_array_3.xml" dapVersion="4.0" dmrVersion="1.0" name="test_array_3">
|
||||
+ <Dimension name="row" size="5"/>
|
||||
+ <String name="x">
|
||||
+ <Dim name="/row"/>
|
||||
+ <Attribute name="DAP4_Checksum_CRC32" type="String">
|
||||
+ <Value>63dceb61</Value>
|
||||
+ <Value>d2207316</Value>
|
||||
+ </Attribute>
|
||||
+ </Structure>
|
||||
+ <Map name="/row"/>
|
||||
+ </String>
|
||||
+</Dataset>
|
||||
+
|
||||
+The data:
|
||||
+{ { 123456789, "Silly test string: 1", { } } }
|
||||
|
||||
From c88a7588892ccaa22954c32bd2f606005d5d3e92 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Thu, 14 Apr 2016 19:34:52 +0200
|
||||
Subject: [PATCH 2/2] remove the condition because we added the missing
|
||||
baselines
|
||||
|
||||
---
|
||||
tests/DMRTest.at | 9 ---------
|
||||
1 file changed, 9 deletions(-)
|
||||
|
||||
diff --git a/tests/DMRTest.at b/tests/DMRTest.at
|
||||
index 93e3b58..3ab1b38 100644
|
||||
--- a/tests/DMRTest.at
|
||||
+++ b/tests/DMRTest.at
|
||||
@@ -240,12 +240,6 @@ DMR_PARSE([dmr-testsuite/test_array_14.xml], [pass])
|
||||
DMR_PARSE([dmr-testsuite/test_simple_6.2.xml], [pass])
|
||||
DMR_PARSE([dmr-testsuite/test_simple_6.3.xml], [pass])
|
||||
|
||||
-# These tests for zero-length array values only work for
|
||||
-# little-endian machines at this time. If baselines for
|
||||
-# big-endian machines are built, this AS_IF can be removed.
|
||||
-# jhrg 1/28/16
|
||||
-AS_IF([test "$WORD_ORDER" = "little-endian"],
|
||||
-[
|
||||
DMR_TRANS([test_array_9.xml], [pass])
|
||||
DMR_TRANS([test_array_12.xml], [pass])
|
||||
DMR_TRANS([test_array_13.xml], [pass])
|
||||
@@ -263,9 +257,6 @@ DMR_INTERN([test_array_14.xml], [pass])
|
||||
DMR_INTERN([test_simple_6.2.xml], [pass])
|
||||
DMR_INTERN([test_simple_6.3.xml], [pass])
|
||||
|
||||
-],
|
||||
-[])
|
||||
-
|
||||
# Test various facets of the CE parser and evaluation engine
|
||||
|
||||
DMR_TRANS_CE([test_array_4.xml], [a], [test_array_4.xml.1.trans_base], [pass])
|
||||
+{ {"Silly test string: 1", "Silly test string: 1", "Silly test string: 1", "Silly test string: 1", "Silly test string: 1"} }
|
||||
|
@ -1,30 +0,0 @@
|
||||
From 08f3403fb6bea17775dacc51c055b3b46f425326 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Dan=20Hor=C3=A1k?= <dan@danny.cz>
|
||||
Date: Fri, 15 Apr 2016 11:06:42 +0200
|
||||
Subject: [PATCH] fallback to pkg-config if cppunit-config is not available
|
||||
|
||||
Recent version of cppunit packages do not distribute the cppunit-config script
|
||||
and expect the usage of pkgconfig file.
|
||||
---
|
||||
configure.ac | 8 +++++++-
|
||||
1 file changed, 7 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 2a7f158..9467a87 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -305,7 +305,13 @@ AC_SUBST([UUID_LIBS])
|
||||
|
||||
AM_PATH_CPPUNIT(1.12.0,
|
||||
[AM_CONDITIONAL([CPPUNIT], [true])],
|
||||
- [AM_CONDITIONAL([CPPUNIT], [false])])
|
||||
+ [
|
||||
+ PKG_CHECK_MODULES(CPPUNIT, [cppunit >= 1.12.0],
|
||||
+ [AM_CONDITIONAL([CPPUNIT], [true])],
|
||||
+ [AM_CONDITIONAL([CPPUNIT], [false])]
|
||||
+ )
|
||||
+ ]
|
||||
+)
|
||||
|
||||
DODS_DEBUG_OPTION
|
||||
|
Loading…
Reference in new issue