parent
4e0839fa3e
commit
2bc49957d5
@ -0,0 +1,48 @@
|
||||
diff -up libdap-3.14.0/d4_ce/lex.d4_ce.cc.flex libdap-3.14.0/d4_ce/lex.d4_ce.cc
|
||||
--- libdap-3.14.0/d4_ce/lex.d4_ce.cc.flex 2015-04-07 00:45:50.000000000 -0600
|
||||
+++ libdap-3.14.0/d4_ce/lex.d4_ce.cc 2015-04-16 11:12:38.074231518 -0600
|
||||
@@ -1276,9 +1276,9 @@ void yyFlexLexer::switch_streams( std::i
|
||||
}
|
||||
|
||||
#ifdef YY_INTERACTIVE
|
||||
-size_t yyFlexLexer::LexerInput( char* buf, size_t /* max_size */ )
|
||||
+int yyFlexLexer::LexerInput( char* buf, int /* max_size */ )
|
||||
#else
|
||||
-size_t yyFlexLexer::LexerInput( char* buf, size_t max_size )
|
||||
+int yyFlexLexer::LexerInput( char* buf, int max_size )
|
||||
#endif
|
||||
{
|
||||
if ( yyin->eof() || yyin->fail() )
|
||||
@@ -1305,7 +1305,7 @@ size_t yyFlexLexer::LexerInput( char* bu
|
||||
#endif
|
||||
}
|
||||
|
||||
-void yyFlexLexer::LexerOutput( const char* buf, size_t size )
|
||||
+void yyFlexLexer::LexerOutput( const char* buf, int size )
|
||||
{
|
||||
(void) yyout->write( buf, size );
|
||||
}
|
||||
diff -up libdap-3.14.0/d4_ce/lex.d4_function.cc.flex libdap-3.14.0/d4_ce/lex.d4_function.cc
|
||||
--- libdap-3.14.0/d4_ce/lex.d4_function.cc.flex 2015-04-03 22:47:36.000000000 -0600
|
||||
+++ libdap-3.14.0/d4_ce/lex.d4_function.cc 2015-04-16 11:12:52.096512693 -0600
|
||||
@@ -1303,9 +1303,9 @@ void yyFlexLexer::switch_streams( std::i
|
||||
}
|
||||
|
||||
#ifdef YY_INTERACTIVE
|
||||
-size_t yyFlexLexer::LexerInput( char* buf, size_t /* max_size */ )
|
||||
+int yyFlexLexer::LexerInput( char* buf, int /* max_size */ )
|
||||
#else
|
||||
-size_t yyFlexLexer::LexerInput( char* buf, size_t max_size )
|
||||
+int yyFlexLexer::LexerInput( char* buf, int max_size )
|
||||
#endif
|
||||
{
|
||||
if ( yyin->eof() || yyin->fail() )
|
||||
@@ -1332,7 +1332,7 @@ size_t yyFlexLexer::LexerInput( char* bu
|
||||
#endif
|
||||
}
|
||||
|
||||
-void yyFlexLexer::LexerOutput( const char* buf, size_t size )
|
||||
+void yyFlexLexer::LexerOutput( const char* buf, int size )
|
||||
{
|
||||
(void) yyout->write( buf, size );
|
||||
}
|
@ -1,12 +1,35 @@
|
||||
diff -up libdap-3.13.1/unit-tests/Makefile.am.offline libdap-3.13.1/unit-tests/Makefile.am
|
||||
--- libdap-3.13.1/unit-tests/Makefile.am.offline 2014-02-04 16:17:16.000000000 -0700
|
||||
+++ libdap-3.13.1/unit-tests/Makefile.am 2014-07-10 13:39:07.193789391 -0600
|
||||
@@ -48,7 +48,7 @@ UNIT_TESTS = marshT arrayT attrTableT st
|
||||
RegexTest \
|
||||
ArrayTest AttrTableTest ByteTest MIMEUtilTest ancT DASTest \
|
||||
DDSTest DDXParserTest generalUtilTest \
|
||||
- HTTPCacheTest HTTPConnectTest parserUtilTest RCReaderTest \
|
||||
+ parserUtilTest RCReaderTest \
|
||||
SequenceTest SignalHandlerTest MarshallerTest \
|
||||
ServerFunctionsListUnitTest
|
||||
|
||||
diff -up libdap-3.14.0/tests/Makefile.am.offline libdap-3.14.0/tests/Makefile.am
|
||||
--- libdap-3.14.0/tests/Makefile.am.offline 2015-04-16 13:58:00.256001226 -0600
|
||||
+++ libdap-3.14.0/tests/Makefile.am 2015-04-16 14:10:17.020831267 -0600
|
||||
@@ -23,7 +23,7 @@ if DAP4_DEFINED
|
||||
check_PROGRAMS += dmr-test
|
||||
endif
|
||||
|
||||
-TESTS = DASTest DDSTest EXPRTest DMRTest getdapTest
|
||||
+TESTS = DASTest DDSTest EXPRTest DMRTest
|
||||
|
||||
dist_check_SCRIPTS = DASTest DDSTest EXPRTest DMRTest getdapTest atconfig atlocal
|
||||
|
||||
diff -up libdap-3.14.0/unit-tests/Makefile.am.offline libdap-3.14.0/unit-tests/Makefile.am
|
||||
--- libdap-3.14.0/unit-tests/Makefile.am.offline 2015-02-26 21:33:44.000000000 -0700
|
||||
+++ libdap-3.14.0/unit-tests/Makefile.am 2015-04-16 13:58:00.260001279 -0600
|
||||
@@ -10,7 +10,6 @@ AUTOMAKE_OPTIONS = foreign
|
||||
AM_CPPFLAGS = -I$(top_srcdir)/GNU -I$(top_srcdir) -I$(top_srcdir)/tests $(CURL_CFLAGS) $(XML2_CFLAGS)
|
||||
AM_LDADD =
|
||||
AM_CXXFLAGS =
|
||||
-CXXFLAGS =
|
||||
|
||||
if COMPILER_IS_GCC
|
||||
AM_CXXFLAGS += -Wall -W -Wcast-align
|
||||
@@ -66,9 +65,9 @@ D4-xml.tar.gz: D4-xml/DMR_*[0-9].xml
|
||||
if CPPUNIT
|
||||
UNIT_TESTS = marshT arrayT attrTableT structT sequenceT ddsT dasT \
|
||||
RegexTest ArrayTest AttrTableTest ByteTest MIMEUtilTest ancT DASTest \
|
||||
- DDSTest DDXParserTest generalUtilTest HTTPConnectTest parserUtilTest \
|
||||
+ DDSTest DDXParserTest generalUtilTest parserUtilTest \
|
||||
RCReaderTest SequenceTest SignalHandlerTest MarshallerTest \
|
||||
- HTTPCacheTest ServerFunctionsListUnitTest
|
||||
+ ServerFunctionsListUnitTest
|
||||
|
||||
if DAP4_DEFINED
|
||||
UNIT_TESTS += D4MarshallerTest D4UnMarshallerTest D4DimensionsTest \
|
||||
|
Loading…
Reference in new issue