You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
libbsd/libbsd-debuginfo.patch

13 lines
423 B

diff -up libbsd-0.2.0/Makefile.makefile libbsd-0.2.0/Makefile
--- libbsd-0.2.0/Makefile.makefile 2010-01-28 19:41:22.000000000 -0800
+++ libbsd-0.2.0/Makefile 2010-01-28 19:42:59.000000000 -0800
@@ -149,7 +149,7 @@ $(LIB_SONAME): $(LIB_SHARED)
ln -fs $^ $@
$(LIB_SHARED): $(LIB_SHARED_OBJS)
- gcc -shared \
+ gcc $(CFLAGS) -shared \
-Wl,-soname -Wl,$(LIB_SONAME) \
-Wl,--version-script=Versions \
-o $@ $^