You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
lazarus/0001-DWARF-debuginfo-everyw...

33 lines
1.2 KiB

--- lazarus-2.2.0--orig/lazarus/components/chmhelp/lhelp/Makefile.fpc 2022-01-02 11:01:23.000000000 +0100
+++ lazarus-2.2.0--patched/lazarus/components/chmhelp/lhelp/Makefile.fpc 2022-01-16 14:38:13.725920651 +0100
@@ -14,9 +14,9 @@
libc=y
packages=rtl
[compiler]
-options=-gs -gl -Sghi -O3 -dlcl$(LCL_PLATFORM) $(DBG_OPTIONS)
+options=-gw -gl -Sghi -O3 -dlcl$(LCL_PLATFORM) $(DBG_OPTIONS)
unittargetdir=lib/$(CPU_TARGET)-$(OS_TARGET)
unitdir=. $(LAZDIR)/components/lazutils/lib/$(CPU_TARGET)-$(OS_TARGET) \
$(LAZDIR)/packager/units/$(CPU_TARGET)-$(OS_TARGET) \
$(LAZDIR)/lcl/units/$(CPU_TARGET)-$(OS_TARGET) \
--- lazarus-2.2.0--orig/lazarus/lcl/interfaces/nogui/Makefile.fpc 2022-01-02 11:01:25.000000000 +0100
+++ lazarus-2.2.0--patched/lazarus/lcl/interfaces/nogui/Makefile.fpc 2022-01-16 15:00:53.421077087 +0100
@@ -7,15 +7,12 @@
[target]
units=lcl.pas
[prerules]
-DBG_OPTIONS=
-ifeq ($(OS_TARGET),darwin)
DBG_OPTIONS=-gw
-endif
[compiler]
-options=-gl -dnogui $(DBG_OPTIONS)
+options=-gw -gl -dnogui $(DBG_OPTIONS)
unitdir=../../units/$(CPU_TARGET)-$(OS_TARGET) \
../../../packager/units/$(CPU_TARGET)-$(OS_TARGET) \
../../../components/lazutils/lib/$(CPU_TARGET)-$(OS_TARGET) \
.. .