- Updated to version 0.9.26

- Removed scripts which are vulnerable to symlink-attacks (bug 460642)
- Build bigide instead of the standard ide
- Build ideintf and the registration for gtk2
- Install the manfiles
- Install the mime-types
- Install the global .xml configuration files
f39
Joost van der Sluis 17 years ago
parent c1d624ff0e
commit 8e0217ce42

@ -1 +1 @@
lazarus-0.9.24-0.tar.gz
lazarus-0.9.26-0.tgz

@ -1,13 +1,13 @@
--- lazarus/install/lazarus.desktop 2007-09-11 19:38:17.000000000 +0200
+++ lazarus/install/lazarus.desktop.n 2008-02-01 11:28:17.000000000 +0100
@@ -5,13 +5,7 @@
--- lazarus/install/lazarus.desktop 2007-11-26 15:34:42.000000000 +0100
+++ lazarus/install/lazarus.desktop.n 2008-10-18 11:52:33.000000000 +0200
@@ -5,13 +5,8 @@
Exec=startlazarus %f
Terminal=false
Type=Application
-Icon=lazarus.png
-Categories=Application;IDE;Development;Programming;
-Categories=Application;IDE;Development;GTK;GUIDesigner;
+Icon=lazarus
+Categories=Development;IDE;GTK;GUIDesigner;
+Categories=IDE;Development;GTK;GUIDesigner;
StartupWMClass=Lazarus
MimeType=text/x-pascal;text/lazarus-project-source;text/lazarus-project-information;text/lazarus-form;text/lazarus-resource;text/lazarus-package;text/lazarus-package-link;text/lazarus-code-inlay;
-Patterns=*.pas;*.pp;*.p;*.inc;*.lpi;*.lpk;*.lpr;*.lfm;*.lrs;*.lpl;*.dci
@ -15,4 +15,4 @@
-Type=QString
-Value=.pas
-X-Ubuntu-Gettext-Domain=desktop_kdelibs
-

@ -1,6 +1,6 @@
Index: lazarus/Makefile.fpc
===================================================================
--- lazarus/Makefile.fpc (revision 10352)
--- lazarus/Makefile.fpc (version 0.9.26)
+++ lazarus/Makefile.fpc (working copy)
@@ -21,7 +21,7 @@
@ -20,14 +20,14 @@ Index: lazarus/Makefile.fpc
INSTALL_MAN_DIR=$(INSTALL_PREFIX)/share/man
ifneq ($(findstring $(OS_TARGET),win32 win64),)
LAZARUS_INSTALL_DIR=C:\lazarus
@@ -104,8 +104,8 @@
@@ -110,8 +110,8 @@
ifeq ($(OS_TARGET),win32)
else
- $(MKDIR) $(INSTALL_PREFIX)/share
- $(MKDIR) $(INSTALL_PREFIX)/share/lazarus
+ $(MKDIR) $(INSTALL_PREFIX)/$(_LIB)
+ $(MKDIR) $(INSTALL_PREFIX)/$(_LIB)/lazarus
$(MKDIR) $(INSTALL_BINDIR)
$(MKDIR) $(INSTALL_MAN_DIR)
endif
- $(MKDIR) $(INSTALL_PREFIX)/share
- $(MKDIR) $(INSTALL_PREFIX)/share/lazarus
+ $(MKDIR) $(INSTALL_PREFIX)/$(_LIB)
+ $(MKDIR) $(INSTALL_PREFIX)/$(_LIB)/lazarus
$(MKDIR) $(INSTALL_BINDIR)
$(MKDIR) $(INSTALL_MAN_DIR)
$(MKDIR) $(INSTALL_MAN_DIR)/man1

@ -1,19 +1,19 @@
Name: lazarus
Version: 0.9.24
Release: 4%{?dist}
Version: 0.9.26
Release: 1%{?dist}
Summary: Lazarus Component Library and IDE for Freepascal
Group: Development/Languages
# GNU Classpath style exception, see COPYING.modifiedLGPL
License: GPLv2+ and MPLv1.1 and LGPLv2+ with exceptions
URL: http://www.lazarus.freepascal.org/
Source0: http://download.sourceforge.net/%{name}/%{name}-%{version}-0.tar.gz
Source0: http://download.sourceforge.net/%{name}/%{name}-%{version}-0.tgz
patch0: Makefile_patch.diff
patch1: Desktop_patch.diff
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: fpc >= 2.2.0, binutils, gdk-pixbuf-devel, gtk+-devel, glibc-devel, desktop-file-utils, gtk2-devel, fpc-src >= 2.2.0
Requires: fpc-src >= 2.2.0, fpc >= 2.2.0, binutils, gdk-pixbuf-devel, gtk+-devel, glibc-devel, gdb
BuildRequires: fpc >= 2.2.2, binutils, gdk-pixbuf-devel, gtk+-devel, glibc-devel, desktop-file-utils, gtk2-devel, fpc-src >= 2.2.2
Requires: fpc-src >= 2.2.2, fpc >= 2.2.2, binutils, gdk-pixbuf-devel, gtk+-devel, glibc-devel, gdb
%description
Lazarus is a free and opensource RAD tool for freepascal using the lazarus
@ -31,16 +31,33 @@ rm -rf debian
rm -rf tools/install/cross_unix/debian_crosswin32
rm tools/install/cross_unix/create_linux_cross_win32_deb.sh
rm tools/install/cross_unix/HowToCreate_fpc_crosswin32_deb.txt
export FPCDIR=/usr/share/fpcsrc
# Remove scripts vulnerable to symlink-attacks (bug 460642)
rm tools/convert_po_file_to_utf-8.sh
rm tools/install/build_fpc_snaphot_rpm.sh
rm tools/install/check_fpc_dependencies.sh
rm tools/install/create_fpc_deb.sh
rm tools/install/create_fpc_export_tgz.sh
rm tools/install/create_fpc_rpm.sh
rm tools/install/create_fpc-src_rpm.sh
rm tools/install/create_fpc_tgz_from_local_dir.sh
rm tools/install/create_lazarus_export_tgz.sh
export FPCDIR=%{_datadir}/fpcsrc/
fpcmake -Tall
make all OPT='-gl'
make tools OPT='-gl'
make bigide OPT='-gl'
make lazbuilder OPT='-gl'
# Add the ability to create gtk2-applications
make -C lcl/interfaces/gtk2/ OPT='-gl'
export LCL_PLATFORM=gtk2
make lcl ideintf packager/registration bigidecomponents OPT='-gl'
export LCL_PLATFORM=
%install
rm -rf %{buildroot}
make -C lazarus install INSTALL_PREFIX=%{buildroot}%{_prefix} _LIB=%{_lib}
make -C lazarus/install/man INSTALL_MANDIR=%{buildroot}%{_mandir}
install -D -p -m 0644 lazarus/install/lazarus-mime.xml $LazBuildDir%{buildroot}%{_datadir}/mime/packages/lazarus.xml
install -D -p -m 0644 lazarus/images/ide_icon48x48.png %{buildroot}%{_datadir}/pixmaps/lazarus.png
desktop-file-install \
--vendor fedora \
@ -51,12 +68,20 @@ ln -sf ../%{_lib}/%{name}/lazarus %{buildroot}%{_bindir}/lazarus-ide
ln -sf ../%{_lib}/%{name}/startlazarus %{buildroot}%{_bindir}/startlazarus
ln -sf ../%{_lib}/%{name}/lazbuild %{buildroot}%{_bindir}/lazbuild
chmod 755 %{buildroot}%{_libdir}/lazarus/components/lazreport/doc/cvs2cl.pl
install -D -p -m 0644 lazarus/tools/install/linux/editoroptions.xml %{buildroot}%{_sysconfdir}/lazarus/editoroptions.xml
cat lazarus/tools/install/linux/environmentoptions.xml | sed -e "s#/usr/lib/lazarus/#%{_libdir}/%{name}#" > %{buildroot}%{_sysconfdir}/lazarus/environmentoptions.xml
chmod 755 %{buildroot}%{_libdir}/%{name}/components/lazreport/tools/localize.sh
%clean
rm -rf %{buildroot}
%post
update-mime-database %{_datadir}/mime &> /dev/null || :
%postun
update-mime-database %{_datadir}/mime &> /dev/null || :
%files
%defattr(-,root,root,-)
%{_libdir}/%{name}
@ -65,11 +90,23 @@ rm -rf %{buildroot}
%{_bindir}/lazbuild
%{_datadir}/pixmaps/lazarus.png
%{_datadir}/applications/fedora-%{name}.desktop
%{_datadir}/mime/packages/lazarus.xml
%doc lazarus/COPYING*
%doc lazarus/README.txt
%config(noreplace) %{_sysconfdir}/lazarus/editoroptions.xml
%config(noreplace) %{_sysconfdir}/lazarus/environmentoptions.xml
%{_mandir}/*/*
%changelog
* Thu Oct 23 2008 Joost van der Sluis <joost@cnoc.nl> 0.9.26-1
- Updated to version 0.9.26
- Removed scripts which are vulnerable to symlink-attacks (bug 460642)
- Build bigide instead of the standard ide
- Build ideintf and the registration for gtk2
- Install the manfiles
- Install the mime-types
- Install the global .xml configuration files
* Wed Jun 18 2008 Joost van der Sluis <joost@cnoc.nl> 0.9.24-4
- removed the trailing slash from the FPCDIR export in the build section

@ -1 +1 @@
bdb0221240d776e4bc32733f2872e2b1 lazarus-0.9.24-0.tar.gz
f1a7b2f89d1e6a246f25abb235880594 lazarus-0.9.26-0.tgz

Loading…
Cancel
Save