You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
141 lines
5.4 KiB
141 lines
5.4 KiB
From 66ba134859f268d36af6bfedf8e851959b06dd2d Mon Sep 17 00:00:00 2001
|
|
From: Michal Privoznik <mprivozn@redhat.com>
|
|
Date: Nov 27 2020 09:00:52 +0000
|
|
Subject: Install into /usr/lib rather than /usr/lib64/
|
|
|
|
|
|
In koji-1.22.0-129-g0ef3c751 I've changed the way how
|
|
site-packages directory is obtained. What I did not realize back
|
|
then is there can be multilib systems which will not search for
|
|
packages in /usr/lib64. But 64bit systems do look into /usr/lib.
|
|
Therefore, let's pick the location where both systems work.
|
|
|
|
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1894261
|
|
Fixes: #2578
|
|
https://pagure.io/koji/issue/2578
|
|
Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
|
|
|
|
---
|
|
|
|
diff --git a/cli/Makefile b/cli/Makefile
|
|
index ddaeba3..122a23f 100644
|
|
--- a/cli/Makefile
|
|
+++ b/cli/Makefile
|
|
@@ -1,7 +1,7 @@
|
|
SUBDIRS=koji_cli
|
|
|
|
PACKAGE = $(shell basename `pwd`)
|
|
-PKGDIR = $(shell $(PYTHON) -c "import site; print(site.getsitepackages()[0])")/$(PACKAGE)
|
|
+PKGDIR = $(shell $(PYTHON) -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")/$(PACKAGE)
|
|
|
|
FILES = koji
|
|
|
|
diff --git a/cli/koji_cli/Makefile b/cli/koji_cli/Makefile
|
|
index fd66929..62b8b53 100644
|
|
--- a/cli/koji_cli/Makefile
|
|
+++ b/cli/koji_cli/Makefile
|
|
@@ -1,7 +1,7 @@
|
|
PYFILES = $(wildcard *.py)
|
|
|
|
PACKAGE = $(shell basename `pwd`)
|
|
-PKGDIR = $(shell $(PYTHON) -c "import site; print(site.getsitepackages()[0])")/$(PACKAGE)
|
|
+PKGDIR = $(shell $(PYTHON) -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")/$(PACKAGE)
|
|
|
|
_default:
|
|
@echo "nothing to make. try make install"
|
|
diff --git a/hub/Makefile b/hub/Makefile
|
|
index 6881f63..a44e1c4 100644
|
|
--- a/hub/Makefile
|
|
+++ b/hub/Makefile
|
|
@@ -1,6 +1,6 @@
|
|
PACKAGE = $(shell basename `pwd`)
|
|
PYFILES = $(wildcard *.py)
|
|
-PKGDIR = $(shell $(PYTHON) -c "import site; print(site.getsitepackages()[0])")/$(PACKAGE)
|
|
+PKGDIR = $(shell $(PYTHON) -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")/$(PACKAGE)
|
|
|
|
SERVERDIR = /usr/share/koji-hub
|
|
PYFILES = $(wildcard *.py)
|
|
diff --git a/koji.spec b/koji.spec
|
|
index 78d1863..7e0b6e7 100644
|
|
--- a/koji.spec
|
|
+++ b/koji.spec
|
|
@@ -62,7 +62,7 @@
|
|
# not yet to RHEL proper.
|
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1307190
|
|
%{!?__python2: %global __python2 /usr/bin/python2}
|
|
-%{!?python2_sitearch: %global python2_sitearch %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
|
|
+%{!?python2_sitelib: %global python2_sitelib %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
|
|
%{!?python2_sitearch: %global python2_sitearch %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
|
|
%{!?py2_build: %global py2_build %{expand: CFLAGS="%{optflags}" %{__python2} setup.py %{?py_setup_args} build --executable="%{__python2} -s"}}
|
|
%{!?py2_install: %global py2_install %{expand: CFLAGS="%{optflags}" %{__python2} setup.py %{?py_setup_args} install -O1 --skip-build --root %{buildroot}}}
|
|
@@ -451,19 +451,19 @@ rm -rf $RPM_BUILD_ROOT
|
|
|
|
%if 0%{py2_support}
|
|
%files -n python2-%{name}
|
|
-%{python2_sitearch}/%{name}
|
|
-%{python2_sitearch}/koji_cli
|
|
+%{python2_sitelib}/%{name}
|
|
+%{python2_sitelib}/koji_cli
|
|
%endif
|
|
|
|
%if 0%{py3_support}
|
|
%files -n python%{python3_pkgversion}-koji
|
|
-%{python3_sitearch}/%{name}
|
|
-%{python3_sitearch}/koji_cli
|
|
+%{python3_sitelib}/%{name}
|
|
+%{python3_sitelib}/koji_cli
|
|
%endif
|
|
|
|
%if 0%{py2_support}
|
|
%files -n python2-%{name}-cli-plugins
|
|
-%{python2_sitearch}/koji_cli_plugins
|
|
+%{python2_sitelib}/koji_cli_plugins
|
|
# we don't have config files for default plugins yet
|
|
#%%dir %%{_sysconfdir}/koji/plugins
|
|
#%%config(noreplace) %%{_sysconfdir}/koji/plugins/*.conf
|
|
@@ -471,7 +471,7 @@ rm -rf $RPM_BUILD_ROOT
|
|
|
|
%if 0%{py3_support}
|
|
%files -n python%{python3_pkgversion}-%{name}-cli-plugins
|
|
-%{python3_sitearch}/koji_cli_plugins
|
|
+%{python3_sitelib}/koji_cli_plugins
|
|
# we don't have config files for default plugins yet
|
|
#%%dir %%{_sysconfdir}/koji/plugins
|
|
#%%config(noreplace) %%{_sysconfdir}/koji/plugins/*.conf
|
|
diff --git a/koji/Makefile b/koji/Makefile
|
|
index 2b6f3d4..0064cdd 100644
|
|
--- a/koji/Makefile
|
|
+++ b/koji/Makefile
|
|
@@ -2,7 +2,7 @@ PACKAGE = $(shell basename `pwd`)
|
|
PYFILES = $(wildcard *.py)
|
|
PYSCRIPTS =
|
|
SUBDIRS =
|
|
-PKGDIR = $(shell $(PYTHON) -c "import site; print(site.getsitepackages()[0])")/$(PACKAGE)
|
|
+PKGDIR = $(shell $(PYTHON) -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")/$(PACKAGE)
|
|
|
|
_default:
|
|
@echo "nothing to make. try make install"
|
|
diff --git a/plugins/Makefile b/plugins/Makefile
|
|
index 10f71e2..6ea1d2a 100644
|
|
--- a/plugins/Makefile
|
|
+++ b/plugins/Makefile
|
|
@@ -1,4 +1,4 @@
|
|
-PKGDIR = $(shell $(PYTHON) -c "import site; print(site.getsitepackages()[0])")/$(PACKAGE)
|
|
+PKGDIR = $(shell $(PYTHON) -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")/$(PACKAGE)
|
|
|
|
CLIPLUGINDIR = $(PKGDIR)/koji_cli_plugins
|
|
HUBPLUGINDIR = /usr/lib/koji-hub-plugins
|
|
diff --git a/www/lib/kojiweb/Makefile b/www/lib/kojiweb/Makefile
|
|
index 8ea3759..5fa67c0 100644
|
|
--- a/www/lib/kojiweb/Makefile
|
|
+++ b/www/lib/kojiweb/Makefile
|
|
@@ -1,6 +1,6 @@
|
|
PACKAGE = $(shell basename `pwd`)
|
|
PYFILES = $(wildcard *.py)
|
|
-PKGDIR = $(shell $(PYTHON) -c "import site; print(site.getsitepackages()[0])")/$(PACKAGE)
|
|
+PKGDIR = $(shell $(PYTHON) -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")/$(PACKAGE)
|
|
|
|
SERVERDIR = /kojiweb
|
|
FILES = $(wildcard *.py *.chtml)
|
|
|