You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
78 lines
2.9 KiB
78 lines
2.9 KiB
Index: src/lib/crypto/Makefile
|
|
===================================================================
|
|
--- src.orig/lib/crypto/Makefile 2023-05-31 09:41:53.066737337 +0200
|
|
+++ src/lib/crypto/Makefile 2023-06-06 01:48:00.997429347 +0200
|
|
@@ -1,8 +1,8 @@
|
|
# SPDX-License-Identifier: GPL-2.0
|
|
|
|
# chacha is used by the /dev/random driver which is always builtin
|
|
-obj-y += chacha.o
|
|
-obj-$(CONFIG_CRYPTO_LIB_CHACHA_GENERIC) += libchacha.o
|
|
+#obj-y += chacha.o
|
|
+#obj-$(CONFIG_CRYPTO_LIB_CHACHA_GENERIC) += libchacha.o
|
|
|
|
obj-$(CONFIG_CRYPTO_LIB_AES) += libaes.o
|
|
libaes-y := aes.o
|
|
@@ -11,34 +11,34 @@
|
|
libarc4-y := arc4.o
|
|
|
|
# blake2s is used by the /dev/random driver which is always builtin
|
|
-obj-y += libblake2s.o
|
|
-libblake2s-y := blake2s.o
|
|
-libblake2s-$(CONFIG_CRYPTO_LIB_BLAKE2S_GENERIC) += blake2s-generic.o
|
|
-
|
|
-obj-$(CONFIG_CRYPTO_LIB_CHACHA20POLY1305) += libchacha20poly1305.o
|
|
-libchacha20poly1305-y += chacha20poly1305.o
|
|
-
|
|
-obj-$(CONFIG_CRYPTO_LIB_CURVE25519_GENERIC) += libcurve25519-generic.o
|
|
-libcurve25519-generic-y := curve25519-fiat32.o
|
|
-libcurve25519-generic-$(CONFIG_ARCH_SUPPORTS_INT128) := curve25519-hacl64.o
|
|
-libcurve25519-generic-y += curve25519-generic.o
|
|
-
|
|
-obj-$(CONFIG_CRYPTO_LIB_CURVE25519) += libcurve25519.o
|
|
-libcurve25519-y += curve25519.o
|
|
-
|
|
-obj-$(CONFIG_CRYPTO_LIB_DES) += libdes.o
|
|
-libdes-y := des.o
|
|
-
|
|
-obj-$(CONFIG_CRYPTO_LIB_POLY1305_GENERIC) += libpoly1305.o
|
|
-libpoly1305-y := poly1305-donna32.o
|
|
-libpoly1305-$(CONFIG_ARCH_SUPPORTS_INT128) := poly1305-donna64.o
|
|
-libpoly1305-y += poly1305.o
|
|
+#obj-y += libblake2s.o
|
|
+#libblake2s-y := blake2s.o
|
|
+#libblake2s-$(CONFIG_CRYPTO_LIB_BLAKE2S_GENERIC) += blake2s-generic.o
|
|
+
|
|
+#obj-$(CONFIG_CRYPTO_LIB_CHACHA20POLY1305) += libchacha20poly1305.o
|
|
+#libchacha20poly1305-y += chacha20poly1305.o
|
|
+
|
|
+#obj-$(CONFIG_CRYPTO_LIB_CURVE25519_GENERIC) += libcurve25519-generic.o
|
|
+#libcurve25519-generic-y := curve25519-fiat32.o
|
|
+#libcurve25519-generic-$(CONFIG_ARCH_SUPPORTS_INT128) := curve25519-hacl64.o
|
|
+#libcurve25519-generic-y += curve25519-generic.o
|
|
+
|
|
+#obj-$(CONFIG_CRYPTO_LIB_CURVE25519) += libcurve25519.o
|
|
+#libcurve25519-y += curve25519.o
|
|
+
|
|
+#obj-$(CONFIG_CRYPTO_LIB_DES) += libdes.o
|
|
+#libdes-y := des.o
|
|
+
|
|
+#obj-$(CONFIG_CRYPTO_LIB_POLY1305_GENERIC) += libpoly1305.o
|
|
+#libpoly1305-y := poly1305-donna32.o
|
|
+#libpoly1305-$(CONFIG_ARCH_SUPPORTS_INT128) := poly1305-donna64.o
|
|
+#libpoly1305-y += poly1305.o
|
|
|
|
obj-$(CONFIG_CRYPTO_LIB_SHA256) += libsha256.o
|
|
libsha256-y := sha256.o
|
|
|
|
-ifneq ($(CONFIG_CRYPTO_MANAGER_DISABLE_TESTS),y)
|
|
-libblake2s-y += blake2s-selftest.o
|
|
-libchacha20poly1305-y += chacha20poly1305-selftest.o
|
|
-libcurve25519-y += curve25519-selftest.o
|
|
-endif
|
|
+#ifneq ($(CONFIG_CRYPTO_MANAGER_DISABLE_TESTS),y)
|
|
+#libblake2s-y += blake2s-selftest.o
|
|
+#libchacha20poly1305-y += chacha20poly1305-selftest.o
|
|
+#libcurve25519-y += curve25519-selftest.o
|
|
+#endif
|