.spec cosmetics, %license, silence debug output (#1272105)

epel9
Rex Dieter 9 years ago
parent 11469eefde
commit da24c68af2

@ -6,7 +6,7 @@ Release: 2%{?dist}
Summary: KDE Frameworks 5 Tier 1 solution for spell checking
License: LGPLv2+
URL: http://www.kde.org
URL: https://projects.kde.org/projects/frameworks/sonnet
%global versiondir %(echo %{version} | cut -d. -f1-2)
%global revision %(echo %{version} | cut -d. -f3)
@ -17,17 +17,20 @@ URL: http://www.kde.org
%endif
Source0: http://download.kde.org/%{stable}/frameworks/%{versiondir}/%{framework}-%{version}.tar.xz
## upstreamable patches
# silence (mostly) needless output by default
Patch1: sonnet-5.15.0-qDebug.patch
# workaround multilib conflicts in trigrams.map by using QMap instead of QHash
# https://bugzilla.redhat.com/show_bug.cgi?id=1262746
Patch2: sonnet-5.13.0-multilib.patch
BuildRequires: cmake
BuildRequires: extra-cmake-modules >= %{version}
BuildRequires: hunspell-devel
BuildRequires: zlib-devel
BuildRequires: kf5-rpm-macros >= %{version}
BuildRequires: extra-cmake-modules >= %{version}
BuildRequires: qt5-qtbase-devel
BuildRequires: qt5-qttools-devel
BuildRequires: zlib-devel
Requires: kf5-filesystem >= %{version}
Requires: %{name}-core%{?_isa} = %{version}-%{release}
@ -64,13 +67,15 @@ GUI part of the Sonnet framework provides widgets with spell checking support.
%prep
%setup -q -n %{framework}-%{version}
%patch1 -p1 -b .qDebug
%patch2 -p1 -b .multilib
%build
mkdir %{_target_platform}
pushd %{_target_platform}
%{cmake_kf5} .. -DHUNSPELL_MAIN_DICT_PATH=%{_datadir}/myspell
%{cmake_kf5} .. \
-DHUNSPELL_MAIN_DICT_PATH:PATH="%{_datadir}/myspell"
popd
make %{?_smp_mflags} -C %{_target_platform}
@ -83,7 +88,8 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%files
%doc COPYING.LIB README.md
%doc README.md
%license COPYING.LIB
%post core -p /sbin/ldconfig
%postun core -p /sbin/ldconfig
@ -103,16 +109,19 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%files devel
%{_kf5_includedir}/sonnet_version.h
%{_kf5_includedir}/SonnetCore
%{_kf5_includedir}/SonnetUi
%{_kf5_includedir}/SonnetCore/
%{_kf5_includedir}/SonnetUi/
%{_kf5_libdir}/libKF5SonnetCore.so
%{_kf5_libdir}/libKF5SonnetUi.so
%{_kf5_libdir}/cmake/KF5Sonnet
%{_kf5_libdir}/cmake/KF5Sonnet/
%{_kf5_archdatadir}/mkspecs/modules/qt_SonnetCore.pri
%{_kf5_archdatadir}/mkspecs/modules/qt_SonnetUi.pri
%changelog
* Mon Oct 19 2015 Rex Dieter <rdieter@fedoraproject.org> 5.15.0-2
- .spec cosmetics, %%license, silence debug output (#1272105)
* Thu Oct 08 2015 Daniel Vrátil <dvratil@redhat.com> - 5.15.0-1
- KDE Frameworks 5.15.0

@ -0,0 +1,12 @@
diff -up sonnet-5.15.0/src/core/loader.cpp.qDebug sonnet-5.15.0/src/core/loader.cpp
--- sonnet-5.15.0/src/core/loader.cpp.qDebug 2015-10-05 03:29:56.000000000 -0500
+++ sonnet-5.15.0/src/core/loader.cpp 2015-10-19 09:39:40.679656424 -0500
@@ -95,7 +95,7 @@ SpellerPlugin *Loader::createSpeller(con
const QVector<Client *> lClients = d->languageClients[plang];
if (lClients.isEmpty()) {
- qWarning() << "No language dictionaries for the language:" << plang;
+ qDebug() << "No language dictionaries for the language:" << plang;
return 0;
}
Loading…
Cancel
Save