use %ldconfig_scriptlets, %make_build, %find_lang_kf5 move translations to main pkgepel9
parent
8b5a87dfe9
commit
5b4336ff89
@ -0,0 +1,14 @@
|
||||
diff --git a/src/solid/devices/backends/udisks2/udisksstorageaccess.cpp b/src/solid/devices/backends/udisks2/udisksstorageaccess.cpp
|
||||
--- a/src/solid/devices/backends/udisks2/udisksstorageaccess.cpp
|
||||
+++ b/src/solid/devices/backends/udisks2/udisksstorageaccess.cpp
|
||||
@@ -111,7 +111,8 @@
|
||||
|
||||
const QString path = filePath();
|
||||
|
||||
- return !path.startsWith(QLatin1String("/media/"))
|
||||
+ return !path.isEmpty()
|
||||
+ && !path.startsWith(QLatin1String("/media/"))
|
||||
&& !path.startsWith(QLatin1String("/run/media/"))
|
||||
&& !path.startsWith(QDir::homePath());
|
||||
}
|
||||
|
@ -1,16 +0,0 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 8a394d1..d88e824 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -45,6 +45,11 @@ set_package_properties(BISON PROPERTIES
|
||||
PURPOSE "Required for the Predicate parser"
|
||||
)
|
||||
|
||||
+# flex-2.6.0 generates C90-incompatible code. KDEFrameworksCompilerSettings
|
||||
+# forces C90 standard though, overriding our CFLAGS env variable, so we must
|
||||
+# override the -std flag here
|
||||
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99")
|
||||
+
|
||||
if (CMAKE_SYSTEM_NAME MATCHES Linux)
|
||||
find_package( UDev )
|
||||
|
Loading…
Reference in new issue