diff --git a/kf5-khtml.spec b/kf5-khtml.spec
index abab7be..e6fd8f2 100644
--- a/kf5-khtml.spec
+++ b/kf5-khtml.spec
@@ -1,13 +1,12 @@
-%undefine __cmake_in_source_build
%global framework khtml
-Name: kf5-%{framework}
+Name: kf5-%{framework}
Version: 5.85.0
Release: 1%{?dist}
-Summary: KDE Frameworks 5 Tier 4 solution with KHTML, a HTML rendering engine
+Summary: KDE Frameworks 5 Tier 4 solution with KHTML, a HTML rendering engine
-License: LGPLv2+ and GPLv3 and MIT and BSD
-URL: https://invent.kde.org/frameworks/%{framework}
+License: LGPLv2+ and GPLv3 and MIT and BSD
+URL: https://invent.kde.org/frameworks/%{framework}
%global versiondir %(echo %{version} | cut -d. -f1-2)
%global revision %(echo %{version} | cut -d. -f3)
@@ -73,8 +72,9 @@ developing applications that use %{name}.
%autosetup -n %{framework}-%{version}
%build
-%{cmake_kf5} \
+%cmake_kf5 \
-DCMAKE_SHARED_LINKER_FLAGS="-Wl,--as-needed"
+
%cmake_build