diff --git a/SOURCES/find-provides.ksyms b/SOURCES/find-provides.ksyms
index 92d6220..aa656e1 100755
--- a/SOURCES/find-provides.ksyms
+++ b/SOURCES/find-provides.ksyms
@@ -1,12 +1,13 @@
 #! /bin/bash
 
 IFS=$'\n'
+export LC_ALL=C
 
 for module in $(grep -E '/lib/modules/.+\.ko(\.gz|\.bz2|\.xz|\.zst)?$') "$@"; do
     dep_pfx="ksym"
     # For built-in kmods, "kernel()" syntax is used instead of "ksym()"
     printf "%s" "$module" | grep -v "^${RPM_BUILD_ROOT}/\?lib/modules/[1-9][^/]*/kernel" > /dev/null \
-	|| dep_pfx="kernel"
+        || dep_pfx="kernel"
 
     tmpfile=""
     if [ "x${module%.ko}" = "x${module}" ]; then
@@ -33,30 +34,35 @@ for module in $(grep -E '/lib/modules/.+\.ko(\.gz|\.bz2|\.xz|\.zst)?$') "$@"; do
         module="$tmpfile"
     fi
 
-    if [[ -n $(nm $module | sed -r -ne 's:^0*([0-9a-f]+) A __crc_(.+):0x\1 \2:p') ]]; then
-        nm $module \
-        | sed -r -ne 's:^0*([0-9a-f]+) A __crc_(.+):0x\1 \2:p' \
-        | awk --non-decimal-data '{printf("'"${dep_pfx}"'(%s) = 0x%08x\n", $2, $1)}' \
-        | LC_ALL=C sort -u
+    if nm "$module" | grep -qE '^([0-9a-f]+) A __crc_(.+)' 2> /dev/null; then
+        nm "$module" \
+        | awk \
+           -v 'dep_pfx='"$dep_pfx" \
+           --non-decimal-data \
+          'match($0, /^([0-9a-f]+) A __crc_(.+)/, a) { printf("%s(%s) = 0x%08x\n", dep_pfx, a[2], strtonum("0x" a[1])) }' \
+        | sort -u
     else
-        ELFRODATA=$(readelf -R .rodata $module | awk '/0x/{printf $2$3$4$5}')
-        if [[ -n $(readelf -h $module | grep "little endian") ]]; then
-            RODATA=$(echo $ELFRODATA | sed 's/\(..\)\(..\)\(..\)\(..\)/\4\3\2\1/g')
-        else
-            RODATA=$ELFRODATA
-        fi
-        # Commit binutils-2_33~1385[1] has changed (and binutils-2_35~1768[2]
-        # has not reverted it) the calculated type for symbols in read-write
-        # .rodata section from 'R' to 'D', since, apparently, many kernel
-        # modules have it indeed read-write.
-        #
-        # [1] https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=a288c270991d
-        # [2] https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=49d9fd42acef
-        for sym in $(nm $module | sed -r -ne 's:^0*([0-9a-f]+) [DR] __crc_(.+):0x\1 \2:p'); do
-            echo $sym $RODATA
+        objdump -t "$module" \
+        | sed -n 's/^[0-9a-f][0-9a-f]* g...... \(.*\)	[0-9a-f][0-9a-f]* __crc_.*$/\1/p' \
+        | sort -u \
+        | while read sectname; do
+            [ -n "$sectname" ] || continue
+
+            ELFSECTDATA=$(readelf -R "$sectname" "$module" | awk '/0x/{printf $2$3$4$5}')
+            if [[ -n $(readelf -h $module | grep "little endian") ]]; then
+                SECTDATA=$(echo $ELFSECTDATA | sed 's/\(..\)\(..\)\(..\)\(..\)/\4\3\2\1/g')
+            else
+                SECTDATA=$ELFSECTDATA
+            fi
+
+            objdump -t "$module" \
+            | awk \
+              -v 'dep_pfx='"$dep_pfx" \
+              -v 'sectdata='"$SECTDATA" \
+              --non-decimal-data \
+              'match($0, /^([0-9a-f]+) g...... .*	[0-9a-f]+ __crc_(.*)$/, a) { printf("%s(%s) = 0x%08s\n", dep_pfx, a[2], substr(sectdata, (strtonum("0x" a[1]) * 2) + 1, 8)) }'
         done \
-        | awk --non-decimal-data '{printf("'"${dep_pfx}"'(%s) = 0x%08s\n", $2, substr($3,($1*2)+1,8))}' \
-        | LC_ALL=C sort -u
+        | sort -u
     fi
 
     [ -z "$tmpfile" ] || rm -f -- "$tmpfile"
diff --git a/SOURCES/find-requires.ksyms b/SOURCES/find-requires.ksyms
index 78a2105..e2cd33b 100755
--- a/SOURCES/find-requires.ksyms
+++ b/SOURCES/find-requires.ksyms
@@ -35,28 +35,33 @@ all_provides() {
             module="$tmpfile"
         fi
 
-        if [[ -n $(nm "$module" | sed -r -ne 's:^0*([0-9a-f]+) A __crc_(.+):0x\1 \2:p') ]]; then
+        if nm "$module" | grep -qE '^([0-9a-f]+) A __crc_(.+)' 2> /dev/null; then
             nm "$module" \
-            | sed -r -ne 's:^0*([0-9a-f]+) A __crc_(.+):0x\1 \2:p' \
-            | awk --non-decimal-data '{printf("%s:0x%08x\n", $2, $1)}'
+            | awk \
+               -v 'dep_pfx='"$dep_pfx" \
+               --non-decimal-data \
+              'match($0, /^([0-9a-f]+) A __crc_(.+)/, a) { printf("%s(%s) = 0x%08x\n", dep_pfx, a[2], strtonum("0x" a[1])) }'
         else
-            ELFRODATA=$(readelf -R .rodata "$module" | awk '/0x/{printf $2$3$4$5}')
-            if [[ -n $(readelf -h "$module" | grep "little endian") ]]; then
-                RODATA=$(echo $ELFRODATA | sed 's/\(..\)\(..\)\(..\)\(..\)/\4\3\2\1/g')
-            else
-                RODATA=$ELFRODATA
-            fi
-            # Commit binutils-2_33~1385[1] has changed (and binutils-2_35~1768[2]
-            # has not reverted it) the calculated type for symbols in read-write
-            # .rodata section from 'R' to 'D', since, apparently, many kernel
-            # modules have it indeed read-write.
-            #
-            # [1] https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=a288c270991d
-            # [2] https://sourceware.org/git/?p=binutils-gdb.git;a=commitdiff;h=49d9fd42acef
-            for sym in $(nm "$module" | sed -r -ne 's:^0*([0-9a-f]+) [DR] __crc_(.+):0x\1 \2:p'); do
-                echo $sym $RODATA
-            done \
-            | awk --non-decimal-data '{printf("%s:0x%08s\n", $2, substr($3,($1*2)+1,8))}'
+            objdump -t "$module" \
+            | sed -n 's/^[0-9a-f][0-9a-f]* g...... \(.*\)	[0-9a-f][0-9a-f]* __crc_.*$/\1/p' \
+            | sort -u \
+            | while read sectname; do
+                [ -n "$sectname" ] || continue
+
+                ELFSECTDATA=$(readelf -R .rodata "$module" | awk '/0x/{printf $2$3$4$5}')
+                if [[ -n $(readelf -h "$module" | grep "little endian") ]]; then
+                    SECTDATA=$(echo $ELFSECTDATA | sed 's/\(..\)\(..\)\(..\)\(..\)/\4\3\2\1/g')
+                else
+                    SECTDATA=$ELFSECTDATA
+                fi
+
+                objdump -t "$module" \
+                | awk \
+                  -v 'dep_pfx='"$dep_pfx" \
+                  -v 'sectdata='"$SECTDATA" \
+                  --non-decimal-data \
+                  'match($0, /^([0-9a-f]+) g...... .*	[0-9a-f]+ __crc_(.*)$/, a) { printf("%s(%s) = 0x%08s\n", dep_pfx, a[2], substr(sectdata, (strtonum("0x" a[1]) * 2) + 1, 8)) }'
+            done
         fi
 
         [ -z "$tmpfile" ] || rm -f -- "$tmpfile"
diff --git a/SPECS/kernel-srpm-macros.spec b/SPECS/kernel-srpm-macros.spec
index 66e4aaf..991e317 100644
--- a/SPECS/kernel-srpm-macros.spec
+++ b/SPECS/kernel-srpm-macros.spec
@@ -1,6 +1,6 @@
 Name:           kernel-srpm-macros
 Version:        1.0
-Release:        11%{?dist}
+Release:        12%{?dist}
 Summary:        RPM macros that list arches the full kernel is built on
 # This package only exist in Fedora repositories
 # The license is the standard (MIT) specified in
@@ -58,8 +58,21 @@ Release: %{release}
 Summary: Macros and scripts for building kernel module packages
 Requires: redhat-rpm-config >= 13
 
-# for brp-kmod-set-exec-bit
+# for brp-kmod-compress
+Requires: %{_bindir}/xz
+# for brp-kmod-compress, brp-kmod-set-exec-bit
 Requires: %{_bindir}/find
+# for find-provides.ksyms, find-requires.ksyms, kmodtool
+Requires: %{_bindir}/sed
+# for find-provides.ksyms, find-requires.ksyms
+Requires: %{_bindir}/awk
+Requires: %{_bindir}/grep
+Requires: %{_bindir}/nm
+Requires: %{_bindir}/objdump
+Requires: %{_bindir}/readelf
+# for find-requires.ksyms
+Requires: %{_sbindir}/modinfo
+Requires: %{_sbindir}/modprobe
 
 %description -n kernel-rpm-macros
 Macros and scripts for building kernel module packages.
@@ -124,6 +137,10 @@ install -p -m 644 -t "%{buildroot}%{_fileattrsdir}" modalias.attr
 * Wed Mar 15 2023 MSVSphere Packaging Team <packager@msvsphere.ru> - 1.0-11
 - Rebuilt for MSVSphere 9.1.
 
+* Tue Jan 31 2023 Eugene Syromiatnikov <esyr@redhat.com> - 1.0-12
+- Support storing of __crc_* symbols in sections other than .rodata.
+- Resolves: #2135047
+
 * Thu Feb 17 2022 Eugene Syromiatnikov <esyr@redhat.com> - 1.0-11
 - Work around a change in type of __crc_* symbols for some kmods printed by nm
   on ppc64le and s390x