better/upstreamable KAccountsConfig fix

epel9
Rex Dieter 9 years ago
parent cb985a1ad9
commit c412ad4f59

5
.gitignore vendored

@ -1,4 +1 @@
/kaccounts-integration-16.04.0.tar.xz
/kaccounts-integration-16.04.1.tar.xz
/kaccounts-integration-16.04.2.tar.xz
/kaccounts-integration-16.04.3.tar.xz
kaccounts-integration-16.04.3.tar.xz

@ -1,9 +1,31 @@
diff -up kaccounts-integration-16.04.3/src/lib/KAccountsConfig.cmake.in.path kaccounts-integration-16.04.3/src/lib/KAccountsConfig.cmake.in
--- kaccounts-integration-16.04.3/src/lib/KAccountsConfig.cmake.in.path 2016-07-02 11:13:43.000000000 -0500
+++ kaccounts-integration-16.04.3/src/lib/KAccountsConfig.cmake.in 2016-07-10 07:35:51.037019206 -0500
@@ -9,4 +9,4 @@ include("${CMAKE_CURRENT_LIST_DIR}/FindA
commit 868f7b29df5d72d3bb62d6527c9c09464b751b85
Author: Rex Dieter <rdieter@math.unl.edu>
Date: Fri Jul 29 10:28:38 2016 -0500
better CMAKECONFIG_INSTALL_DIR fix
this should handle both relative and full paths properly
diff --git a/src/lib/CMakeLists.txt b/src/lib/CMakeLists.txt
index 9aaf488..650f046 100644
--- a/src/lib/CMakeLists.txt
+++ b/src/lib/CMakeLists.txt
@@ -4,7 +4,7 @@ include_directories(
${CMAKE_CURRENT_BINARY_DIR}
)
-set(CMAKECONFIG_INSTALL_DIR "${CMAKECONFIG_INSTALL_PREFIX}/KAccounts")
+set(CMAKECONFIG_INSTALL_DIR "${KDE_INSTALL_FULL_CMAKEPACKAGEDIR}/KAccounts")
include(ECMPackageConfigHelpers)
include(ECMSetupVersion)
diff --git a/src/lib/KAccountsConfig.cmake.in b/src/lib/KAccountsConfig.cmake.in
index 3a1e524..0922496 100644
--- a/src/lib/KAccountsConfig.cmake.in
+++ b/src/lib/KAccountsConfig.cmake.in
@@ -9,4 +9,4 @@ include("${CMAKE_CURRENT_LIST_DIR}/FindAccountsFileDir.cmake")
include("${CMAKE_CURRENT_LIST_DIR}/KAccountsTargets.cmake")
include("${CMAKE_CURRENT_LIST_DIR}/KAccountsMacros.cmake")
-set(KACCOUNTS_MACROS_PATH "@CMAKE_INSTALL_PREFIX@/@CMAKECONFIG_INSTALL_DIR@")
+set(KACCOUNTS_MACROS_PATH "@KDE_INSTALL_FULL_CMAKEPACKAGEDIR@/KAccounts")
+set(KACCOUNTS_MACROS_PATH "@CMAKECONFIG_INSTALL_DIR@")

@ -1,7 +1,7 @@
Name: kaccounts-integration
Version: 16.04.3
Release: 2%{?dist}
Release: 3%{?dist}
Summary: Small system to administer web accounts across the KDE desktop
License: GPLv2+
URL: https://quickgit.kde.org/?p=%{name}.git
@ -98,6 +98,9 @@ make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
%changelog
* Fri Jul 29 2016 Rex Dieter <rdieter@fedoraproject.org> - 16.04.3-3
- better/upstreamable KAccountsConfig fix
* Sun Jul 10 2016 Rex Dieter <rdieter@fedoraproject.org> - 16.04.3-2
- fix KAccountsConfig to not make any assumptions about relative/full paths
- drop akonadi conditionals

Loading…
Cancel
Save