c8-stream-0.92.3
imports/c8-stream-0.92.3/inkscape-0.92.3-16.module+el8.6.0+13197+b722211d
commit
2cb742a28c
@ -0,0 +1,2 @@
|
||||
SOURCES/ImageMagick-6.9.9.38-1.fc32.src.rpm
|
||||
SOURCES/inkscape-0.92.3.tar.bz2
|
@ -0,0 +1,2 @@
|
||||
2d9033b4b8e57adbd5ccfa945c0bbab460e205b1 SOURCES/ImageMagick-6.9.9.38-1.fc32.src.rpm
|
||||
e1886317f8e6d4fb340f6a783fe410aaff9f28a7 SOURCES/inkscape-0.92.3.tar.bz2
|
@ -0,0 +1,71 @@
|
||||
diff -up inkscape-0.92.3/share/filters/CMakeLists.txt.python2 inkscape-0.92.3/share/filters/CMakeLists.txt
|
||||
--- inkscape-0.92.3/share/filters/CMakeLists.txt.python2 2018-07-13 09:49:16.745284660 +0200
|
||||
+++ inkscape-0.92.3/share/filters/CMakeLists.txt 2018-07-13 09:49:19.718289481 +0200
|
||||
@@ -1,6 +1,6 @@
|
||||
add_custom_command(
|
||||
OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/filters.svg.h
|
||||
- COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${CMAKE_CURRENT_SOURCE_DIR}/filters.svg > ${CMAKE_CURRENT_SOURCE_DIR}/filters.svg.h
|
||||
+ COMMAND python2 ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${CMAKE_CURRENT_SOURCE_DIR}/filters.svg > ${CMAKE_CURRENT_SOURCE_DIR}/filters.svg.h
|
||||
MAIN_DEPENDENCY ${CMAKE_CURRENT_SOURCE_DIR}/filters.svg
|
||||
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py
|
||||
)
|
||||
diff -up inkscape-0.92.3/share/palettes/CMakeLists.txt.python2 inkscape-0.92.3/share/palettes/CMakeLists.txt
|
||||
--- inkscape-0.92.3/share/palettes/CMakeLists.txt.python2 2018-07-13 09:48:29.279207685 +0200
|
||||
+++ inkscape-0.92.3/share/palettes/CMakeLists.txt 2018-07-13 09:48:32.351212667 +0200
|
||||
@@ -2,7 +2,7 @@ set(I18N_FILES "inkscape.gpl" "svg.gpl"
|
||||
|
||||
add_custom_command(
|
||||
OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/palettes.h
|
||||
- COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${I18N_FILES} > ${CMAKE_CURRENT_SOURCE_DIR}/palettes.h
|
||||
+ COMMAND python2 ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${I18N_FILES} > ${CMAKE_CURRENT_SOURCE_DIR}/palettes.h
|
||||
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
||||
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${I18N_FILES}
|
||||
)
|
||||
diff -up inkscape-0.92.3/share/patterns/CMakeLists.txt.python2 inkscape-0.92.3/share/patterns/CMakeLists.txt
|
||||
--- inkscape-0.92.3/share/patterns/CMakeLists.txt.python2 2018-07-13 09:48:48.886239480 +0200
|
||||
+++ inkscape-0.92.3/share/patterns/CMakeLists.txt 2018-07-13 09:48:51.762244143 +0200
|
||||
@@ -1,6 +1,6 @@
|
||||
add_custom_command(
|
||||
OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/patterns.svg.h
|
||||
- COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${CMAKE_CURRENT_SOURCE_DIR}/patterns.svg > ${CMAKE_CURRENT_SOURCE_DIR}/patterns.svg.h
|
||||
+ COMMAND python2 ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${CMAKE_CURRENT_SOURCE_DIR}/patterns.svg > ${CMAKE_CURRENT_SOURCE_DIR}/patterns.svg.h
|
||||
MAIN_DEPENDENCY ${CMAKE_CURRENT_SOURCE_DIR}/patterns.svg
|
||||
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py
|
||||
)
|
||||
diff -up inkscape-0.92.3/share/symbols/CMakeLists.txt.python2 inkscape-0.92.3/share/symbols/CMakeLists.txt
|
||||
--- inkscape-0.92.3/share/symbols/CMakeLists.txt.python2 2018-07-13 09:49:03.745263577 +0200
|
||||
+++ inkscape-0.92.3/share/symbols/CMakeLists.txt 2018-07-13 09:49:05.959267167 +0200
|
||||
@@ -2,7 +2,7 @@ file(GLOB _FILES RELATIVE ${CMAKE_CURREN
|
||||
|
||||
add_custom_command(
|
||||
OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/symbols.h
|
||||
- COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${_FILES} > ${CMAKE_CURRENT_SOURCE_DIR}/symbols.h
|
||||
+ COMMAND python2 ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${_FILES} > ${CMAKE_CURRENT_SOURCE_DIR}/symbols.h
|
||||
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
||||
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${_FILES}
|
||||
)
|
||||
diff -up inkscape-0.92.3/share/templates/CMakeLists.txt.python2 inkscape-0.92.3/share/templates/CMakeLists.txt
|
||||
--- inkscape-0.92.3/share/templates/CMakeLists.txt.python2 2018-07-12 14:53:11.195317573 +0200
|
||||
+++ inkscape-0.92.3/share/templates/CMakeLists.txt 2018-07-12 14:53:13.824322527 +0200
|
||||
@@ -2,7 +2,7 @@ file(GLOB _FILES RELATIVE ${CMAKE_CURREN
|
||||
|
||||
add_custom_command(
|
||||
OUTPUT ${CMAKE_CURRENT_SOURCE_DIR}/templates.h
|
||||
- COMMAND python ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${_FILES} > ${CMAKE_CURRENT_SOURCE_DIR}/templates.h
|
||||
+ COMMAND python2 ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${_FILES} > ${CMAKE_CURRENT_SOURCE_DIR}/templates.h
|
||||
WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
|
||||
DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/i18n.py ${_FILES}
|
||||
)
|
||||
diff -up inkscape-0.92.3/src/extension/implementation/implementation.cpp.python2 inkscape-0.92.3/src/extension/implementation/implementation.cpp
|
||||
diff -up inkscape-0.92.3/src/extension/implementation/script.cpp.python2 inkscape-0.92.3/src/extension/implementation/script.cpp
|
||||
--- inkscape-0.92.3/src/extension/implementation/script.cpp.python2 2018-07-12 14:54:09.974428340 +0200
|
||||
+++ inkscape-0.92.3/src/extension/implementation/script.cpp 2018-07-12 14:54:19.590446461 +0200
|
||||
@@ -87,7 +87,7 @@ Script::interpreter_t const Script::inte
|
||||
#ifdef WIN32
|
||||
{"python", "python-interpreter", "pythonw" },
|
||||
#else
|
||||
- {"python", "python-interpreter", "python" },
|
||||
+ {"python", "python-interpreter", "python2" },
|
||||
#endif
|
||||
{"ruby", "ruby-interpreter", "ruby" },
|
||||
{"shell", "shell-interpreter", "sh" },
|
@ -0,0 +1,12 @@
|
||||
--- src/libnrtype/Layout-TNG-OutIter.cpp~ 2018-03-11 16:38:09.000000000 -0400
|
||||
+++ src/libnrtype/Layout-TNG-OutIter.cpp 2018-06-16 13:17:03.129605681 -0400
|
||||
@@ -182,6 +182,8 @@
|
||||
if (_input_stream[source_index]->Type() != TEXT_SOURCE)
|
||||
return iterator(this, char_index);
|
||||
|
||||
+ if (char_index >= _characters.size())
|
||||
+ return end();
|
||||
return iterator(this, char_index);
|
||||
/* This code was never used, the text_iterator argument was "NULL" in all calling code
|
||||
InputStreamTextSource const *text_source = static_cast<InputStreamTextSource const *>(_input_stream[source_index]);
|
||||
|
@ -0,0 +1,14 @@
|
||||
GIMP Palette
|
||||
Name: Fedora RGB
|
||||
Columns: 2
|
||||
#
|
||||
60 110 180 Fedora Blue
|
||||
41 65 114 Fedora Dark Blue
|
||||
219 50 121 Friends Magenta
|
||||
229 151 40 Features Orange
|
||||
121 219 50 First Green
|
||||
160 124 188 Freedom Purple
|
||||
0 0 0 Black
|
||||
76 76 76 Dark Grey
|
||||
140 140 140 Grey
|
||||
222 222 222 Light Grey
|
@ -0,0 +1,120 @@
|
||||
From a600c6438fef2f4c06f9a4a7d933d99fb054a973 Mon Sep 17 00:00:00 2001
|
||||
From: Eduard Braun <eduard.braun2@gmx.de>
|
||||
Date: Tue, 24 Apr 2018 19:18:26 +0200
|
||||
Subject: [PATCH] Fix compilation with poppler 0.64
|
||||
|
||||
---
|
||||
src/extension/internal/pdfinput/pdf-parser.cpp | 10 +++++-----
|
||||
src/extension/internal/pdfinput/pdf-parser.h | 2 +-
|
||||
src/extension/internal/pdfinput/svg-builder.cpp | 4 ++--
|
||||
src/extension/internal/pdfinput/svg-builder.h | 3 +--
|
||||
4 files changed, 9 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
index 15bc2d746d..6c498f9812 100644
|
||||
--- a/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
+++ b/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
@@ -2582,7 +2582,7 @@ void PdfParser::opShowSpaceText(Object args[], int /*numArgs*/)
|
||||
}
|
||||
}
|
||||
|
||||
-void PdfParser::doShowText(GooString *s) {
|
||||
+void PdfParser::doShowText(const GooString *s) {
|
||||
GfxFont *font;
|
||||
int wMode;
|
||||
double riseX, riseY;
|
||||
@@ -2601,7 +2601,7 @@ void PdfParser::doShowText(GooString *s) {
|
||||
font = state->getFont();
|
||||
wMode = font->getWMode();
|
||||
|
||||
- builder->beginString(state, s);
|
||||
+ builder->beginString(state);
|
||||
|
||||
// handle a Type 3 char
|
||||
if (font->getType() == fontType3 && 0) {//out->interpretType3Chars()) {
|
||||
@@ -2631,7 +2631,7 @@ void PdfParser::doShowText(GooString *s) {
|
||||
double lineX = state->getLineX();
|
||||
double lineY = state->getLineY();
|
||||
oldParser = parser;
|
||||
- p = s->getCString();
|
||||
+ p = g_strdup(s->getCString());
|
||||
len = s->getLength();
|
||||
while (len > 0) {
|
||||
n = font->getNextChar(p, len, &code,
|
||||
@@ -2686,7 +2686,7 @@ void PdfParser::doShowText(GooString *s) {
|
||||
|
||||
} else {
|
||||
state->textTransformDelta(0, state->getRise(), &riseX, &riseY);
|
||||
- p = s->getCString();
|
||||
+ p = g_strdup(s->getCString());
|
||||
len = s->getLength();
|
||||
while (len > 0) {
|
||||
n = font->getNextChar(p, len, &code,
|
||||
@@ -2732,7 +2732,7 @@ void PdfParser::opXObject(Object args[], int /*numArgs*/)
|
||||
{
|
||||
Object obj1, obj2, obj3, refObj;
|
||||
|
||||
- char *name = args[0].getName();
|
||||
+ char *name = g_strdup(args[0].getName());
|
||||
#if defined(POPPLER_NEW_OBJECT_API)
|
||||
if ((obj1 = res->lookupXObject(name)).isNull()) {
|
||||
#else
|
||||
diff --git a/src/extension/internal/pdfinput/pdf-parser.h b/src/extension/internal/pdfinput/pdf-parser.h
|
||||
index e28fecc2e1..f985b15cad 100644
|
||||
--- a/src/extension/internal/pdfinput/pdf-parser.h
|
||||
+++ b/src/extension/internal/pdfinput/pdf-parser.h
|
||||
@@ -287,7 +287,7 @@ private:
|
||||
void opMoveShowText(Object args[], int numArgs);
|
||||
void opMoveSetShowText(Object args[], int numArgs);
|
||||
void opShowSpaceText(Object args[], int numArgs);
|
||||
- void doShowText(GooString *s);
|
||||
+ void doShowText(const GooString *s);
|
||||
|
||||
// XObject operators
|
||||
void opXObject(Object args[], int numArgs);
|
||||
diff --git a/src/extension/internal/pdfinput/svg-builder.cpp b/src/extension/internal/pdfinput/svg-builder.cpp
|
||||
index 158c5ae068..8e5a5f6396 100644
|
||||
--- a/src/extension/internal/pdfinput/svg-builder.cpp
|
||||
+++ b/src/extension/internal/pdfinput/svg-builder.cpp
|
||||
@@ -1021,7 +1021,7 @@ void SvgBuilder::updateFont(GfxState *state) {
|
||||
GfxFont *font = state->getFont();
|
||||
// Store original name
|
||||
if (font->getName()) {
|
||||
- _font_specification = font->getName()->getCString();
|
||||
+ _font_specification = g_strdup(font->getName()->getCString());
|
||||
} else {
|
||||
_font_specification = (char*) "Arial";
|
||||
}
|
||||
@@ -1362,7 +1362,7 @@ void SvgBuilder::_flushText() {
|
||||
_glyphs.clear();
|
||||
}
|
||||
|
||||
-void SvgBuilder::beginString(GfxState *state, GooString * /*s*/) {
|
||||
+void SvgBuilder::beginString(GfxState *state) {
|
||||
if (_need_font_update) {
|
||||
updateFont(state);
|
||||
}
|
||||
diff --git a/src/extension/internal/pdfinput/svg-builder.h b/src/extension/internal/pdfinput/svg-builder.h
|
||||
index ad15c9c06f..ed2a4d48e0 100644
|
||||
--- a/src/extension/internal/pdfinput/svg-builder.h
|
||||
+++ b/src/extension/internal/pdfinput/svg-builder.h
|
||||
@@ -29,7 +29,6 @@ namespace Inkscape {
|
||||
#include <glibmm/ustring.h>
|
||||
|
||||
#include "CharTypes.h"
|
||||
-class GooString;
|
||||
class Function;
|
||||
class GfxState;
|
||||
struct GfxColor;
|
||||
@@ -136,7 +135,7 @@ public:
|
||||
void clearSoftMask(GfxState *state);
|
||||
|
||||
// Text handling
|
||||
- void beginString(GfxState *state, GooString *s);
|
||||
+ void beginString(GfxState *state);
|
||||
void endString(GfxState *state);
|
||||
void addChar(GfxState *state, double x, double y,
|
||||
double dx, double dy,
|
||||
--
|
||||
2.17.1
|
||||
|
@ -0,0 +1,29 @@
|
||||
From fa1c469aa8c005e07bb8676d72af9f7c16fae3e0 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Palus <atler@pld-linux.org>
|
||||
Date: Fri, 25 May 2018 00:30:17 +0200
|
||||
Subject: [PATCH] Fix compilation with poppler 0.65.0
|
||||
|
||||
replace unused includes with one that is actually used
|
||||
|
||||
Signed-off-by: Jan Palus <atler@pld-linux.org>
|
||||
---
|
||||
src/extension/internal/pdfinput/pdf-parser.cpp | 3 +--
|
||||
1 file changed, 1 insertion(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/extension/internal/pdfinput/pdf-parser.cpp b/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
index 6c498f9812..caaeca18e0 100644
|
||||
--- a/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
+++ b/src/extension/internal/pdfinput/pdf-parser.cpp
|
||||
@@ -37,8 +37,7 @@ extern "C" {
|
||||
#include "util/units.h"
|
||||
|
||||
#include "goo/gmem.h"
|
||||
-#include "goo/GooTimer.h"
|
||||
-#include "goo/GooHash.h"
|
||||
+#include "goo/GooString.h"
|
||||
#include "GlobalParams.h"
|
||||
#include "CharTypes.h"
|
||||
#include "Object.h"
|
||||
--
|
||||
2.17.1
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -0,0 +1,31 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!-- Copyright 2014 Richard Hughes <richard@hughsie.com> -->
|
||||
<!--
|
||||
BugReportURL: http://inkscape.13.x6.nabble.com/Inkscape-and-AppData-td4967842.html
|
||||
SentUpstream: 2013-09-06
|
||||
-->
|
||||
<application>
|
||||
<id type="desktop">inkscape.desktop</id>
|
||||
<metadata_license>CC0-1.0</metadata_license>
|
||||
<description>
|
||||
<p>
|
||||
An Open Source vector graphics editor, with capabilities similar to Illustrator,
|
||||
CorelDraw, or Xara X, using the W3C standard Scalable Vector Graphics (SVG) file
|
||||
format.
|
||||
</p>
|
||||
<p>
|
||||
Inkscape supports many advanced SVG features (markers, clones, alpha blending,
|
||||
etc.) and great care is taken in designing a streamlined interface. It is very
|
||||
easy to edit nodes, perform complex path operations, trace bitmaps and much more.
|
||||
We also aim to maintain a thriving user and developer community by using open,
|
||||
community-oriented development.
|
||||
</p>
|
||||
</description>
|
||||
<url type="homepage">http://inkscape.org/</url>
|
||||
<screenshots>
|
||||
<screenshot type="default">https://raw.githubusercontent.com/hughsie/fedora-appstream/master/screenshots-extra/inkscape/a.png</screenshot>
|
||||
</screenshots>
|
||||
<!-- FIXME: change this to an upstream email address for spec updates
|
||||
<updatecontact>someone_who_cares@upstream_project.org</updatecontact>
|
||||
-->
|
||||
</application>
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue