diff --git a/indent-2.2.11-Modernize-texi2html-arguments.patch b/indent-2.2.11-Modernize-texi2html-arguments.patch
new file mode 100644
index 0000000..b199929
--- /dev/null
+++ b/indent-2.2.11-Modernize-texi2html-arguments.patch
@@ -0,0 +1,41 @@
+From 7df0983c326f406dddbcc7c98dce72d5174d2a3c Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?=
+Date: Wed, 18 Mar 2015 18:30:01 +0100
+Subject: [PATCH] Modernize texi2html arguments
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+texi2html-5.0 complains on -number argument:
+
+ Option number is ambiguous (number-footnotes, number-sections)
+
+This patch updates texi2html arguments to comply with texi2html-5.0.
+
+Signed-off-by: Petr Písař
+
+diff --git a/doc/Makefile.am b/doc/Makefile.am
+index d1fb09a..5eb9dc0 100644
+--- a/doc/Makefile.am
++++ b/doc/Makefile.am
+@@ -34,14 +34,14 @@ html-monolithic: @PACKAGE@.html
+ html-split: @PACKAGE@_toc.html
+
+ @PACKAGE@.html: version.texi $(@PACKAGE@_TEXINFOS)
+- $(TEXI2HTML) -expandinfo -number -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
++ $(TEXI2HTML) -expand info -number-sections -monolithic `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi`
+
+ @PACKAGE@_toc.html: version.texi $(@PACKAGE@_TEXINFOS)
+ case "$(TEXI2HTML)" in \
+ *"/missing texi2html") \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
++ $(TEXI2HTML) -expand info -number-sections -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` || exit 0 ;; \
+ *) $(RM) @PACKAGE@_*.html ; \
+- $(TEXI2HTML) -expand info -number -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
++ $(TEXI2HTML) -expand info -number-sections -nomenu -split section `if test -f @PACKAGE@.texinfo; then echo @PACKAGE@.texinfo; else echo $(srcdir)/@PACKAGE@.texinfo; fi` ;; \
+ esac
+
+ install-html-monolithic: @PACKAGE@.html
+--
+2.1.0
+
diff --git a/indent.spec b/indent.spec
index 3f425f7..f1c71e5 100644
--- a/indent.spec
+++ b/indent.spec
@@ -30,6 +30,9 @@ Patch12: indent-2.2.11-Fix-copying-overlapping-comment.patch
# Submitted to upstream
#
Patch13: indent-2.2.11-Support-hexadecimal-floats.patch
+# Submitted to upstream
+#
+Patch14: indent-2.2.11-Modernize-texi2html-arguments.patch
# gperf to update pre-generated code to fix compiler warnings
BuildRequires: gperf
BuildRequires: texinfo texi2html
@@ -57,6 +60,7 @@ you want a program to format your code.
%patch11 -p1 -b .warnings
%patch12 -p1 -b .comments
%patch13 -p1 -b .hexa_float
+%patch14 -p1 -b .texi2html5
# Regenerate sources
rm src/gperf.c src/gperf-cc.c
# Update config.sub to support aarch64, bug #925588
@@ -96,6 +100,7 @@ fi
%changelog
* Wed Mar 18 2015 Petr Pisar - 2.2.11-16
- Support hexadecimal floats
+- Adapt to changes in texi2html-5.0
* Sat Aug 16 2014 Fedora Release Engineering - 2.2.11-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild