c8-stream-rhel8
imports/c8-stream-rhel8/icu4j-65.1-3.module+el8.2.1+6727+059d025f
commit
7cc57b288b
@ -0,0 +1 @@
|
||||
SOURCES/icu4j-65_1.tgz
|
@ -0,0 +1 @@
|
||||
87636fc1c7ad98306c4f68169042dd96fc67be1c SOURCES/icu4j-65_1.tgz
|
@ -0,0 +1,47 @@
|
||||
--- manifest.stub.orig 2018-11-27 10:26:04.174847598 +0000
|
||||
+++ manifest.stub 2018-11-27 10:27:14.685508767 +0000
|
||||
@@ -15,5 +15,23 @@
|
||||
Bundle-Copyright: @COPYRIGHT@
|
||||
Bundle-RequiredExecutionEnvironment: @EXECENV@
|
||||
Main-Class: com.ibm.icu.util.VersionInfo
|
||||
-Export-Package: com.ibm.icu.lang,com.ibm.icu.math,com.ibm.icu.number,com.ibm.icu.text,com.ibm.icu.util
|
||||
+Export-Package: com.ibm.icu.lang;base=true;full=true;version="@IMPLVERSION@",
|
||||
+ com.ibm.icu.math;base=true;full=true;version="@IMPLVERSION@",
|
||||
+ com.ibm.icu.number;base=true;full=true;version="@IMPLVERSION@",
|
||||
+ com.ibm.icu.text;base=true;full=true;version="@IMPLVERSION@",
|
||||
+ com.ibm.icu.util;base=true;full=true;version="@IMPLVERSION@",
|
||||
+ com.ibm.icu.impl;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data.icudt@DATAVERSION@b;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data.icudt@DATAVERSION@b.brkitr;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data.icudt@DATAVERSION@b.coll;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data.icudt@DATAVERSION@b.curr;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data.icudt@DATAVERSION@b.lang;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data.icudt@DATAVERSION@b.rbnf;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data.icudt@DATAVERSION@b.region;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data.icudt@DATAVERSION@b.translit;x-internal:=true,
|
||||
+ com.ibm.icu.impl.data.icudt@DATAVERSION@b.zone;x-internal:=true,
|
||||
+ com.ibm.icu.impl.duration;x-internal:=true,
|
||||
+ com.ibm.icu.impl.locale;x-internal:=true
|
||||
+Bundle-ActivationPolicy: lazy
|
||||
Automatic-Module-Name: com.ibm.icu
|
||||
--- main/shared/build/common-targets.xml.orig 2014-11-17 14:59:05.335849961 +0000
|
||||
+++ main/shared/build/common-targets.xml 2014-11-17 14:59:36.868423736 +0000
|
||||
@@ -75,6 +75,7 @@
|
||||
<filterset>
|
||||
<filter token="SPECVERSION" value="${jar.spec.version}"/>
|
||||
<filter token="IMPLVERSION" value="${jar.impl.version}"/>
|
||||
+ <filter token="DATAVERSION" value="${icu4j.data.version}"/>
|
||||
<filter token="COPYRIGHT" value="${jar.copyright.info}"/>
|
||||
<filter token="EXECENV" value="${jar.exec.env}"/>
|
||||
</filterset>
|
||||
--- build.xml.orig 2014-11-17 21:45:53.308610711 +0000
|
||||
+++ build.xml 2014-11-17 21:46:29.969096734 +0000
|
||||
@@ -683,6 +683,7 @@
|
||||
<filterset>
|
||||
<filter token="SPECVERSION" value="${jar.spec.version}"/>
|
||||
<filter token="IMPLVERSION" value="${jar.impl.version}"/>
|
||||
+ <filter token="DATAVERSION" value="${icu4j.data.version}"/>
|
||||
<filter token="COPYRIGHT" value="${jar.copyright.info}"/>
|
||||
<filter token="EXECENV" value="${jar.exec.env}"/>
|
||||
</filterset>
|
@ -0,0 +1,378 @@
|
||||
%global gittag %(v=%{version}; echo "release-$v" | sed 's/\\./-/')
|
||||
%global srctgz %(v=%{version}; echo "icu4j-$v" | sed 's/\\./_/')
|
||||
|
||||
Name: icu4j
|
||||
Version: 65.1
|
||||
Release: 3%{?dist}
|
||||
Epoch: 1
|
||||
Summary: International Components for Unicode for Java
|
||||
# ICU itself is now covered by Unicode license, but still has contributed
|
||||
# components covered by MIT and BSD licenses
|
||||
# Data from the Timezone Database is Public Domain
|
||||
License: Unicode and MIT and BSD and Public Domain
|
||||
URL: http://site.icu-project.org/
|
||||
|
||||
Source0: https://github.com/unicode-org/icu/releases/download/%{gittag}/%{srctgz}.tgz
|
||||
|
||||
# Add better OSGi metadata to core jar
|
||||
Patch0: improve-osgi-manifest.patch
|
||||
|
||||
BuildRequires: ant
|
||||
BuildRequires: ant-junit
|
||||
BuildRequires: java-javadoc
|
||||
BuildRequires: javapackages-local
|
||||
BuildRequires: ivy-local
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
The International Components for Unicode (ICU) library provides robust and
|
||||
full-featured Unicode services on a wide variety of platforms. ICU supports
|
||||
the most current version of the Unicode standard, and provides support for
|
||||
supplementary characters (needed for GB 18030 repertoire support).
|
||||
|
||||
Java provides a very strong foundation for global programs, and IBM and the
|
||||
ICU team played a key role in providing globalization technology into Sun's
|
||||
Java. But because of its long release schedule, Java cannot always keep
|
||||
up-to-date with evolving standards. The ICU team continues to extend Java's
|
||||
Unicode and internationalization support, focusing on improving
|
||||
performance, keeping current with the Unicode standard, and providing
|
||||
richer APIs, while remaining as compatible as possible with the original
|
||||
Java text and internationalization API design.
|
||||
|
||||
%package charset
|
||||
Summary: Charset converter library of %{name}
|
||||
|
||||
%description charset
|
||||
Charset converter library of %{name}.
|
||||
|
||||
%package localespi
|
||||
Summary: Locale SPI library of %{name}
|
||||
|
||||
%description localespi
|
||||
Locale SPI library of %{name}.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
Requires: java-javadoc
|
||||
|
||||
%description javadoc
|
||||
API documentation for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -c
|
||||
%patch0
|
||||
|
||||
# Ivy local does not name these libs as icu4j expects
|
||||
sed -i -e 's/junit-4.12/junit-SYSTEM/' \
|
||||
-e 's/hamcrest-core-1.3/hamcrest-core-SYSTEM/' build.xml
|
||||
|
||||
# Missing dep on pl.pragmatists:JUnitParams for tests, so delete tests that
|
||||
# requires it for now
|
||||
sed -i -e '/pl.pragmatists/d' ivy.xml
|
||||
rm main/tests/core/src/com/ibm/icu/dev/test/format/DataDrivenFormatTest.java
|
||||
rm main/tests/core/src/com/ibm/icu/dev/test/calendar/DataDrivenCalendarTest.java
|
||||
rm main/tests/core/src/com/ibm/icu/dev/test/serializable/CompatibilityTest.java
|
||||
rm main/tests/core/src/com/ibm/icu/dev/test/serializable/CoverageTest.java
|
||||
rm main/tests/core/src/com/ibm/icu/dev/test/util/LocaleMatcherTest.java
|
||||
rm main/tests/charset/src/com/ibm/icu/dev/test/charset/TestConversion.java
|
||||
rm main/tests/translit/src/com/ibm/icu/dev/test/translit/TransliteratorDisorderedMarksTest.java
|
||||
|
||||
%build
|
||||
export JAVA_HOME=%{_jvmdir}/java/
|
||||
mkdir -p ~/.ant/lib
|
||||
ant -Djavac.source=8 -Djavac.target=8 -Divy.mode=local -Doffline=true -Dicu4j.api.doc.jdk.link=%{_javadocdir}/java all
|
||||
|
||||
for jar in icu4j icu4j-charset icu4j-localespi ; do
|
||||
sed -i -e 's/@POMVERSION@/%{version}/' maven/$jar/pom.xml
|
||||
%mvn_artifact maven/$jar/pom.xml $jar.jar
|
||||
%mvn_package :$jar $jar
|
||||
done
|
||||
|
||||
%install
|
||||
%mvn_install -J doc
|
||||
|
||||
# No poms for these, so install manually
|
||||
install -m 644 icu4j-charset.jar %{buildroot}%{_javadir}/icu4j/
|
||||
install -m 644 icu4j-localespi.jar %{buildroot}%{_javadir}/icu4j/
|
||||
|
||||
%files -f .mfiles-icu4j
|
||||
%license main/shared/licenses/*
|
||||
%doc readme.html APIChangeReport.html
|
||||
|
||||
%files charset -f .mfiles-icu4j-charset
|
||||
|
||||
%files localespi -f .mfiles-icu4j-localespi
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
%license main/shared/licenses/*
|
||||
|
||||
%changelog
|
||||
* Wed May 20 2020 Mat Booth <mat.booth@redhat.com> - 1:65.1-3
|
||||
- Allow building on Java 11
|
||||
|
||||
* Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1:65.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Jan 23 2020 Mat Booth <mat.booth@redhat.com> - 1:65.1-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Thu Dec 12 2019 Mat Booth <mat.booth@redhat.com> - 1:64.2-3
|
||||
- Tests take too long on 32bit arm
|
||||
|
||||
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:64.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Thu Apr 25 2019 Mat Booth <mat.booth@redhat.com> - 1:64.2-1
|
||||
- Update to latest upstream release
|
||||
|
||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1:63.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Tue Nov 27 2018 Mat Booth <mat.booth@redhat.com> - 1:63.1-1
|
||||
- Update to latest upstream version
|
||||
|
||||
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:62.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Jun 28 2018 Mat Booth <mat.booth@redhat.com> - 1:62.1-1
|
||||
- Update to latest upstream for Unicode 10 and 11 support
|
||||
- License update
|
||||
|
||||
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1:59.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1:59.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Thu May 18 2017 Mat Booth <mat.booth@redhat.com> - 1:59.1-1
|
||||
- Update to latest upstream release
|
||||
- Drop old obsoletes/provides
|
||||
|
||||
* Fri Feb 10 2017 Mat Booth <mat.booth@redhat.com> - 1:58.2-1
|
||||
- Update to 58.2 release
|
||||
|
||||
* Thu Jan 26 2017 Mat Booth <mat.booth@redhat.com> - 1:58.1-1
|
||||
- Update to latest upstream release
|
||||
- Adopt license macro
|
||||
- Drop no longer needed patches
|
||||
|
||||
* Thu Jul 21 2016 Mat Booth <mat.booth@redhat.com> - 1:54.1.1-8
|
||||
- Disable doclinting during javadoc generation
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1:54.1.1-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Mon Jun 22 2015 Mat Booth <mat.booth@redhat.com> - 1:54.1.1-6
|
||||
- Remove incomplete SCL macros
|
||||
|
||||
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:54.1.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Nov 21 2014 Mat Booth <mat.booth@redhat.com> - 1:54.1.1-4
|
||||
- Drop unnecessay requires on main package and fix requires on sub packages
|
||||
|
||||
* Fri Nov 21 2014 Mat Booth <mat.booth@redhat.com> - 1:54.1.1-3
|
||||
- Drop the eclipse sub-package, no longer needed
|
||||
|
||||
* Mon Nov 17 2014 Mat Booth <mat.booth@redhat.com> - 1:54.1.1-2
|
||||
- Fix typo in osgi manifest patch
|
||||
|
||||
* Mon Nov 17 2014 Mat Booth <mat.booth@redhat.com> - 1:54.1.1-1
|
||||
- Update to latest upstream release
|
||||
- Add patch for building against java 8 taglet API
|
||||
- Fixes: rhbz#1087450, rhbz#1106794
|
||||
- Add patch for generating better OSGi metadata in core lib
|
||||
- Install core lib with mvn_install
|
||||
- Package localespi lib
|
||||
- Run test suite
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:52.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri Mar 28 2014 Michael Simacek <msimacek@redhat.com> - 1:52.1-2
|
||||
- Use Requires: java-headless rebuild (#1067528)
|
||||
|
||||
* Tue Mar 18 2014 Michael Simacek <msimacek@redhat.com> - 1:52.1-1
|
||||
- Update to upstream version 52.1
|
||||
- Require java-headless
|
||||
|
||||
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:50.1.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue May 14 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:50.1.1-1
|
||||
- Update to latest upstream.
|
||||
|
||||
* Fri Mar 22 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:50.1.0-7
|
||||
- Build sclized version using SCLized Eclipse.
|
||||
|
||||
* Thu Feb 21 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:50.1.0-6
|
||||
- RHBZ#913369 Provide icu4j-charset library
|
||||
|
||||
* Tue Feb 12 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:50.1.0-5
|
||||
- SCLize.
|
||||
|
||||
* Mon Feb 11 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:50.1.0-4
|
||||
- Revert a hardcoded path.
|
||||
|
||||
* Mon Feb 11 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:50.1.0-3
|
||||
- Complete the removal.
|
||||
|
||||
* Mon Feb 11 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:50.1.0-2
|
||||
- Remove the main jar manifest.
|
||||
|
||||
* Thu Feb 7 2013 Krzysztof Daniel <kdaniel@redhat.com> 1:50.1.0-1
|
||||
- Update to latest upstream.
|
||||
|
||||
* Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:4.4.2.2-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Tue Apr 24 2012 Alexander Kurtakov <akurtako@redhat.com> 1:4.4.2.2-12
|
||||
- Don't build icu4j-eclipse for rhel.
|
||||
|
||||
* Thu Feb 16 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.4.2.2-11
|
||||
- Make the package noarch.
|
||||
|
||||
* Wed Feb 1 2012 Daniel Mach <dmach@redhat.com> 1:4.4.2.2-10
|
||||
- Tweak with_eclipse macro for rhel and non-intel architectures.
|
||||
|
||||
* Fri Jan 27 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.4.2.2-9
|
||||
- Getting back to 4 digit version
|
||||
|
||||
* Thu Jan 26 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.4.2-8
|
||||
- Proper sources uploaded
|
||||
|
||||
* Thu Jan 26 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.4.2-7
|
||||
- Better versioning consistent with previous releases
|
||||
|
||||
* Mon Jan 16 2012 Krzysztof Daniel <kdaniel@redhat.com> 1:4.4.2.2-6
|
||||
- Update to 4.4.2.2.
|
||||
|
||||
* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:4.4.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Tue Nov 15 2011 Alexander Kurtakov <akurtako@redhat.com> 1:4.4.2-4
|
||||
- Add proper manifest to the jar in the main package.
|
||||
|
||||
* Fri Sep 16 2011 Alexander Kurtakov <akurtako@redhat.com> 1:4.4.2-3
|
||||
- Adapt to current guidelines.
|
||||
|
||||
* Mon May 9 2011 Alexander Kurtakov <akurtako@redhat.com> 1:4.4.2-2
|
||||
- Use proper tarball.
|
||||
- Fix build.
|
||||
|
||||
* Tue Apr 05 2011 Chris Aniszczyk <zx@redhat.com> 1:4.4.2-1
|
||||
- Update to 4.4.2.
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:4.2.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Jul 8 2010 Alexander Kurtakov <akurtako@redhat.com> 1:4.2.1-1
|
||||
- Update to 4.2.1.
|
||||
|
||||
* Fri Feb 5 2010 Mary Ellen Foster <mefoster at gmail.com> 1:4.0.1-5
|
||||
- Add maven pom and depmap fragment
|
||||
|
||||
* Tue Sep 29 2009 Alexander Kurtakov <akurtako@redhat.com> 1:4.0.1-4
|
||||
- Simplify with_eclipse conditional.
|
||||
|
||||
* Mon Aug 10 2009 Alexander Kurtakov <akurtako@redhat.com> 1:4.0.1-3
|
||||
- Update qualifier to the Eclipse 3.5.0 release.
|
||||
|
||||
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:4.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Apr 8 2009 Alexander Kurtakov <akurtako@redhat.com> 1:4.0.1-1
|
||||
- Update to 4.0.1.
|
||||
|
||||
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:3.8.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Oct 8 2008 Ville Skyttä <ville.skytta at iki.fi> - 0:3.8.1-4
|
||||
- Disable debuginfo package when built with Eclipse support, change to
|
||||
noarch when built without it (#464017).
|
||||
|
||||
* Mon Aug 11 2008 Andrew Overholt <overholt@redhat.com> 3.8.1-3
|
||||
- Get rid of eclipse_name macro
|
||||
- Rebuild with Eclipse 3.4 and put into Eclipse stuff into
|
||||
%%{_libdir}/eclipse
|
||||
- Remove now-unnecessary OSGi configuration dir patch
|
||||
- Add patch to point to PDE Build location
|
||||
|
||||
* Fri Jul 11 2008 Andrew Overholt <overholt@redhat.com> 0:3.8.1-2
|
||||
- Remove GCJ support due to
|
||||
com.sun.tools.doclets.internal.toolkit.taglets.* import (not in gjdoc)
|
||||
|
||||
* Fri Jul 11 2008 Andrew Overholt <overholt@redhat.com> 0:3.8.1-1
|
||||
- 3.8.1
|
||||
|
||||
* Wed Jul 9 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:3.6.1-3
|
||||
- drop repotag
|
||||
- fix license tag
|
||||
|
||||
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:3.6.1-2jpp.6
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Tue Nov 13 2007 Andrew Overholt <overholt@redhat.com> 3.6.1-1jpp.6
|
||||
- Bump release and change updatetimestamp patch to have DOS
|
||||
line-endings.
|
||||
|
||||
* Tue Nov 13 2007 Andrew Overholt <overholt@redhat.com> 3.6.1-1jpp.5
|
||||
- Bump release.
|
||||
|
||||
* Fri Sep 28 2007 Andrew Overholt <overholt@redhat.com> 3.6.1-1jpp.4
|
||||
- Update timestamp to match Eclipse 3.3.1 release.
|
||||
|
||||
* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 3.6.1-1jpp.3
|
||||
- Rebuild for selinux ppc32 issue.
|
||||
|
||||
* Wed Jun 27 2007 Ben Konrath <bkonrath@redhat.com> - 0:3.6.1-1jpp.2
|
||||
- Remove requires eclipse-rcp in eclipse sub-package.
|
||||
|
||||
* Thu Jun 07 2007 Ben Konrath <bkonrath@redhat.com> - 0:3.6.1-1jpp.1
|
||||
- 3.6.1.
|
||||
- Enable eclipse sub-package.
|
||||
|
||||
* Fri Mar 16 2007 Jeff Johnston <jjohnstn@redhat.com> - 0:3.4.5-2jpp.2
|
||||
- Disable eclipse plugin support temporarily until build problems
|
||||
can be worked out. Plugin is still being built as part of
|
||||
eclipse platform.
|
||||
- BuildRequire sinjdoc.
|
||||
|
||||
* Mon Feb 12 2007 Matt Wringe <mwringe@redhat.com> - 0:3.4.5-2jpp.1
|
||||
- Fix some rpmlint issues
|
||||
- Make use of buildroot more consistent
|
||||
- Remove javadoc post and postun sections as per new jpp standard
|
||||
- Change license section to 'MIT style' license from 'MIT' license.
|
||||
This was done since the source package calls the license the
|
||||
"X license" (see readme.html in src jar).
|
||||
- Install eclipse plugin into /usr/share/eclipse
|
||||
|
||||
* Mon Jan 22 2007 Fernando Nasser <fnasser@redhat.com> - 0:3.4.5-2jpp.1
|
||||
- Merge with upstream
|
||||
|
||||
* Mon Jan 22 2007 Fernando Nasser <fnasser@redhat.com> - 0:3.4.5-2jpp
|
||||
- Add optional eclipse subpackage, created by
|
||||
Jeff Johnston <jjohnstn@rdhat.com> :
|
||||
- Add eclipse sub-package to create plugins.
|
||||
|
||||
* Mon Jan 22 2007 Fernando Nasser <fnasser@redhat.com> - 0:3.4.5-1jpp
|
||||
- Upgrade to 3.4.5 with merge
|
||||
- Re-enable javadoc
|
||||
|
||||
* Mon Sep 04 2006 Ben Konrath <bkonrath@redhat.com> 0:3.4.5-1jpp_1fc
|
||||
- 3.4.5.
|
||||
- Add GCJ support with spec-convert-gcj-1.6.
|
||||
|
||||
* Mon Jul 17 2006 Ben Konrath <bkonrath@redhat.com> 0:3.4.4-1jpp_1fc
|
||||
- 3.4.4.
|
||||
- Add disable javadocs patch.
|
||||
|
||||
* Tue Feb 28 2006 Fernando Nasser <fnasser@redhat.com> - 0:3.2-2jpp_1rh
|
||||
- First Red Hat build
|
||||
|
||||
* Mon Feb 27 2006 Fernando Nasser <fnasser@redhat.com> - 0:3.2-2jpp
|
||||
- First JPP 1.7 build
|
||||
|
||||
* Sat Jan 29 2005 David Walluck <david@jpackage.org> 0:3.2-1jpp
|
||||
- release (contributed by Mary Ellen Foster <mefoster at gmail.com>)
|
Loading…
Reference in new issue