@ -1,7 +1,7 @@
diff - ru --exclude=config.h htop-0.9/configure.ac htop-0.9-patched /configure.ac
--- htop- 0.9/configure.ac 2010-11-23 16:56:32 .000000000 +0100
+++ htop- 0.9-patched/configure.ac 2011-03-09 16:58:38.471801331 +0100
@@ - 18,11 +18 ,13 @@
diff - Naur htop-1.0/configure.ac.orig htop-1.0 /configure.ac
--- htop- 1.0/configure.ac.orig 2011-11-21 03:46:48 .000000000 +0100
+++ htop- 1.0/configure.ac 2012-02-07 17:21:59.098852884 +0100
@@ - 23,11 +23 ,13 @@
# Checks for libraries.
AC_CHECK_LIB([m], [ceil], [], [missing_libraries="$missing_libraries libm"])
@ -15,36 +15,36 @@ diff -ru --exclude=config.h htop-0.9/configure.ac htop-0.9-patched/configure.ac
+AC_CHECK_HEADERS([stdlib.h string.h strings.h sys/param.h sys/time.h unistd.h curses.h pthread.h],[:],[
missing_headers="$missing_headers $ac_header"
])
diff - ru --exclude=config.h htop-0.9/htop.1 htop-0.9-patched /htop.1
--- htop- 0.9/htop.1 2010-11-23 17:34:04.000000000 +0100
+++ htop- 0.9-patched/htop.1 2011-03-09 16:44:07.065449472 +0100
@@ - 25 ,6 +25 ,9 @@
\fB\-u USERNAME\fR
Show only processes of a given user
AC_CHECK_HEADERS([execinfo.h],[:],[:])
diff - Naur htop-1.0/htop.1.orig htop-1.0 /htop.1
--- htop- 1.0/htop.1.orig 2012-02-07 17:28:48.935889755 +0100
+++ htop- 1.0/htop.1 2012-02-07 17:27:44.087881744 +0100
@@ - 3 2,6 +3 2,9 @@
\fB\-u \-\-user= USERNAME\fR
Show only the processes of a given user
.TP
+\fB\-p\fR
+Start working thread for pagemap memory stats
+.TP
\fB\-\-sort\-key COLUMN\fR
Sort by this column (use --sort-key help for a column list)
.P P
diff - ru --exclude=config.h htop-0.9/htop.1.in htop-0.9-patched /htop.1.in
--- htop- 0.9/htop.1.in 2010-06-17 21:03:41 .000000000 +0200
+++ htop- 0.9-patched/htop.1.in 2011-03-09 16:44:07.066449478 +0100
@@ - 25 ,6 +25 ,9 @@
\fB\-u USERNAME\fR
Show only processes of a given user
\fB\-s \- \-sort\-key COLUMN\fR
Sort by this column (use \ -\ -sort\ -key help for a column list)
.T P
diff - Naur htop-1.0/htop.1.in.orig htop-1.0 /htop.1.in
--- htop- 1.0/htop.1.in.orig 2011-09-27 01:59:36 .000000000 +0200
+++ htop- 1.0/htop.1.in 2012-02-07 17:25:23.161867112 +0100
@@ - 3 2,6 +3 2,9 @@
\fB\-u \-\-user= USERNAME\fR
Show only the processes of a given user
.TP
+\fB\-p\fR
+Start working thread for pagemap memory stats
+.TP
\fB\-\-sort\-key COLUMN\fR
Sort by this column (use --sort-key help for a column list)
.P P
diff - ru --exclude=config.h htop-0.9/htop.c htop-0.9-patched /htop.c
--- htop- 0.9/htop.c 2010-11-24 19:45:38 .000000000 +0100
+++ htop- 0.9-patched/htop.c 2011-03-09 16:44:07.067449482 +0100
\fB\-s \- \-sort\-key COLUMN\fR
Sort by this column (use \ -\ -sort\ -key help for a column list)
.T P
diff - Naur htop-1.0/htop.c.orig htop-1.0 /htop.c
--- htop- 1.0/htop.c.orig 2011-11-21 03:48:11 .000000000 +0100
+++ htop- 1.0/htop.c 2012-02-07 17:36:15.348965585 +0100
@@ -13,6 +13,7 @@
#include <stdbool.h>
#include <locale.h>
@ -53,7 +53,7 @@ diff -ru --exclude=config.h htop-0.9/htop.c htop-0.9-patched/htop.c
#include "ProcessList.h"
#include "CRT.h"
@@ -5 2,6 +53 ,9 @@
@@ -5 1,6 +52 ,9 @@
"-C --no-color Use a monochrome color scheme\n"
"-d --delay=DELAY Set the delay between updates, in tenths of seconds\n"
"-h --help Print this help screen\n"
@ -63,7 +63,7 @@ diff -ru --exclude=config.h htop-0.9/htop.c htop-0.9-patched/htop.c
"-s --sort-key=COLUMN Sort by COLUMN (try --sort-key=help for a list)\n"
"-u --user=USERNAME Show only processes of a given user\n"
"-v --version Print version info\n"
@@ -2 44,12 +248,23 @@
@@ -2 38,6 +242,16 @@
ProcessList_printHeader(pl, Panel_getHeader(panel));
}
@ -77,17 +77,18 @@ diff -ru --exclude=config.h htop-0.9/htop.c htop-0.9-patched/htop.c
+}
+#endif
+
int main(int argc, char** argv) {
int delay = -1;
typedef struct IncBuffer_ {
char buffer[INCSEARCH_MAX];
int index;
@@ -255,6 +269,7 @@
bool userOnly = false;
uid_t userId = 0;
int usecolors = 1;
+ int pagemap_enable = 0;
TreeType treeType = TREE_TYPE_AUTO;
int opt, opti=0;
static struct option long_opts[] =
@@ -261,6 +276,9 @@
@@ -267,6 +282,9 @@
{"user", required_argument, 0, 'u'},
{"no-color", no_argument, 0, 'C'},
{"no-colour",no_argument, 0, 'C'},
@ -97,16 +98,16 @@ diff -ru --exclude=config.h htop-0.9/htop.c htop-0.9-patched/htop.c
{0,0,0,0}
};
int sortKey = 0;
@@ -2 72,7 +290 ,7 @@
setlocale(LC_CTYPE, getenv( "LC_ALL ") );
@@ -2 80,7 +298 ,7 @@
setlocale(LC_CTYPE, "");
/* Parse arguments */
- while ((opt = getopt_long _only (argc, argv, "hvCs:d:u:", long_opts, &opti))) {
+ while ((opt = getopt_long _only (argc, argv, "hpvCs:d:u:", long_opts, &opti))) {
- while ((opt = getopt_long (argc, argv, "hvCs:d:u:", long_opts, &opti))) {
+ while ((opt = getopt_long (argc, argv, "hpvCs:d:u:", long_opts, &opti))) {
if (opt == EOF) break;
switch (opt) {
case 'h':
@@ -3 05 ,6 +32 3,11 @@
@@ -3 2 0,6 +338 ,11 @@
case 'C':
usecolors=0;
break;
@ -115,11 +116,11 @@ diff -ru --exclude=config.h htop-0.9/htop.c htop-0.9-patched/htop.c
+ pagemap_enable=1;
+ break;
+#endif
default:
exit(1);
}
}
@@ -379,6 +402,18 @@
int ch = 0;
@@ -432,6 +455,18 @@
int ch = ERR;
int closeTimeout = 0;
+#ifdef HAVE_LIBPAGEMAP
@ -137,7 +138,7 @@ diff -ru --exclude=config.h htop-0.9/htop.c htop-0.9-patched/htop.c
while (!quit) {
gettimeofday(&tv, NULL);
newTime = ((double)tv.tv_sec * 10) + ((double)tv.tv_usec / 100000);
@@ - 817,6 +852 ,12 @@
@@ - 912,6 +947 ,12 @@
if (settings->changed)
Settings_write(settings);
Header_delete(header);
@ -148,8 +149,8 @@ diff -ru --exclude=config.h htop-0.9/htop.c htop-0.9-patched/htop.c
+ }
+#endif
ProcessList_delete(pl);
FunctionBar_delete((Object*)searchB ar);
FunctionBar_delete((Object*)defaultB ar);
FunctionBar_delete((Object*)incFilter.b ar);
FunctionBar_delete((Object*)incSearch.b ar);
diff -ru --exclude=config.h htop-0.9/htop.h htop-0.9-patched/htop.h
--- htop-0.9/htop.h 2010-11-24 19:45:40.000000000 +0100
+++ htop-0.9-patched/htop.h 2011-03-09 16:48:37.672644570 +0100
@ -163,9 +164,9 @@ diff -ru --exclude=config.h htop-0.9/htop.h htop-0.9-patched/htop.h
#include "ProcessList.h"
#include "CRT.h"
diff - ru --exclude=config.h htop-0.9/Process.c htop-0.9-patched /Process.c
--- htop- 0.9/Process.c 2010-11-23 16:56:32 .000000000 +0100
+++ htop- 0.9-patched/Process.c 2011-03-09 16:44:07.069449489 +0100
diff - Naur htop-1.0/Process.c.orig htop-1.0 /Process.c
--- htop- 1.0/Process.c.orig 2011-11-21 03:47:49 .000000000 +0100
+++ htop- 1.0/Process.c 2012-02-07 17:41:02.322032224 +0100
@@ -72,6 +72,9 @@
#ifdef HAVE_CGROUP
CGROUP,
@ -215,14 +216,14 @@ diff -ru --exclude=config.h htop-0.9/Process.c htop-0.9-patched/Process.c
"*** report bug! ***"
};
@@ - 393,6 +405 ,32 @@
case M_SIZE: Process_printLarge Number(this, str, this->m_size * PAGE_SIZE_KB); return;
case M_RESIDENT: Process_printLarge Number(this, str, this->m_resident * PAGE_SIZE_KB); return;
case M_SHARE: Process_printLarge Number(this, str, this->m_share * PAGE_SIZE_KB); return;
@@ - 440,6 +452 ,32 @@
case M_SIZE: Process_human Number(this, str, this->m_size * PAGE_SIZE_KB); return;
case M_RESIDENT: Process_human Number(this, str, this->m_resident * PAGE_SIZE_KB); return;
case M_SHARE: Process_human Number(this, str, this->m_share * PAGE_SIZE_KB); return;
+ #ifdef HAVE_LIBPAGEMAP
+ case M_USS:
+ if (Process_getuid == 0 && this->pl->pagemap_table != NULL) {
+ Process_ printLarge Number(this, str, this->m_uss * PAGE_SIZE_KB);
+ Process_ human Number(this, str, this->m_uss * PAGE_SIZE_KB);
+ return;
+ } else {
+ snprintf(buffer, n, " - ");
@ -230,7 +231,7 @@ diff -ru --exclude=config.h htop-0.9/Process.c htop-0.9-patched/Process.c
+ break;
+ case M_PSS:
+ if (Process_getuid == 0 && this->pl->pagemap_table != NULL) {
+ Process_ printLarge Number(this, str, this->m_pss * PAGE_SIZE_KB);
+ Process_ human Number(this, str, this->m_pss * PAGE_SIZE_KB);
+ return;
+ } else {
+ snprintf(buffer, n, " - ");
@ -238,7 +239,7 @@ diff -ru --exclude=config.h htop-0.9/Process.c htop-0.9-patched/Process.c
+ break;
+ case M_SWAP:
+ if ((Process_getuid == 0 || Process_getuid == this->st_uid) && this->pl->pagemap_table != NULL) {
+ Process_ printLarge Number(this, str, this->m_swap * PAGE_SIZE_KB);
+ Process_ human Number(this, str, this->m_swap * PAGE_SIZE_KB);
+ return;
+ } else {
+ snprintf(buffer, n, " - ");
@ -248,7 +249,7 @@ diff -ru --exclude=config.h htop-0.9/Process.c htop-0.9-patched/Process.c
case ST_UID: snprintf(buffer, n, "%4d ", this->st_uid); break;
case USER: {
if (Process_getuid != (int) this->st_uid)
@@ - 583,6 +621 ,14 @@
@@ - 677,6 +715 ,14 @@
return (p2->m_resident - p1->m_resident);
case M_SHARE:
return (p2->m_share - p1->m_share);
@ -295,9 +296,9 @@ diff -ru --exclude=config.h htop-0.9/Process.h htop-0.9-patched/Process.h
uid_t st_uid;
float percent_cpu;
float percent_mem;
diff - ru --exclude=config.h htop-0.9/ProcessList.c htop-0.9-patched /ProcessList.c
--- htop- 0.9/ProcessList.c 2010-11-26 17:50:25 .000000000 +0100
+++ htop- 0.9-patched/ProcessList.c 2011-03-09 16:44:07.071449495 +0100
diff - Naur htop-1.0/ProcessList.c.orig htop-1.0 /ProcessList.c
--- htop- 1.0/ProcessList.c.orig 2011-11-21 03:47:37 .000000000 +0100
+++ htop- 1.0/ProcessList.c 2012-02-07 17:43:52.289077822 +0100
@@ -10,6 +10,9 @@
#include "config.h"
#endif
@ -316,28 +317,28 @@ diff -ru --exclude=config.h htop-0.9/ProcessList.c htop-0.9-patched/ProcessList.
#include "debug.h"
#include <assert.h>
@@ -1 25,6 +129 ,10 @@
bool highlightThreads ;
bool detailedCPUTime ;
@@ -1 48,6 +152 ,10 @@
bool countCPUsFromZero ;
const char **treeStr ;
+#ifdef HAVE_LIBPAGEMAP
+ pagemap_tbl * pagemap_table;
+#endif
+
} ProcessList;
}*/
@@ -177,6 +185,9 @@
this->highlightBaseName = false;
this->highlightMegabytes = false;
}*/
@@ -230,6 +238,9 @@
this->detailedCPUTime = false;
this->countCPUsFromZero = false;
this->treeStr = NULL;
+#ifdef HAVE_LIBPAGEMAP
+ this->pagemap_table = NULL;
+#endif
+#endif
return this;
}
@@ -4 29,6 +440 ,29 @@
@@ -4 96,6 +507 ,29 @@
return (num == 7);
}
@ -367,7 +368,7 @@ diff -ru --exclude=config.h htop-0.9/ProcessList.c htop-0.9-patched/ProcessList.
#ifdef HAVE_OPENVZ
static void ProcessList_readOpenVZData(Process* process, const char* dirname, const char* name) {
@@ - 589,6 +623 ,11 @@
@@ - 660,6 +694 ,11 @@
if (! ProcessList_readStatmFile(process, dirname, name))
goto errorReadingProcess;
@ -379,9 +380,9 @@ diff -ru --exclude=config.h htop-0.9/ProcessList.c htop-0.9-patched/ProcessList.
process->show = ! ((hideKernelThreads && Process_isKernelThread(process)) || (hideUserlandThreads && Process_isUserlandThread(process)));
char command[MAX_NAME+1];
diff - ru --exclude=config.h htop-0.9/ProcessList.h htop-0.9-patched /ProcessList.h
--- htop- 0.9/ProcessList.h 2010-11-26 17:51:25 .000000000 +0100
+++ htop- 0.9-patched/ProcessList.h 2011-03-09 16:44:07.072449499 +0100
diff - Naur htop-1.0/ProcessList.h.orig htop-1.0 /ProcessList.h
--- htop- 1.0/ProcessList.h.orig 2011-11-21 03:49:01 .000000000 +0100
+++ htop- 1.0/ProcessList.h 2012-02-07 17:45:46.224110828 +0100
@@ -14,6 +14,9 @@
#include "config.h"
#endif
@ -400,9 +401,9 @@ diff -ru --exclude=config.h htop-0.9/ProcessList.h htop-0.9-patched/ProcessList.
#include "debug.h"
#include <assert.h>
@@ -1 25,6 +129 ,10 @@
bool highlightThreads ;
bool detailedCPUTime ;
@@ -1 50,6 +154 ,10 @@
bool countCPUsFromZero ;
const char **treeStr ;
+#ifdef HAVE_LIBPAGEMAP
+ pagemap_tbl * pagemap_table;
@ -410,8 +411,8 @@ diff -ru --exclude=config.h htop-0.9/ProcessList.h htop-0.9-patched/ProcessList.
+
} ProcessList;
ProcessList* ProcessList_new(UsersTable* usersTable);
@@ -1 45,6 +15 3,10 @@
@@ -1 75,6 +18 3,10 @@
#endif