You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
35 lines
1.2 KiB
35 lines
1.2 KiB
The pcardext Python extension cannot be loaded because it has not been
|
|
ported to Python 3:
|
|
|
|
>>> import pcardext
|
|
Traceback (most recent call last):
|
|
File "<stdin>", line 1, in <module>
|
|
ImportError: /usr/lib64/python3.11/site-packages/pcardext.so: undefined symbol: PyString_AsStringAndSize
|
|
>>>
|
|
|
|
Stop building this extension because it breaks the build if the
|
|
compiler lacks support for implicit function declarations.
|
|
|
|
Bug: <https://bugzilla.redhat.com/show_bug.cgi?id=2148210>
|
|
|
|
Submitted upstream: <https://bugs.launchpad.net/hplip/+bug/1997875>
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index ddac16a9dd514008..15d953af9150c09e 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -306,13 +306,6 @@ if !HPLIP_CLASS_DRIVER
|
|
pcarddir = $(hplipdir)/pcard
|
|
dist_pcard_DATA = pcard/__init__.py pcard/photocard.py
|
|
|
|
-# pcardext
|
|
-pcardextdir = $(pyexecdir)
|
|
-pcardext_LTLIBRARIES = pcardext.la
|
|
-pcardext_la_LDFLAGS = -module -avoid-version
|
|
-pcardext_la_SOURCES = pcard/pcardext/pcardext.c pcard/fat.c pcard/pcardext/pcardext.h
|
|
-pcardext_la_CFLAGS = -I$(PYTHONINCLUDEDIR)
|
|
-
|
|
# prnt
|
|
prntdir = $(hplipdir)/prnt
|
|
dist_prnt_DATA = prnt/cups.py prnt/__init__.py prnt/ldl.py prnt/pcl.py prnt/colorcal.py
|