- Update to 1.8.3

- Update signal and detect patches
- Drop open patch fixed upstream
epel9
Orion Poplawski 16 years ago
parent 1ca91c3887
commit e8b4b3b6f5

@ -1 +1 @@
hdf5-1.8.2.tar.gz
hdf5-1.8.3.tar.gz

@ -1,11 +0,0 @@
--- hdf5-1.6.5/perform/zip_perf.c.open 2007-08-08 14:55:09.000000000 -0600
+++ hdf5-1.6.5/perform/zip_perf.c 2007-08-08 14:55:25.000000000 -0600
@@ -545,7 +545,7 @@
unlink(filename);
/* do compressed data write */
- output = open(filename, O_RDWR | O_CREAT);
+ output = open(filename, O_RDWR | O_CREAT, S_IRWXU);
if (output == -1)
error(strerror(errno));

@ -1,5 +1,5 @@
--- hdf5-1.8.2/src/Makefile.in.detect 2008-11-10 14:40:45.000000000 -0700
+++ hdf5-1.8.2/src/Makefile.in 2009-02-23 13:26:39.000000000 -0700
--- hdf5-1.8.3/src/Makefile.in.detect 2009-05-13 09:02:40.000000000 -0600
+++ hdf5-1.8.3/src/Makefile.in 2009-06-02 10:36:58.506563941 -0600
@@ -132,7 +132,7 @@
H5detect_OBJECTS = H5detect-H5detect.$(OBJEXT)
H5detect_LDADD = $(LDADD)
@ -9,16 +9,16 @@
$(LDFLAGS) -o $@
DEFAULT_INCLUDES = -I.@am__isrc@
depcomp = $(SHELL) $(top_srcdir)/bin/depcomp
@@ -408,7 +408,7 @@
@@ -409,7 +409,7 @@
LT_VERS_INTERFACE = 6
LT_VERS_REVISION = 1
LT_VERS_REVISION = 2
LT_VERS_AGE = 0
-H5detect_CFLAGS = -g
+H5detect_CFLAGS = -g -O0
# Our main target, the HDF5 library
lib_LTLIBRARIES = libhdf5.la
@@ -860,18 +860,18 @@
@@ -864,18 +864,18 @@
@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
H5detect-H5detect.o: H5detect.c

@ -1,15 +1,15 @@
--- hdf5-1.8.2/src/H5detect.c.signal 2008-11-10 14:28:08.000000000 -0700
+++ hdf5-1.8.2/src/H5detect.c 2008-11-14 15:10:51.000000000 -0700
@@ -109,7 +109,7 @@
static void detect_C99_integers64(void);
--- hdf5-1.8.3/src/H5detect.c.signal 2009-05-13 09:02:41.000000000 -0600
+++ hdf5-1.8.3/src/H5detect.c 2009-06-02 10:34:24.203510646 -0600
@@ -110,7 +110,7 @@
static void detect_alignments(void);
static void insert_libhdf5_settings(void);
static size_t align_g[] = {1, 2, 4, 8, 16};
-static jmp_buf jbuf_g;
+static sigjmp_buf jbuf_g;
/*-------------------------------------------------------------------------
@@ -368,7 +368,7 @@
@@ -369,7 +369,7 @@
void (*_handler2)(int) = signal(SIGSEGV, sigsegv_handler); \
\
_buf = (char*)malloc(sizeof(TYPE) + align_g[NELMTS(align_g) - 1]); \
@ -18,7 +18,7 @@
if(_ano < NELMTS(align_g)) { \
*((TYPE*)(_buf+align_g[_ano])) = _val; /*possible SIGBUS or SEGSEGV*/ \
_val2 = *((TYPE*)(_buf+align_g[_ano])); /*possible SIGBUS or SEGSEGV*/ \
@@ -385,7 +385,7 @@
@@ -386,7 +386,7 @@
memcpy(_buf+align_g[_ano]+(INFO.offset/8),((char *)&_val)+(INFO.offset/8),(size_t)(INFO.precision/8)); \
_val2 = *((TYPE*)(_buf+align_g[_ano])); \
if(_val!=_val2) \
@ -27,7 +27,7 @@
/* End Cray Check */ \
(INFO.align)=align_g[_ano]; \
} else { \
@@ -456,7 +456,7 @@
@@ -457,7 +457,7 @@
* it's not nearly as nice to work with, it does the job for
* this simple stuff.
*
@ -36,7 +36,7 @@
*
* Programmer: Robb Matzke
* Thursday, March 18, 1999
@@ -469,7 +469,7 @@
@@ -470,7 +470,7 @@
sigsegv_handler(int UNUSED signo)
{
signal(SIGSEGV, sigsegv_handler);
@ -45,7 +45,7 @@
}
@@ -481,7 +481,7 @@
@@ -482,7 +482,7 @@
* it's not nearly as nice to work with, it does the job for
* this simple stuff.
*
@ -54,7 +54,7 @@
*
* Programmer: Robb Matzke
* Thursday, March 18, 1999
@@ -494,7 +494,7 @@
@@ -495,7 +495,7 @@
sigbus_handler(int UNUSED signo)
{
signal(SIGBUS, sigbus_handler);

@ -1,6 +1,6 @@
Name: hdf5
Version: 1.8.2
Release: 1%{?dist}.1
Version: 1.8.3
Release: 1%{?dist}
Summary: A general purpose library and file format for storing scientific data
License: BSD
Group: System Environment/Libraries
@ -8,12 +8,11 @@ URL: http://www.hdfgroup.org/HDF5/
Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz
#Source0: ftp://ftp.hdfgroup.uiuc.edu/pub/outgoing/hdf5/snapshots/v18/hdf5-1.8.1-rc1.tar.gz
Source1: h5comp
Patch1: hdf5-1.8.2-signal.patch
Patch2: hdf5-1.8.2-detect.patch
Patch1: hdf5-1.8.3-signal.patch
Patch2: hdf5-1.8.3-detect.patch
Patch3: hdf5-1.8.0-multiarch.patch
Patch5: hdf5-1.8.0-longdouble.patch
Patch6: hdf5-1.8.1-filter-as-option.patch
Patch10: hdf5-1.6.5-open.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: krb5-devel, openssl-devel, zlib-devel, gcc-gfortran, time
@ -54,7 +53,6 @@ HDF5 static libraries.
%patch5 -p1 -b .longdouble
%endif
%patch6 -p1 -b .filter-as-option
%patch10 -p1 -b .open
%build
@ -161,6 +159,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Tue Jun 2 2009 Orion Poplawski <orion@cora.nwra.com> 1.8.3-1
- Update to 1.8.3
- Update signal and detect patches
- Drop open patch fixed upstream
* Sat Apr 18 2009 Karsten Hopp <karsten@redhat.com> 1.8.2-1.1
- fix s390x builds, s390x is 64bit, s390 is 32bit

@ -1 +1 @@
af92ef65ef495dbd205131574ad4eee1 hdf5-1.8.2.tar.gz
5ce228d860bf9e797ca40ab1a823c380 hdf5-1.8.3.tar.gz

Loading…
Cancel
Save