Update to 1.8.10

Rebase LD_LIBRARY_PATH patch
Drop ph5diff patch fixed upstream
epel9
Orion Poplawski 12 years ago
parent ec7778ebf9
commit 7468b4ff9d

1
.gitignore vendored

@ -4,3 +4,4 @@ hdf5-1.8.5.tar.bz2
/hdf5-1.8.7.tar.bz2
/hdf5-1.8.8.tar.bz2
/hdf5-1.8.9.tar.bz2
/hdf5-1.8.10.tar.bz2

@ -1,19 +1,20 @@
diff -up hdf5-1.8.8/configure.LD_LIBRARY_PATH hdf5-1.8.8/configure
--- hdf5-1.8.8/configure.LD_LIBRARY_PATH 2011-11-16 11:21:54.511269486 -0700
+++ hdf5-1.8.8/configure 2011-11-16 11:28:18.673392600 -0700
@@ -26746,8 +26746,6 @@ $as_echo_n "checking how to print long l
if ${hdf5_cv_printf_ll+:} false; then :
diff -up hdf5-1.8.10/configure.LD_LIBRARY_PATH hdf5-1.8.10/configure
--- hdf5-1.8.10/configure.LD_LIBRARY_PATH 2012-10-26 18:14:59.000000000 -0600
+++ hdf5-1.8.10/configure 2012-11-14 08:56:52.695024834 -0700
@@ -27496,9 +27496,6 @@ if ${hdf5_cv_printf_ll+:} false; then :
$as_echo_n "(cached) " >&6
else
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH`echo $AM_LDFLAGS $LDFLAGS | sed -e 's/-L/:/g' -e 's/ //g'`"
-export LD_LIBRARY_PATH
-LD_LIBRARY_PATH="$LD_LIBRARY_PATH`echo $AM_LDFLAGS $LDFLAGS | sed -e 's/-L/:/g' -e 's/ //g'`"
-export LD_LIBRARY_PATH
-
for hdf5_cv_printf_ll in l ll L q unknown; do
if test "$cross_compiling" = yes; then :
diff -up hdf5-1.8.8/src/Makefile.in.LD_LIBRARY_PATH hdf5-1.8.8/src/Makefile.in
--- hdf5-1.8.8/src/Makefile.in.LD_LIBRARY_PATH 2011-11-15 08:13:54.000000000 -0700
+++ hdf5-1.8.8/src/Makefile.in 2011-11-16 11:43:42.938914069 -0700
@@ -1267,8 +1267,6 @@ help:
continue
diff -up hdf5-1.8.10/src/Makefile.in.LD_LIBRARY_PATH hdf5-1.8.10/src/Makefile.in
--- hdf5-1.8.10/src/Makefile.in.LD_LIBRARY_PATH 2012-10-26 18:14:55.000000000 -0600
+++ hdf5-1.8.10/src/Makefile.in 2012-11-14 08:55:35.197476914 -0700
@@ -1327,8 +1327,6 @@ help:
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
# is set to ignore the error.
H5Tinit.c: H5detect$(EXEEXT)
@ -22,7 +23,7 @@ diff -up hdf5-1.8.8/src/Makefile.in.LD_LIBRARY_PATH hdf5-1.8.8/src/Makefile.in
$(RUNSERIAL) ./H5detect$(EXEEXT) > $@ || \
(test $$HDF5_Make_Ignore && echo "*** Error ignored") || \
($(RM) $@ ; exit 1)
@@ -1279,8 +1277,6 @@ H5Tinit.c: H5detect$(EXEEXT)
@@ -1339,8 +1337,6 @@ H5Tinit.c: H5detect$(EXEEXT)
# Remove the generated .c file if errors occur unless HDF5_Make_Ignore
# is set to ignore the error.
H5lib_settings.c: H5make_libsettings$(EXEEXT) libhdf5.settings

@ -1,12 +0,0 @@
diff -up hdf5-1.8.8/tools/lib/h5diff.c.ph5diff hdf5-1.8.8/tools/lib/h5diff.c
--- hdf5-1.8.8/tools/lib/h5diff.c.ph5diff 2011-11-07 15:11:35.000000000 -0700
+++ hdf5-1.8.8/tools/lib/h5diff.c 2012-02-09 12:14:59.788422152 -0700
@@ -1391,7 +1391,7 @@ hsize_t diff_match(hid_t file1_id, const
options->not_cmp = options->not_cmp | nFoundbyWorker.not_cmp;
busyTasks--;
} /* end if */
- else if(Status.MPI_TAG == MPI_TAG_TOK_RETURN)
+ else if(Status.MPI_TAG == MPI_TAG_DONE)
{
MPI_Recv(&nFoundbyWorker, sizeof(nFoundbyWorker), MPI_BYTE, Status.MPI_SOURCE, MPI_TAG_DONE, MPI_COMM_WORLD, &Status);
nfound += nFoundbyWorker.nfound;

@ -3,8 +3,8 @@
# NOTE: Try not to realease new versions to released versions of Fedora
# You need to recompile all users of HDF5 for each version change
Name: hdf5
Version: 1.8.9
Release: 4%{?dist}
Version: 1.8.10
Release: 1%{?dist}
Summary: A general purpose library and file format for storing scientific data
License: BSD
Group: System Environment/Libraries
@ -13,8 +13,6 @@ Source0: http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-%{version}%{?snaprel}
Source1: h5comp
Patch0: hdf5-LD_LIBRARY_PATH.patch
Patch1: hdf5-1.8.8-tstlite.patch
# Fix typo bug in parallel h5diff
Patch3: hdf5-ph5diff.patch
BuildRequires: krb5-devel, openssl-devel, zlib-devel, gcc-gfortran, time
# Needed for mpi tests
@ -139,7 +137,6 @@ HDF5 parallel openmpi static libraries
# the tstlite test fails with "stack smashing detected" on these arches
%patch1 -p1 -b .tstlite
%endif
%patch3 -p1 -b .ph5diff
#This should be fixed in 1.8.7
find \( -name '*.[ch]*' -o -name '*.f90' -o -name '*.txt' \) -exec chmod -x {} +
@ -149,7 +146,7 @@ find \( -name '*.[ch]*' -o -name '*.f90' -o -name '*.txt' \) -exec chmod -x {} +
%global _configure ../configure
#Common configure options
%global configure_opts \\\
--disable-dependency-tracking \\\
--disable-silent-rules \\\
--enable-fortran \\\
--enable-fortran2003 \\\
--enable-hl \\\
@ -382,6 +379,11 @@ done
%changelog
* Wed Nov 14 2012 Orion Poplawski <orion@cora.nwra.com> 1.8.10-1
- Update to 1.8.10
- Rebase LD_LIBRARY_PATH patch
- Drop ph5diff patch fixed upstream
* Mon Nov 5 2012 Orion Poplawski <orion@cora.nwra.com> 1.8.9-4
- Rebuild for fixed openmpi f90 soname

@ -1 +1 @@
33e105583417eff1c57fff910a53cd6f hdf5-1.8.9.tar.bz2
8166c0fa3ee34fee6cdef4c5f3cbc94e hdf5-1.8.10.tar.bz2

Loading…
Cancel
Save