parent
93f48b758c
commit
5ffa3a8802
@ -1 +1 @@
|
||||
hdf5-1.8.3.tar.gz
|
||||
hdf5-1.8.3-snap12.tar.gz
|
||||
|
@ -1,28 +0,0 @@
|
||||
--- hdf5-1.8.0-snap6/test/dt_arith.c.longdouble 2008-05-05 16:13:15.000000000 -0600
|
||||
+++ hdf5-1.8.0-snap6/test/dt_arith.c 2008-05-13 09:47:36.000000000 -0600
|
||||
@@ -4929,10 +4929,12 @@
|
||||
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_USHORT, H5T_NATIVE_LDOUBLE);
|
||||
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_INT, H5T_NATIVE_LDOUBLE);
|
||||
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_UINT, H5T_NATIVE_LDOUBLE);
|
||||
+/* Fails on ppc64
|
||||
#if H5_SIZEOF_LONG!=H5_SIZEOF_INT
|
||||
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_LONG, H5T_NATIVE_LDOUBLE);
|
||||
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_ULONG, H5T_NATIVE_LDOUBLE);
|
||||
#endif
|
||||
+*/
|
||||
#if H5_SIZEOF_LONG_LONG!=H5_SIZEOF_LONG
|
||||
#if H5_LLONG_TO_LDOUBLE_CORRECT
|
||||
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_LLONG, H5T_NATIVE_LDOUBLE);
|
||||
@@ -5115,10 +5117,12 @@
|
||||
#endif
|
||||
}
|
||||
#endif /*H5_LDOUBLE_TO_UINT_ACCURATE*/
|
||||
+/* Fails on ppc64
|
||||
#if H5_SIZEOF_LONG!=H5_SIZEOF_INT && H5_SIZEOF_LONG_DOUBLE!=0
|
||||
nerrors += test_conv_int_fp(name, test_values, H5T_NATIVE_LDOUBLE, H5T_NATIVE_LONG);
|
||||
nerrors += test_conv_int_fp(name, test_values, H5T_NATIVE_LDOUBLE, H5T_NATIVE_ULONG);
|
||||
#endif
|
||||
+*/
|
||||
|
||||
#if H5_SIZEOF_LONG_LONG!=H5_SIZEOF_LONG && H5_SIZEOF_LONG_DOUBLE!=0
|
||||
#ifdef H5_LDOUBLE_TO_LLONG_ACCURATE
|
@ -1,11 +0,0 @@
|
||||
--- hdf5-1.8.1/configure.filter-as-option 2008-05-29 10:39:04.000000000 -0600
|
||||
+++ hdf5-1.8.1/configure 2008-09-26 14:49:26.000000000 -0600
|
||||
@@ -4929,7 +4929,7 @@
|
||||
|
||||
;;
|
||||
# Ignore these flags.
|
||||
- -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | -LIST:* | -LNO:*)
|
||||
+ -little | -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | -LIST:* | -LNO:*)
|
||||
;;
|
||||
-lkernel32)
|
||||
test x"$CYGWIN" != xyes && ac_cv_fc_libs="$ac_cv_fc_libs $ac_arg"
|
@ -1,43 +0,0 @@
|
||||
--- hdf5-1.8.3/src/Makefile.in.detect 2009-05-13 09:02:40.000000000 -0600
|
||||
+++ hdf5-1.8.3/src/Makefile.in 2009-06-02 10:36:58.506563941 -0600
|
||||
@@ -132,7 +132,7 @@
|
||||
H5detect_OBJECTS = H5detect-H5detect.$(OBJEXT)
|
||||
H5detect_LDADD = $(LDADD)
|
||||
H5detect_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
|
||||
- --mode=link $(CCLD) $(H5detect_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
|
||||
+ --mode=link $(CCLD) $(CFLAGS) $(H5detect_CFLAGS) $(AM_LDFLAGS) \
|
||||
$(LDFLAGS) -o $@
|
||||
DEFAULT_INCLUDES = -I.@am__isrc@
|
||||
depcomp = $(SHELL) $(top_srcdir)/bin/depcomp
|
||||
@@ -409,7 +409,7 @@
|
||||
LT_VERS_INTERFACE = 6
|
||||
LT_VERS_REVISION = 2
|
||||
LT_VERS_AGE = 0
|
||||
-H5detect_CFLAGS = -g
|
||||
+H5detect_CFLAGS = -g -O0
|
||||
|
||||
# Our main target, the HDF5 library
|
||||
lib_LTLIBRARIES = libhdf5.la
|
||||
@@ -864,18 +864,18 @@
|
||||
@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
|
||||
|
||||
H5detect-H5detect.o: H5detect.c
|
||||
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -MT H5detect-H5detect.o -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
|
||||
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -MT H5detect-H5detect.o -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
|
||||
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/H5detect-H5detect.Tpo $(DEPDIR)/H5detect-H5detect.Po
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='H5detect.c' object='H5detect-H5detect.o' libtool=no @AMDEPBACKSLASH@
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
|
||||
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
|
||||
|
||||
H5detect-H5detect.obj: H5detect.c
|
||||
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -MT H5detect-H5detect.obj -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
|
||||
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -MT H5detect-H5detect.obj -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
|
||||
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/H5detect-H5detect.Tpo $(DEPDIR)/H5detect-H5detect.Po
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='H5detect.c' object='H5detect-H5detect.obj' libtool=no @AMDEPBACKSLASH@
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
|
||||
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
|
||||
|
||||
mostlyclean-libtool:
|
||||
-rm -f *.lo
|
@ -0,0 +1,11 @@
|
||||
--- hdf5-1.8.3-snap12/hl/fortran/test/Makefile.in.tstlite 2009-09-21 16:41:49.000000000 -0600
|
||||
+++ hdf5-1.8.3-snap12/hl/fortran/test/Makefile.in 2009-10-01 14:05:01.628777355 -0600
|
||||
@@ -355,7 +355,7 @@
|
||||
@FORTRAN_SHARED_CONDITIONAL_FALSE@AM_LDFLAGS = -static
|
||||
|
||||
# Our main target, the test programs
|
||||
-TEST_PROG = tstlite tstimage tsttable
|
||||
+TEST_PROG = tstimage tsttable
|
||||
LDADD = $(LIBH5F_HL) $(LIBH5F) $(LIBH5_HL) $(LIBHDF5)
|
||||
|
||||
# Source files for the programs
|
Loading…
Reference in new issue