- Update to 1.8.3

- Update signal and detect patches
- Drop open patch fixed upstream
epel9
Orion Poplawski 15 years ago
parent 93f48b758c
commit 5ffa3a8802

@ -1 +1 @@
hdf5-1.8.3.tar.gz
hdf5-1.8.3-snap12.tar.gz

@ -1,28 +0,0 @@
--- hdf5-1.8.0-snap6/test/dt_arith.c.longdouble 2008-05-05 16:13:15.000000000 -0600
+++ hdf5-1.8.0-snap6/test/dt_arith.c 2008-05-13 09:47:36.000000000 -0600
@@ -4929,10 +4929,12 @@
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_USHORT, H5T_NATIVE_LDOUBLE);
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_INT, H5T_NATIVE_LDOUBLE);
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_UINT, H5T_NATIVE_LDOUBLE);
+/* Fails on ppc64
#if H5_SIZEOF_LONG!=H5_SIZEOF_INT
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_LONG, H5T_NATIVE_LDOUBLE);
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_ULONG, H5T_NATIVE_LDOUBLE);
#endif
+*/
#if H5_SIZEOF_LONG_LONG!=H5_SIZEOF_LONG
#if H5_LLONG_TO_LDOUBLE_CORRECT
nerrors += test_conv_int_fp(name, TEST_NORMAL, H5T_NATIVE_LLONG, H5T_NATIVE_LDOUBLE);
@@ -5115,10 +5117,12 @@
#endif
}
#endif /*H5_LDOUBLE_TO_UINT_ACCURATE*/
+/* Fails on ppc64
#if H5_SIZEOF_LONG!=H5_SIZEOF_INT && H5_SIZEOF_LONG_DOUBLE!=0
nerrors += test_conv_int_fp(name, test_values, H5T_NATIVE_LDOUBLE, H5T_NATIVE_LONG);
nerrors += test_conv_int_fp(name, test_values, H5T_NATIVE_LDOUBLE, H5T_NATIVE_ULONG);
#endif
+*/
#if H5_SIZEOF_LONG_LONG!=H5_SIZEOF_LONG && H5_SIZEOF_LONG_DOUBLE!=0
#ifdef H5_LDOUBLE_TO_LLONG_ACCURATE

@ -1,11 +0,0 @@
--- hdf5-1.8.1/configure.filter-as-option 2008-05-29 10:39:04.000000000 -0600
+++ hdf5-1.8.1/configure 2008-09-26 14:49:26.000000000 -0600
@@ -4929,7 +4929,7 @@
;;
# Ignore these flags.
- -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | -LIST:* | -LNO:*)
+ -little | -lang* | -lcrt*.o | -lc | -lgcc* | -lSystem | -libmil | -LANG:=* | -LIST:* | -LNO:*)
;;
-lkernel32)
test x"$CYGWIN" != xyes && ac_cv_fc_libs="$ac_cv_fc_libs $ac_arg"

@ -1,43 +0,0 @@
--- hdf5-1.8.3/src/Makefile.in.detect 2009-05-13 09:02:40.000000000 -0600
+++ hdf5-1.8.3/src/Makefile.in 2009-06-02 10:36:58.506563941 -0600
@@ -132,7 +132,7 @@
H5detect_OBJECTS = H5detect-H5detect.$(OBJEXT)
H5detect_LDADD = $(LDADD)
H5detect_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
- --mode=link $(CCLD) $(H5detect_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
+ --mode=link $(CCLD) $(CFLAGS) $(H5detect_CFLAGS) $(AM_LDFLAGS) \
$(LDFLAGS) -o $@
DEFAULT_INCLUDES = -I.@am__isrc@
depcomp = $(SHELL) $(top_srcdir)/bin/depcomp
@@ -409,7 +409,7 @@
LT_VERS_INTERFACE = 6
LT_VERS_REVISION = 2
LT_VERS_AGE = 0
-H5detect_CFLAGS = -g
+H5detect_CFLAGS = -g -O0
# Our main target, the HDF5 library
lib_LTLIBRARIES = libhdf5.la
@@ -864,18 +864,18 @@
@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
H5detect-H5detect.o: H5detect.c
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -MT H5detect-H5detect.o -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -MT H5detect-H5detect.o -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/H5detect-H5detect.Tpo $(DEPDIR)/H5detect-H5detect.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='H5detect.c' object='H5detect-H5detect.o' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
H5detect-H5detect.obj: H5detect.c
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -MT H5detect-H5detect.obj -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -MT H5detect-H5detect.obj -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/H5detect-H5detect.Tpo $(DEPDIR)/H5detect-H5detect.Po
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='H5detect.c' object='H5detect-H5detect.obj' libtool=no @AMDEPBACKSLASH@
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
mostlyclean-libtool:
-rm -f *.lo

@ -1,15 +1,15 @@
--- hdf5-1.8.3/src/H5detect.c.signal 2009-05-13 09:02:41.000000000 -0600
+++ hdf5-1.8.3/src/H5detect.c 2009-06-02 10:34:24.203510646 -0600
@@ -110,7 +110,7 @@
static void detect_alignments(void);
static void insert_libhdf5_settings(void);
--- hdf5-1.8.3-snap12/src/H5detect.c.signal 2009-09-21 16:41:39.000000000 -0600
+++ hdf5-1.8.3-snap12/src/H5detect.c 2009-09-30 10:04:26.657899636 -0600
@@ -111,7 +111,7 @@
static void insert_libhdf5_settings(FILE *flibinfo);
static void make_libinfo(void);
static size_t align_g[] = {1, 2, 4, 8, 16};
-static jmp_buf jbuf_g;
+static sigjmp_buf jbuf_g;
/*-------------------------------------------------------------------------
@@ -369,7 +369,7 @@
@@ -370,7 +370,7 @@
void (*_handler2)(int) = signal(SIGSEGV, sigsegv_handler); \
\
_buf = (char*)malloc(sizeof(TYPE) + align_g[NELMTS(align_g) - 1]); \
@ -18,7 +18,7 @@
if(_ano < NELMTS(align_g)) { \
*((TYPE*)(_buf+align_g[_ano])) = _val; /*possible SIGBUS or SEGSEGV*/ \
_val2 = *((TYPE*)(_buf+align_g[_ano])); /*possible SIGBUS or SEGSEGV*/ \
@@ -386,7 +386,7 @@
@@ -387,7 +387,7 @@
memcpy(_buf+align_g[_ano]+(INFO.offset/8),((char *)&_val)+(INFO.offset/8),(size_t)(INFO.precision/8)); \
_val2 = *((TYPE*)(_buf+align_g[_ano])); \
if(_val!=_val2) \
@ -27,7 +27,7 @@
/* End Cray Check */ \
(INFO.align)=align_g[_ano]; \
} else { \
@@ -457,7 +457,7 @@
@@ -458,7 +458,7 @@
* it's not nearly as nice to work with, it does the job for
* this simple stuff.
*
@ -36,7 +36,7 @@
*
* Programmer: Robb Matzke
* Thursday, March 18, 1999
@@ -470,7 +470,7 @@
@@ -471,7 +471,7 @@
sigsegv_handler(int UNUSED signo)
{
signal(SIGSEGV, sigsegv_handler);
@ -45,7 +45,7 @@
}
@@ -482,7 +482,7 @@
@@ -483,7 +483,7 @@
* it's not nearly as nice to work with, it does the job for
* this simple stuff.
*
@ -54,7 +54,7 @@
*
* Programmer: Robb Matzke
* Thursday, March 18, 1999
@@ -495,7 +495,7 @@
@@ -496,7 +496,7 @@
sigbus_handler(int UNUSED signo)
{
signal(SIGBUS, sigbus_handler);

@ -0,0 +1,11 @@
--- hdf5-1.8.3-snap12/hl/fortran/test/Makefile.in.tstlite 2009-09-21 16:41:49.000000000 -0600
+++ hdf5-1.8.3-snap12/hl/fortran/test/Makefile.in 2009-10-01 14:05:01.628777355 -0600
@@ -355,7 +355,7 @@
@FORTRAN_SHARED_CONDITIONAL_FALSE@AM_LDFLAGS = -static
# Our main target, the test programs
-TEST_PROG = tstlite tstimage tsttable
+TEST_PROG = tstimage tsttable
LDADD = $(LIBH5F_HL) $(LIBH5F) $(LIBH5_HL) $(LIBHDF5)
# Source files for the programs

@ -1,18 +1,21 @@
%define snaprel -snap12
Name: hdf5
Version: 1.8.3
Release: 2%{?dist}
Release: 3.snap12%{?dist}
Summary: A general purpose library and file format for storing scientific data
License: BSD
Group: System Environment/Libraries
URL: http://www.hdfgroup.org/HDF5/
Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz
#Source0: ftp://ftp.hdfgroup.uiuc.edu/pub/outgoing/hdf5/snapshots/v18/hdf5-1.8.1-rc1.tar.gz
#Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz
Source0: ftp://ftp.hdfgroup.uiuc.edu/pub/outgoing/hdf5/snapshots/v18/hdf5-%{version}%{?snaprel}.tar.gz
Source1: h5comp
Patch1: hdf5-1.8.3-signal.patch
Patch2: hdf5-1.8.3-detect.patch
Patch1: hdf5-1.8.3-snap12-signal.patch
Patch3: hdf5-1.8.0-multiarch.patch
Patch5: hdf5-1.8.0-longdouble.patch
Patch6: hdf5-1.8.1-filter-as-option.patch
# There is a problem with the h5ltread_dataset_string_f() api in that the
# string will be NULL terminated. The tstlite test ends up crashing with
# a stack smash. Reported upstream 9/30/2009, but probably will take a bit
# of work to fix. This disables that test
Patch4: hdf5-1.8.3-snap12-tstlite.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: krb5-devel, openssl-devel, zlib-devel, gcc-gfortran, time
@ -45,14 +48,11 @@ HDF5 static libraries.
%prep
%setup -q
%setup -q -n %{name}-%{version}%{?snaprel}
%patch1 -p1 -b .signal
%patch2 -p1 -b .detect
%patch3 -p1 -b .multiarch
%ifarch ppc64
%patch5 -p1 -b .longdouble
%endif
%patch6 -p1 -b .filter-as-option
%patch4 -p1 -b .tstlite
find -name '*.[ch]' -o -name '*.f90' -exec chmod -x {} +
%build
@ -60,10 +60,15 @@ export CC=gcc
export CXX=g++
export F9X=gfortran
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
# Must turn of production mode to preserve -g during compile
%configure --enable-production=no --enable-debug=no \
--enable-cxx --enable-fortran \
--with-ssl
%configure \
--disable-dependency-tracking \
--enable-cxx \
--enable-fortran \
--enable-hl \
--with-ssl
# --enable-cxx/fortran and --enable-parallel flags are incompatible
# --with-mpe=DIR Use MPE instrumentation [default=no]
# --enable-cxx/fortran/parallel and --enable-threadsafe flags are incompatible
#Multiarch header
%ifarch x86_64 ppc64 ia64 s390x sparc64 alpha
cp src/H5pubconf.h \
@ -159,6 +164,14 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Thu Oct 1 2009 Orion Poplawski <orion@cora.nwra.com> 1.8.3-3.snap12
- Update to 1.8.3-snap12
- Update signal patch
- Drop detect and filter-as-option patch fixed upstream
- Drop ppc only patch
- Add patch to skip tstlite test for now, problem reported upstream
- Fixup some source file permissions
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
@ -249,7 +262,7 @@ rm -rf $RPM_BUILD_ROOT
- Add patch to use POSIX sort key option
- Remove useless and multilib conflicting Makefiles from html docs
(bug #228365)
- Make hdf5-devel own %{_docdir}/%{name}
- Make hdf5-devel own %%{_docdir}/%%{name}
* Tue Aug 29 2006 Orion Poplawski <orion@cora.nwra.com> 1.6.5-6
- Rebuild for FC6
@ -292,9 +305,9 @@ rm -rf $RPM_BUILD_ROOT
* Wed Jul 01 2005 Orion Poplawski <orion@cora.nwra.com> 1.6.4-3
- Add --enable-threads --with-pthreads to configure
- Add %check
- Add some %docs
- Use %makeinstall
- Add %%check
- Add some %%docs
- Use %%makeinstall
- Add patch to fix test for h5repack
- Add patch to fix h5diff_attr.c

@ -1 +1 @@
5ce228d860bf9e797ca40ab1a823c380 hdf5-1.8.3.tar.gz
5ef4a3940a8952fe057a176b93e9b176 hdf5-1.8.3-snap12.tar.gz

Loading…
Cancel
Save