- Add patch to compile H5detect without optimization - make detection of datatype characteristics more robust - esp. long double - Update signal patch - Drop destdir patch fixed upstream - Drop scaleoffset patch - Re-add -fno-strict-aliasing - Keep settings file needed for -showconfig (bug #481032) - Wrapper script needs to pass arguments (bug #481032)epel9
parent
95418c4346
commit
5690b849c9
@ -1 +1 @@
|
||||
hdf5-1.8.1.tar.gz
|
||||
hdf5-1.8.2.tar.gz
|
||||
|
@ -1,61 +0,0 @@
|
||||
--- hdf5-1.8.0/tools/misc/Makefile.in.destdir 2008-02-12 19:38:48.000000000 -0700
|
||||
+++ hdf5-1.8.0/tools/misc/Makefile.in 2008-02-28 14:19:35.000000000 -0700
|
||||
@@ -731,9 +731,9 @@
|
||||
@$(top_srcdir)/bin/makehelp
|
||||
|
||||
install-exec-local:
|
||||
- @$(INSTALL) h5cc $(bindir)/$(H5CC_NAME)
|
||||
+ @$(INSTALL) h5cc $(DESTDIR)$(bindir)/$(H5CC_NAME)
|
||||
uninstall-local:
|
||||
- @$(RM) $(bindir)/$(H5CC_NAME)
|
||||
+ @$(RM) $(DESTDIR)$(bindir)/$(H5CC_NAME)
|
||||
|
||||
# How to build h5redeploy script
|
||||
h5redeploy: h5redeploy.in
|
||||
--- hdf5-1.8.0/fortran/src/Makefile.in.destdir 2008-02-12 19:39:01.000000000 -0700
|
||||
+++ hdf5-1.8.0/fortran/src/Makefile.in 2008-02-28 15:02:08.000000000 -0700
|
||||
@@ -821,20 +821,20 @@
|
||||
|
||||
install-data-local:
|
||||
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
|
||||
- $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
|
||||
+ $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(DESTDIR)$(includedir)/. ; \
|
||||
fi
|
||||
|
||||
uninstall-local:
|
||||
@if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
|
||||
- if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
|
||||
- set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
|
||||
+ if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(DESTDIR)$(includedir)/HDF5.$(F9XMODEXT)"; then \
|
||||
+ set -x; $(RM) $(DESTDIR)$(includedir)/*.$(F9XMODEXT); \
|
||||
fi; \
|
||||
fi; \
|
||||
- $(RM) $(bindir)/$(H5FC_NAME)
|
||||
+ $(RM) $(DESTDIR)$(bindir)/$(H5FC_NAME)
|
||||
|
||||
# Also install and uninstall (uninstall-local above) h5fc script
|
||||
install-exec-local:
|
||||
- @$(INSTALL) h5fc $(bindir)/$(H5FC_NAME)
|
||||
+ @$(INSTALL) h5fc $(DESTDIR)$(bindir)/$(H5FC_NAME)
|
||||
|
||||
#Specify what Automake needs to create: first the H5fort_type_defines.h
|
||||
# header, then H5match_types which includes that header, then
|
||||
--- hdf5-1.8.0/hl/fortran/src/Makefile.in.destdir 2008-02-12 19:38:56.000000000 -0700
|
||||
+++ hdf5-1.8.0/hl/fortran/src/Makefile.in 2008-02-28 15:26:42.000000000 -0700
|
||||
@@ -681,13 +681,13 @@
|
||||
|
||||
install-data-local:
|
||||
@if test -n "$(F9XMODEXT)" && test "X$(F9XMODEXT)" != "Xo"; then \
|
||||
- $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(includedir)/. ; \
|
||||
+ $(CP) $(top_builddir)/$(subdir)/*.$(F9XMODEXT) $(DESTDIR)$(includedir)/. ; \
|
||||
fi
|
||||
|
||||
uninstall-local:
|
||||
@if test -n "$(F9XMODEXT)" -a "X$(F9XMODEXT)" != "Xo"; then \
|
||||
- if test -f "$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(includedir)/HDF5.$(F9XMODEXT)"; then \
|
||||
- set -x; $(RM) $(includedir)/*.$(F9XMODEXT); \
|
||||
+ if test -f "$(DESTDIR)$(includedir)/hdf5.$(F9XMODEXT)" -o -f "$(DESTDIR)$(includedir)/HDF5.$(F9XMODEXT)"; then \
|
||||
+ set -x; $(RM) $(DESTDIR)$(includedir)/*.$(F9XMODEXT); \
|
||||
fi; \
|
||||
fi
|
||||
|
@ -1,15 +0,0 @@
|
||||
--- hdf5-1.8.0-snap5/test/dsets.c.scaleoffset 2008-05-01 18:27:56.000000000 -0600
|
||||
+++ hdf5-1.8.0-snap5/test/dsets.c 2008-05-05 14:47:15.000000000 -0600
|
||||
@@ -6458,10 +6458,11 @@
|
||||
nerrors += (test_nbit_compound_3(file) < 0 ? 1 : 0);
|
||||
nerrors += (test_scaleoffset_int(file) < 0 ? 1 : 0);
|
||||
nerrors += (test_scaleoffset_int_2(file) < 0 ? 1 : 0);
|
||||
+ /* fails
|
||||
nerrors += (test_scaleoffset_float(file) < 0 ? 1 : 0);
|
||||
nerrors += (test_scaleoffset_float_2(file) < 0 ? 1 : 0);
|
||||
nerrors += (test_scaleoffset_double(file) < 0 ? 1 : 0);
|
||||
- nerrors += (test_scaleoffset_double_2(file) < 0 ? 1 : 0);
|
||||
+ nerrors += (test_scaleoffset_double_2(file) < 0 ? 1 : 0); */
|
||||
nerrors += (test_multiopen (file) < 0 ? 1 : 0);
|
||||
nerrors += (test_types(file) < 0 ? 1 : 0);
|
||||
nerrors += (test_userblock_offset(my_fapl) < 0 ? 1 : 0);
|
@ -0,0 +1,43 @@
|
||||
--- hdf5-1.8.2/src/Makefile.in.detect 2008-11-10 14:40:45.000000000 -0700
|
||||
+++ hdf5-1.8.2/src/Makefile.in 2009-02-23 13:26:39.000000000 -0700
|
||||
@@ -132,7 +132,7 @@
|
||||
H5detect_OBJECTS = H5detect-H5detect.$(OBJEXT)
|
||||
H5detect_LDADD = $(LDADD)
|
||||
H5detect_LINK = $(LIBTOOL) --tag=CC $(AM_LIBTOOLFLAGS) $(LIBTOOLFLAGS) \
|
||||
- --mode=link $(CCLD) $(H5detect_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) \
|
||||
+ --mode=link $(CCLD) $(CFLAGS) $(H5detect_CFLAGS) $(AM_LDFLAGS) \
|
||||
$(LDFLAGS) -o $@
|
||||
DEFAULT_INCLUDES = -I.@am__isrc@
|
||||
depcomp = $(SHELL) $(top_srcdir)/bin/depcomp
|
||||
@@ -408,7 +408,7 @@
|
||||
LT_VERS_INTERFACE = 6
|
||||
LT_VERS_REVISION = 1
|
||||
LT_VERS_AGE = 0
|
||||
-H5detect_CFLAGS = -g
|
||||
+H5detect_CFLAGS = -g -O0
|
||||
|
||||
# Our main target, the HDF5 library
|
||||
lib_LTLIBRARIES = libhdf5.la
|
||||
@@ -860,18 +860,18 @@
|
||||
@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<
|
||||
|
||||
H5detect-H5detect.o: H5detect.c
|
||||
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -MT H5detect-H5detect.o -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
|
||||
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -MT H5detect-H5detect.o -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
|
||||
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/H5detect-H5detect.Tpo $(DEPDIR)/H5detect-H5detect.Po
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='H5detect.c' object='H5detect-H5detect.o' libtool=no @AMDEPBACKSLASH@
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
|
||||
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -c -o H5detect-H5detect.o `test -f 'H5detect.c' || echo '$(srcdir)/'`H5detect.c
|
||||
|
||||
H5detect-H5detect.obj: H5detect.c
|
||||
-@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -MT H5detect-H5detect.obj -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
|
||||
+@am__fastdepCC_TRUE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -MT H5detect-H5detect.obj -MD -MP -MF $(DEPDIR)/H5detect-H5detect.Tpo -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
|
||||
@am__fastdepCC_TRUE@ mv -f $(DEPDIR)/H5detect-H5detect.Tpo $(DEPDIR)/H5detect-H5detect.Po
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ source='H5detect.c' object='H5detect-H5detect.obj' libtool=no @AMDEPBACKSLASH@
|
||||
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
|
||||
-@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(H5detect_CFLAGS) $(CFLAGS) -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
|
||||
+@am__fastdepCC_FALSE@ $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS) $(H5detect_CFLAGS) -c -o H5detect-H5detect.obj `if test -f 'H5detect.c'; then $(CYGPATH_W) 'H5detect.c'; else $(CYGPATH_W) '$(srcdir)/H5detect.c'; fi`
|
||||
|
||||
mostlyclean-libtool:
|
||||
-rm -f *.lo
|
Loading…
Reference in new issue