- Update to 1.8.5

- Drop patches fixed upstream
epel9
Orion Poplawski 15 years ago
parent 34801a9df3
commit 0d33588682

@ -1 +1 @@
hdf5-1.8.4-patch1.tar.bz2
hdf5-1.8.5.tar.bz2

@ -1,65 +0,0 @@
--- hdf5-1.8.3-snap12/src/H5detect.c.signal 2009-09-21 16:41:39.000000000 -0600
+++ hdf5-1.8.3-snap12/src/H5detect.c 2009-09-30 10:04:26.657899636 -0600
@@ -111,7 +111,7 @@
static void insert_libhdf5_settings(FILE *flibinfo);
static void make_libinfo(void);
static size_t align_g[] = {1, 2, 4, 8, 16};
-static jmp_buf jbuf_g;
+static sigjmp_buf jbuf_g;
/*-------------------------------------------------------------------------
@@ -370,7 +370,7 @@
void (*_handler2)(int) = signal(SIGSEGV, sigsegv_handler); \
\
_buf = (char*)malloc(sizeof(TYPE) + align_g[NELMTS(align_g) - 1]); \
- if(setjmp(jbuf_g)) _ano++; \
+ if(sigsetjmp(jbuf_g, 1)) _ano++; \
if(_ano < NELMTS(align_g)) { \
*((TYPE*)(_buf+align_g[_ano])) = _val; /*possible SIGBUS or SEGSEGV*/ \
_val2 = *((TYPE*)(_buf+align_g[_ano])); /*possible SIGBUS or SEGSEGV*/ \
@@ -387,7 +387,7 @@
memcpy(_buf+align_g[_ano]+(INFO.offset/8),((char *)&_val)+(INFO.offset/8),(size_t)(INFO.precision/8)); \
_val2 = *((TYPE*)(_buf+align_g[_ano])); \
if(_val!=_val2) \
- longjmp(jbuf_g, 1); \
+ siglongjmp(jbuf_g, 1); \
/* End Cray Check */ \
(INFO.align)=align_g[_ano]; \
} else { \
@@ -458,7 +458,7 @@
* it's not nearly as nice to work with, it does the job for
* this simple stuff.
*
- * Return: Returns via longjmp to jbuf_g.
+ * Return: Returns via siglongjmp to jbuf_g.
*
* Programmer: Robb Matzke
* Thursday, March 18, 1999
@@ -471,7 +471,7 @@
sigsegv_handler(int UNUSED signo)
{
signal(SIGSEGV, sigsegv_handler);
- longjmp(jbuf_g, 1);
+ siglongjmp(jbuf_g, 1);
}
@@ -483,7 +483,7 @@
* it's not nearly as nice to work with, it does the job for
* this simple stuff.
*
- * Return: Returns via longjmp to jbuf_g.
+ * Return: Returns via siglongjmp to jbuf_g.
*
* Programmer: Robb Matzke
* Thursday, March 18, 1999
@@ -496,7 +496,7 @@
sigbus_handler(int UNUSED signo)
{
signal(SIGBUS, sigbus_handler);
- longjmp(jbuf_g, 1);
+ siglongjmp(jbuf_g, 1);
#ifdef H5_HAVE_SIGLONGJMP
siglongjmp(jbuf_g, 1);
#endif /* H5_HAVE_SIGLONGJMP */

@ -1,11 +0,0 @@
--- hdf5-1.8.4/hl/fortran/test/Makefile.in.tstlite 2009-11-10 14:12:08.000000000 -0700
+++ hdf5-1.8.4/hl/fortran/test/Makefile.in 2010-01-06 10:59:07.916197584 -0700
@@ -364,7 +364,7 @@
f1tab.h5
# Our main target, the test programs
-TEST_PROG = tstlite tstimage tsttable
+TEST_PROG = tstimage tsttable
LDADD = $(LIBH5F_HL) $(LIBH5F) $(LIBH5_HL) $(LIBHDF5)
# Source files for the programs

@ -1,22 +1,15 @@
%define snaprel -patch1
%define snaprel %{nil}
Name: hdf5
Version: 1.8.4.patch1
Version: 1.8.5
Release: 1%{?dist}
Summary: A general purpose library and file format for storing scientific data
License: BSD
Group: System Environment/Libraries
URL: http://www.hdfgroup.org/HDF5/
#Source0: ftp://ftp.hdfgroup.org/HDF5/current/src/%{name}-%{version}.tar.gz
#Source0: http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-%{version}%{?snaprel}.tar.bz2
Source0: http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-1.8.4%{?snaprel}.tar.bz2
Source0: http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-%{version}%{?snaprel}.tar.bz2
Source1: h5comp
Patch1: hdf5-1.8.3-snap12-signal.patch
Patch3: hdf5-1.8.0-multiarch.patch
# There is a problem with the h5ltread_dataset_string_f() api in that the
# string will be NULL terminated. The tstlite test ends up crashing with
# a stack smash. Reported upstream 9/30/2009, but probably will take a bit
# of work to fix. This disables that test
Patch4: hdf5-1.8.4-tstlite.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: krb5-devel, openssl-devel, zlib-devel, gcc-gfortran, time
@ -49,11 +42,8 @@ HDF5 static libraries.
%prep
#setup -q -n %{name}-%{version}%{?snaprel}
%setup -q -n %{name}-1.8.4%{?snaprel}
%patch1 -p1 -b .signal
%setup -q -n %{name}-%{version}%{?snaprel}
%patch3 -p1 -b .multiarch
%patch4 -p1 -b .tstlite
find -name '*.[ch]' -o -name '*.f90' -exec chmod -x {} +
@ -158,6 +148,7 @@ rm -rf $RPM_BUILD_ROOT
%{_libdir}/*.so
%{_libdir}/*.settings
%{_fmoddir}/*.mod
%{_datadir}/hdf5_examples/
%files static
%defattr(-,root,root,-)
@ -165,6 +156,10 @@ rm -rf $RPM_BUILD_ROOT
%changelog
* Mon Jun 21 2010 Orion Poplawski <orion@cora.nwra.com> 1.8.5-1
- Update to 1.8.5
- Drop patches fixed upstream
* Mon Mar 1 2010 Orion Poplawski <orion@cora.nwra.com> 1.8.4.patch1-1
- Update to 1.8.4-patch1

@ -1 +1 @@
b19f4dfbf654a2af3653c492fc1c7513 hdf5-1.8.4-patch1.tar.bz2
a400fe6c1c5964a7224dc684225d415c hdf5-1.8.5.tar.bz2

Loading…
Cancel
Save