|
|
|
@ -1,49 +1,49 @@
|
|
|
|
|
diff -up hdf-4.2.10/hdf/examples/Makefile.am.examplesdir hdf-4.2.10/hdf/examples/Makefile.am
|
|
|
|
|
--- hdf-4.2.10/hdf/examples/Makefile.am.examplesdir 2014-02-09 19:28:50.000000000 -0700
|
|
|
|
|
+++ hdf-4.2.10/hdf/examples/Makefile.am 2014-02-14 10:10:17.854023687 -0700
|
|
|
|
|
diff -up hdf-4.2.12/hdf/examples/Makefile.am.examplesdir hdf-4.2.12/hdf/examples/Makefile.am
|
|
|
|
|
--- hdf-4.2.12/hdf/examples/Makefile.am.examplesdir 2017-01-31 14:41:51.947802481 -0700
|
|
|
|
|
+++ hdf-4.2.12/hdf/examples/Makefile.am 2017-01-31 14:42:34.883572782 -0700
|
|
|
|
|
@@ -46,8 +46,8 @@ INSTALL_TOP_SCRIPT_FILES = run-all-ex.sh
|
|
|
|
|
INSTALL_TOP_FILES = README
|
|
|
|
|
|
|
|
|
|
# Where to install example files
|
|
|
|
|
-EXAMPLEDIR=$(prefix)/examples/c
|
|
|
|
|
-EXAMPLETOPDIR=$(prefix)/examples
|
|
|
|
|
-EXAMPLEDIR=${DESTDIR}$(prefix)/examples/c
|
|
|
|
|
-EXAMPLETOPDIR=${DESTDIR}$(prefix)/examples
|
|
|
|
|
+EXAMPLEDIR=$(docdir)/examples/c
|
|
|
|
|
+EXAMPLETOPDIR=$(docdir)/examples
|
|
|
|
|
|
|
|
|
|
# How to build C programs using h4cc
|
|
|
|
|
$(EXTRA_PROG): $(H4CC)
|
|
|
|
|
diff -up hdf-4.2.10/hdf/fortran/examples/Makefile.am.examplesdir hdf-4.2.10/hdf/fortran/examples/Makefile.am
|
|
|
|
|
--- hdf-4.2.10/hdf/fortran/examples/Makefile.am.examplesdir 2014-02-09 19:28:49.000000000 -0700
|
|
|
|
|
+++ hdf-4.2.10/hdf/fortran/examples/Makefile.am 2014-02-14 10:10:30.082961395 -0700
|
|
|
|
|
diff -up hdf-4.2.12/hdf/fortran/examples/Makefile.am.examplesdir hdf-4.2.12/hdf/fortran/examples/Makefile.am
|
|
|
|
|
--- hdf-4.2.12/hdf/fortran/examples/Makefile.am.examplesdir 2017-01-31 14:41:51.949802471 -0700
|
|
|
|
|
+++ hdf-4.2.12/hdf/fortran/examples/Makefile.am 2017-01-31 14:43:07.968395906 -0700
|
|
|
|
|
@@ -41,7 +41,7 @@ INSTALL_FILES= VD_read_from_vdata.f VD_r
|
|
|
|
|
INSTALL_SCRIPT_FILES = run-fortran-ex.sh
|
|
|
|
|
|
|
|
|
|
# Where to install Fortran example files
|
|
|
|
|
-EXAMPLEDIR=$(prefix)/examples/fortran
|
|
|
|
|
-EXAMPLEDIR=${DESTDIR}$(prefix)/examples/fortran
|
|
|
|
|
+EXAMPLEDIR=$(docdir)/examples/fortran
|
|
|
|
|
|
|
|
|
|
# How to build Fortran programs using h4fc
|
|
|
|
|
$(EXTRA_PROG): $(H4FC)
|
|
|
|
|
diff -up hdf-4.2.10/mfhdf/examples/Makefile.am.examplesdir hdf-4.2.10/mfhdf/examples/Makefile.am
|
|
|
|
|
--- hdf-4.2.10/mfhdf/examples/Makefile.am.examplesdir 2014-02-09 19:28:45.000000000 -0700
|
|
|
|
|
+++ hdf-4.2.10/mfhdf/examples/Makefile.am 2014-02-14 10:09:41.465209051 -0700
|
|
|
|
|
diff -up hdf-4.2.12/mfhdf/examples/Makefile.am.examplesdir hdf-4.2.12/mfhdf/examples/Makefile.am
|
|
|
|
|
--- hdf-4.2.12/mfhdf/examples/Makefile.am.examplesdir 2017-01-31 14:41:51.950802465 -0700
|
|
|
|
|
+++ hdf-4.2.12/mfhdf/examples/Makefile.am 2017-01-31 14:43:23.376314066 -0700
|
|
|
|
|
@@ -23,7 +23,7 @@ INSTALL_FILES = SD_create_sds.c SD_write
|
|
|
|
|
SD_get_info.c SD_find_sds_by_name.c SD_set_get_dim_info.c \
|
|
|
|
|
SD_dimscale_vs_sds.c SD_set_attr.c SD_get_attr.c SD_chunking_example.c
|
|
|
|
|
|
|
|
|
|
-EXAMPLEDIR=$(prefix)/examples/c
|
|
|
|
|
-EXAMPLEDIR=${DESTDIR}$(prefix)/examples/c
|
|
|
|
|
+EXAMPLEDIR=$(docdir)/examples/c
|
|
|
|
|
|
|
|
|
|
# How to build programs using h4cc
|
|
|
|
|
$(EXTRA_PROG): $(H4CC)
|
|
|
|
|
diff -up hdf-4.2.10/mfhdf/fortran/examples/Makefile.am.examplesdir hdf-4.2.10/mfhdf/fortran/examples/Makefile.am
|
|
|
|
|
--- hdf-4.2.10/mfhdf/fortran/examples/Makefile.am.examplesdir 2014-02-09 19:28:44.000000000 -0700
|
|
|
|
|
+++ hdf-4.2.10/mfhdf/fortran/examples/Makefile.am 2014-02-14 10:09:52.818151212 -0700
|
|
|
|
|
diff -up hdf-4.2.12/mfhdf/fortran/examples/Makefile.am.examplesdir hdf-4.2.12/mfhdf/fortran/examples/Makefile.am
|
|
|
|
|
--- hdf-4.2.12/mfhdf/fortran/examples/Makefile.am.examplesdir 2017-01-31 14:41:51.952802455 -0700
|
|
|
|
|
+++ hdf-4.2.12/mfhdf/fortran/examples/Makefile.am 2017-01-31 14:43:40.206224672 -0700
|
|
|
|
|
@@ -24,7 +24,7 @@ INSTALL_FILES=SD_create_sds.f SD_write_t
|
|
|
|
|
SD_set_attr.f SD_get_attr.f SD_compress_sds.f SD_chunking_example.f
|
|
|
|
|
|
|
|
|
|
# Where to install example files
|
|
|
|
|
-EXAMPLEDIR=$(prefix)/examples/fortran
|
|
|
|
|
-EXAMPLEDIR=${DESTDIR}$(prefix)/examples/fortran
|
|
|
|
|
+EXAMPLEDIR=$(docdir)/examples/fortran
|
|
|
|
|
|
|
|
|
|
# How to build Fortran programs using h4fc
|
|
|
|
|