You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
29 lines
1.2 KiB
29 lines
1.2 KiB
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
|
|
index 4304995..5ca735b 100644
|
|
--- a/googlemock/CMakeLists.txt
|
|
+++ b/googlemock/CMakeLists.txt
|
|
@@ -99,6 +99,9 @@ else()
|
|
target_link_libraries(gmock_main gmock)
|
|
endif()
|
|
|
|
+set_target_properties(gmock PROPERTIES VERSION 1.8.0)
|
|
+set_target_properties(gmock_main PROPERTIES VERSION 1.8.0)
|
|
+
|
|
# If the CMake version supports it, attach header directory information
|
|
# to the targets for when we are part of a parent build (ie being pulled
|
|
# in via add_subdirectory() rather than being a standalone build).
|
|
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
|
|
index ab82f23..97f7554 100644
|
|
--- a/googletest/CMakeLists.txt
|
|
+++ b/googletest/CMakeLists.txt
|
|
@@ -88,7 +88,9 @@ endif()
|
|
# are used for other targets, to ensure that gtest can be compiled by a user
|
|
# aggressive about warnings.
|
|
cxx_library(gtest "${cxx_strict}" src/gtest-all.cc)
|
|
+set_target_properties(gtest PROPERTIES VERSION 1.8.0)
|
|
cxx_library(gtest_main "${cxx_strict}" src/gtest_main.cc)
|
|
+set_target_properties(gtest_main PROPERTIES VERSION 1.8.0)
|
|
target_link_libraries(gtest_main gtest)
|
|
|
|
# If the CMake version supports it, attach header directory information
|