You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
30 lines
1.5 KiB
30 lines
1.5 KiB
diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
|
|
index 8a8de1f..d67c0f5 100644
|
|
--- a/googlemock/CMakeLists.txt
|
|
+++ b/googlemock/CMakeLists.txt
|
|
@@ -109,8 +109,10 @@ if (MSVC)
|
|
else()
|
|
cxx_library(gmock "${cxx_strict}" src/gmock-all.cc)
|
|
target_link_libraries(gmock PUBLIC gtest)
|
|
+ set_target_properties(gmock PROPERTIES VERSION ${GOOGLETEST_VERSION})
|
|
cxx_library(gmock_main "${cxx_strict}" src/gmock_main.cc)
|
|
target_link_libraries(gmock_main PUBLIC gmock)
|
|
+ set_target_properties(gmock_main PROPERTIES VERSION ${GOOGLETEST_VERSION})
|
|
endif()
|
|
# If the CMake version supports it, attach header directory information
|
|
# to the targets for when we are part of a parent build (ie being pulled
|
|
diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
|
|
index 9ee7940..1f3de11 100644
|
|
--- a/googletest/CMakeLists.txt
|
|
+++ b/googletest/CMakeLists.txt
|
|
@@ -131,7 +131,9 @@ endif()
|
|
# are used for other targets, to ensure that gtest can be compiled by a user
|
|
# aggressive about warnings.
|
|
cxx_library(gtest "${cxx_strict}" src/gtest-all.cc)
|
|
+set_target_properties(gtest PROPERTIES VERSION ${GOOGLETEST_VERSION})
|
|
cxx_library(gtest_main "${cxx_strict}" src/gtest_main.cc)
|
|
+set_target_properties(gtest_main PROPERTIES VERSION ${GOOGLETEST_VERSION})
|
|
# If the CMake version supports it, attach header directory information
|
|
# to the targets for when we are part of a parent build (ie being pulled
|
|
# in via add_subdirectory() rather than being a standalone build).
|