import grilo-0.3.16-6.el10

i10ce changed/i10ce/grilo-0.3.16-6.el10
Arkady L. Shane 1 month ago
parent 7a8c94d1e8
commit 0ceac35b6e
Signed by: tigro
GPG Key ID: 1EC08A25C9DB2503

2
.gitignore vendored

@ -1 +1 @@
SOURCES/grilo-0.3.13.tar.xz
SOURCES/grilo-0.3.16.tar.xz

@ -1 +1 @@
aa5f1fd521727c4aeb02b7c6af46930b12183083 SOURCES/grilo-0.3.13.tar.xz
f291f2d855f45fa4682d9361bbcf5692577faef5 SOURCES/grilo-0.3.16.tar.xz

@ -1,59 +0,0 @@
From 89537b8c4bae8857078de5d084f79ffe532a7ba8 Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 21 Jun 2021 14:16:37 +0200
Subject: [PATCH 1/2] build: Clarify LGPLv2.1 or later license
The COPYING file by itself isn't enough to know under which license the
project is released, as a combined work.
Clarify this in the build system and the README.
---
README.md | 5 +++++
doc/grilo/overview.xml | 3 ++-
meson.build | 2 +-
3 files changed, 8 insertions(+), 2 deletions(-)
diff --git a/README.md b/README.md
index c6fe38e..16f9453 100644
--- a/README.md
+++ b/README.md
@@ -89,4 +89,9 @@ ninja -C build
./build/tools/grilo-test-ui/grilo-test-ui-0.3
```
+## License
+
+grilo is available under the [GNU Lesser General Public License v2.1 or later](https://spdx.org/licenses/LGPL-2.1-or-later.html).
+Check the sources themselves for individual copyrights and licenses.
+
Enjoy!
diff --git a/doc/grilo/overview.xml b/doc/grilo/overview.xml
index aa169ae..52b8e41 100644
--- a/doc/grilo/overview.xml
+++ b/doc/grilo/overview.xml
@@ -99,7 +99,8 @@ developers.
</para>
<para>
-Grilo is licensed under the GNU Lesser General Public License (LGPL).
+Grilo is licensed under the GNU Lesser General Public License (LGPL)
+version 2.1 or later.
</para>
</section>
diff --git a/meson.build b/meson.build
index cf12454..f76d790 100644
--- a/meson.build
+++ b/meson.build
@@ -12,7 +12,7 @@ project('grilo', 'c',
'c_std=gnu99',
'warning_level=1'
],
- license: 'LGPL 2.1',
+ license: 'LGPL-2.1-or-later',
meson_version: '>= 0.46.0')
grilo_version = meson.project_version()
--
2.31.1

@ -1,33 +0,0 @@
From cd2472e506dafb1bb8ae510e34ad4797f63e263e Mon Sep 17 00:00:00 2001
From: Bastien Nocera <hadess@hadess.net>
Date: Mon, 21 Jun 2021 15:00:14 +0200
Subject: [PATCH 2/2] net: Fix TLS cert validation not being done for any
network call
The default SoupSessionAsync behaviour does not perform any TLS certificate
validation, unless the ssl-use-system-ca-file property is set to true.
See https://blogs.gnome.org/mcatanzaro/2021/05/25/reminder-soupsessionsync-and-soupsessionasync-default-to-no-tls-certificate-verification/
This mitigates CVE-2016-20011.
Closes: #146
---
libs/net/grl-net-wc.c | 1 +
1 file changed, 1 insertion(+)
diff --git a/libs/net/grl-net-wc.c b/libs/net/grl-net-wc.c
index 5a8e89f..5ff1d17 100644
--- a/libs/net/grl-net-wc.c
+++ b/libs/net/grl-net-wc.c
@@ -314,6 +314,7 @@ grl_net_wc_init (GrlNetWc *wc)
wc->priv = grl_net_wc_get_instance_private (wc);
wc->priv->session = soup_session_async_new ();
+ g_object_set (G_OBJECT (wc->priv->session), "ssl-use-system-ca-file", TRUE, NULL);
wc->priv->pending = g_queue_new ();
set_thread_context (wc);
--
2.31.1

@ -1,12 +1,22 @@
## START: Set by rpmautospec
## (rpmautospec version 0.6.5)
## RPMAUTOSPEC: autorelease, autochangelog
%define autorelease(e:s:pb:n) %{?-p:0.}%{lua:
release_number = 6;
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
print(release_number + base_release_number - 1);
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{!?-n:%{?dist}}
## END: Set by rpmautospec
# first two digits of version
%define release_version %(echo %{version} | awk -F. '{print $1"."$2}')
Name: grilo
Version: 0.3.13
Release: 7%{?dist}
Version: 0.3.16
Release: %autorelease
Summary: Content discovery framework
License: LGPLv2+
License: LGPL-2.1-or-later
URL: https://wiki.gnome.org/Projects/Grilo
Source0: https://download.gnome.org/sources/grilo/%{release_version}/grilo-%{version}.tar.xz
@ -18,17 +28,16 @@ BuildRequires: vala >= 0.27.1
BuildRequires: gtk-doc
BuildRequires: gobject-introspection-devel >= 0.9.0
BuildRequires: libxml2-devel
BuildRequires: libsoup-devel
BuildRequires: libsoup3-devel
BuildRequires: glib2-devel
# For the test UI
BuildRequires: gtk3-devel
%if 0%{?fedora}
BuildRequires: liboauth-devel
%endif
BuildRequires: totem-pl-parser-devel
# https://gitlab.gnome.org/GNOME/grilo/-/merge_requests/77
Patch0: 0001-build-Clarify-LGPLv2.1-or-later-license.patch
# https://gitlab.gnome.org/GNOME/grilo/-/merge_requests/78
Patch1: 0002-net-Fix-TLS-cert-validation-not-being-done-for-any-n.patch
%description
Grilo is a framework that provides access to different sources of
multimedia content, using a pluggable system.
@ -48,7 +57,8 @@ general and API documentation.
%autosetup -p1 -S git
%build
%meson -Denable-gtk-doc=true
%meson \
-Denable-gtk-doc=true
%meson_build
@ -60,12 +70,12 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/grilo-%{release_version}/plugins/
%find_lang grilo
%ldconfig_scriptlets
%files -f grilo.lang
%license COPYING
%doc AUTHORS NEWS README.md TODO
%{_libdir}/*.so.*
%{_libdir}/libgrilo-%{release_version}.so.0*
%{_libdir}/libgrlnet-%{release_version}.so.0*
%{_libdir}/libgrlpls-%{release_version}.so.0*
%{_libdir}/girepository-1.0/
%{_bindir}/grl-inspect-%{release_version}
%{_bindir}/grl-launch-%{release_version}
@ -85,22 +95,60 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/grilo-%{release_version}/plugins/
%{_datadir}/vala/
%changelog
* Mon Aug 23 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.3.13-7
- Drop the BuildRequires on liboauth
Resolves: #1996880
* Sat Dec 28 2024 Arkady L. Shane <tigro@msvsphere-os.ru> - 0.3.16-6
- Rebuilt for MSVSphere 10
## START: Generated by rpmautospec
* Thu Jul 18 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.16-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
* Fri Feb 02 2024 Miroslav Suchý <msuchy@redhat.com> - 0.3.16-5
- Migrate to SPDX license
* Wed Jan 24 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.16-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Sat Jan 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.16-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
* Thu Jul 20 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.16-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
* Tue May 09 2023 Victor Toso <victortoso@redhat.com> - 0.3.16-1
- Update to release 0.3.16
* Mon Aug 09 2021 Mohan Boddu <mboddu@redhat.com> - 0.3.13-6
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688
* Fri Feb 17 2023 Michael Catanzaro <mcatanzaro@redhat.com> - 0.3.15-8
- Switch to libsoup 3
* Mon Jun 28 2021 Bastien Nocera <bnocera@redhat.com> - 0.3.13-5
+ grilo-0.3.13-5
* Thu Jan 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.15-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
* Tue Aug 16 2022 Victor Toso <victortoso@redhat.com> - 0.3.15-2
- Switch back to libsoup2 to avoid issues when apps are using
libsoup2 and libsoup3
* Tue Aug 16 2022 Victor Toso <victortoso@redhat.com> - 0.3.15-1
- Update to 0.3.15. GrlNet library is now using libsoup3.
* Thu Jul 21 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.14-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
* Thu Jan 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.14-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
* Tue Oct 5 2021 Victor Toso <victortoso@redhat.com> - 0.3.14-1
- Update to 0.3.14
* Mon Aug 23 2021 Debarshi Ray <rishi@fedoraproject.org> - 0.3.13-6
- Drop the BuildRequires on liboauth from RHEL >= 9
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
* Tue Jun 22 2021 Bastien Nocera <bnocera@redhat.com> - 0.3.13-4
+ grilo-0.3.13-4
- Clarify license
- Fix TLS not being validated correctly
- Resolves: rhbz#1976719
* Thu Apr 15 2021 Mohan Boddu <mboddu@redhat.com> - 0.3.13-4
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.13-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
@ -320,3 +368,5 @@ Resolves: #1996880
- Fist package, based on upstream work by Juan A.
Suarez Romero <jasuarez@igalia.com>
## END: Generated by rpmautospec

Loading…
Cancel
Save