You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
27 lines
776 B
27 lines
776 B
From 3b3e316908e4fb15056d10fb9d5271eed6f65051 Mon Sep 17 00:00:00 2001
|
|
From: q66 <daniel@octaforge.org>
|
|
Date: Wed, 9 Jun 2021 15:47:14 +0200
|
|
Subject: [PATCH] meson: fix gcc vector 64-bit check
|
|
|
|
the previous behavior only ever enabled gcc vectors no x86_64
|
|
---
|
|
meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 5dbfb63..fd37036 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -328,7 +328,7 @@ if get_option('gcc_vector')
|
|
# error "GCC vector intrinsics are disabled on GCC prior to 4.9"
|
|
# elif defined(__arm__)
|
|
# error "GCC vector intrinsics are disabled on ARM"
|
|
-# elif !defined(__x86_64__)
|
|
+# elif (__SIZEOF_POINTER__ < 8)
|
|
# error "GCC vector intrinsics are disabled on 32bit"
|
|
# endif
|
|
#else
|
|
--
|
|
2.31.1
|
|
|