- Complete fix for parted check and apply patch on configure.in

epel8
Deji Akingunola 18 years ago
parent 4cd5195aac
commit b41152ce86

@ -0,0 +1,45 @@
--- configure.in 2006/09/11 09:46:42 1.62
+++ configure.in 2006/09/14 20:34:49 1.63
@@ -33,7 +33,8 @@
AC_CHECK_LIB(dl, dlopen, [], AC_MSG_ERROR([*** dl library (libdl) not found]))
dnl libparted
-AC_MSG_CHECKING(for libparted >= 1.7.1)
+LIBPARTED_VERSION=1.7.1
+AC_MSG_CHECKING(for libparted >= $LIBPARTED_VERSION)
LDFLAGS=-lparted
AC_TRY_RUN(
#include <stdio.h>
@@ -41,16 +42,28 @@
int main ()
{
+ int min_major ;
+ int min_minor ;
+ int min_micro ;
int major ;
int minor ;
int micro ;
- if ( sscanf( ped_get_version(), "%d.%d.%d", &major, &minor, &micro ) == 3 )
- printf( "Found libparted %s\t", ped_get_version() ) ;
+ if ( sscanf( "$LIBPARTED_VERSION", "%d.%d.%d", &min_major, &min_minor, &min_micro ) == 3 )
+ {
+ if ( sscanf( ped_get_version(), "%d.%d.%d", &major, &minor, &micro ) == 3 )
+ {
+ printf( "Found libparted %s\t", ped_get_version() ) ;
+
+ return ! ((major > min_major) ||
+ ((major == min_major) && (minor > min_minor)) ||
+ ((major == min_major) && (minor == min_minor) && (micro >= min_micro))) ;
+ }
+ }
- return ! ( major == 1 && minor == 7 && micro >= 1 ) ;
+ return 1 ;
}
-,AC_MSG_RESULT(OK),AC_MSG_ERROR(*** Requires libparted >= 1.7.1) )
+,AC_MSG_RESULT(OK),AC_MSG_ERROR(*** Requires libparted >= $LIBPARTED_VERSION) )
dnl GTKMM

@ -1,16 +1,18 @@
Summary: Gnome Partition Editor
Name: gparted
Version: 0.3.1
Release: 3%{?dist}
Release: 4%{?dist}
Group: Applications/System
License: GPL
URL: http://gparted.sourceforge.net
Source0: http://dl.sf.net/sourceforge/%{name}/%{name}-%{version}.tar.bz2
Patch0: gparted-configure.patch
Patch0: gparted-parted-check.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gtkmm24-devel parted-devel
BuildRequires: e2fsprogs-devel gettext perl(XML::Parser)
BuildRequires: desktop-file-utils
#Temporarily
BuildRequires: automake autoconf
%description
GParted stands for Gnome Partition Editor and is a graphical frontend to
@ -21,9 +23,12 @@ will be detected at runtime and don't require a rebuild of GParted
%prep
%setup -q
%patch0 -p0 -b .config
%patch0 -p0 -b .parted
%build
aclocal
automake
autoconf
%configure
make %{?_smp_mflags}
@ -79,6 +84,9 @@ rm -rf %{buildroot}
%config(noreplace) %{_sysconfdir}/security/console.apps/gparted
%changelog
* Mon Nov 27 2006 Deji Akingunola <dakingun@gmail.com> - 0.3.1-4
- Complete fix for parted check and apply patch on configure.in
* Wed Nov 23 2006 Deji Akingunola <dakingun@gmail.com> - 0.3.1-3
- Backport a fix from cvs to properly check for libparted version

Loading…
Cancel
Save