parent
c16bd53750
commit
f2b96187a3
@ -1,42 +0,0 @@
|
||||
--- a/applications/dashcast/video_encoder.c
|
||||
+++ b/applications/dashcast/video_encoder.c
|
||||
@@ -144,7 +144,7 @@
|
||||
}
|
||||
|
||||
//the global header gives access to the extradata (SPS/PPS)
|
||||
- video_output_file->codec_ctx->flags |= CODEC_FLAG_GLOBAL_HEADER;
|
||||
+ video_output_file->codec_ctx->flags |= AV_CODEC_FLAG_GLOBAL_HEADER;
|
||||
|
||||
video_output_file->vstream_idx = 0;//video_stream->index;
|
||||
|
||||
|
||||
--- a/modules/ffmpeg_in/ffmpeg_decode.c
|
||||
+++ b/modules/ffmpeg_in/ffmpeg_decode.c
|
||||
@@ -49,7 +49,7 @@
|
||||
static uint8_t * ffmpeg_realloc_buffer(uint8_t * oldBuffer, u32 size) {
|
||||
uint8_t * buffer;
|
||||
/* Size of buffer must be larger, see avcodec_decode_video2 documentation */
|
||||
- u32 allocatedSz = sizeof( char ) * (FF_INPUT_BUFFER_PADDING_SIZE + size);
|
||||
+ u32 allocatedSz = sizeof( char ) * (AV_INPUT_BUFFER_PADDING_SIZE + size);
|
||||
if (oldBuffer)
|
||||
gf_free(oldBuffer);
|
||||
buffer = (uint8_t*)gf_malloc( allocatedSz );
|
||||
@@ -577,7 +577,7 @@
|
||||
capability->cap.valueInt = 1;
|
||||
return GF_OK;
|
||||
case GF_CODEC_PADDING_BYTES:
|
||||
- capability->cap.valueInt = FF_INPUT_BUFFER_PADDING_SIZE;
|
||||
+ capability->cap.valueInt = AV_INPUT_BUFFER_PADDING_SIZE;
|
||||
return GF_OK;
|
||||
case GF_CODEC_REORDER:
|
||||
capability->cap.valueInt = 1;
|
||||
@@ -669,7 +669,7 @@
|
||||
break;
|
||||
|
||||
case GF_CODEC_PADDING_BYTES:
|
||||
- capability->cap.valueInt = FF_INPUT_BUFFER_PADDING_SIZE;
|
||||
+ capability->cap.valueInt = AV_INPUT_BUFFER_PADDING_SIZE;
|
||||
break;
|
||||
default:
|
||||
capability->cap.valueInt = 0;
|
||||
|
@ -1,23 +0,0 @@
|
||||
From 669258a21dcc9827e1496c460af0bff83aa5d654 Mon Sep 17 00:00:00 2001
|
||||
From: Romain Bouqueau <romain.bouqueau.pro@gmail.com>
|
||||
Date: Thu, 27 Apr 2017 13:32:14 +0200
|
||||
Subject: [PATCH] fix typo
|
||||
|
||||
fix #815
|
||||
---
|
||||
Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 9849173..1ac8eaf 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -112,7 +112,7 @@ ifneq ($(CONFIG_WIN32), yes)
|
||||
ifneq ($(CONFIG_FFMPEG), no)
|
||||
ifneq ($(DISABLE_CORE_TOOLS), yes)
|
||||
ifneq ($(DISABLE_AV_PARSERS), yes)
|
||||
- if [ -f bin/gcc/DashCast$(EXE_SUFFIX)g ] ; then \
|
||||
+ if [ -f bin/gcc/DashCast$(EXE_SUFFIX) ] ; then \
|
||||
$(INSTALL) $(INSTFLAGS) -m 755 bin/gcc/DashCast$(EXE_SUFFIX) "$(DESTDIR)$(prefix)/bin" ; \
|
||||
fi
|
||||
endif
|
@ -1,11 +0,0 @@
|
||||
--- a/src/utils/downloader.c
|
||||
+++ b/src/utils/downloader.c
|
||||
@@ -391,7 +391,6 @@
|
||||
}
|
||||
SSL_library_init();
|
||||
SSL_load_error_strings();
|
||||
- SSLeay_add_all_algorithms();
|
||||
SSLeay_add_ssl_algorithms();
|
||||
_ssl_is_initialized = GF_TRUE;
|
||||
GF_LOG(GF_LOG_DEBUG, GF_LOG_NETWORK, ("[HTTPS] Initalization of SSL library complete.\n"));
|
||||
|
Loading…
Reference in new issue