parent
5988133f6b
commit
5ab1ef9710
@ -1 +1 @@
|
||||
gpac-20100527.tar.bz2
|
||||
gpac-20110915.tar.bz2
|
||||
|
@ -1,80 +0,0 @@
|
||||
diff -up gpac/configure.ffmpeg gpac/configure
|
||||
--- gpac/configure.ffmpeg 2010-01-16 19:09:26.451865570 +0100
|
||||
+++ gpac/configure 2010-01-16 19:19:49.604861370 +0100
|
||||
@@ -852,12 +852,21 @@ fi
|
||||
|
||||
#look for FFMPEG support
|
||||
|
||||
+if pkg-config --exists libavcodec libavformat libswscale 2> /dev/null ; then
|
||||
+ ffmpeg_cflags=`pkg-config --cflags libavcodec libavformat libswscale libavutil`
|
||||
+ ffmpeg_lflags=`pkg-config --libs libavcodec libavformat libswscale libavutil`
|
||||
+ has_ffmpeg="system"
|
||||
+else
|
||||
+ ffmpeg_cflags=``
|
||||
+ ffmpeg_lflags=`-lz -lavcodec -lavformat`
|
||||
+fi
|
||||
+
|
||||
cat > $TMPC << EOF
|
||||
#include <libavcodec/avcodec.h>
|
||||
int main( void ) { return 0; }
|
||||
EOF
|
||||
|
||||
-if $cc $TMPO -c $TMPC 2> /dev/null ; then
|
||||
+if $cc $TMPO $ffmpeg_cflags -c $TMPC 2> /dev/null ; then
|
||||
old_ffmpeg_inc="no"
|
||||
else
|
||||
|
||||
@@ -872,10 +881,10 @@ fi
|
||||
|
||||
|
||||
if test "$cross_prefix" != "" ; then
|
||||
- if $cc -o $TMPO $TMPC -I$prefix/include -L$prefix/lib -lz -lavcodec -lavformat -lavutil 2> /dev/null ; then
|
||||
+ if $cc -o $TMPO $TMPC -I$prefix/include -L$prefix/lib $ffmpeg_cflags $ffmpeg_lflags 2> /dev/null ; then
|
||||
has_ffmpeg="system"
|
||||
else
|
||||
- if $cc -o $TMPO $TMPC -I$local_inc -L$local_lib -lz -lavcodec -lavformat 2> /dev/null ; then
|
||||
+ if $cc -o $TMPO $TMPC -I$local_inc -L$local_lib $ffmpeg_cflags $ffmpeg_lflags 2> /dev/null ; then
|
||||
has_ffmpeg="local"
|
||||
echo OK
|
||||
fi
|
||||
@@ -1978,6 +1987,10 @@ echo "CONFIG_VORBIS=$has_vorbis" >> conf
|
||||
echo "CONFIG_THEORA=$has_theora" >> config.mak
|
||||
echo "CONFIG_FFMPEG=$has_ffmpeg" >> config.mak
|
||||
echo "CONFIG_FFMPEG_OLD=$old_ffmpeg_inc" >> config.mak
|
||||
+if test x$has_ffmpeg != x ; then
|
||||
+ echo "FFMPEG_CFLAGS=$ffmpeg_cflags" >> config.mak
|
||||
+ echo "FFMPEG_LFLAGS=$ffmpeg_lflags" >> config.mak
|
||||
+fi
|
||||
|
||||
echo "CONFIG_OSS_AUDIO=$has_oss_audio" >> config.mak
|
||||
echo "CONFIG_ALSA=$has_alsa" >> config.mak
|
||||
diff -up gpac/modules/ffmpeg_in/Makefile.ffmpeg gpac/modules/ffmpeg_in/Makefile
|
||||
--- gpac/modules/ffmpeg_in/Makefile.ffmpeg 2010-05-21 01:49:31.000000000 -0600
|
||||
+++ gpac/modules/ffmpeg_in/Makefile 2010-05-27 13:17:56.052191678 -0600
|
||||
@@ -2,7 +2,7 @@ include ../../config.mak
|
||||
|
||||
vpath %.c $(SRC_PATH)/modules/ffmpeg_in
|
||||
|
||||
-CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include
|
||||
+CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include $(FFMPEG_CFLAGS)
|
||||
|
||||
ifeq ($(DEBUGBUILD), yes)
|
||||
CFLAGS+=-g
|
||||
@@ -15,7 +15,7 @@ LDFLAGS+=-pg
|
||||
endif
|
||||
|
||||
LOCAL_LIB=
|
||||
-LINKLIBS=-lgpac -lavcodec -lavformat -lavutil -lz
|
||||
+LINKLIBS=-lgpac -lz $(FFMPEG_LFLAGS)
|
||||
|
||||
#darwin needs bz2
|
||||
ifeq ($(CONFIG_DARWIN),yes)
|
||||
@@ -25,8 +25,6 @@ endif
|
||||
#old ffmpeg lib
|
||||
ifeq ($(CONFIG_FFMPEG_OLD), yes)
|
||||
CFLAGS+=-DFFMPEG_OLD_HEADERS
|
||||
-else
|
||||
-LINKLIBS+=-lswscale
|
||||
endif
|
||||
|
||||
#common obj
|
@ -1,51 +0,0 @@
|
||||
--- gpac/Makefile.makefix 2010-05-05 09:18:35.000000000 -0600
|
||||
+++ gpac/Makefile 2010-05-27 12:19:54.051316154 -0600
|
||||
@@ -60,11 +60,11 @@
|
||||
install -d "$(DESTDIR)$(mandir)"
|
||||
install -d "$(DESTDIR)$(mandir)/man1"
|
||||
if [ -d doc ] ; then \
|
||||
- install -m 644 doc/man/mp4box.1 $(DESTDIR)$(mandir)/man1/ ; \
|
||||
- install -m 644 doc/man/mp4client.1 $(DESTDIR)$(mandir)/man1/ ; \
|
||||
- install -m 644 doc/man/gpac.1 $(DESTDIR)$(mandir)/man1/ ; \
|
||||
+ install -pm 644 doc/man/mp4box.1 $(DESTDIR)$(mandir)/man1/ ; \
|
||||
+ install -pm 644 doc/man/mp4client.1 $(DESTDIR)$(mandir)/man1/ ; \
|
||||
+ install -pm 644 doc/man/gpac.1 $(DESTDIR)$(mandir)/man1/ ; \
|
||||
install -d "$(DESTDIR)$(prefix)/share/gpac" ; \
|
||||
- install -m 644 doc/gpac.mp4 $(DESTDIR)$(prefix)/share/gpac/ ; \
|
||||
+ install -pm 644 doc/gpac.mp4 $(DESTDIR)$(prefix)/share/gpac/ ; \
|
||||
fi
|
||||
|
||||
# install -d "$(DESTDIR)$(prefix)/share/gpac/gui" ; \
|
||||
@@ -97,23 +97,25 @@
|
||||
install -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac-$(VERSION).$(DYN_LIB_SUFFIX)
|
||||
ln -sf libgpac-$(VERSION).$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
|
||||
else
|
||||
- install $(INSTFLAGS) -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac-$(VERSION).$(DYN_LIB_SUFFIX)
|
||||
- ln -sf libgpac-$(VERSION).$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
|
||||
+ install $(INSTFLAGS) -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX).$(VERSION)
|
||||
+ ln -sf libgpac.$(DYN_LIB_SUFFIX).$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
|
||||
+ifeq ($(DESTDIR)$(prefix),$(prefix))
|
||||
ldconfig || true
|
||||
endif
|
||||
endif
|
||||
+endif
|
||||
|
||||
install-lib:
|
||||
mkdir -p "$(DESTDIR)$(prefix)/include/gpac"
|
||||
- install -m 644 $(SRC_PATH)/include/gpac/*.h "$(DESTDIR)$(prefix)/include/gpac"
|
||||
+ install -pm 644 $(SRC_PATH)/include/gpac/*.h "$(DESTDIR)$(prefix)/include/gpac"
|
||||
mkdir -p "$(DESTDIR)$(prefix)/include/gpac/internal"
|
||||
- install -m 644 $(SRC_PATH)/include/gpac/internal/*.h "$(DESTDIR)$(prefix)/include/gpac/internal"
|
||||
+ install -pm 644 $(SRC_PATH)/include/gpac/internal/*.h "$(DESTDIR)$(prefix)/include/gpac/internal"
|
||||
mkdir -p "$(DESTDIR)$(prefix)/include/gpac/modules"
|
||||
- install -m 644 $(SRC_PATH)/include/gpac/modules/*.h "$(DESTDIR)$(prefix)/include/gpac/modules"
|
||||
- install -m 644 $(SRC_PATH)/config.h "$(DESTDIR)$(prefix)/include/gpac/configuration.h"
|
||||
+ install -pm 644 $(SRC_PATH)/include/gpac/modules/*.h "$(DESTDIR)$(prefix)/include/gpac/modules"
|
||||
+ install -pm 644 $(SRC_PATH)/config.h "$(DESTDIR)$(prefix)/include/gpac/configuration.h"
|
||||
ifeq ($(GPAC_ENST), yes)
|
||||
mkdir -p "$(DESTDIR)$(prefix)/include/gpac/enst"
|
||||
- install -m 644 $(SRC_PATH)/include/gpac/enst/*.h "$(DESTDIR)$(prefix)/include/gpac/enst"
|
||||
+ install -pm 644 $(SRC_PATH)/include/gpac/enst/*.h "$(DESTDIR)$(prefix)/include/gpac/enst"
|
||||
endif
|
||||
mkdir -p "$(DESTDIR)$(prefix)/$(libdir)"
|
||||
install -m 644 "./bin/gcc/libgpac_static.a" "$(DESTDIR)$(prefix)/$(libdir)"
|
@ -1,12 +0,0 @@
|
||||
diff -up gpac/configure.noldflag gpac/configure
|
||||
--- gpac/configure.noldflag 2011-03-10 16:15:56.887459002 +0100
|
||||
+++ gpac/configure 2011-03-10 16:58:50.029459001 +0100
|
||||
@@ -143,7 +143,7 @@ extralibs="-lm"
|
||||
bigendian="no"
|
||||
SHFLAGS=-shared
|
||||
need_inet_aton="no"
|
||||
-LDFLAGS="$LDFLAGS -Wl --warn-common"
|
||||
+#LDFLAGS="$LDFLAGS -Wl --warn-common"
|
||||
CFLAGS=""
|
||||
CPPFLAGS=""
|
||||
GPAC_SH_FLAGS=-lpthread
|
@ -1,14 +0,0 @@
|
||||
--- gpac/configure.osmo 2010-05-27 13:25:30.365191378 -0600
|
||||
+++ gpac/configure 2010-05-27 14:03:08.494369924 -0600
|
||||
@@ -1007,6 +1016,11 @@ wx_cflags=`wx-config --cppflags core, ba
|
||||
wx_lflags=`wx-config --libs core, base`
|
||||
fi
|
||||
|
||||
+if test "$has_wx" = "yes"; then
|
||||
+wx_lflags="${wx_lflags} `gtk-config --libs`"
|
||||
+wx_lflags="${wx_lflags} `pkg-config --libs gdk-2.0` -lstdc++"
|
||||
+fi
|
||||
+
|
||||
if test "$darwin" = "yes" ; then
|
||||
wx_lflags="-Wl,-bind_at_load $wx_lflags -lstdc++" #10.4 needs it, not sure about 10.3
|
||||
fi
|
Loading…
Reference in new issue