parent
77d0a83dea
commit
1ef3d0bd40
@ -1 +1 @@
|
||||
gpac-0.4.5-repack.tar.bz2
|
||||
gpac-20090919.tar.bz2
|
||||
|
@ -1,112 +0,0 @@
|
||||
diff -up gpac/configure.ffmpeg gpac/configure
|
||||
--- gpac/configure.ffmpeg 2009-03-20 21:46:41.000000000 +0100
|
||||
+++ gpac/configure 2009-03-20 21:58:21.000000000 +0100
|
||||
@@ -737,10 +737,11 @@ fi
|
||||
#look for FFMPEG support
|
||||
cat > $TMPC << EOF
|
||||
#include <stddef.h>
|
||||
-#include <ffmpeg/avcodec.h>
|
||||
+#include <libavcodec/avcodec.h>
|
||||
int main( void ) { return 0; }
|
||||
EOF
|
||||
-
|
||||
+ffmpeg_cflags=`pkg-config --cflags libavcodec libavformat libswscale`
|
||||
+ffmpeg_lflags=`pkg-config --libs libavcodec libavformat libswscale`
|
||||
if test "$cross_prefix" != "" ; then
|
||||
echo "HELLO"
|
||||
echo "HELLO"
|
||||
@@ -756,7 +757,7 @@ if test "$cross_prefix" != "" ; then
|
||||
fi
|
||||
fi
|
||||
else
|
||||
- if $cc -o $TMPO $TMPC -lz -lavcodec -lavformat 2> /dev/null ; then
|
||||
+ if $cc -o $TMPO $TMPC $ffmpeg_cflags $ffmpeg_lflags 2> /dev/null ; then
|
||||
has_ffmpeg="system"
|
||||
elif test "$alt_macosx_dir" != "" ; then
|
||||
if $cc -o $TMPO $TMPC -I$alt_macosx_dir/include -L$alt_macosx_dir/lib -lz -lavcodec -lavformat 2> /dev/null ; then
|
||||
@@ -1587,6 +1588,10 @@ echo "CONFIG_OGG=$has_ogg" >> config.mak
|
||||
echo "CONFIG_VORBIS=$has_vorbis" >> config.mak
|
||||
echo "CONFIG_THEORA=$has_theora" >> config.mak
|
||||
echo "CONFIG_FFMPEG=$has_ffmpeg" >> config.mak
|
||||
+if test "$has_ffmpeg" = "system"; then
|
||||
+ echo "FFMPEG_CFLAGS=$ffmpeg_cflags" >> config.mak
|
||||
+ echo "FFMPEG_LFLAGS=$ffmpeg_lflags" >> config.mak
|
||||
+fi
|
||||
echo "CONFIG_OSS_AUDIO=$has_oss_audio" >> config.mak
|
||||
echo "CONFIG_ALSA=$has_alsa" >> config.mak
|
||||
echo "CONFIG_JACK=$has_jack" >> config.mak
|
||||
diff -up gpac/modules/ffmpeg_in/ffmpeg_decode.c.ffmpeg gpac/modules/ffmpeg_in/ffmpeg_decode.c
|
||||
--- gpac/modules/ffmpeg_in/ffmpeg_decode.c.ffmpeg 2008-11-28 18:26:06.000000000 +0100
|
||||
+++ gpac/modules/ffmpeg_in/ffmpeg_decode.c 2009-03-20 22:12:55.000000000 +0100
|
||||
@@ -241,7 +241,7 @@ static GF_Err FFDEC_AttachStream(GF_Base
|
||||
|
||||
/*setup audio streams*/
|
||||
if (ffd->st==GF_STREAM_AUDIO) {
|
||||
- if ((ffd->codec->type == CODEC_ID_MP3LAME) || (ffd->codec->type == CODEC_ID_MP2)) {
|
||||
+ if ((ffd->codec->type == CODEC_ID_MP3) || (ffd->codec->type == CODEC_ID_MP2)) {
|
||||
ffd->ctx->frame_size = (ffd->ctx->sample_rate > 24000) ? 1152 : 576;
|
||||
}
|
||||
/*may be 0 (cfg not known yet)*/
|
||||
@@ -444,9 +444,9 @@ static GF_Err FFDEC_ProcessData(GF_Media
|
||||
return GF_OK;
|
||||
}
|
||||
if (ffd->frame_start>inBufferLength) ffd->frame_start = 0;
|
||||
-
|
||||
+ gotpic=buf_size;
|
||||
redecode:
|
||||
- len = avcodec_decode_audio(ffd->ctx, (short *)ffd->audio_buf, &gotpic, inBuffer + ffd->frame_start, inBufferLength - ffd->frame_start);
|
||||
+ len = avcodec_decode_audio2(ffd->ctx, (short *)ffd->audio_buf, &gotpic, inBuffer + ffd->frame_start, inBufferLength - ffd->frame_start);
|
||||
|
||||
if (len<0) { ffd->frame_start = 0; return GF_NON_COMPLIANT_BITSTREAM; }
|
||||
if (gotpic<0) { ffd->frame_start = 0; return GF_OK; }
|
||||
@@ -643,7 +643,7 @@ redecode:
|
||||
NULL, NULL, NULL);
|
||||
|
||||
if (ffd->sws_ctx)
|
||||
- sws_scale(ffd->sws_ctx, ffd->frame->data, ffd->frame->linesize, 0, ffd->ctx->height->codec->height, pict.data, pict.linesize);
|
||||
+ sws_scale(ffd->sws_ctx, ffd->frame->data, ffd->frame->linesize, 0, ffd->ctx->height, pict.data, pict.linesize);
|
||||
|
||||
#endif
|
||||
|
||||
diff -up gpac/modules/ffmpeg_in/ffmpeg_in.h.ffmpeg gpac/modules/ffmpeg_in/ffmpeg_in.h
|
||||
--- gpac/modules/ffmpeg_in/ffmpeg_in.h.ffmpeg 2008-10-20 13:04:40.000000000 +0200
|
||||
+++ gpac/modules/ffmpeg_in/ffmpeg_in.h 2009-03-20 21:47:50.000000000 +0100
|
||||
@@ -56,14 +56,14 @@
|
||||
|
||||
|
||||
/*include FFMPEG APIs*/
|
||||
-#include <ffmpeg/avformat.h>
|
||||
+#include <libavformat/avformat.h>
|
||||
|
||||
void gf_av_vlog(void* avcl, int level, const char *fmt, va_list vl);
|
||||
|
||||
|
||||
#if LIBAVCODEC_VERSION_INT > ((52<<16)+(0<<8)+0)
|
||||
#define FFMPEG_SWSCALE
|
||||
-#include <ffmpeg/swscale.h>
|
||||
+#include <libswscale/swscale.h>
|
||||
#endif
|
||||
|
||||
/*FFMPEG decoder module */
|
||||
diff -up gpac/modules/ffmpeg_in/Makefile.ffmpeg gpac/modules/ffmpeg_in/Makefile
|
||||
--- gpac/modules/ffmpeg_in/Makefile.ffmpeg 2008-11-24 10:14:18.000000000 +0100
|
||||
+++ gpac/modules/ffmpeg_in/Makefile 2009-03-20 21:46:41.000000000 +0100
|
||||
@@ -2,7 +2,7 @@ include ../../config.mak
|
||||
|
||||
vpath %.c $(SRC_PATH)/modules/ffmpeg_in
|
||||
|
||||
-CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include
|
||||
+CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include $(FFMPEG_CFLAGS)
|
||||
|
||||
ifeq ($(DEBUGBUILD), yes)
|
||||
CFLAGS+=-g
|
||||
@@ -15,7 +15,7 @@ LDFLAGS+=-pg
|
||||
endif
|
||||
|
||||
LOCAL_LIB=
|
||||
-LINKLIBS=-lgpac -lavcodec -lavformat -lz
|
||||
+LINKLIBS=-lgpac $(FFMPEG_LFLAGS) -lz
|
||||
|
||||
#common obj
|
||||
OBJS=ffmpeg_decode.o ffmpeg_demux.o ffmpeg_load.o
|
||||
|
@ -1,51 +0,0 @@
|
||||
diff -up gpac/applications/generators/SVG/Makefile.libxml2 gpac/applications/generators/SVG/Makefile
|
||||
--- gpac/applications/generators/SVG/Makefile.libxml2 2008-12-17 12:59:23.000000000 +0100
|
||||
+++ gpac/applications/generators/SVG/Makefile 2008-12-17 12:59:23.000000000 +0100
|
||||
@@ -37,7 +37,7 @@ SRCS := $(OBJS:.o=.c)
|
||||
all: $(PROG)
|
||||
|
||||
SVGGen$(EXE): $(OBJS)
|
||||
- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XML2_LFLAGS) $(EXTRALIBS)
|
||||
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XML2_LIBS) $(EXTRALIBS)
|
||||
|
||||
|
||||
%.o: %.c
|
||||
diff -up gpac/configure.libxml2 gpac/configure
|
||||
--- gpac/configure.libxml2 2008-12-17 12:59:23.000000000 +0100
|
||||
+++ gpac/configure 2008-12-17 13:02:37.000000000 +0100
|
||||
@@ -68,6 +68,7 @@ has_alsa="no"
|
||||
has_jack="no"
|
||||
has_x11="no"
|
||||
has_x11_shm="no"
|
||||
+has_libxml2="no"
|
||||
has_x11_xv="no"
|
||||
disable_svg="no"
|
||||
no_gcc_opt="no"
|
||||
@@ -901,6 +902,15 @@ fi
|
||||
fi
|
||||
#end wx test
|
||||
|
||||
+# If svg isn't disabled
|
||||
+if test "$disable_svg" != "yes"; then
|
||||
+# Then we check libxm2 presence via pkg-config
|
||||
+ if pkg-config libxml-2.0 --exists > /dev/null 2>&1 ; then
|
||||
+ libxml2_cflags=`pkg-config libxml-2.0 --cflags`
|
||||
+ libxml2_lib_flags=`pkg-config libxml-2.0 --libs`
|
||||
+ has_libxml2="yes"
|
||||
+ fi
|
||||
+fi
|
||||
|
||||
# look for IPv6
|
||||
cat > $TMPC << EOF
|
||||
@@ -1579,6 +1589,11 @@ echo "CONFIG_JACK=$has_jack" >> config.m
|
||||
echo "CONFIG_A52=$has_a52" >> config.mak
|
||||
|
||||
echo "DISABLE_SVG=$disable_svg" >> config.mak
|
||||
+echo "HAS_LIBXML2=$has_libxml2" >> config.mak
|
||||
+if test "$has_libxml2" = "yes"; then
|
||||
+ echo "XML2_CFLAGS=$libxml2_cflags" >> config.mak
|
||||
+ echo "XML2_LIBS=$libxml2_lib_flags" >> config.mak
|
||||
+fi
|
||||
echo "GPAC_USE_TINYGL=$has_tinygl" >> config.mak
|
||||
echo "OGL_INCLS=$INCL3D" >> config.mak
|
||||
if test "$disable_svg" = "yes" ; then
|
@ -0,0 +1,83 @@
|
||||
diff -up gpac/configure.ffmpeg gpac/configure
|
||||
--- gpac/configure.ffmpeg 2009-09-01 16:50:50.270496559 +0200
|
||||
+++ gpac/configure 2009-09-01 17:59:05.902493824 +0200
|
||||
@@ -808,25 +808,19 @@ cat > $TMPC << EOF
|
||||
int main( void ) { return 0; }
|
||||
EOF
|
||||
|
||||
-if $cc $TMPO -c $TMPC 2> /dev/null ; then
|
||||
-old_ffmpeg_inc="no"
|
||||
+if pkg-config --exists libavcodec libavformat libswscale 2> /dev/null ; then
|
||||
+ ffmpeg_cflags=`pkg-config --cflags libavcodec libavformat libswscale`
|
||||
+ ffmpeg_lflags=`pkg-config --libs libavcodec libavformat libswscale`
|
||||
+ has_ffmpeg="system"
|
||||
else
|
||||
-
|
||||
-old_ffmpeg_inc="yes"
|
||||
-
|
||||
-cat > $TMPC << EOF
|
||||
-#include <ffmpeg/avcodec.h>
|
||||
-int main( void ) { return 0; }
|
||||
-EOF
|
||||
-
|
||||
-fi
|
||||
-
|
||||
+ ffmpeg_cflags=
|
||||
+ ffmpeg_lflags=`-lavcodec -lavformat`
|
||||
|
||||
if test "$cross_prefix" != "" ; then
|
||||
- if $cc -o $TMPO $TMPC -I$prefix/include -L$prefix/lib -lz -lavcodec -lavformat -lavutil 2> /dev/null ; then
|
||||
+ if $cc -o $TMPO $TMPC -I$prefix/include -L$prefix/lib -lz $ffmpeg_lflags -lavutil 2> /dev/null ; then
|
||||
has_ffmpeg="system"
|
||||
else
|
||||
- if $cc -o $TMPO $TMPC -I$local_inc -L$local_lib -lz -lavcodec -lavformat 2> /dev/null ; then
|
||||
+ if $cc -o $TMPO $TMPC -I$local_inc -L$local_lib -lz $ffmpeg_lflags 2> /dev/null ; then
|
||||
has_ffmpeg="local"
|
||||
fi
|
||||
fi
|
||||
@@ -841,6 +835,7 @@ else
|
||||
has_ffmpeg="local"
|
||||
fi
|
||||
fi
|
||||
+fi
|
||||
|
||||
#look for vorbis support
|
||||
cat > $TMPC << EOF
|
||||
@@ -1912,6 +1907,10 @@ echo "CONFIG_VORBIS=$has_vorbis" >> conf
|
||||
echo "CONFIG_THEORA=$has_theora" >> config.mak
|
||||
echo "CONFIG_FFMPEG=$has_ffmpeg" >> config.mak
|
||||
echo "CONFIG_FFMPEG_OLD=$old_ffmpeg_inc" >> config.mak
|
||||
+if test x$has_ffmpeg != x ; then
|
||||
+ echo "FFMPEG_CFLAGS=$ffmpeg_cflags" >> config.mak
|
||||
+ echo "FFMPEG_LFLAGS=$ffmpeg_lflags" >> config.mak
|
||||
+fi
|
||||
|
||||
echo "CONFIG_OSS_AUDIO=$has_oss_audio" >> config.mak
|
||||
echo "CONFIG_ALSA=$has_alsa" >> config.mak
|
||||
diff -up gpac/modules/ffmpeg_in/Makefile.ffmpeg gpac/modules/ffmpeg_in/Makefile
|
||||
--- gpac/modules/ffmpeg_in/Makefile.ffmpeg 2009-07-31 09:37:41.000000000 +0200
|
||||
+++ gpac/modules/ffmpeg_in/Makefile 2009-09-01 17:49:55.333497907 +0200
|
||||
@@ -2,7 +2,7 @@ include ../../config.mak
|
||||
|
||||
vpath %.c $(SRC_PATH)/modules/ffmpeg_in
|
||||
|
||||
-CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include
|
||||
+CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include $(FFMPEG_CFLAGS)
|
||||
|
||||
ifeq ($(DEBUGBUILD), yes)
|
||||
CFLAGS+=-g
|
||||
@@ -15,13 +15,11 @@ LDFLAGS+=-pg
|
||||
endif
|
||||
|
||||
LOCAL_LIB=
|
||||
-LINKLIBS=-lgpac -lavcodec -lavformat -lz
|
||||
+LINKLIBS=-lgpac $(FFMPEG_LFLAGS) -lz
|
||||
|
||||
#old ffmpeg lib
|
||||
ifeq ($(CONFIG_FFMPEG_OLD), yes)
|
||||
CFLAGS+=-DFFMPEG_OLD_HEADERS
|
||||
-else
|
||||
-LINKLIBS+=-lswscale
|
||||
endif
|
||||
|
||||
#common obj
|
@ -0,0 +1,13 @@
|
||||
diff -up gpac/configure.js gpac/configure
|
||||
diff -up gpac/src/Makefile.js gpac/src/Makefile
|
||||
--- gpac/src/Makefile.js 2009-09-01 16:23:44.053745967 +0200
|
||||
+++ gpac/src/Makefile 2009-09-01 16:47:32.491499125 +0200
|
||||
@@ -76,7 +76,7 @@ endif
|
||||
#3 - spidermonkey support
|
||||
ifeq ($(CONFIG_JS),no)
|
||||
else
|
||||
-SCENEGRAPH_CFLAGS+=$(JS_FLAGS)
|
||||
+CFLAGS+=$(JS_FLAGS)
|
||||
ifeq ($(CONFIG_JS),local)
|
||||
NEED_LOCAL_LIB="yes"
|
||||
endif
|
@ -0,0 +1,76 @@
|
||||
diff -up gpac/applications/generators/SVG/Makefile.libxml2 gpac/applications/generators/SVG/Makefile
|
||||
--- gpac/applications/generators/SVG/Makefile.libxml2 2009-09-01 16:12:48.317745990 +0200
|
||||
+++ gpac/applications/generators/SVG/Makefile 2009-09-01 16:14:27.221497909 +0200
|
||||
@@ -37,7 +37,7 @@ SRCS := $(OBJS:.o=.c)
|
||||
all: $(PROG)
|
||||
|
||||
SVGGen$(EXE): $(OBJS)
|
||||
- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XML2_LFLAGS) $(EXTRALIBS)
|
||||
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XML2_LIBS) $(EXTRALIBS)
|
||||
|
||||
|
||||
%.o: %.c
|
||||
diff -up gpac/applications/generators/SVG/Makefile.shared.libxml2 gpac/applications/generators/SVG/Makefile.shared
|
||||
--- gpac/applications/generators/SVG/Makefile.shared.libxml2 2008-11-24 09:40:04.000000000 +0100
|
||||
+++ gpac/applications/generators/SVG/Makefile.shared 2009-09-01 16:20:46.049498877 +0200
|
||||
@@ -35,7 +35,7 @@ SRCS := $(OBJS:.o=.c)
|
||||
all: $(PROG)
|
||||
|
||||
SVGGen$(EXE): $(OBJS)
|
||||
- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(XML2_LFLAGS) $(EXTRALIBS)
|
||||
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(XML2_LIBS) $(EXTRALIBS)
|
||||
|
||||
|
||||
%.o: %.c
|
||||
diff -up gpac/applications/testapps/loadcompare/Makefile.libxml2 gpac/applications/testapps/loadcompare/Makefile
|
||||
--- gpac/applications/testapps/loadcompare/Makefile.libxml2 2008-11-24 09:56:20.000000000 +0100
|
||||
+++ gpac/applications/testapps/loadcompare/Makefile 2009-09-01 16:21:19.341500133 +0200
|
||||
@@ -29,7 +29,7 @@ else
|
||||
EXT=
|
||||
PROG=LoadCompare
|
||||
#LINKFLAGS+=-lgpac_static $(EXTRALIBS) $(GPAC_SH_FLAGS) -lz
|
||||
-LINKFLAGS+=-lgpac -lz $(XML2_LFLAGS)
|
||||
+LINKFLAGS+=-lgpac -lz $(XML2_LIBS)
|
||||
endif
|
||||
|
||||
|
||||
diff -up gpac/configure.libxml2 gpac/configure
|
||||
--- gpac/configure.libxml2 2009-09-01 16:15:10.226496731 +0200
|
||||
+++ gpac/configure 2009-09-01 16:18:23.287494600 +0200
|
||||
@@ -87,6 +87,7 @@ has_ipv6="no"
|
||||
has_dvb4linux="no"
|
||||
has_xmlrpc="no"
|
||||
has_openjpeg="no"
|
||||
+has_libxml2="no"
|
||||
gprof_build="no"
|
||||
PIC_CFLAGS=""
|
||||
want_pic="no"
|
||||
@@ -980,6 +981,16 @@ fi
|
||||
fi
|
||||
#end wx test
|
||||
|
||||
+# If svg isn't disabled
|
||||
+if test "$disable_svg" != "yes"; then
|
||||
+# Then we check libxm2 presence via pkg-config
|
||||
+ if pkg-config libxml-2.0 --exists > /dev/null 2>&1 ; then
|
||||
+ libxml2_cflags=`pkg-config libxml-2.0 --cflags`
|
||||
+ libxml2_lib_flags=`pkg-config libxml-2.0 --libs`
|
||||
+ has_libxml2="yes"
|
||||
+ fi
|
||||
+fi
|
||||
+
|
||||
|
||||
# look for IPv6
|
||||
cat > $TMPC << EOF
|
||||
@@ -1908,6 +1919,11 @@ echo "CONFIG_JACK=$has_jack" >> config.m
|
||||
echo "CONFIG_A52=$has_a52" >> config.mak
|
||||
|
||||
echo "DISABLE_SVG=$disable_svg" >> config.mak
|
||||
+echo "HAS_LIBXML2=$has_libxml2" >> config.mak
|
||||
+if test "$has_libxml2" = "yes"; then
|
||||
+ echo "XML2_CFLAGS=$libxml2_cflags" >> config.mak
|
||||
+ echo "XML2_LIBS=$libxml2_lib_flags" >> config.mak
|
||||
+fi
|
||||
echo "GPAC_USE_TINYGL=$has_tinygl" >> config.mak
|
||||
echo "OGL_INCLS=$INCL3D" >> config.mak
|
||||
|
@ -0,0 +1,12 @@
|
||||
diff -up gpac/configure.ogl_libs gpac/configure
|
||||
--- gpac/configure.ogl_libs 2009-09-19 13:29:46.988993098 +0200
|
||||
+++ gpac/configure 2009-09-19 13:33:34.840741932 +0200
|
||||
@@ -1319,7 +1319,7 @@ if test "$disable_3d" = "no" ; then
|
||||
elif test "$darwin" = "yes" ; then
|
||||
LINK3D="-lgl -lglu"
|
||||
else
|
||||
- LINK3D="-lGL -lglut"
|
||||
+ LINK3D="-lGLU -lGL -lglut"
|
||||
fi
|
||||
if $cc -o $TMPO $TMPC $LINK3D 2> /dev/null ; then
|
||||
has_opengl="yes"
|
@ -1,14 +0,0 @@
|
||||
diff -up gpac/configure~ gpac/configure
|
||||
--- gpac/configure~ 2008-12-17 14:58:05.000000000 +0100
|
||||
+++ gpac/configure 2008-12-18 23:10:50.000000000 +0100
|
||||
@@ -236,6 +236,10 @@ case "$cpu" in
|
||||
alpha)
|
||||
cpu="alpha"
|
||||
;;
|
||||
+ ppc64)
|
||||
+ cpu="powerpc"
|
||||
+ libdir="lib64"
|
||||
+ ;;
|
||||
"Power Macintosh"|ppc)
|
||||
cpu="powerpc"
|
||||
;;
|
Loading…
Reference in new issue