Update gpac

el8
Nicolas Chauvet 16 years ago
parent 77d0a83dea
commit 1ef3d0bd40

2
.gitignore vendored

@ -1 +1 @@
gpac-0.4.5-repack.tar.bz2
gpac-20090919.tar.bz2

@ -1,112 +0,0 @@
diff -up gpac/configure.ffmpeg gpac/configure
--- gpac/configure.ffmpeg 2009-03-20 21:46:41.000000000 +0100
+++ gpac/configure 2009-03-20 21:58:21.000000000 +0100
@@ -737,10 +737,11 @@ fi
#look for FFMPEG support
cat > $TMPC << EOF
#include <stddef.h>
-#include <ffmpeg/avcodec.h>
+#include <libavcodec/avcodec.h>
int main( void ) { return 0; }
EOF
-
+ffmpeg_cflags=`pkg-config --cflags libavcodec libavformat libswscale`
+ffmpeg_lflags=`pkg-config --libs libavcodec libavformat libswscale`
if test "$cross_prefix" != "" ; then
echo "HELLO"
echo "HELLO"
@@ -756,7 +757,7 @@ if test "$cross_prefix" != "" ; then
fi
fi
else
- if $cc -o $TMPO $TMPC -lz -lavcodec -lavformat 2> /dev/null ; then
+ if $cc -o $TMPO $TMPC $ffmpeg_cflags $ffmpeg_lflags 2> /dev/null ; then
has_ffmpeg="system"
elif test "$alt_macosx_dir" != "" ; then
if $cc -o $TMPO $TMPC -I$alt_macosx_dir/include -L$alt_macosx_dir/lib -lz -lavcodec -lavformat 2> /dev/null ; then
@@ -1587,6 +1588,10 @@ echo "CONFIG_OGG=$has_ogg" >> config.mak
echo "CONFIG_VORBIS=$has_vorbis" >> config.mak
echo "CONFIG_THEORA=$has_theora" >> config.mak
echo "CONFIG_FFMPEG=$has_ffmpeg" >> config.mak
+if test "$has_ffmpeg" = "system"; then
+ echo "FFMPEG_CFLAGS=$ffmpeg_cflags" >> config.mak
+ echo "FFMPEG_LFLAGS=$ffmpeg_lflags" >> config.mak
+fi
echo "CONFIG_OSS_AUDIO=$has_oss_audio" >> config.mak
echo "CONFIG_ALSA=$has_alsa" >> config.mak
echo "CONFIG_JACK=$has_jack" >> config.mak
diff -up gpac/modules/ffmpeg_in/ffmpeg_decode.c.ffmpeg gpac/modules/ffmpeg_in/ffmpeg_decode.c
--- gpac/modules/ffmpeg_in/ffmpeg_decode.c.ffmpeg 2008-11-28 18:26:06.000000000 +0100
+++ gpac/modules/ffmpeg_in/ffmpeg_decode.c 2009-03-20 22:12:55.000000000 +0100
@@ -241,7 +241,7 @@ static GF_Err FFDEC_AttachStream(GF_Base
/*setup audio streams*/
if (ffd->st==GF_STREAM_AUDIO) {
- if ((ffd->codec->type == CODEC_ID_MP3LAME) || (ffd->codec->type == CODEC_ID_MP2)) {
+ if ((ffd->codec->type == CODEC_ID_MP3) || (ffd->codec->type == CODEC_ID_MP2)) {
ffd->ctx->frame_size = (ffd->ctx->sample_rate > 24000) ? 1152 : 576;
}
/*may be 0 (cfg not known yet)*/
@@ -444,9 +444,9 @@ static GF_Err FFDEC_ProcessData(GF_Media
return GF_OK;
}
if (ffd->frame_start>inBufferLength) ffd->frame_start = 0;
-
+ gotpic=buf_size;
redecode:
- len = avcodec_decode_audio(ffd->ctx, (short *)ffd->audio_buf, &gotpic, inBuffer + ffd->frame_start, inBufferLength - ffd->frame_start);
+ len = avcodec_decode_audio2(ffd->ctx, (short *)ffd->audio_buf, &gotpic, inBuffer + ffd->frame_start, inBufferLength - ffd->frame_start);
if (len<0) { ffd->frame_start = 0; return GF_NON_COMPLIANT_BITSTREAM; }
if (gotpic<0) { ffd->frame_start = 0; return GF_OK; }
@@ -643,7 +643,7 @@ redecode:
NULL, NULL, NULL);
if (ffd->sws_ctx)
- sws_scale(ffd->sws_ctx, ffd->frame->data, ffd->frame->linesize, 0, ffd->ctx->height->codec->height, pict.data, pict.linesize);
+ sws_scale(ffd->sws_ctx, ffd->frame->data, ffd->frame->linesize, 0, ffd->ctx->height, pict.data, pict.linesize);
#endif
diff -up gpac/modules/ffmpeg_in/ffmpeg_in.h.ffmpeg gpac/modules/ffmpeg_in/ffmpeg_in.h
--- gpac/modules/ffmpeg_in/ffmpeg_in.h.ffmpeg 2008-10-20 13:04:40.000000000 +0200
+++ gpac/modules/ffmpeg_in/ffmpeg_in.h 2009-03-20 21:47:50.000000000 +0100
@@ -56,14 +56,14 @@
/*include FFMPEG APIs*/
-#include <ffmpeg/avformat.h>
+#include <libavformat/avformat.h>
void gf_av_vlog(void* avcl, int level, const char *fmt, va_list vl);
#if LIBAVCODEC_VERSION_INT > ((52<<16)+(0<<8)+0)
#define FFMPEG_SWSCALE
-#include <ffmpeg/swscale.h>
+#include <libswscale/swscale.h>
#endif
/*FFMPEG decoder module */
diff -up gpac/modules/ffmpeg_in/Makefile.ffmpeg gpac/modules/ffmpeg_in/Makefile
--- gpac/modules/ffmpeg_in/Makefile.ffmpeg 2008-11-24 10:14:18.000000000 +0100
+++ gpac/modules/ffmpeg_in/Makefile 2009-03-20 21:46:41.000000000 +0100
@@ -2,7 +2,7 @@ include ../../config.mak
vpath %.c $(SRC_PATH)/modules/ffmpeg_in
-CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include
+CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include $(FFMPEG_CFLAGS)
ifeq ($(DEBUGBUILD), yes)
CFLAGS+=-g
@@ -15,7 +15,7 @@ LDFLAGS+=-pg
endif
LOCAL_LIB=
-LINKLIBS=-lgpac -lavcodec -lavformat -lz
+LINKLIBS=-lgpac $(FFMPEG_LFLAGS) -lz
#common obj
OBJS=ffmpeg_decode.o ffmpeg_demux.o ffmpeg_load.o

@ -1,51 +0,0 @@
diff -up gpac/applications/generators/SVG/Makefile.libxml2 gpac/applications/generators/SVG/Makefile
--- gpac/applications/generators/SVG/Makefile.libxml2 2008-12-17 12:59:23.000000000 +0100
+++ gpac/applications/generators/SVG/Makefile 2008-12-17 12:59:23.000000000 +0100
@@ -37,7 +37,7 @@ SRCS := $(OBJS:.o=.c)
all: $(PROG)
SVGGen$(EXE): $(OBJS)
- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XML2_LFLAGS) $(EXTRALIBS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XML2_LIBS) $(EXTRALIBS)
%.o: %.c
diff -up gpac/configure.libxml2 gpac/configure
--- gpac/configure.libxml2 2008-12-17 12:59:23.000000000 +0100
+++ gpac/configure 2008-12-17 13:02:37.000000000 +0100
@@ -68,6 +68,7 @@ has_alsa="no"
has_jack="no"
has_x11="no"
has_x11_shm="no"
+has_libxml2="no"
has_x11_xv="no"
disable_svg="no"
no_gcc_opt="no"
@@ -901,6 +902,15 @@ fi
fi
#end wx test
+# If svg isn't disabled
+if test "$disable_svg" != "yes"; then
+# Then we check libxm2 presence via pkg-config
+ if pkg-config libxml-2.0 --exists > /dev/null 2>&1 ; then
+ libxml2_cflags=`pkg-config libxml-2.0 --cflags`
+ libxml2_lib_flags=`pkg-config libxml-2.0 --libs`
+ has_libxml2="yes"
+ fi
+fi
# look for IPv6
cat > $TMPC << EOF
@@ -1579,6 +1589,11 @@ echo "CONFIG_JACK=$has_jack" >> config.m
echo "CONFIG_A52=$has_a52" >> config.mak
echo "DISABLE_SVG=$disable_svg" >> config.mak
+echo "HAS_LIBXML2=$has_libxml2" >> config.mak
+if test "$has_libxml2" = "yes"; then
+ echo "XML2_CFLAGS=$libxml2_cflags" >> config.mak
+ echo "XML2_LIBS=$libxml2_lib_flags" >> config.mak
+fi
echo "GPAC_USE_TINYGL=$has_tinygl" >> config.mak
echo "OGL_INCLS=$INCL3D" >> config.mak
if test "$disable_svg" = "yes" ; then

@ -0,0 +1,83 @@
diff -up gpac/configure.ffmpeg gpac/configure
--- gpac/configure.ffmpeg 2009-09-01 16:50:50.270496559 +0200
+++ gpac/configure 2009-09-01 17:59:05.902493824 +0200
@@ -808,25 +808,19 @@ cat > $TMPC << EOF
int main( void ) { return 0; }
EOF
-if $cc $TMPO -c $TMPC 2> /dev/null ; then
-old_ffmpeg_inc="no"
+if pkg-config --exists libavcodec libavformat libswscale 2> /dev/null ; then
+ ffmpeg_cflags=`pkg-config --cflags libavcodec libavformat libswscale`
+ ffmpeg_lflags=`pkg-config --libs libavcodec libavformat libswscale`
+ has_ffmpeg="system"
else
-
-old_ffmpeg_inc="yes"
-
-cat > $TMPC << EOF
-#include <ffmpeg/avcodec.h>
-int main( void ) { return 0; }
-EOF
-
-fi
-
+ ffmpeg_cflags=
+ ffmpeg_lflags=`-lavcodec -lavformat`
if test "$cross_prefix" != "" ; then
- if $cc -o $TMPO $TMPC -I$prefix/include -L$prefix/lib -lz -lavcodec -lavformat -lavutil 2> /dev/null ; then
+ if $cc -o $TMPO $TMPC -I$prefix/include -L$prefix/lib -lz $ffmpeg_lflags -lavutil 2> /dev/null ; then
has_ffmpeg="system"
else
- if $cc -o $TMPO $TMPC -I$local_inc -L$local_lib -lz -lavcodec -lavformat 2> /dev/null ; then
+ if $cc -o $TMPO $TMPC -I$local_inc -L$local_lib -lz $ffmpeg_lflags 2> /dev/null ; then
has_ffmpeg="local"
fi
fi
@@ -841,6 +835,7 @@ else
has_ffmpeg="local"
fi
fi
+fi
#look for vorbis support
cat > $TMPC << EOF
@@ -1912,6 +1907,10 @@ echo "CONFIG_VORBIS=$has_vorbis" >> conf
echo "CONFIG_THEORA=$has_theora" >> config.mak
echo "CONFIG_FFMPEG=$has_ffmpeg" >> config.mak
echo "CONFIG_FFMPEG_OLD=$old_ffmpeg_inc" >> config.mak
+if test x$has_ffmpeg != x ; then
+ echo "FFMPEG_CFLAGS=$ffmpeg_cflags" >> config.mak
+ echo "FFMPEG_LFLAGS=$ffmpeg_lflags" >> config.mak
+fi
echo "CONFIG_OSS_AUDIO=$has_oss_audio" >> config.mak
echo "CONFIG_ALSA=$has_alsa" >> config.mak
diff -up gpac/modules/ffmpeg_in/Makefile.ffmpeg gpac/modules/ffmpeg_in/Makefile
--- gpac/modules/ffmpeg_in/Makefile.ffmpeg 2009-07-31 09:37:41.000000000 +0200
+++ gpac/modules/ffmpeg_in/Makefile 2009-09-01 17:49:55.333497907 +0200
@@ -2,7 +2,7 @@ include ../../config.mak
vpath %.c $(SRC_PATH)/modules/ffmpeg_in
-CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include
+CFLAGS= $(OPTFLAGS) -I$(SRC_PATH)/include $(FFMPEG_CFLAGS)
ifeq ($(DEBUGBUILD), yes)
CFLAGS+=-g
@@ -15,13 +15,11 @@ LDFLAGS+=-pg
endif
LOCAL_LIB=
-LINKLIBS=-lgpac -lavcodec -lavformat -lz
+LINKLIBS=-lgpac $(FFMPEG_LFLAGS) -lz
#old ffmpeg lib
ifeq ($(CONFIG_FFMPEG_OLD), yes)
CFLAGS+=-DFFMPEG_OLD_HEADERS
-else
-LINKLIBS+=-lswscale
endif
#common obj

@ -0,0 +1,13 @@
diff -up gpac/configure.js gpac/configure
diff -up gpac/src/Makefile.js gpac/src/Makefile
--- gpac/src/Makefile.js 2009-09-01 16:23:44.053745967 +0200
+++ gpac/src/Makefile 2009-09-01 16:47:32.491499125 +0200
@@ -76,7 +76,7 @@ endif
#3 - spidermonkey support
ifeq ($(CONFIG_JS),no)
else
-SCENEGRAPH_CFLAGS+=$(JS_FLAGS)
+CFLAGS+=$(JS_FLAGS)
ifeq ($(CONFIG_JS),local)
NEED_LOCAL_LIB="yes"
endif

@ -0,0 +1,76 @@
diff -up gpac/applications/generators/SVG/Makefile.libxml2 gpac/applications/generators/SVG/Makefile
--- gpac/applications/generators/SVG/Makefile.libxml2 2009-09-01 16:12:48.317745990 +0200
+++ gpac/applications/generators/SVG/Makefile 2009-09-01 16:14:27.221497909 +0200
@@ -37,7 +37,7 @@ SRCS := $(OBJS:.o=.c)
all: $(PROG)
SVGGen$(EXE): $(OBJS)
- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XML2_LFLAGS) $(EXTRALIBS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XML2_LIBS) $(EXTRALIBS)
%.o: %.c
diff -up gpac/applications/generators/SVG/Makefile.shared.libxml2 gpac/applications/generators/SVG/Makefile.shared
--- gpac/applications/generators/SVG/Makefile.shared.libxml2 2008-11-24 09:40:04.000000000 +0100
+++ gpac/applications/generators/SVG/Makefile.shared 2009-09-01 16:20:46.049498877 +0200
@@ -35,7 +35,7 @@ SRCS := $(OBJS:.o=.c)
all: $(PROG)
SVGGen$(EXE): $(OBJS)
- $(CC) $(LDFLAGS) -o $@ $(OBJS) $(XML2_LFLAGS) $(EXTRALIBS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(XML2_LIBS) $(EXTRALIBS)
%.o: %.c
diff -up gpac/applications/testapps/loadcompare/Makefile.libxml2 gpac/applications/testapps/loadcompare/Makefile
--- gpac/applications/testapps/loadcompare/Makefile.libxml2 2008-11-24 09:56:20.000000000 +0100
+++ gpac/applications/testapps/loadcompare/Makefile 2009-09-01 16:21:19.341500133 +0200
@@ -29,7 +29,7 @@ else
EXT=
PROG=LoadCompare
#LINKFLAGS+=-lgpac_static $(EXTRALIBS) $(GPAC_SH_FLAGS) -lz
-LINKFLAGS+=-lgpac -lz $(XML2_LFLAGS)
+LINKFLAGS+=-lgpac -lz $(XML2_LIBS)
endif
diff -up gpac/configure.libxml2 gpac/configure
--- gpac/configure.libxml2 2009-09-01 16:15:10.226496731 +0200
+++ gpac/configure 2009-09-01 16:18:23.287494600 +0200
@@ -87,6 +87,7 @@ has_ipv6="no"
has_dvb4linux="no"
has_xmlrpc="no"
has_openjpeg="no"
+has_libxml2="no"
gprof_build="no"
PIC_CFLAGS=""
want_pic="no"
@@ -980,6 +981,16 @@ fi
fi
#end wx test
+# If svg isn't disabled
+if test "$disable_svg" != "yes"; then
+# Then we check libxm2 presence via pkg-config
+ if pkg-config libxml-2.0 --exists > /dev/null 2>&1 ; then
+ libxml2_cflags=`pkg-config libxml-2.0 --cflags`
+ libxml2_lib_flags=`pkg-config libxml-2.0 --libs`
+ has_libxml2="yes"
+ fi
+fi
+
# look for IPv6
cat > $TMPC << EOF
@@ -1908,6 +1919,11 @@ echo "CONFIG_JACK=$has_jack" >> config.m
echo "CONFIG_A52=$has_a52" >> config.mak
echo "DISABLE_SVG=$disable_svg" >> config.mak
+echo "HAS_LIBXML2=$has_libxml2" >> config.mak
+if test "$has_libxml2" = "yes"; then
+ echo "XML2_CFLAGS=$libxml2_cflags" >> config.mak
+ echo "XML2_LIBS=$libxml2_lib_flags" >> config.mak
+fi
echo "GPAC_USE_TINYGL=$has_tinygl" >> config.mak
echo "OGL_INCLS=$INCL3D" >> config.mak

@ -1,29 +1,7 @@
diff -up gpac/Makefile.makefix gpac/Makefile
--- gpac/Makefile.makefix 2008-10-23 17:40:38.000000000 +0200
+++ gpac/Makefile 2008-12-17 12:10:45.000000000 +0100
@@ -53,9 +53,8 @@ install:
install $(INSTFLAGS) -m 755 bin/gcc/MP4Box "$(DESTDIR)$(prefix)/bin"
$(MAKE) -C applications install
install -d "$(DESTDIR)$(moddir)"
- install bin/gcc/*.$(DYN_LIB_SUFFIX) "$(DESTDIR)$(moddir)"
- rm -f $(DESTDIR)$(moddir)/libgpac.$(DYN_LIB_SUFFIX)
- rm -f $(DESTDIR)$(moddir)/nposmozilla.$(DYN_LIB_SUFFIX)
+ install bin/gcc/gm*.$(DYN_LIB_SUFFIX) "$(DESTDIR)$(moddir)"
+
ifeq ($(CONFIG_WIN32),yes)
install $(INSTFLAGS) -m 755 bin/gcc/libgpac.dll $(prefix)/$(libdir)
else
@@ -66,19 +65,18 @@ ifeq ($(CONFIG_DARWIN),yes)
install -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac-$(VERSION).$(DYN_LIB_SUFFIX)
ln -sf libgpac-$(VERSION).$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
else
- install $(INSTFLAGS) -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac-$(VERSION).$(DYN_LIB_SUFFIX)
- ln -sf libgpac-$(VERSION).$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
- ldconfig || true
+ install $(INSTFLAGS) -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX).$(VERSION)
+ ln -sf libgpac.$(DYN_LIB_SUFFIX).$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
endif
endif
--- gpac/Makefile.makefix 2009-07-31 18:43:25.000000000 +0200
+++ gpac/Makefile 2009-09-01 17:14:20.615499921 +0200
@@ -60,11 +60,11 @@ install:
install -d "$(DESTDIR)$(mandir)"
install -d "$(DESTDIR)$(mandir)/man1"
if [ -d doc ] ; then \
@ -39,7 +17,19 @@ diff -up gpac/Makefile.makefix gpac/Makefile
fi
uninstall:
@@ -94,17 +92,15 @@ uninstall:
@@ -89,23 +89,25 @@ ifeq ($(CONFIG_DARWIN),yes)
install -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac-$(VERSION).$(DYN_LIB_SUFFIX)
ln -sf libgpac-$(VERSION).$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
else
- install $(INSTFLAGS) -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac-$(VERSION).$(DYN_LIB_SUFFIX)
- ln -sf libgpac-$(VERSION).$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
+ install $(INSTFLAGS) -m 755 bin/gcc/libgpac.$(DYN_LIB_SUFFIX) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX).$(VERSION)
+ ln -sf libgpac.$(DYN_LIB_SUFFIX).$(VERSION) $(DESTDIR)$(prefix)/$(libdir)/libgpac.$(DYN_LIB_SUFFIX)
+ifeq ($(DESTDIR)$(prefix),$(prefix))
ldconfig || true
endif
endif
+endif
install-lib:
mkdir -p "$(DESTDIR)$(prefix)/include/gpac"
@ -50,14 +40,13 @@ diff -up gpac/Makefile.makefix gpac/Makefile
+ install -pm 644 $(SRC_PATH)/include/gpac/internal/*.h "$(DESTDIR)$(prefix)/include/gpac/internal"
mkdir -p "$(DESTDIR)$(prefix)/include/gpac/modules"
- install -m 644 $(SRC_PATH)/include/gpac/modules/*.h "$(DESTDIR)$(prefix)/include/gpac/modules"
- install -m 644 $(SRC_PATH)/config.h "$(DESTDIR)$(prefix)/include/gpac/configuration.h"
+ install -pm 644 $(SRC_PATH)/include/gpac/modules/*.h "$(DESTDIR)$(prefix)/include/gpac/modules"
+ install -pm 644 $(SRC_PATH)/config.h "$(DESTDIR)$(prefix)/include/gpac/configuration.h"
ifeq ($(GPAC_ENST), yes)
mkdir -p "$(DESTDIR)$(prefix)/include/gpac/enst"
- install -m 644 $(SRC_PATH)/include/gpac/enst/*.h "$(DESTDIR)$(prefix)/include/gpac/enst"
+ install -pm 644 $(SRC_PATH)/include/gpac/enst/*.h "$(DESTDIR)$(prefix)/include/gpac/enst"
endif
- mkdir -p "$(DESTDIR)$(prefix)/lib"
- install -m 644 "./bin/gcc/libgpac_static.a" "$(DESTDIR)$(prefix)/lib"
mkdir -p "$(DESTDIR)$(prefix)/$(libdir)"
install -m 644 "./bin/gcc/libgpac_static.a" "$(DESTDIR)$(prefix)/$(libdir)"

@ -0,0 +1,12 @@
diff -up gpac/configure.ogl_libs gpac/configure
--- gpac/configure.ogl_libs 2009-09-19 13:29:46.988993098 +0200
+++ gpac/configure 2009-09-19 13:33:34.840741932 +0200
@@ -1319,7 +1319,7 @@ if test "$disable_3d" = "no" ; then
elif test "$darwin" = "yes" ; then
LINK3D="-lgl -lglu"
else
- LINK3D="-lGL -lglut"
+ LINK3D="-lGLU -lGL -lglut"
fi
if $cc -o $TMPO $TMPC $LINK3D 2> /dev/null ; then
has_opengl="yes"

@ -1,14 +0,0 @@
diff -up gpac/configure~ gpac/configure
--- gpac/configure~ 2008-12-17 14:58:05.000000000 +0100
+++ gpac/configure 2008-12-18 23:10:50.000000000 +0100
@@ -236,6 +236,10 @@ case "$cpu" in
alpha)
cpu="alpha"
;;
+ ppc64)
+ cpu="powerpc"
+ libdir="lib64"
+ ;;
"Power Macintosh"|ppc)
cpu="powerpc"
;;

@ -6,35 +6,38 @@
# - Submit and import patches upstream.
# - Fix unused-direct-shlib-dependency on libgpac
%define osmo Osmo4
#define cvs 20080217
%define with_static 1
%define with_osmo 0
%global osmo Osmo4
%global cvs 20090919
%global with_osmo 0
# Mozilla stuff fails. It's completely disabled for now.
%define mozver 3.0
%define geckover 1.9.1
%define xuldir %{_datadir}/idl/xulrunner-sdk-%{geckover}
%define xulbindir %{_libdir}/xulrunner-%{geckover}
%global mozver 3.0
%global geckover 1.9.1
%global xuldir %{_datadir}/idl/xulrunner-sdk-%{geckover}
%global xulbindir %{_libdir}/xulrunner-%{geckover}
Name: gpac
Summary: MPEG-4 multimedia framework
Version: 0.4.5
Release: 7%{?dist}
Version: 0.4.6
Release: 0.1.cvs%{?cvs}%{?dist}
License: LGPLv2+
Group: System Environment/Libraries
URL: http://gpac.sourceforge.net/
#Source0: http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
Source0: http://rpms.kwizart.net/fedora/SOURCE/gpac-%{version}-repack.tar.bz2
Source0: http://rpms.kwizart.net/fedora/SOURCE/gpac-%{cvs}.tar.bz2
Source9: gpac-snapshot.sh
Patch0: gpac-0.4.5-makefix.patch
#https://sourceforge.net/tracker/?func=detail&atid=571740&aid=2853860&group_id=84101
Patch0: gpac-0.4.6-makefix.patch
Patch1: gpac-0.4.5-soname.patch
Patch2: gpac-0.4.5-amr.patch
Patch3: gpac-0.4.5-lib64.patch
Patch4: gpac-0.4.5-system_openjpeg.patch
Patch5: gpac-0.4.6-js_cflags.patch
Patch6: gpac-0.4.5-shared_sggen.patch
Patch7: gpac-0.4.5-libxml2.patch
Patch8: gpac-ppc64.patch
Patch9: gpac-0.4.5-ffmpeg.patch
#https://sourceforge.net/tracker/?func=detail&atid=571740&aid=2853856&group_id=84101
Patch7: gpac-0.4.6-libxml2.patch
#https://sourceforge.net/tracker/?func=detail&atid=571740&aid=2853857&group_id=84101
Patch9: gpac-0.4.6-ffmpeg.patch
Patch10: gpac-0.4.6-ogl_libs.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -u -n)
BuildRequires: ImageMagick
@ -50,6 +53,7 @@ BuildRequires: libpng-devel >= 1.2.5
BuildRequires: libmad-devel
BuildRequires: xvidcore-devel >= 1.0.0
BuildRequires: ffmpeg-devel
BuildRequires: js-devel
BuildRequires: libxml2-devel
BuildRequires: openssl-devel
BuildRequires: openjpeg-devel
@ -89,14 +93,11 @@ The %{name}-libs package contains library for %{name}.
Summary: Development libraries and files for %{name}
Group: Development/Libraries
Requires: %{name}-libs = %{version}-%{release}
%if %{with_static}
%else
%endif
%description devel
Development libraries and files for gpac.
%if %{with_static}
%package devel-static
Summary: Development libraries and files for %{name}
Group: Development/Libraries
@ -105,7 +106,6 @@ Requires: %{name}-devel = %{version}-%{release}
%description devel-static
Static library for gpac.
%endif
%if %{with_osmo}
%package -n %{osmo}
@ -150,21 +150,17 @@ web browsers.
%patch3 -p1 -b .lib64
%endif
%patch4 -p1 -b .openjpeg
%patch5 -p1 -b .jscflags
%patch6 -p1 -b .shared
%patch7 -p1 -b .libxml2
%patch8 -p1 -b .ppc64
%patch9 -p1 -b .ffmpeg
%patch10 -p1 -b .ogl_libs
## kwizart - enable dynamic mode - hardcoded with patch2
# define SONAME number from the first number of gpac version.
#define soname libgpac.so.0
#sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
# Update doxygen
pushd doc
doxygen -u
popd
# Fix encoding warnings
cp -p Changelog Changelog.origine
iconv -f ISO-8859-1 -t UTF8 Changelog.origine > Changelog
@ -260,13 +256,13 @@ desktop-file-install --vendor "" \
#icons
mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
install -m 0644 applications/osmo4_wx/osmo4.xpm $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{osmo}.xpm
install -pm 0644 applications/osmo4_wx/osmo4.xpm $RPM_BUILD_ROOT%{_datadir}/pixmaps/%{osmo}.xpm
%else
rm -rf $RPM_BUILD_ROOT%{_bindir}/%{osmo}
%endif
## kwizart - rpmlint gpac no-ldconfig-symlink
ln -sf libgpac.so.%{version} $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
ln -sf libgpac.so.%{version}-DEV $RPM_BUILD_ROOT%{_libdir}/libgpac.so.0
ln -sf libgpac.so.0 $RPM_BUILD_ROOT%{_libdir}/libgpac.so
#Install generated sggen binaries
@ -324,15 +320,21 @@ rm -rf $RPM_BUILD_ROOT
%{_includedir}/gpac/
%{_libdir}/libgpac.so
%if %{with_static}
%files devel-static
%defattr(-,root,root,-)
%{_libdir}/libgpac_static.a
%else
%exclude %{_libdir}/libgpac_static.a
%endif
%changelog
* Sat Sep 19 2009 kwizart < kwizart at gmail.com > - 0.4.6-0.1cvs20090919
- Update to 0.4.6 pre cvs snapshoot 20090919
- Fix OGL link flag
* Tue Sep 1 2009 kwizart < kwizart at gmail.com > - 0.4.6-0.1cvs20090901
- Update to 0.4.6 pre cvs snapshoot 20090901
- Remove merged patch (1) update old (4)
- Clean static conditional
* Fri Mar 27 2009 kwizart < kwizart at gmail.com > - 0.4.5-7
- Rebuild for faad x264

@ -1 +1 @@
adf9be7956cf35b01dd14bd622e16e86 gpac-0.4.5-repack.tar.bz2
3211533978e01971f9817ae844536d76 gpac-20090919.tar.bz2

Loading…
Cancel
Save