Update to 2.9.90, remove vfolder cruft

f38
Matthias Clasen 20 years ago
parent 7961f8077a
commit 77ba13ac68

@ -4,3 +4,4 @@ gnome-vfs-2.8.0.tar.bz2
desktop-file-utils-0.8.tar.gz
gnome-vfs-2.8.1.tar.bz2
gnome-vfs-2.8.2.tar.bz2
gnome-vfs-2.9.90.tar.bz2

@ -0,0 +1,10 @@
--- gnome-vfs-2.9.90/modules/default-modules.conf.modules-conf 2005-01-10 11:22:41.000000000 -0500
+++ gnome-vfs-2.9.90/modules/default-modules.conf 2005-01-31 10:05:54.986703000 -0500
@@ -43,3 +43,7 @@
ssh: sftp
tar: tar
+
+favorites: desktop
+
+start-here: desktop

@ -0,0 +1,23 @@
--- gnome-vfs-2.9.90/modules/Makefile.am.old-modules 2005-01-10 11:22:41.000000000 -0500
+++ gnome-vfs-2.9.90/modules/Makefile.am 2005-01-31 10:11:41.564778000 -0500
@@ -67,6 +67,7 @@
$(SMB_LTLIBS) \
libsftp.la \
libtar.la \
+ libdesktop.la \
$(NULL)
# Not currently supported
@@ -161,6 +162,12 @@
libftp_la_LDFLAGS = $(module_flags)
libftp_la_LIBADD = $(MODULES_LIBS) $(GSSAPI_LIBS) ../libgnomevfs/libgnomevfs-2.la
+### `desktop' method
+
+libdesktop_la_SOURCES = desktop-method.c
+libdesktop_la_LDFLAGS = $(module_flags)
+libdesktop_la_LIBADD = ../libgnomevfs/libgnomevfs-2.la
+
### `nfs' method
#libnfs_la_SOURCES = \

@ -3,26 +3,22 @@
%define gconf2_version 1.2.0
%define gtkdoc_version 0.9
%define gnome_mime_data_version 2.0.0-11
%define redhat_menus_version 1.0
%define perl_XML_Parser_version 2.31-16
%define po_package gnome-vfs-2.0
Summary: The GNOME virtual file-system libraries.
Name: gnome-vfs2
Version: 2.8.2
Release: 10
Version: 2.9.90
Release: 1
License: LGPL
Group: System Environment/Libraries
Source: gnome-vfs-%{version}.tar.bz2
Source2: vfolder-desktop-method.c
Source3: desktop-method.c
Source4: desktop-file-utils-0.8.tar.gz
Source0: gnome-vfs-%{version}.tar.bz2
Source1: desktop-method.c
URL: http://www.gnome.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-root
Requires: gnome-mime-data >= %{gnome_mime_data_version}
Requires: shared-mime-info
Requires: redhat-menus >= %{redhat_menus_version}
Requires: howl-libs >= 0.9.8
BuildRequires: libbonobo-devel >= %{libbonobo_version}
BuildRequires: GConf2-devel >= %{gconf2_version}
@ -40,34 +36,19 @@ BuildRequires: howl-devel >= 0.9.8
BuildRequires: hal-devel
Prereq: GConf2 >= %{gconf2_version}
Patch1: gnome-vfs-1.9.16-moved-menu-files.patch
Patch2: gnome-vfs-2.0.1-only-show-in.patch
Patch3: gnome-vfs-2.5.90-modules-conf.patch
Patch4: gnome-vfs-2.0.2-newstat.patch
Patch5: gnome-vfs-2.0.2-read-only.patch
Patch3: gnome-vfs-2.9.90-modules-conf.patch
## this is the automake-requiring patch
Patch6: gnome-vfs-2.1.6-old-modules.patch
Patch6: gnome-vfs-2.9.90-old-modules.patch
Patch7: gnome-vfs-2.1.6-never-show-if-empty.patch
Patch8: gnome-vfs-2.1.6-hide-with-empty-subfolders.patch
Patch9: gnome-vfs-2.1.6-no-private-methods.patch
Patch10: gnome-vfs2-2.5.5-vfolder-hacks.patch
# desktop-file-utils patches
Patch50: desktop-file-utils-0.8-gnomevfs-embed.patch
Patch51: desktop-file-utils-0.8-pleasecreate.patch
# send to upstream
Patch101: gnome-vfs-2.8.2-schema_about_for_upstream.patch
Patch102: gnome-vfs-2.8.2-bufer-fix.patch
Patch103: gnome-vfs-2.8.2-mtab-mtime-check.patch
# Default
Patch104: gnome-vfs-2.8.2-browser_default.patch
Patch200: gnome-vfs-2.8.1-hal.patch
Patch201: gnome-vfs-2.8.1-console-mount-opt.patch
%description
@ -104,53 +85,23 @@ This package provides support for reading and writing files on windows
shares (SMB) to applications using GNOME VFS.
%prep
%setup -q -n gnome-vfs-%{version} -a 4
cp -f %{SOURCE2} modules
cp -f %{SOURCE3} modules
(cd modules && cp default-modules.conf default-modules.conf.with-menu-editing)
%setup -q -n gnome-vfs-%{version}
## clean out the methods that don't work with our setup
DMC=modules/default-modules.conf.with-menu-editing
perl -pi -e 's/all-applications:\s+libvfolder-desktop.so//g' $DMC
perl -pi -e 's/all-preferences:\s+libvfolder-desktop.so//g' $DMC
perl -pi -e 's/favorites:\s+libvfolder-desktop.so//g' $DMC
cp -f %{SOURCE1} modules
## these two should actually work
## perl -pi -e 's/applications-all-users:\s+libvfolder-desktop.so//g' $DMC
## perl -pi -e 's/preferences-all-users:\s+libvfolder-desktop.so//g' $DMC
%patch1 -p1 -b .moved-menu-files
%patch2 -p1 -b .only-show-in
%patch3 -p1 -b .modules-conf
%patch4 -p1 -b .newstat
%patch5 -p1 -b .read-only
%patch6 -p1 -b .old-modules
%patch7 -p1 -b .never-show-if-empty
%patch8 -p1 -b .hide-with-empty-subfolders
%patch9 -p1 -b .no-private-methods
%patch10 -p1 -b .vfolder-hacks
# desktop-file-utils patches
%patch50 -p0 -b .embedded
%patch51 -p0 -b .pleasecreate
# send to upstream
%patch101 -p1 -b .schema_about
%patch102 -p0 -b .buffer-fix
%patch103 -p0 -b .mtab_mtime_check
%patch104 -p1 -b .browser_default
%patch200 -p0 -b .hal
%patch201 -p0 -b .console
%build
# needed for patch10 (changing makefile to old vfolder backend)
# needed for patch6 (changing makefile to old vfolder backend)
aclocal-1.6
automake-1.6
if pkg-config openssl ; then
@ -164,14 +115,6 @@ autoconf
export tagname=CC
make LIBTOOL=/usr/bin/libtool
(cd desktop-file-utils-0.8;
aclocal-1.6;
automake-1.6;
autoconf;
%configure;
make LIBTOOL=/usr/bin/libtool
)
%install
rm -fr %{buildroot}
@ -180,10 +123,6 @@ export tagname=CC
make install DESTDIR=$RPM_BUILD_ROOT LIBTOOL=/usr/bin/libtool
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
(cd desktop-file-utils-0.8;
cp src/.libs/libmenu.so $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/
)
rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/lib*.a
rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/lib*.la
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
@ -194,12 +133,6 @@ rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libvfolder-deskto*.so
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gnome-vfs-2.0/vfolders/*.vfolder-info
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gnome-vfs-2.0/vfolders/*.vfolder-info-default
install -m 644 modules/default-modules.conf.with-menu-editing $RPM_BUILD_ROOT%{_sysconfdir}/gnome-vfs-2.0/modules/
## Remove this line and update file list to revert to
## no-menu-editing-by-default
# (cd $RPM_BUILD_ROOT%{_sysconfdir}/gnome-vfs-2.0/modules/; mv default-modules.conf default-modules.conf.without-menu-editing; mv default-modules.conf.with-menu-editing default-modules.conf)
rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.2.0/filesystems/*.{a,la}
rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/monikers/*.{a,la}
@ -229,7 +162,6 @@ done
#%dir %{_sysconfdir}/gnome-vfs-2.0/vfolders
%config %{_sysconfdir}/gnome-vfs-2.0/modules/*.conf
%exclude %{_sysconfdir}/gnome-vfs-2.0/modules/smb-module.conf
%config %{_sysconfdir}/gnome-vfs-2.0/modules/*.conf.with-menu-editing
## we aren't really using the .vfolder-info config files,
## so installing them is a little misleading.
## %config %{_sysconfdir}/gnome-vfs-2.0/vfolders/*.vfolder-info

@ -1,2 +1 @@
b0dc11041949eecb877f755105f6b036 desktop-file-utils-0.8.tar.gz
d2bd8d9a5fb7ddad68c5e878ba269a5c gnome-vfs-2.8.2.tar.bz2
e641450b1de51f861885ecfabdc1373f gnome-vfs-2.9.90.tar.bz2

Loading…
Cancel
Save