Changes similar to those in glm-0.9.6.1-bigendian.patch and glm-0.9.6.3-nom64.patch had appeared in upstream sources, so these patches were dropped. GLM has started shipping cmake config files, so these are now provided by glm-devel.f41
parent
0e2d5602ac
commit
f986b914d7
@ -1,29 +0,0 @@
|
||||
diff -up glm/glm/detail/func_integer.inl.befix glm/glm/detail/func_integer.inl
|
||||
--- glm/glm/detail/func_integer.inl.befix 2015-01-28 08:44:30.468627717 +0100
|
||||
+++ glm/glm/detail/func_integer.inl 2015-01-28 08:46:19.990024091 +0100
|
||||
@@ -248,10 +248,8 @@ namespace detail
|
||||
GLM_STATIC_ASSERT(sizeof(uint) == sizeof(uint32), "uint and uint32 size mismatch");
|
||||
|
||||
uint64 Value64 = static_cast<uint64>(x) * static_cast<uint64>(y);
|
||||
- uint32* PointerMSB = (reinterpret_cast<uint32*>(&Value64) + 1);
|
||||
- msb = *PointerMSB;
|
||||
- uint32* PointerLSB = (reinterpret_cast<uint32*>(&Value64) + 0);
|
||||
- lsb = *PointerLSB;
|
||||
+ msb = Value64 >> 32;
|
||||
+ lsb = Value64;
|
||||
}
|
||||
|
||||
template <precision P, template <typename, precision> class vecType>
|
||||
@@ -270,10 +268,8 @@ namespace detail
|
||||
GLM_STATIC_ASSERT(sizeof(int) == sizeof(int32), "int and int32 size mismatch");
|
||||
|
||||
int64 Value64 = static_cast<int64>(x) * static_cast<int64>(y);
|
||||
- int32* PointerMSB = (reinterpret_cast<int32*>(&Value64) + 1);
|
||||
- msb = *PointerMSB;
|
||||
- int32* PointerLSB = (reinterpret_cast<int32*>(&Value64));
|
||||
- lsb = *PointerLSB;
|
||||
+ msb = Value64 >> 32;
|
||||
+ lsb = Value64;
|
||||
}
|
||||
|
||||
template <precision P, template <typename, precision> class vecType>
|
@ -1,12 +0,0 @@
|
||||
diff -ru glm/CMakeLists.txt glm-nom64/CMakeLists.txt
|
||||
--- glm/CMakeLists.txt 2015-02-14 00:51:30.000000000 +0200
|
||||
+++ glm-nom64/CMakeLists.txt 2015-04-25 10:14:57.585689646 +0300
|
||||
@@ -129,7 +129,7 @@
|
||||
if(CMAKE_COMPILER_IS_GNUCXX)
|
||||
#add_definitions(-S)
|
||||
#add_definitions(-s)
|
||||
- add_definitions(-m64)
|
||||
+ #add_definitions(-m64)
|
||||
add_definitions(-O2)
|
||||
|
||||
#add_definitions(-fprofile-arcs -ftest-coverage) gcov
|
Loading…
Reference in new issue