Update to glm-0.9.7.0

Changes similar to those in
glm-0.9.6.1-bigendian.patch and glm-0.9.6.3-nom64.patch
had appeared in upstream sources, so these patches were
dropped.

GLM has started shipping cmake config files, so these
are now provided by glm-devel.
f41
Joonas Sarajärvi 10 years ago
parent 0e2d5602ac
commit f986b914d7

1
.gitignore vendored

@ -8,3 +8,4 @@
/glm-0.9.5.2.zip
/glm-0.9.6.1.zip
/glm-0.9.6.3.zip
/glm-0.9.7.0.zip

@ -1,29 +0,0 @@
diff -up glm/glm/detail/func_integer.inl.befix glm/glm/detail/func_integer.inl
--- glm/glm/detail/func_integer.inl.befix 2015-01-28 08:44:30.468627717 +0100
+++ glm/glm/detail/func_integer.inl 2015-01-28 08:46:19.990024091 +0100
@@ -248,10 +248,8 @@ namespace detail
GLM_STATIC_ASSERT(sizeof(uint) == sizeof(uint32), "uint and uint32 size mismatch");
uint64 Value64 = static_cast<uint64>(x) * static_cast<uint64>(y);
- uint32* PointerMSB = (reinterpret_cast<uint32*>(&Value64) + 1);
- msb = *PointerMSB;
- uint32* PointerLSB = (reinterpret_cast<uint32*>(&Value64) + 0);
- lsb = *PointerLSB;
+ msb = Value64 >> 32;
+ lsb = Value64;
}
template <precision P, template <typename, precision> class vecType>
@@ -270,10 +268,8 @@ namespace detail
GLM_STATIC_ASSERT(sizeof(int) == sizeof(int32), "int and int32 size mismatch");
int64 Value64 = static_cast<int64>(x) * static_cast<int64>(y);
- int32* PointerMSB = (reinterpret_cast<int32*>(&Value64) + 1);
- msb = *PointerMSB;
- int32* PointerLSB = (reinterpret_cast<int32*>(&Value64));
- lsb = *PointerLSB;
+ msb = Value64 >> 32;
+ lsb = Value64;
}
template <precision P, template <typename, precision> class vecType>

@ -1,12 +0,0 @@
diff -ru glm/CMakeLists.txt glm-nom64/CMakeLists.txt
--- glm/CMakeLists.txt 2015-02-14 00:51:30.000000000 +0200
+++ glm-nom64/CMakeLists.txt 2015-04-25 10:14:57.585689646 +0300
@@ -129,7 +129,7 @@
if(CMAKE_COMPILER_IS_GNUCXX)
#add_definitions(-S)
#add_definitions(-s)
- add_definitions(-m64)
+ #add_definitions(-m64)
add_definitions(-O2)
#add_definitions(-fprofile-arcs -ftest-coverage) gcov

@ -2,18 +2,15 @@
%global debug_package %{nil}
Name: glm
Version: 0.9.6.3
Release: 2%{?dist}
Version: 0.9.7.0
Release: 1%{?dist}
Summary: C++ mathematics library for graphics programming
License: MIT
URL: http://glm.g-truc.net/
Source0: http://downloads.sourceforge.net/ogl-math/%{name}-%{version}/%{name}-%{version}.zip
Source0: https://github.com/g-truc/glm/releases/download/%{version}/%{name}-%{version}.zip
Patch0: glm-0.9.5.2-smallercount.patch
Patch1: glm-0.9.6.1-ulp.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1185298
Patch2: glm-0.9.6.1-bigendian.patch
Patch3: glm-0.9.6.3-nom64.patch
BuildRequires: cmake
@ -73,7 +70,7 @@ a programming manual for the %{name}-devel package.
# This release of glm seems to have shipped with no CRLF file
# endings at all, so these are commented out.
sed -i 's/\r//' copying.txt
sed -i 's/\r//' readme.txt
sed -i 's/\r//' readme.md
sed -i 's/\r//' doc/api/doxygen.css
sed -i 's/\r//' doc/api/dynsections.js
sed -i 's/\r//' doc/api/jquery.js
@ -82,8 +79,6 @@ sed -i 's/\r//' doc/api/tabs.css
%patch0 -p1 -b .smallercount
%patch1 -p1 -b .ulp
%patch2 -p1 -b .bigendian
%patch3 -p1 -b .nom64
%build
mkdir build
@ -106,14 +101,17 @@ make install DESTDIR=$RPM_BUILD_ROOT
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
find $RPM_BUILD_ROOT -name CMakeLists.txt -exec rm -f {} ';'
# This is not packaged until there is consensus that
# packages should install FindSomething.cmake files.
# https://bugzilla.redhat.com/show_bug.cgi?id=1022088
rm $RPM_BUILD_ROOT%{_libdir}/cmake/FindGLM.cmake
# The cmake config files seem architecture independent and since
# also glm-devel is otherwise noarch, it is desired to ship the
# cmake configuration files under /usr/share.
mkdir -pv $RPM_BUILD_ROOT%{_datadir}
mv $RPM_BUILD_ROOT%{_libdir}/cmake $RPM_BUILD_ROOT%{_datadir}/cmake
%files devel
%doc copying.txt readme.txt
%doc copying.txt readme.md
%{_includedir}/%{name}
%{_datadir}/cmake
%{_datadir}/cmake/%{name}
%files doc
%doc copying.txt
@ -121,6 +119,10 @@ rm $RPM_BUILD_ROOT%{_libdir}/cmake/FindGLM.cmake
%doc doc/api/
%changelog
* Wed Aug 05 2015 Joonas Sarajärvi <muep@iki.fi> - 0.9.7.0-1
- Update to upstream GLM version 0.9.7.0
- CMake config files are added
* Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6.3-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild

@ -1 +1 @@
acd0b517c37ed25c3f11ee155ee8257e glm-0.9.6.3.zip
34c3eb7e99e1ae68a7d42bd401bf38bb glm-0.9.7.0.zip

Loading…
Cancel
Save