You can not select more than 25 topics
Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
260 lines
8.1 KiB
260 lines
8.1 KiB
From 97700a34f36721b11a754cf37a1cc40695ece1fd Mon Sep 17 00:00:00 2001
|
|
From: "H.J. Lu" <hjl.tools@gmail.com>
|
|
Date: Mon, 21 Jan 2019 11:23:59 -0800
|
|
Subject: [PATCH] x86-64 memchr/wmemchr: Properly handle the length parameter
|
|
[BZ# 24097]
|
|
Content-type: text/plain; charset=UTF-8
|
|
|
|
On x32, the size_t parameter may be passed in the lower 32 bits of a
|
|
64-bit register with the non-zero upper 32 bits. The string/memory
|
|
functions written in assembly can only use the lower 32 bits of a
|
|
64-bit register as length or must clear the upper 32 bits before using
|
|
the full 64-bit register for length.
|
|
|
|
This pach fixes memchr/wmemchr for x32. Tested on x86-64 and x32. On
|
|
x86-64, libc.so is the same with and withou the fix.
|
|
|
|
[BZ# 24097]
|
|
CVE-2019-6488
|
|
* sysdeps/x86_64/memchr.S: Use RDX_LP for length. Clear the
|
|
upper 32 bits of RDX register.
|
|
* sysdeps/x86_64/multiarch/memchr-avx2.S: Likewise.
|
|
* sysdeps/x86_64/x32/Makefile (tests): Add tst-size_t-memchr and
|
|
tst-size_t-wmemchr.
|
|
* sysdeps/x86_64/x32/test-size_t.h: New file.
|
|
* sysdeps/x86_64/x32/tst-size_t-memchr.c: Likewise.
|
|
* sysdeps/x86_64/x32/tst-size_t-wmemchr.c: Likewise.
|
|
---
|
|
sysdeps/x86_64/memchr.S | 10 ++--
|
|
sysdeps/x86_64/multiarch/memchr-avx2.S | 8 ++-
|
|
sysdeps/x86_64/x32/Makefile | 8 +++
|
|
sysdeps/x86_64/x32/test-size_t.h | 35 ++++++++++++
|
|
sysdeps/x86_64/x32/tst-size_t-memchr.c | 72 +++++++++++++++++++++++++
|
|
sysdeps/x86_64/x32/tst-size_t-wmemchr.c | 20 +++++++
|
|
6 files changed, 148 insertions(+), 5 deletions(-)
|
|
create mode 100644 sysdeps/x86_64/x32/test-size_t.h
|
|
create mode 100644 sysdeps/x86_64/x32/tst-size_t-memchr.c
|
|
create mode 100644 sysdeps/x86_64/x32/tst-size_t-wmemchr.c
|
|
|
|
Conflicts:
|
|
ChangeLog
|
|
(removed)
|
|
NEWS
|
|
(removed)
|
|
|
|
diff --git a/sysdeps/x86_64/memchr.S b/sysdeps/x86_64/memchr.S
|
|
index feef5d4f..cb320257 100644
|
|
--- a/sysdeps/x86_64/memchr.S
|
|
+++ b/sysdeps/x86_64/memchr.S
|
|
@@ -34,12 +34,16 @@ ENTRY(MEMCHR)
|
|
mov %edi, %ecx
|
|
|
|
#ifdef USE_AS_WMEMCHR
|
|
- test %rdx, %rdx
|
|
+ test %RDX_LP, %RDX_LP
|
|
jz L(return_null)
|
|
- shl $2, %rdx
|
|
+ shl $2, %RDX_LP
|
|
#else
|
|
+# ifdef __ILP32__
|
|
+ /* Clear the upper 32 bits. */
|
|
+ movl %edx, %edx
|
|
+# endif
|
|
punpcklbw %xmm1, %xmm1
|
|
- test %rdx, %rdx
|
|
+ test %RDX_LP, %RDX_LP
|
|
jz L(return_null)
|
|
punpcklbw %xmm1, %xmm1
|
|
#endif
|
|
diff --git a/sysdeps/x86_64/multiarch/memchr-avx2.S b/sysdeps/x86_64/multiarch/memchr-avx2.S
|
|
index 5f5e7725..c81da19b 100644
|
|
--- a/sysdeps/x86_64/multiarch/memchr-avx2.S
|
|
+++ b/sysdeps/x86_64/multiarch/memchr-avx2.S
|
|
@@ -40,16 +40,20 @@
|
|
ENTRY (MEMCHR)
|
|
# ifndef USE_AS_RAWMEMCHR
|
|
/* Check for zero length. */
|
|
- testq %rdx, %rdx
|
|
+ test %RDX_LP, %RDX_LP
|
|
jz L(null)
|
|
# endif
|
|
movl %edi, %ecx
|
|
/* Broadcast CHAR to YMM0. */
|
|
vmovd %esi, %xmm0
|
|
# ifdef USE_AS_WMEMCHR
|
|
- shl $2, %rdx
|
|
+ shl $2, %RDX_LP
|
|
vpbroadcastd %xmm0, %ymm0
|
|
# else
|
|
+# ifdef __ILP32__
|
|
+ /* Clear the upper 32 bits. */
|
|
+ movl %edx, %edx
|
|
+# endif
|
|
vpbroadcastb %xmm0, %ymm0
|
|
# endif
|
|
/* Check if we may cross page boundary with one vector load. */
|
|
diff --git a/sysdeps/x86_64/x32/Makefile b/sysdeps/x86_64/x32/Makefile
|
|
index f2ebc24f..7d528889 100644
|
|
--- a/sysdeps/x86_64/x32/Makefile
|
|
+++ b/sysdeps/x86_64/x32/Makefile
|
|
@@ -4,3 +4,11 @@ ifeq ($(subdir),math)
|
|
# 64-bit llround. Add -fno-builtin-lround to silence the compiler.
|
|
CFLAGS-s_llround.c += -fno-builtin-lround
|
|
endif
|
|
+
|
|
+ifeq ($(subdir),string)
|
|
+tests += tst-size_t-memchr
|
|
+endif
|
|
+
|
|
+ifeq ($(subdir),wcsmbs)
|
|
+tests += tst-size_t-wmemchr
|
|
+endif
|
|
diff --git a/sysdeps/x86_64/x32/test-size_t.h b/sysdeps/x86_64/x32/test-size_t.h
|
|
new file mode 100644
|
|
index 00000000..78a94086
|
|
--- /dev/null
|
|
+++ b/sysdeps/x86_64/x32/test-size_t.h
|
|
@@ -0,0 +1,35 @@
|
|
+/* Test string/memory functions with size_t in the lower 32 bits of
|
|
+ 64-bit register.
|
|
+ Copyright (C) 2019 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <http://www.gnu.org/licenses/>. */
|
|
+
|
|
+#define TEST_MAIN
|
|
+#include <string/test-string.h>
|
|
+
|
|
+/* On x32, parameter_t may be passed in a 64-bit register with the LEN
|
|
+ field in the lower 32 bits. When the LEN field of 64-bit register
|
|
+ is passed to string/memory function as the size_t parameter, only
|
|
+ the lower 32 bits can be used. */
|
|
+typedef struct
|
|
+{
|
|
+ union
|
|
+ {
|
|
+ size_t len;
|
|
+ void (*fn) (void);
|
|
+ };
|
|
+ void *p;
|
|
+} parameter_t;
|
|
diff --git a/sysdeps/x86_64/x32/tst-size_t-memchr.c b/sysdeps/x86_64/x32/tst-size_t-memchr.c
|
|
new file mode 100644
|
|
index 00000000..29a3daf1
|
|
--- /dev/null
|
|
+++ b/sysdeps/x86_64/x32/tst-size_t-memchr.c
|
|
@@ -0,0 +1,72 @@
|
|
+/* Test memchr with size_t in the lower 32 bits of 64-bit register.
|
|
+ Copyright (C) 2019 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <http://www.gnu.org/licenses/>. */
|
|
+
|
|
+#ifndef WIDE
|
|
+# define TEST_NAME "memchr"
|
|
+#else
|
|
+# define TEST_NAME "wmemchr"
|
|
+#endif /* WIDE */
|
|
+#include "test-size_t.h"
|
|
+
|
|
+#ifndef WIDE
|
|
+# define MEMCHR memchr
|
|
+# define CHAR char
|
|
+# define UCHAR unsigned char
|
|
+#else
|
|
+# include <wchar.h>
|
|
+# define MEMCHR wmemchr
|
|
+# define CHAR wchar_t
|
|
+# define UCHAR wchar_t
|
|
+#endif /* WIDE */
|
|
+
|
|
+IMPL (MEMCHR, 1)
|
|
+
|
|
+typedef CHAR * (*proto_t) (const CHAR*, int, size_t);
|
|
+
|
|
+static CHAR *
|
|
+__attribute__ ((noinline, noclone))
|
|
+do_memchr (parameter_t a, parameter_t b)
|
|
+{
|
|
+ return CALL (&b, a.p, (uintptr_t) b.p, a.len);
|
|
+}
|
|
+
|
|
+static int
|
|
+test_main (void)
|
|
+{
|
|
+ test_init ();
|
|
+
|
|
+ parameter_t src = { { page_size / sizeof (CHAR) }, buf2 };
|
|
+ parameter_t c = { { 0 }, (void *) (uintptr_t) 0x12 };
|
|
+
|
|
+ int ret = 0;
|
|
+ FOR_EACH_IMPL (impl, 0)
|
|
+ {
|
|
+ c.fn = impl->fn;
|
|
+ CHAR *res = do_memchr (src, c);
|
|
+ if (res)
|
|
+ {
|
|
+ error (0, 0, "Wrong result in function %s: %p != NULL",
|
|
+ impl->name, res);
|
|
+ ret = 1;
|
|
+ }
|
|
+ }
|
|
+
|
|
+ return ret ? EXIT_FAILURE : EXIT_SUCCESS;
|
|
+}
|
|
+
|
|
+#include <support/test-driver.c>
|
|
diff --git a/sysdeps/x86_64/x32/tst-size_t-wmemchr.c b/sysdeps/x86_64/x32/tst-size_t-wmemchr.c
|
|
new file mode 100644
|
|
index 00000000..877801d6
|
|
--- /dev/null
|
|
+++ b/sysdeps/x86_64/x32/tst-size_t-wmemchr.c
|
|
@@ -0,0 +1,20 @@
|
|
+/* Test wmemchr with size_t in the lower 32 bits of 64-bit register.
|
|
+ Copyright (C) 2019 Free Software Foundation, Inc.
|
|
+ This file is part of the GNU C Library.
|
|
+
|
|
+ The GNU C Library is free software; you can redistribute it and/or
|
|
+ modify it under the terms of the GNU Lesser General Public
|
|
+ License as published by the Free Software Foundation; either
|
|
+ version 2.1 of the License, or (at your option) any later version.
|
|
+
|
|
+ The GNU C Library is distributed in the hope that it will be useful,
|
|
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
|
|
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
|
|
+ Lesser General Public License for more details.
|
|
+
|
|
+ You should have received a copy of the GNU Lesser General Public
|
|
+ License along with the GNU C Library; if not, see
|
|
+ <http://www.gnu.org/licenses/>. */
|
|
+
|
|
+#define WIDE 1
|
|
+#include "tst-size_t-memchr.c"
|
|
--
|
|
GitLab
|
|
|