parent
55b1dd9733
commit
0dad7e2116
@ -1 +1 @@
|
||||
SOURCES/glew-2.0.0.tgz
|
||||
SOURCES/glew-2.2.0.tgz
|
||||
|
@ -1 +1 @@
|
||||
6e15c84f7e1fad34cd3679f784a233744ddf048f SOURCES/glew-2.0.0.tgz
|
||||
22d6e9b9e691080eb6313407dbf51cfebc3345ea SOURCES/glew-2.2.0.tgz
|
||||
|
@ -0,0 +1,19 @@
|
||||
diff -up glew-2.1.0/Makefile.install glew-2.1.0/Makefile
|
||||
--- glew-2.1.0/Makefile.install 2018-08-15 13:51:45.220637107 +0200
|
||||
+++ glew-2.1.0/Makefile 2018-08-15 13:52:02.168740876 +0200
|
||||
@@ -231,6 +231,7 @@ install.bin: glew.bin
|
||||
|
||||
install.include:
|
||||
$(INSTALL) -d -m 0755 "$(DESTDIR)$(INCDIR)"
|
||||
+ $(INSTALL) -m 0644 include/GL/eglew.h "$(DESTDIR)$(INCDIR)/"
|
||||
$(INSTALL) -m 0644 include/GL/wglew.h "$(DESTDIR)$(INCDIR)/"
|
||||
$(INSTALL) -m 0644 include/GL/glew.h "$(DESTDIR)$(INCDIR)/"
|
||||
$(INSTALL) -m 0644 include/GL/glxew.h "$(DESTDIR)$(INCDIR)/"
|
||||
@@ -241,6 +242,7 @@ install.pkgconfig: glew.pc
|
||||
$(INSTALL) -m 0644 glew.pc "$(DESTDIR)$(PKGDIR)/"
|
||||
|
||||
uninstall:
|
||||
+ $(RM) "$(DESTDIR)$(INCDIR)/eglew.h"
|
||||
$(RM) "$(DESTDIR)$(INCDIR)/wglew.h"
|
||||
$(RM) "$(DESTDIR)$(INCDIR)/glew.h"
|
||||
$(RM) "$(DESTDIR)$(INCDIR)/glxew.h"
|
@ -0,0 +1,13 @@
|
||||
diff -up glew-2.2.0/include/GL/glew.h~ glew-2.2.0/include/GL/glew.h
|
||||
--- glew-2.2.0/include/GL/glew.h~ 2020-03-15 12:53:59.000000000 +0100
|
||||
+++ glew-2.2.0/include/GL/glew.h 2022-02-22 23:17:58.889834158 +0100
|
||||
@@ -220,7 +220,8 @@ typedef _W64 int ptrdiff_t;
|
||||
*/
|
||||
|
||||
#if defined(__APPLE__) || defined(__linux__)
|
||||
-# if defined(__cplusplus)
|
||||
+/* GCC12 errors out when including <cstdint> with __cplusplus < 201103L */
|
||||
+# if defined(__cplusplus) && __cplusplus >= 201103L
|
||||
# include <cstddef>
|
||||
# include <cstdint>
|
||||
# else
|
Loading…
Reference in new issue