commit
67980272c1
@ -0,0 +1,2 @@
|
||||
3a35d0571c517f7f4cb2e1dfbd315e7c32023e2b SOURCES/git-2.39.1.tar.xz
|
||||
87d3a395bad523277647f8614fbd9fefe0450fc6 SOURCES/gpgkey-junio.asc
|
@ -0,0 +1,2 @@
|
||||
SOURCES/git-2.39.1.tar.xz
|
||||
SOURCES/gpgkey-junio.asc
|
@ -0,0 +1,73 @@
|
||||
From aedeaaf788bd8a7fc5a1887196b6f6d8a5c31362 Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Sun, 21 Aug 2022 13:49:57 -0400
|
||||
Subject: [PATCH] t/lib-httpd: try harder to find a port for apache
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
When running multiple builds concurrently, tests which run daemons, like
|
||||
apache httpd, sometimes conflict with each other, leading to spurious
|
||||
failures:
|
||||
|
||||
++ /usr/sbin/httpd -d '/tmp/git-t.ck9I/trash directory.t9118-git-svn-funky-branch-names/httpd' \
|
||||
-f /builddir/build/BUILD/git-2.37.2/t/lib-httpd/apache.conf -DDAV -DSVN -c 'Listen 127.0.0.1:9118' \
|
||||
-k start
|
||||
(98)Address already in use: AH00072: make_sock: could not bind to address 127.0.0.1:9118
|
||||
no listening sockets available, shutting down
|
||||
AH00015: Unable to open logs
|
||||
++ test 1 -ne 0
|
||||
|
||||
Try a bit harder to find an open port to use to avoid these intermittent
|
||||
failures. If we fail to start httpd, increment the port number and try
|
||||
again. By default, we make 3 attempts. This may be overridden by
|
||||
setting GIT_TEST_START_HTTPD_TRIES to a different value.
|
||||
|
||||
Helped-by: Ondřej Pohořelský <opohorel@redhat.com>
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
t/lib-httpd.sh | 29 ++++++++++++++++++-----------
|
||||
1 file changed, 18 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/t/lib-httpd.sh b/t/lib-httpd.sh
|
||||
index 1f6b9b08d1..9279dcd659 100644
|
||||
--- a/t/lib-httpd.sh
|
||||
+++ b/t/lib-httpd.sh
|
||||
@@ -175,19 +175,26 @@ prepare_httpd() {
|
||||
}
|
||||
|
||||
start_httpd() {
|
||||
- prepare_httpd >&3 2>&4
|
||||
-
|
||||
test_atexit stop_httpd
|
||||
|
||||
- "$LIB_HTTPD_PATH" -d "$HTTPD_ROOT_PATH" \
|
||||
- -f "$TEST_PATH/apache.conf" $HTTPD_PARA \
|
||||
- -c "Listen 127.0.0.1:$LIB_HTTPD_PORT" -k start \
|
||||
- >&3 2>&4
|
||||
- if test $? -ne 0
|
||||
- then
|
||||
- cat "$HTTPD_ROOT_PATH"/error.log >&4 2>/dev/null
|
||||
- test_skip_or_die GIT_TEST_HTTPD "web server setup failed"
|
||||
- fi
|
||||
+ i=0
|
||||
+ while test $i -lt ${GIT_TEST_START_HTTPD_TRIES:-3}
|
||||
+ do
|
||||
+ i=$(($i + 1))
|
||||
+ prepare_httpd >&3 2>&4
|
||||
+ say >&3 "Starting httpd on port $LIB_HTTPD_PORT"
|
||||
+ "$LIB_HTTPD_PATH" -d "$HTTPD_ROOT_PATH" \
|
||||
+ -f "$TEST_PATH/apache.conf" $HTTPD_PARA \
|
||||
+ -c "Listen 127.0.0.1:$LIB_HTTPD_PORT" -k start \
|
||||
+ >&3 2>&4
|
||||
+ test $? -eq 0 && return
|
||||
+ LIB_HTTPD_PORT=$(($LIB_HTTPD_PORT + 1))
|
||||
+ export LIB_HTTPD_PORT
|
||||
+ # clean up modules symlink, prepare_httpd will re-create it
|
||||
+ rm -f "$HTTPD_ROOT_PATH/modules"
|
||||
+ done
|
||||
+ cat "$HTTPD_ROOT_PATH"/error.log >&4 2>/dev/null
|
||||
+ test_skip_or_die GIT_TEST_HTTPD "web server setup failed"
|
||||
}
|
||||
|
||||
stop_httpd() {
|
@ -0,0 +1,88 @@
|
||||
From 16750d024ce038b019ab2e9ee5639901e445af37 Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Fri, 26 Aug 2022 18:28:44 -0400
|
||||
Subject: [PATCH] t/lib-git-daemon: try harder to find a port
|
||||
|
||||
As with the previous commit, try harder to find an open port to avoid
|
||||
intermittent failures on busy/shared build systems.
|
||||
|
||||
By default, we make 3 attempts. This may be overridden by setting
|
||||
GIT_TEST_START_GIT_DAEMON_TRIES to a different value.
|
||||
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
t/lib-git-daemon.sh | 60 ++++++++++++++++++++++++++++-----------------
|
||||
1 file changed, 37 insertions(+), 23 deletions(-)
|
||||
|
||||
diff --git a/t/lib-git-daemon.sh b/t/lib-git-daemon.sh
|
||||
index e62569222b..c3e8dda9ff 100644
|
||||
--- a/t/lib-git-daemon.sh
|
||||
+++ b/t/lib-git-daemon.sh
|
||||
@@ -51,30 +51,44 @@ start_git_daemon() {
|
||||
registered_stop_git_daemon_atexit_handler=AlreadyDone
|
||||
fi
|
||||
|
||||
- say >&3 "Starting git daemon ..."
|
||||
- mkfifo git_daemon_output
|
||||
- ${LIB_GIT_DAEMON_COMMAND:-git daemon} \
|
||||
- --listen=127.0.0.1 --port="$LIB_GIT_DAEMON_PORT" \
|
||||
- --reuseaddr --verbose --pid-file="$GIT_DAEMON_PIDFILE" \
|
||||
- --base-path="$GIT_DAEMON_DOCUMENT_ROOT_PATH" \
|
||||
- "$@" "$GIT_DAEMON_DOCUMENT_ROOT_PATH" \
|
||||
- >&3 2>git_daemon_output &
|
||||
- GIT_DAEMON_PID=$!
|
||||
- {
|
||||
- read -r line <&7
|
||||
- printf "%s\n" "$line" >&4
|
||||
- cat <&7 >&4 &
|
||||
- } 7<git_daemon_output &&
|
||||
+ i=0
|
||||
+ while test $i -lt ${GIT_TEST_START_GIT_DAEMON_TRIES:-3}
|
||||
+ do
|
||||
+ say >&3 "Starting git daemon on port $LIB_GIT_DAEMON_PORT ..."
|
||||
+ mkfifo git_daemon_output
|
||||
+ ${LIB_GIT_DAEMON_COMMAND:-git daemon} \
|
||||
+ --listen=127.0.0.1 --port="$LIB_GIT_DAEMON_PORT" \
|
||||
+ --reuseaddr --verbose --pid-file="$GIT_DAEMON_PIDFILE" \
|
||||
+ --base-path="$GIT_DAEMON_DOCUMENT_ROOT_PATH" \
|
||||
+ "$@" "$GIT_DAEMON_DOCUMENT_ROOT_PATH" \
|
||||
+ >&3 2>git_daemon_output &
|
||||
+ GIT_DAEMON_PID=$!
|
||||
+ {
|
||||
+ read -r line <&7
|
||||
+ printf "%s\n" "$line" >&4
|
||||
+ cat <&7 >&4 &
|
||||
+ } 7<git_daemon_output &&
|
||||
|
||||
- # Check expected output
|
||||
- if test x"$(expr "$line" : "\[[0-9]*\] \(.*\)")" != x"Ready to rumble"
|
||||
- then
|
||||
- kill "$GIT_DAEMON_PID"
|
||||
- wait "$GIT_DAEMON_PID"
|
||||
- unset GIT_DAEMON_PID
|
||||
- test_skip_or_die GIT_TEST_GIT_DAEMON \
|
||||
- "git daemon failed to start"
|
||||
- fi
|
||||
+ # Check expected output
|
||||
+ output="$(expr "$line" : "\[[0-9]*\] \(.*\)")"
|
||||
+ # Return if found
|
||||
+ test x"$output" = x"Ready to rumble" && return
|
||||
+ # Increment port for retry if not found
|
||||
+ LIB_GIT_DAEMON_PORT=$(($LIB_GIT_DAEMON_PORT + 1))
|
||||
+ export LIB_GIT_DAEMON_PORT
|
||||
+ GIT_DAEMON_HOST_PORT=127.0.0.1:$LIB_GIT_DAEMON_PORT
|
||||
+ GIT_DAEMON_URL=git://$GIT_DAEMON_HOST_PORT
|
||||
+ # unset GIT_DAEMON_PID; remove the fifo & pid file
|
||||
+ GIT_DAEMON_PID=
|
||||
+ rm -f git_daemon_output "$GIT_DAEMON_PIDFILE"
|
||||
+ done
|
||||
+
|
||||
+ # Clean up and return failure
|
||||
+ kill "$GIT_DAEMON_PID"
|
||||
+ wait "$GIT_DAEMON_PID"
|
||||
+ unset GIT_DAEMON_PID
|
||||
+ test_skip_or_die GIT_TEST_GIT_DAEMON \
|
||||
+ "git daemon failed to start"
|
||||
}
|
||||
|
||||
stop_git_daemon() {
|
@ -0,0 +1,85 @@
|
||||
From aa5105dc115b43edc6c9c11714b092583f1221aa Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Fri, 26 Aug 2022 18:28:44 -0400
|
||||
Subject: [PATCH] t/lib-git-svn: try harder to find a port
|
||||
|
||||
As with the previous commits, try harder to find an open port to avoid
|
||||
intermittent failures on busy/shared build systems.
|
||||
|
||||
By default, we make 3 attempts. This may be overridden by setting
|
||||
GIT_TEST_START_SVNSERVE_TRIES to a different value.
|
||||
|
||||
Run svnserve in daemon mode and use 'test_atexit' to stop it. This is
|
||||
cleaner than running in the foreground with --listen-once and having to
|
||||
manage the PID ourselves.
|
||||
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
t/lib-git-svn.sh | 34 +++++++++++++++++++++++++----
|
||||
t/t9113-git-svn-dcommit-new-file.sh | 1 -
|
||||
2 files changed, 30 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/t/lib-git-svn.sh b/t/lib-git-svn.sh
|
||||
index ea28971e8e..04e660e2ba 100644
|
||||
--- a/t/lib-git-svn.sh
|
||||
+++ b/t/lib-git-svn.sh
|
||||
@@ -17,6 +17,7 @@ fi
|
||||
GIT_DIR=$PWD/.git
|
||||
GIT_SVN_DIR=$GIT_DIR/svn/refs/remotes/git-svn
|
||||
SVN_TREE=$GIT_SVN_DIR/svn-tree
|
||||
+SVNSERVE_PIDFILE="$PWD"/daemon.pid
|
||||
test_set_port SVNSERVE_PORT
|
||||
|
||||
svn >/dev/null 2>&1
|
||||
@@ -119,10 +120,35 @@ require_svnserve () {
|
||||
}
|
||||
|
||||
start_svnserve () {
|
||||
- svnserve --listen-port $SVNSERVE_PORT \
|
||||
- --root "$rawsvnrepo" \
|
||||
- --listen-once \
|
||||
- --listen-host 127.0.0.1 &
|
||||
+ test_atexit stop_svnserve
|
||||
+
|
||||
+ i=0
|
||||
+ while test $i -lt ${GIT_TEST_START_SVNSERVE_TRIES:-3}
|
||||
+ do
|
||||
+ say >&3 "Starting svnserve on port $SVNSERVE_PORT ..."
|
||||
+ svnserve --listen-port $SVNSERVE_PORT \
|
||||
+ --root "$rawsvnrepo" \
|
||||
+ --daemon --pid-file="$SVNSERVE_PIDFILE" \
|
||||
+ --listen-host 127.0.0.1
|
||||
+ ret=$?
|
||||
+ # increment port and retry if unsuccessful
|
||||
+ if test $ret -ne 0
|
||||
+ then
|
||||
+ SVNSERVE_PORT=$(($SVNSERVE_PORT + 1))
|
||||
+ export SVNSERVE_PORT
|
||||
+ else
|
||||
+ break
|
||||
+ fi
|
||||
+ done
|
||||
+}
|
||||
+
|
||||
+stop_svnserve () {
|
||||
+ say >&3 "Stopping svnserve ..."
|
||||
+ SVNSERVE_PID="$(cat "$SVNSERVE_PIDFILE")"
|
||||
+ if test -n "$SVNSERVE_PID"
|
||||
+ then
|
||||
+ kill "$SVNSERVE_PID" 2>/dev/null
|
||||
+ fi
|
||||
}
|
||||
|
||||
prepare_utf8_locale () {
|
||||
diff --git a/t/t9113-git-svn-dcommit-new-file.sh b/t/t9113-git-svn-dcommit-new-file.sh
|
||||
index e8479cec7a..5925891f5d 100755
|
||||
--- a/t/t9113-git-svn-dcommit-new-file.sh
|
||||
+++ b/t/t9113-git-svn-dcommit-new-file.sh
|
||||
@@ -28,7 +28,6 @@ test_expect_success 'create files in new directory with dcommit' "
|
||||
echo hello > git-new-dir/world &&
|
||||
git update-index --add git-new-dir/world &&
|
||||
git commit -m hello &&
|
||||
- start_svnserve &&
|
||||
git svn dcommit
|
||||
"
|
||||
|
@ -0,0 +1,70 @@
|
||||
diff -ur a/builtin/receive-pack.c b/builtin/receive-pack.c
|
||||
--- a/builtin/receive-pack.c 2022-10-07 06:48:26.000000000 +0200
|
||||
+++ b/builtin/receive-pack.c 2022-11-21 16:34:02.417278135 +0100
|
||||
@@ -30,6 +30,8 @@
|
||||
#include "commit-reach.h"
|
||||
#include "worktree.h"
|
||||
#include "shallow.h"
|
||||
+#include <openssl/hmac.h>
|
||||
+#include <openssl/evp.h>
|
||||
|
||||
static const char * const receive_pack_usage[] = {
|
||||
N_("git receive-pack <git-dir>"),
|
||||
@@ -528,43 +530,11 @@
|
||||
return 0;
|
||||
}
|
||||
|
||||
-static void hmac_hash(unsigned char *out,
|
||||
+static inline void hmac_hash(unsigned char *out,
|
||||
const char *key_in, size_t key_len,
|
||||
const char *text, size_t text_len)
|
||||
{
|
||||
- unsigned char key[GIT_MAX_BLKSZ];
|
||||
- unsigned char k_ipad[GIT_MAX_BLKSZ];
|
||||
- unsigned char k_opad[GIT_MAX_BLKSZ];
|
||||
- int i;
|
||||
- git_hash_ctx ctx;
|
||||
-
|
||||
- /* RFC 2104 2. (1) */
|
||||
- memset(key, '\0', GIT_MAX_BLKSZ);
|
||||
- if (the_hash_algo->blksz < key_len) {
|
||||
- the_hash_algo->init_fn(&ctx);
|
||||
- the_hash_algo->update_fn(&ctx, key_in, key_len);
|
||||
- the_hash_algo->final_fn(key, &ctx);
|
||||
- } else {
|
||||
- memcpy(key, key_in, key_len);
|
||||
- }
|
||||
-
|
||||
- /* RFC 2104 2. (2) & (5) */
|
||||
- for (i = 0; i < sizeof(key); i++) {
|
||||
- k_ipad[i] = key[i] ^ 0x36;
|
||||
- k_opad[i] = key[i] ^ 0x5c;
|
||||
- }
|
||||
-
|
||||
- /* RFC 2104 2. (3) & (4) */
|
||||
- the_hash_algo->init_fn(&ctx);
|
||||
- the_hash_algo->update_fn(&ctx, k_ipad, sizeof(k_ipad));
|
||||
- the_hash_algo->update_fn(&ctx, text, text_len);
|
||||
- the_hash_algo->final_fn(out, &ctx);
|
||||
-
|
||||
- /* RFC 2104 2. (6) & (7) */
|
||||
- the_hash_algo->init_fn(&ctx);
|
||||
- the_hash_algo->update_fn(&ctx, k_opad, sizeof(k_opad));
|
||||
- the_hash_algo->update_fn(&ctx, out, the_hash_algo->rawsz);
|
||||
- the_hash_algo->final_fn(out, &ctx);
|
||||
+ HMAC(EVP_sha1(), key_in, key_len, text, text_len, out, NULL);
|
||||
}
|
||||
|
||||
static char *prepare_push_cert_nonce(const char *path, timestamp_t stamp)
|
||||
diff -ur a/Makefile b/Makefile
|
||||
--- a/Makefile 2022-10-07 06:48:26.000000000 +0200
|
||||
+++ b/Makefile 2022-11-21 16:35:56.986792752 +0100
|
||||
@@ -2008,6 +2008,8 @@
|
||||
EXTLIBS += -lcrypto -lssl
|
||||
endif
|
||||
|
||||
+EXTLIBS += -lcrypto
|
||||
+
|
||||
ifneq ($(PROCFS_EXECUTABLE_PATH),)
|
||||
procfs_executable_path_SQ = $(subst ','\'',$(PROCFS_EXECUTABLE_PATH))
|
||||
BASIC_CFLAGS += '-DPROCFS_EXECUTABLE_PATH="$(procfs_executable_path_SQ)"'
|
Binary file not shown.
@ -0,0 +1,26 @@
|
||||
From 09891c65a5f7409ce0bd37daced0ff31fbb1b1c9 Mon Sep 17 00:00:00 2001
|
||||
From: Todd Zullinger <tmz@pobox.com>
|
||||
Date: Mon, 23 Mar 2009 00:03:36 -0400
|
||||
Subject: [PATCH] git-cvsimport: Ignore cvsps-2.2b1 Branches: output
|
||||
|
||||
Signed-off-by: Todd Zullinger <tmz@pobox.com>
|
||||
---
|
||||
git-cvsimport.perl | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/git-cvsimport.perl b/git-cvsimport.perl
|
||||
index e439202..d020f1a 100755
|
||||
--- a/git-cvsimport.perl
|
||||
+++ b/git-cvsimport.perl
|
||||
@@ -952,7 +952,7 @@ while (<CVS>) {
|
||||
} elsif (/^-+$/) { # end of unknown-line processing
|
||||
$state = 1;
|
||||
} elsif ($state != 11) { # ignore stuff when skipping
|
||||
- print STDERR "* UNKNOWN LINE * $_\n";
|
||||
+ print STDERR "* UNKNOWN LINE * $_\n" unless /^Branches: /;
|
||||
}
|
||||
}
|
||||
commit() if $branch and $state != 11;
|
||||
--
|
||||
1.6.2.2
|
||||
|
@ -0,0 +1,9 @@
|
||||
[Desktop Entry]
|
||||
Name=Git GUI
|
||||
GenericName=Git GUI
|
||||
Comment=A graphical interface to Git
|
||||
Exec=git gui
|
||||
Icon=/usr/share/git-gui/lib/git-gui.ico
|
||||
Terminal=false
|
||||
Type=Application
|
||||
Categories=Development;
|
@ -0,0 +1,9 @@
|
||||
[Unit]
|
||||
Description=Git Activation Socket
|
||||
|
||||
[Socket]
|
||||
ListenStream=9418
|
||||
Accept=true
|
||||
|
||||
[Install]
|
||||
WantedBy=sockets.target
|
@ -0,0 +1,14 @@
|
||||
# default: off
|
||||
# description: The git dæmon allows git repositories to be exported using \
|
||||
# the git:// protocol.
|
||||
|
||||
service git
|
||||
{
|
||||
disable = yes
|
||||
socket_type = stream
|
||||
wait = no
|
||||
user = nobody
|
||||
server = @GITEXECDIR@/git-daemon
|
||||
server_args = --base-path=@BASE_PATH@ --export-all --user-path=public_git --syslog --inetd --verbose
|
||||
log_on_failure += USERID
|
||||
}
|
@ -0,0 +1,10 @@
|
||||
[Unit]
|
||||
Description=Git Repositories Server Daemon
|
||||
Documentation=man:git-daemon(1)
|
||||
|
||||
[Service]
|
||||
User=nobody
|
||||
ExecStart=-@GITEXECDIR@/git-daemon --base-path=@BASE_PATH@ --export-all \
|
||||
--user-path=public_git --inetd --log-destination=stderr --verbose
|
||||
StandardInput=socket
|
||||
StandardError=journal
|
@ -0,0 +1,7 @@
|
||||
Alias /git /var/www/git
|
||||
|
||||
<Directory /var/www/git>
|
||||
Options +ExecCGI
|
||||
AddHandler cgi-script .cgi
|
||||
DirectoryIndex gitweb.cgi
|
||||
</Directory>
|
@ -0,0 +1,53 @@
|
||||
# The gitweb config file is a fragment of perl code. You can set variables
|
||||
# using "our $variable = value"; text from "#" character until the end of a
|
||||
# line is ignored. See perlsyn(1) man page for details.
|
||||
#
|
||||
# See /usr/share/doc/gitweb-*/README and /usr/share/doc/gitweb-*/INSTALL for
|
||||
# more details and available configuration variables.
|
||||
|
||||
# Set the path to git projects. This is an absolute filesystem path which will
|
||||
# be prepended to the project path.
|
||||
#our $projectroot = "@PROJECTROOT@";
|
||||
|
||||
# Set the list of git base URLs used for URL to where fetch project from, i.e.
|
||||
# the full URL is "$git_base_url/$project". By default this is empty
|
||||
#our @git_base_url_list = qw(git://git.example.com
|
||||
# ssh://git.example.com@PROJECTROOT@);
|
||||
|
||||
# Enable the 'blame' blob view, showing the last commit that modified
|
||||
# each line in the file. This can be very CPU-intensive. Disabled by default
|
||||
#$feature{'blame'}{'default'} = [1];
|
||||
#
|
||||
# Allow projects to override the default setting via git config file.
|
||||
# Example: gitweb.blame = 0|1;
|
||||
#$feature{'blame'}{'override'} = 1;
|
||||
|
||||
# Disable the 'snapshot' link, providing a compressed archive of any tree. This
|
||||
# can potentially generate high traffic if you have large project. Enabled for
|
||||
# .tar.gz snapshots by default.
|
||||
#
|
||||
# Value is a list of formats defined in %known_snapshot_formats that you wish
|
||||
# to offer.
|
||||
#$feature{'snapshot'}{'default'} = [];
|
||||
#
|
||||
# Allow projects to override the default setting via git config file.
|
||||
# Example: gitweb.snapshot = tbz2,zip; (use "none" to disable)
|
||||
#$feature{'snapshot'}{'override'} = 1;
|
||||
|
||||
# Disable grep search, which will list the files in currently selected tree
|
||||
# containing the given string. This can be potentially CPU-intensive, of
|
||||
# course. Enabled by default.
|
||||
#$feature{'grep'}{'default'} = [0];
|
||||
#
|
||||
# Allow projects to override the default setting via git config file.
|
||||
# Example: gitweb.grep = 0|1;
|
||||
#$feature{'grep'}{'override'} = 1;
|
||||
|
||||
# Disable the pickaxe search, which will list the commits that modified a given
|
||||
# string in a file. This can be practical and quite faster alternative to
|
||||
# 'blame', but still potentially CPU-intensive. Enabled by default.
|
||||
#$feature{'pickaxe'}{'default'} = [0];
|
||||
#
|
||||
# Allow projects to override the default setting via git config file.
|
||||
# Example: gitweb.pickaxe = 0|1;
|
||||
#$feature{'pickaxe'}{'override'} = 1;
|
@ -0,0 +1,13 @@
|
||||
#!/bin/bash
|
||||
|
||||
shopt -s failglob
|
||||
|
||||
# Print output from failing tests
|
||||
printf -v sep "%0.s-" {1..80}
|
||||
for exit_file in t/test-results/*.exit; do
|
||||
[ "$(< "$exit_file")" -eq 0 ] && continue
|
||||
out_file="${exit_file%exit}out"
|
||||
printf '\n%s\n%s\n%s\n' "$sep" "$out_file" "$sep"
|
||||
cat "$out_file"
|
||||
done
|
||||
exit 1
|
File diff suppressed because it is too large
Load Diff
Loading…
Reference in new issue