diff --git a/ghc-zlib.spec b/ghc-zlib.spec
index 0ef948a..b5e4167 100644
--- a/ghc-zlib.spec
+++ b/ghc-zlib.spec
@@ -1,21 +1,23 @@
-# Haskell package name
 %define pkg_name zlib
-# Haskell compiler
 %define ghc_version 6.10.1
 
 %define pkg_libdir %{_libdir}/ghc-%{ghc_version}/%{pkg_name}-%{version}
 %define pkg_docdir %{_docdir}/ghc/libraries/%{pkg_name}
-# Haskell compilers do not emit debug information.
+
+%define build_prof 1
+%define build_doc 1
+
+# ghc does not emit debug information
 %define debug_package %{nil}
 
 Name: ghc-%{pkg_name}
 Version: 0.5.0.0
-Release: 2%{?dist}
+Release: 3%{?dist}
 License: BSD
 Group: Development/Libraries
 URL: http://hackage.haskell.org/cgi-bin/hackage-scripts/package/%{pkg_name}
 Source: http://hackage.haskell.org/packages/archive/%{pkg_name}/%{version}/%{pkg_name}-%{version}.tar.gz
-Summary: Haskell compression and decompression in the zlib and gzip formats
+Summary: Haskell compression and decompression library binding
 Provides: %{name}-devel = %{version}-%{release}
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 ExclusiveArch:	i386 x86_64 ppc
@@ -40,13 +42,16 @@ the few cases where more control is needed, it provides access to the
 full zlib feature set.
 
 
+%if %{build_prof}
 %package prof
 Summary: Profiling libraries for %{name}
 Group: Development/Libraries
+Requires: %{name} = %{version}-%{release}
 Requires: ghc-prof = %{ghc_version}
 
 %description prof
 This package contains profiling libraries for %{name}.
+%endif
 
 
 %prep
@@ -54,49 +59,72 @@ This package contains profiling libraries for %{name}.
 
 
 %build
-%cabal_configure -p --ghc
+%cabal_configure --ghc \
+%if %{build_prof}
+  -p
+%else
+%{nil}
+%endif
 %cabal build
+%if %{build_doc}
 %cabal haddock
+%endif
 %ghc_gen_scripts
 
 
 %install
-rm -rf ${RPM_BUILD_ROOT}
+rm -rf $RPM_BUILD_ROOT
 %cabal_install
 %ghc_install_scripts
 %ghc_gen_filelists %{name}
 
 
 %clean
-rm -rf ${RPM_BUILD_ROOT}
+rm -rf $RPM_BUILD_ROOT
 
 
 %post 
-%ghc_postinst_script
+%ghc_register_pkg
+%if %{build_doc}
 %ghc_reindex_haddock
+%endif
 
 
 %preun 
-%ghc_preun_script
+if [ "$1" -eq 0 ] ; then
+  %ghc_unregister_pkg
+fi
 
 
 %postun
 if [ "$1" -eq 0 ] ; then
+%if %{build_doc}
   %ghc_reindex_haddock
+%endif
 fi
 
 
 %files -f %{name}.files
 %defattr(-,root,root,-)
 %doc LICENSE
+%if %{build_doc}
 %{pkg_docdir}
+%endif
 
 
+%if %{build_prof}
 %files prof -f %{name}-prof.files
 %defattr(-,root,root,-)
+%endif
 
 
 %changelog
+* Mon Dec  1 2008 Jens Petersen <petersen@redhat.com> - 0.5.0.0-3
+- sync with lib template:
+  - add build_prof and build_doc
+  - prof requires main package
+  - update scriptlet macro names
+
 * Tue Nov 25 2008 Jens Petersen <petersen@redhat.com> - 0.5.0.0-2
 - build with ghc-6.10.1
 - no longer buildrequire haddock09