From 89124c0c49a09349366600ac645f45fd4ac8dd80 Mon Sep 17 00:00:00 2001
From: Jens Petersen <petersen@redhat.com>
Date: Fri, 17 Jul 2020 16:38:02 +0800
Subject: [PATCH] add revision

---
 ghc-zlib.spec      |   2 +
 zlib-0.6.2.1.cabal | 111 +++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 113 insertions(+)
 create mode 100644 zlib-0.6.2.1.cabal

diff --git a/ghc-zlib.spec b/ghc-zlib.spec
index ca95b3e..f5a2b57 100644
--- a/ghc-zlib.spec
+++ b/ghc-zlib.spec
@@ -15,6 +15,7 @@ License:        BSD
 Url:            https://hackage.haskell.org/package/%{pkg_name}
 # Begin cabal-rpm sources:
 Source0:        https://hackage.haskell.org/package/%{pkgver}/%{pkgver}.tar.gz
+Source1:        https://hackage.haskell.org/package/%{pkgver}/%{pkg_name}.cabal#/%{pkgver}.cabal
 # End cabal-rpm sources
 
 # Begin cabal-rpm deps:
@@ -82,6 +83,7 @@ This package provides the Haskell %{pkg_name} profiling library.
 %prep
 # Begin cabal-rpm setup:
 %setup -q -n %{pkgver}
+cp -bp %{SOURCE1} %{pkg_name}.cabal
 chmod a-x changelog
 # End cabal-rpm setup
 #remove the copy library
diff --git a/zlib-0.6.2.1.cabal b/zlib-0.6.2.1.cabal
new file mode 100644
index 0000000..c29ade1
--- /dev/null
+++ b/zlib-0.6.2.1.cabal
@@ -0,0 +1,111 @@
+cabal-version:   >= 1.10
+name:            zlib
+version:         0.6.2.1
+x-revision: 1
+
+copyright:       (c) 2006-2016 Duncan Coutts
+license:         BSD3
+license-file:    LICENSE
+author:          Duncan Coutts <duncan@community.haskell.org>
+maintainer:      Duncan Coutts <duncan@community.haskell.org>
+bug-reports:     https://github.com/haskell/zlib/issues
+category:        Codec
+synopsis:        Compression and decompression in the gzip and zlib formats
+description:     This package provides a pure interface for compressing and 
+                 decompressing streams of data represented as lazy 
+                 'ByteString's. It uses the
+                 <https://en.wikipedia.org/wiki/Zlib zlib C library>
+                 so it has high performance. It supports the \"zlib\",
+                 \"gzip\" and \"raw\" compression formats.
+                 .
+                 It provides a convenient high level API suitable for most
+                 tasks and for the few cases where more control is needed it
+                 provides access to the full zlib feature set.
+build-type:      Simple
+tested-with:     GHC ==7.0.4, GHC ==7.2.2, GHC ==7.4.2, GHC ==7.6.3, GHC ==7.8.4, GHC ==7.10.3, GHC ==8.0.1, GHC==8.0.2, GHC ==8.2.2, GHC ==8.4.4, GHC==8.6.5, GHC==8.8.3, GHC==8.10.1
+
+extra-source-files: changelog
+                    -- zlib C sources (for Windows)
+                    cbits/crc32.h cbits/inffast.h cbits/inflate.h
+                    cbits/trees.h cbits/deflate.h cbits/inffixed.h
+                    cbits/inftrees.h cbits/zutil.h cbits/gzguts.h
+                    -- test data files
+                    test/data/bad-crc.gz test/data/custom-dict.zlib
+                    test/data/custom-dict.zlib-dict test/data/hello.gz
+                    test/data/not-gzip test/data/two-files.gz
+                    -- demo programs:
+                    examples/gzip.hs examples/gunzip.hs
+
+source-repository head
+  type: git
+  location: https://github.com/haskell/zlib.git
+
+flag non-blocking-ffi
+  default:     False
+  manual:      True
+  description: The (de)compression calls can sometimes take a long time, which
+               prevents other Haskell threads running. Enabling this flag
+               avoids this unfairness, but with greater overall cost.
+
+flag pkg-config
+  default:     False
+  manual:      True
+  description: Use @pkg-config(1)@ to locate foreign @zlib@ library.
+
+library
+  exposed-modules: Codec.Compression.GZip,
+                   Codec.Compression.Zlib,
+                   Codec.Compression.Zlib.Raw,
+                   Codec.Compression.Zlib.Internal
+  other-modules:   Codec.Compression.Zlib.Stream
+  if impl(ghc < 7)
+    default-language: Haskell98
+    default-extensions: PatternGuards
+  else
+    default-language: Haskell2010
+  other-extensions: CPP, ForeignFunctionInterface, RankNTypes, BangPatterns,
+                    DeriveDataTypeable
+  if impl(ghc >= 7.2)
+    other-extensions: DeriveGeneric
+  if impl(ghc >= 7.6)
+    other-extensions: CApiFFI
+  build-depends:   base >= 4 && < 4.15,
+                   bytestring >= 0.9 && < 0.11
+  if impl(ghc >= 7.2 && < 7.6)
+    build-depends: ghc-prim
+  includes:        zlib.h
+  ghc-options:     -Wall -fwarn-tabs
+  if flag(non-blocking-ffi)
+    cpp-options:   -DNON_BLOCKING_FFI
+  if flag(pkg-config)
+    -- NB: pkg-config is available on windows as well when using msys2
+    pkgconfig-depends: zlib
+  else
+    -- don't use pkg-config
+    if !os(windows)
+      -- Normally we use the the standard system zlib.
+      extra-libraries: z
+    else
+      -- However for the benefit of users of Windows (which does not have zlib
+      -- by default) we bundle a complete copy of the C sources of zlib-1.2.8
+      c-sources:   cbits/adler32.c cbits/compress.c cbits/crc32.c
+                   cbits/deflate.c cbits/infback.c
+                   cbits/inffast.c cbits/inflate.c cbits/inftrees.c
+                   cbits/trees.c cbits/uncompr.c cbits/zutil.c
+      include-dirs:  cbits
+      install-includes: zlib.h zconf.h
+
+test-suite tests
+  type: exitcode-stdio-1.0
+  main-is:         Test.hs
+  other-modules:   Utils,
+                   Test.Codec.Compression.Zlib.Internal,
+                   Test.Codec.Compression.Zlib.Stream
+  hs-source-dirs:  test
+  default-language: Haskell2010
+  build-depends:   base, bytestring, zlib,
+                   QuickCheck       == 2.*,
+                   tasty            >= 0.8 && < 1.3,
+                   tasty-quickcheck >= 0.8 && < 0.11,
+                   tasty-hunit      >= 0.8 && < 0.11
+  ghc-options:     -Wall